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C H A P T E R 1

Introduction

This guide provides usage instructions for Optimal Trace Enterprise. To become familiar with
Optimal Trace Enterprise, you should first review the glossary for product-related concepts and
all of this Introduction chapter.

Optimal Trace Overview
Optimal Trace is a collaborative team-oriented requirements capture and management tool. It
allows structured requirements capture, establishing a system's scope. It facilitates all aspects
of requirements capture from drafting initial notes at a customer site through generating final
requirements documents. It is designed for teams with the following roles Business Analysts,
Systems Analysts, Project Managers, Test/QA engineers, Software Architects/Designers,
providing:

• A user-friendly work environment

• An intuitive interface for capturing, viewing and managing customer requirements

• A sophisticated project collaboration tool - multiple analysts can work concurrently

• An ability to create projects from predefined or custom project templates

• An ability to generate requirements in a document format that is both comprehensible to the
customer and unambiguous to Analysts, Project Managers and Developers working on a
project

• A comprehensive report generation to HTML, commas-delimited and other formats

• A managed, concurrent working environment that is virtually transparent

• An access control for projects and project packages

• An automatic test generator for QA

• A baseline creation and management tool

• An automatic e-mail notification tool on project changes

• A comprehensive traceability tree with automatic detection of suspect links
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• A powerful query and filtering mechanism

• A flexible document and text file import mechanism

At the fundamental level, the requirements-gathering paradigm is focused on two core constructs:
structured requirements and simple requirements. Structured requirements directly and
comprehensibly capture detailed functional requirements. This provides unambiguous
specifications driven by business need for all project stakeholders. A single structured requirement
is a strand of functionality proposed for a system. A collection of structured requirements can
express the entire functional behavior of a system. For example, when writing the specifications
for an online ordering system, formulate an individual structured requirement to satisfy each
goal for the set of expected users. Typical structured requirements might be Browse Orders,
Create/Edit Orders, and Login to System.
Structured requirements borrow much from the world of use cases, agile, and iterative concepts
while still allowing the capture of non-functional operational and other requirement types as
simple requirements. Optimal Trace is also designed to capture less-structured or simple
requirements. For example, it is critical to express the number of concurrent users for the
structured requirement Browse Orders, i.e. Must support 200 concurrent users. These
non-structured or non-functional requirements generally fall into two categories:

• Qualities: expressing aspects that the systemmust satisfy such as number of concurrent users,
security etc.

• Constraints: expressing hard realities such as type of infrastructure the system must run on,
coding language required, browser versions to be supported etc.

These can be captured in Optimal Trace, either by associating them with individual structured
requirements or by defining them system-wide as part of the over all project. Using refinement
relationships allows for full traceability. As important as structured requirements are for defining
functional needs, it would be a mistake to omit non-functional requirements such as scalability
or throughput. Optimal Trace, by using refinement relationships for such requirements, allows
complete traceability from functional to non-functional and vice versa. This traceability reduces
the risk of incomplete requirement specifications.

Project and Functionality Overview
Each organized set of related requirements is contained in a project. Each project can have
project level links to related resources. Additionally, each project has access to memoranda in
the form of project level notes. You can also define a glossary and a list of actors (people or
things involved) for each project. Each project contains a default requirement package, which
cannot be removed but can be renamed. It is possible to create subordinate packages. These
packages can be named, renamed, tagged, given a unique description, copied, moved, and
removed.
The core business facing unit of Optimal Trace is the requirement. Requirements exist within
the context of a package. Two types of requirements can be created in a project, simple
requirements and structured requirements. Simple requirements are specifications you would
like the system to support. A simple requirement can optionally contain one or more items. An
item is information that supplements the simple requirement. For example, an itemmay contain
a data type name and definition. Items may contain links to related resources, and custom
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properties. Simple requirements also may contain links to related resources, custom properties,
and notes. Each structured requirement can have links to related resources and its own set of
notes, custom properties, and non-functional requirements associated with it.
The core unit of a structured requirement is the step, and a requirement can be comprised of
none or many steps. Steps mimic the actions that you take to realize the goal or objective of a
requirement. The series of steps, which realize the successful completion of the main function
of the requirement, are collectively referred to as the Main Success Scenario. This could be
your structured requirement's critical path. Any series of steps within the same requirement that
provides an alternative path or solution to the main success scenario is collectively referred to
as an Alternate Scenario. This is a contingency plan for when behavior may need to address
exceptional situations. You may have any number of alternative scenarios in a requirement.
Optimal Trace Enterprise allows you to branch from one step to another step either in the same
scenario or another scenario. You can also branch from a step to an existing or new requirement,
optionally creating the requirement in the branching process.
Optimal Trace allows you to refine a step or an item to an existing or new requirement, creating
it in the process. This effectively links high to low-level requirements. This can be especially
useful when comparing as is/to be requirements that are linked to a given step at a higher level.
Optimal Trace allows you to link a requirement and all elements to an existing requirement or
other artifacts either within or across projects. Optimal Trace provides you with a document
profiles facility containing requirements document templates. Additionally, you can create your
own profiles and templates. Use document profiles to tailor generated documents to your branding
needs. Additionally, use the document profiles output to accept certain elements of the project.
Optimal Trace allows you to perform the following additional functions:

• Move a requirement or sets of requirements to another package or project andmove a package
or sets of packages to another package or project.

• Copy and paste actors, glossary items, requirements, and steps among projects.

• Search and filter within and across projects.

• Use customized and Windows shortcut keys.

• Work collaboratively on a single set of requirements, always aware of the latest changes
made by your colleagues.

• Work offline at a customer site and merge changes safely into the master requirements
document when you return to the office.

• Use local and remote projects.

• Upload your local projects to the central repository.

• Version projects or apply baselines to projects.

• Generate test cases from business requirements.

• Spell check a project or part of a project.

• View project version history.

• Publish requirements to the web.

• Visually merge projects.

• Merge two versions of the same project.
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• Merge a document into a project.

• Integrate with external test and design tools.

• Add non-Optimal Trace elements into the document.

• Reverse a document back into a project.

• Perform full round-trip engineering of Microsoft Word documents.

• Security enable projects.

• Import the contents of a text file or a Microsoft Word document into a project.

Screen Layout
When editing a project, a screen similar to the following appears. It demonstrates general project
components that exist in the product.

Figure 1. Optimal Trace Main Screen

Optimal Trace is comprised of the following sections:

Table 1. Main Sections

DescriptionSection

Contains menus, submenus, and options that can be used when running
Optimal Trace Enterprise. Click the options and sub-options as required.

Menu bar

For many of the options in the submenus you will see icons, text, and
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DescriptionSection

shortcut keys. For example, to create a new requirement under
Requirements in the Menu, you will see:

• Icon.

• Text - New Requirement. When the Requirements menu is extended,
click [Alt+C]. This functionality is available on other options, too.

• Shortcut key: [Ctrl+Shift+C].

Contains a list of frequently used items that can be used when running
Optimal Trace.

Tool bar

Contains a list of currently opened projects or project templates and their
respective contents. A project contained in the tree is comprised of actors,

Tree view

glossary entries, packages collections, and structured requirements. Each
entry in the tree is referred to as a node.

Contains a miniature of the requirement map view or flow diagram view.Thumbnail view

Contains the list of queries and offers an ability to perform simple
searches. Additionally, provides the ability to create, edit, and run queries.

Query View

Contains theTraceability tree. This shows relationships between projects
and elements as well as flagging suspect links and relationships.

Traceability view

Contains details associated with the specific node selected in the tree
view. For example, projects or requirements.

Details view

Contains specific detail relevant to the node selected in the tree view. In
instances where requirements or packages are selected, this area displays

Right Pane View

a map of related nodes (either the requirement map or flow diagram) and
text associated with requirements.

NOTE
Click the edge of a column to adjust the width. Optimal Trace retains the width for all
requirements in the package. There are two possible scenarios for column width retention:

• Example 1: open Requirement 1 in Package 1 and adjust the column widths. Open
Requirement 2 in Package 2, and return to Requirement 1 in Package 2. Optimal Trace kept
the changed width.

• Example 2, open Requirement 1 in Package 1 and adjust the column widths. Open
Requirement 2 in Package 1, the widths set for Requirement 1 have been retained.

Optimal Trace Documentation
The Optimal Trace documentation set includes the following:

• Optimal Trace Release Notes (Enterprise, Enterprise Server, Professional)

• Optimal Trace Installation Guide
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• Optimal Trace Enterprise Help

• Optimal Trace Enterprise Server Help

• Optimal Trace Professional Help

• Optimal Trace Administrator Help

• Customizing Exports and Reports Using Velocity Script

• Integration documents and Release Notes for each supported integration. Refer to SupportLine
for Optimal Trace integrations.

Getting Help
If ever you have any problems or you would like additional technical information or advice,
there are several sources. In some countries, product support fromMicro Focus may be available
only to customers who have maintenance agreements.
If you obtained this product directly from Micro Focus, contact us as described below. If you
obtained it from another source, such as an authorized distributor, contact them for help first.
If they are unable to help, contact us as described below.
However you contact us, please try to include the information below, if you have it. The more
information you can give, the better Product Support can help you. But if you don't know all
the answers, or you think some are irrelevant to your problem, please give whatever information
you have.

• The name, release (version), and build number of the product.

• Installation information, including installed options, whether the product uses local or network
databases, whether it is installed in the default directories, whether it is a standalone or
network installation, and whether it is a client or server installation.

• Environment information, such as the operating system and release on which the product is
installed, memory, hardware/network specifications, and the names and releases of other
applications that were running.

• The location of the problem in the product software, and the actions taken before the problem
occurred.

• The exact product error message, if any.

• The exact application, licensing, or operating system error messages, if any.

• Your Micro Focus client, office, or site number, if available.

Contact

Our web site gives up-to-date details of contact numbers and addresses. To connect, enter
www.microfocus.com in your browser to go to the Micro Focus home page, or go to
http://supportline.microfocus.com.
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Licensing
Table 2. Licensing Options

This table describes licensing options for both Optimal Trace Enterprise and Optimal Trace Professional.

DescriptionOption

Optimal Trace can be evaluated for a specific period of time without
a license key. When you first run the product, you do not require a

Evaluate Optimal Trace

license. The evaluation period is calculated from the time of first
usage, in other words from the initial running.
Once this period of time elapses youmust either purchase a full license
or else apply for an extension key.

Aside from the initial evaluation period as outlined in the previous
section, Optimal Trace requires a license to run. It ships with a License

License the application fully or
use an extended evaluation
license key Administration utility called the LAU (License AdministrationUtility).

For full details on how to license Optimal Trace, please run the LAU
and refer to the LAU help file under the Help.

If upgrading from a previous release of Optimal Trace, you will need
to install a new license.

Upgrading from a previous
release

References
• [1] Writing Effective Use Cases, Alistair Cockburn. 2001.

• [2] Unified Modeling Language (UML), http://www.omg.org/uml/
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C H A P T E R 2

Project Menu

Project Menu Overview
Use the Project menu to create, open, close, save, save as, upload, and download your projects.
Additionally, the Project menu allows you open project templates, save projects as templates,
and apply templates. You can create project baselines and be notified of changes to specific
project elements. You can also save images of certain views of your project and you can export
your project contents to structured text-based (CSV) outputs.
The Project menu also allows you to import project data from aMicrosoft OfficeWord document
or a text file into your project. If you are logged in you can change your password from the
Project menu. Everything associated with a particular set of requirements is contained within
a project. Each project consists of collections of packages, simple requirements, structured
requirements, actors, glossaries, and a number of additional entities such as notes and links.
All projects are created initially from project templates. Using these in conjunction with custom
properties allows you to provide sets of pre-configured properties that can be used for all your
projects. Corporate standards can be encouraged and sets of useful information introduced from
project inception across the enterprise.

NOTE
Beside containing sets of custom properties, project templates can contain specific pre-built
project elements such as glossary items, packages, simple and structured Requirements, etc.
You may want to consider creating templates of common flows that tend to recur across your
projects. For example, login is a common repetitive flow.

Projects
To create remote projects, you need to configure Optimal Trace to communicate with an Optimal
Trace Enterprise Server host. A local project is stored on your computer's hard drive. Only one
user at a time can edit the local project. Local projects are stored as XML formatted text files. A
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remote project is stored in the repository (an Optimal Trace Enterprise Server) and can be viewed
and edited by multiple users concurrently.

Table 3. Project Types

Use the following table to decide which type of project you need:

DescriptionProject Type

Create a local project if:Local

• You do not wish to use any collaboration facilities within the project.

• You want to quickly get up and running on the very early stages of a project and you
are the only person modifying it.

• You are working offsite or away from your office and have no access to your
repository server.

Create a remote project if:Remote

• You want to use collaboration facilities within the project.

• You have access to your repository server.

• You want to secure the project using access control.

NOTE
It is common for users to initially create a local project and at a later point upload the project
to the server. For example, if working to capture the business information in a JAD (Joint
Application Development) workshop, initially capture the requirements directly into a local
project. Using a projector to show the graphical flows and textual detail with the business
stakeholders facilitates stakeholder agreement. When you have returned onsite or when you are
connected with the server, upload the captured information and make it your baseline.

Project Templates
When creating a new project, specify a project template. Optimal Trace ships with the following
project templates:

Table 4. Project Templates

DescriptionTemplate

This is an empty template meaning it does not have any predefined custom
properties or project structure. This is the default when running Optimal Trace
for the first time.

Empty

Use this template when defining higher level business processes. This template
contains the following custom properties:

Business Process
Template

• Project: project scope, business stakeholders
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DescriptionTemplate

• Requirement: business priority (Bound and one of high, medium, or low) and
business level (Bound and one of high, medium, or low), time, resources

• Requirement Step: time, inputs (Bound and empty), outputs (Bound and
empty) Note: Bound inputs and outputs are typically a set of predefined items.
For example, PO, invoice, etc.

Use this template as one approach when relating product/project features to
detailed requirements. This template structures a project into two packages. The

Feature Driven
Development

first package is Features with the tag FR denoting Feature Requests or Feature
Requirements. The second Detailed Requirements with tag SR denoting Software
Requirements. Capture your specific features in the features package as Simple
Requirements and the related detailed functional flows as structured requirements
in the second package. Use refinements to connect features to detailed
requirements.

Use this template to integrate with QADirector projects based on a Manual Risk
Model. This template contains custom properties that correspond to the Manual
Risk Model custom attributes.

Optimal Trace -
QADirector
Integration Manual
RiskModel Template

Use this template to integrate with QADirector projects based on a QualityPoint
Risk Model. This template contains custom properties that correspond to the
QualityPoint Risk Model custom attributes.

Optimal Trace -
QADirector
Integration
QualityPoint Risk
Model Template

Use this template to integrate withQADirector projects based on a Standard Risk
Model. This template contains custom properties that correspond to the Standard
Risk Model custom attributes.

Optimal Trace -
QADirector
Integration Standard
Model Template

Use this template when defining test requirements. Typically these requirements
will link or trace back to business requirements. This template contains the
following custom properties

QA Template

• Project: scope, out of scope, QA team, test schedule, test hardware, test
software

• Requirement: tester

• Requirement Step: expected result, result

Use this template when defining requirements for typical software projects. This
template contains the following custom properties:

Standard Software
Development

• Project: project scope, business case, project team, project schedule and
risk/mitigation

• Requirement: delivery increment (bound and one of increment 1, 2, or 3),
business priority (bound and one of High, Medium, or Low), and tech risk
(bound and one of High, Medium, or Low)
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NOTE
You may want to change the default project template when creating new projects. Click
Options>General Options to adjust the project template settings.

Creating Projects
Use this option to set up a new project. This is the first step in gathering requirements. Click
Project>New Project.

Figure 2. New Project Dialog box

Opening a Project
To open a project:

1. Click Project>Open Project.
2. Check the Open a remote project in the repository for remote projects or Open a local

project for offline (file based) projects.
3. Select the project you wish to open. To facilitate project selection, the dialog box displays

the project name, project creator, project created on date, and project last modified date.
You can sort these columns or hover over the project to view a description.

4. Click Open.
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Optimal Trace allows multiple remote projects, local projects, or a mixture of both project
types to load at any one time. If you open multiple projects, you can copy, cut, and paste
artifacts such as requirements and actors between the various projects. After creating a
Project, configure the details associated with the project, and specify properties, links,
notes, and non-functional requirements. It is also possible to customize some project settings.
Projects can be configured as security enabled meaning that permissions are applied to the
project. Security enabled projects appear in the list of projects with a key icon next to them.
If attempting to open a security enabled project, the system prompts you to login. Enter
your user name and password in the fields provided.

NOTE

• User IDs and passwords are case sensitive. Ensure that you are using the correct case
if you are having difficulty when logging in.

• When new users are created, they are assigned the default password of password. Contact
your Optimal Trace Administrator for more details. Refer to the Optimal Trace
Administrator Help for more information on users.

Working with Remote Projects
Once created, a new remote project behaves exactly like a local project. The difference is that
when you save changes, the changes are written to the repository rather that to a local disk.

About Deleting Remote Projects
You can delete remote projects in an Optimal Trace repository from the Optimal Trace Enterprise
client provided that delete permissions have been granted. For more information, see Deleting
Remote Projects [p. 21]. Additionally, you can delete remote projects from Optimal Trace
Administrator. Refer to the Optimal Trace Administrator Help for more information about
deleting remote projects and setting permissions.
Prior to deleting a project, consider doing the following:

• Taking the project offline as a precautionary measure in case you wish to recover that project
at a later time.

• Making a backup copy in the repository.

Deleting Remote Projects
To delete a remote project from the Optimal Trace client, you must have delete permission set
for the specific project to delete. Additionally, you can delete remote projects from the Optimal
Trace Administrator. For more information, refer to the Setting Project and Package Permissions
topic in the Optimal Trace Administrator Help.

1. Click Project>Delete Project.
The Delete Remote Project dialog box appears.

2. Select the project to delete, and then click Delete.
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Amessage box appears asking you to confirm the deletion. ClickYes to dismiss the message
box and delete the project.

Closing a Project
Use this option to close your local or remote project. It will no longer appear in the tree view,
but the project will remain in the repository or file folder. To close a project:

1. Click Project>Close Project. Prior to closing, if Optimal Trace detects that you do have
unsaved changes, it will prompt you to save before proceeding.

2. Click either Yes or No to close.

Project Baselines
Project baselines are archived snapshots of a project. Every Baseline is associated with the
originating project. Baselines are typically created when you are at a meaningful point in the
project lifecycle. Subsequent changes in the project can be reviewed and monitored by using
baselines.
Examples of key milestones where project baselines might be created are:

• After completing the first or subsequent iteration of requirements with a customer

• Before and after a review session with technical stakeholders

• Before and after a group review session with the QA Team

• After entry into the build phase

• After final project delivery

• For maintenance of delivered systems where there is alteration of behavior

The baseline feature supports review sessions and allows focus on changes that have occurred
since the last or any other baseline. When creating a baseline, specify a baseline name and
description. This enables tracking of specific baseline events.
Projects baselines can be created, can be compared, can be merged, can be deleted and can
acquire permissions. If permissions are set, project baselines can be opened, edited, and
manipulated in the same way as normal projects.

NOTE
All repository projects are baselined with a tag called Latest. This allows the current or latest
project to be compared with any previous baseline.

Creating Baselines
To create a baseline:

1. Open a project. Since baselines are associated with repository based projects, ensure that
you have a project open.

2. Click Project>Baselines>Create Baselines. The Create Baseline dialog box appears.
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3. Type a name and description in the appropriate fields.
4. Click Create. You have created a baseline that is associated with this project and can be

opened.

NOTE
If you need to baseline for a session where you will be working offline, there are two
approaches you can take. You can first create the baseline when online, then take the project
offline using Download. When merging changes into the repository, you can compare the
before and after state using Compare Baselines... option. Alternatively, you can take the
project offline, make any offline changes without having created an initial baseline. Before
merging, create a Pre-merge labeled baseline. This allows you to compare all changes
before and after the merge.

Opening Baselines
Use the procedure below to open a baseline. After the baseline is open, it can be used in exactly
the same way as any project.

1. Click Project>Baselines>Open Baseline…. The current list of baselines appear. For each
Baseline, the system presents the date the baseline was created along with the person who
created it. If no baselines have been created to date, the list is empty.

2. Chose a baseline and click Open.

Deleting Baselines
You can delete project baselines in an Optimal Trace repository from the Optimal Trace client
provided that delete permissions have been granted. Additionally, you can delete project baselines
from the Optimal Trace Administrator. For more information, refer to the Setting Project and
Package Permissions topic in the Optimal Trace Administrator.
To delete a baseline from the Optimal Trace Enterprise client, follow these steps:

1. Click Project>Baselines>Delete Baselines.
The Delete Project Baseline dialog box appears.

2. Select the baseline to delete.
3. Click Delete.

Amessage box appears asking you to confirm the deletion. ClickYes to dismiss the message
box and delete the project baseline.

Comparing Baselines
Individual baselines can be compared to access the changes from one baseline to another. To
compare baselines:

1. Click Project>Baselines>Compare Baselines.... The Compare Baselines dialog box
appears.

2. Select the baselines to be compared.
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3. ClickOK. The Baseline Comparison screen appears. For more information, see Baseline
Comparison Dialog Box [p. 24].

Baseline Comparison Dialog Box
The Baseline Comparison Dialog Box consists of three panes. The Compare panes display
two baselines of the same project labeled From andTo and shows the differences between them
in the Differences pane, which is located below the two Compare panes.
Any objects that exist in both the From and the To projects that have different attributes trigger
a visual conflict. For example, two actors both called "User", that have different descriptions
are flagged in the Compare panes and an explicit description of the difference is displayed in
the Differences pane.
The following differences can occur between baselines:

• Objects can reside in the From baseline but not in the To baseline

• Objects can reside in the To baseline but not in the From baseline

• Objects can be common to both theFrom and theTo baseline but can have different attributes

Figure 3. Baseline Comparison Dialog Box
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To move up or down between differences, use the Up and Down arrows. Selecting an entry in
the Differences pane selects the associated entry in the Compare panes. Conversely, selecting
an entry in the Compare Baselines panes selects the associated entry in the Differences pane.
When differences occur in the Differences screen, there can be a number of reasons. The
following table lists the icons and their definitions. Additionally, it provides a description of
Difference States when a specific button is enabled. Icons can appear in the From and To
baselines in the normal tree view, without any adornments such as pluses or circles. In this
instance, this signifies that an object of this type was found in each baseline and these were
found to be identical, hence there is no difference between the two baselines.

Table 5. Baseline Comparison Differences Markers

The following markers appear in Compare panes to denote the type of difference between the two
baselines.

DescriptionActionMarker

The selected element was removed from the baseline.Removed

The selected element was added to the baseline.Added

There are two scenarios when this icon appears:Different
sub-element(s)

or • The first scenario is that the change occurred when a sub-element
was added or removed. For instance adding a new link to a
requirement.

or a property
difference

• The second scenario is that the changes are at the property level. For
example, a name or description changed in a package. In this scenario,
the exact text of the change displays in the appropriate column.
Additionally, the property that changed is reflected in the Action
column.

Another element that is associated with this element has changed. For
example, a step element is associated with an actor element.

Associated
element has
changedor

The position of the selected element has changed. Positional changes
happen when elements are added or removed to an area where there are

Positional
change

or more elements after the specific element. For example, if step 4 were
removed from of a total of 6 steps, a step positional change results.
Positional changes also occur if an element is moved up or down.

It is possible to save the results in the third pane to a text file as well as generating a HTML
view of the results. Click View>HTML... and then click Open.
The differences in the third pane display as a single HTML file.
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NOTE
The HTML report can easily be mailed to colleagues for review. This allows you to mail a
concise view of the differences. To access the HTML file, go to your Optimal Trace installation
directory and find the file called BaseLineCompareOutput.html. The default installation
directory is <Optimal Trace Install Root>\projects\reports.

To save the differences to a text file:

• Click Compare > Save as...

• Type a file name.

• Click Save.

Merging Baselines
To resolve the following issues, you can merge the differences appearing in one baseline into
another baseline:

• There was information in a previous baseline that may have been subsequently altered or
deleted but has become relevant again. For example, functional flows. In this case, the specific
functional flows could be merged forward into the latest baseline.

• You want to adjust a previous baseline without having to re-baseline.

To merge baselines:

1. Choose Project>Baselines>Merge Baselines.

2. In the Baseline From list, select the baseline that you want to merge or include in another
baseline. This is the source baseline and will not be updated with any differences appearing
in the target baseline.

3. In the Baseline To list, select the target baseline in which to update with differences
appearing in the source baseline.

4. Click OK. The Project Merge dialog box appears in which you can select elements to
merge into the target baseline.

Notifications
Optimal Trace provides email notification of changes applied to any part of a given project. If
changes are made, an e-mail is issued automatically from the Optimal Trace Enterprise Server.

NOTE
Projects must be secure before registering for notifications. For more about making projects
secure, see the Optimal Trace Administrator Help.
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Table 6. Change Notification Elements

Register for change notifications on the following project elements:

DescriptionElement

Change to project attributes or constituent elements such as notes, etc.Project Level

Change to any glossary entry, addition of glossary entries, or removal of
glossary entries.

Glossary

Change to any actor entry, addition of actors, or removal of actorsActor List

Change to the package attributes, addition of entries, or removal of entries.Package

Change to any level of the requirement.Structured Requirement

Change to any level of the requirement.Simple Requirement

For more information, see Registering for Notifications [p. 27].

Registering for Notifications
To register for notifications:

1. Select the element in the tree. If you select a package you can also have the option of
registering for all the package sub-elements.

2. Click Project>Notifications>Register for Notification. You can alternatively right-click
in the tree to access the shortcut menu.

3. Click Yes.
A message appears confirming the registration.

• If registering for a package and if the package contains sub-packages and requirements,
Optimal Trace prompts for a confirmation to register for these elements.

• If the server side SMTP mail settings have not been configured, a message appears. Contact
your Optimal Trace administrator to have these set correctly. See the Optimal Trace Enterprise
Server Help for more information on configuring SMTP mail settings.

Viewing and Unsubscribing from Notifications
It is possible to view the list of element(s) that have been configured for notifications.
Additionally, it is possible to unsubscribe from notifications on any elements. To view or
unsubscribe from notifications:

1. Click Project>Notifications>View/Unsubscribe Notifications. The screen displays the
current subscribed project elements.

2. Uncheck one or more elements to unsubscribed from mail notifications on that element.
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Saving Projects
Because the undo and redo memory is cleared after a save, you cannot undo or redo any actions
you made before saving; however, any new actions perfomed after saving a project can be
undone or redone.
To save a project:

1. Click Project>Save Project. If a project was previously saved, any changes made to the
project are automatically saved without a confirmational message appearing. For new
projects, however, the Save dialog box appears.

2. Type a name for the project in the Name field.
3. Click Save.

Saving a Project As a Different Name
Use this option to save a project as a different name. If a project is repository-based, Optimal
Trace prompts you to enter only the name of the project.

NOTE

• Use the save as option to archive repository projects. This creates a complete copy of the
project in the repository.

• The undo and redo memory is cleared after a save. Consequently, once a Project is saved
you cannot undo or redo any actions you made before saving. Any new actions since saving
can be undone or redone.

If the project is a local project (file-based project) Optimal Trace prompts you to enter the file
name of the project.
To use the Save As option for both repository and local projects:

Click Project>Save Project As.
• For repository projects, the Save Project As dialog box appears. Type a new name in the

box, and then click OK.

• For local projects, the Save dialog box appears. Type a new name, and then click Save.

Saving Projects as Templates
Create new templates either from existing projects or existing templates.
Using this option saves the currently loaded and selected project or template as a new template.
Optimal Trace prompts for the template name and description.
Any custom properties and structural elements are saved forming the new template. The template
is saved in the location specified in the General Options >Default Directories>Project
Templates Directory option. For more information, see General Options [p. 103].To modify
The next time a new project is created, the template appears as a template selection.
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Applying Templates to Projects
Templates can be applied to existing projects or to other templates.
Applying a template to a project layers the custom properties and structural elements of the
template on top of the destination project.
Consider applying templates if you have initially created the project from one template and at
a later point you wish to layer custom properties and/or structural elements from a different
template onto the same project.

NOTE
When applying a template, the custom properties in the destination project and any associated
data is preserved if custom properties having the same name are encountered in both the template
and the destination project. Additionally a message regarding the duplication appears.

Figure 4. Apply Project Template Dialog Box

To view the details of a project template, click the… button next to the template on the Apply
Project Template dialog box. TheProject Template Details dialog box summarized the custom
properties currently defined for the selected template. You can also open the specific template
and navigate to its full set of data and custom properties.
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Figure 5. Project Template Details Dialog Box

Opening Project Templates
Use this option to open an existing template to view or modify. A list of available templates
appears. To view details for each template, click the… to the right of the template. After opening
a template, the template indicator icon appears adjacent to the template name within the tree
view. Since templates are specialized projects, all project level editing, reporting, etc. capabilities
can be applied to project templates. Existing templates can be saved with another name. Create
as many specialized templates as necessary.

Changing Project Password
If logged into a secure project that is not using Windows Integrated Authentication, you can
change your password. To change the password:
ClickProject>Change Password. The Set Password dialog box appears. Enter a new password
in the appropriate fields and click OK.

Downloading a Repository Project to a Local Project
Downloading a complete copy of your project from the repository allows you to work
disconnected from the repository. This is useful if working on site with your customer or at
home where you do not have network access.
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NOTE
Optimal Trace tracks that a project was downloaded from a repository project. When you return
the project to the server by uploading it, Optimal Trace will automatically launch the project
merge screen.

To download a project: click Project>Download repository Project to local Project. The
Save to File dialog box appears. Optionally, change the file name and then click Save.
After the download completes:

• The project path displayed in the tree view points to the local file.

• The project behaves as a local project.

• The Project Status indicator at the bottom right of the screen will read 'Project Status: Offline'

• All subsequent Project changes are saved locally.

• A connection to a Repository Server is not required and you may proceed to work 'offline'.
You may subsequently choose to go back online.

NOTE
Offline and Master Projects. Taking projects offline does not prevent other users from
simultaneously editing the master version on the repository. By the time you are ready to put
your changes back online and if other users have made conflicting changes to some of the same
project elements in the intervening period, then the Visual Merge Tool is invoked. This allows
you to compare two versions of a project and selectively accept or reject either the From or To
version of every conflict. For more information, see Merging Projects [p. 122].

Upload Local Project to Repository
Use this option if you are either reconciling a previously downloaded offline project or if you
want to transfer a local project to the Repository to begin working collaboratively.
Click Project>Upload local project to repository, and Optimal Trace will attempt to upload
the file.
If the project was originally a repository based project that was taken offline for local access
then the Optimal Trace Enterprise Server will detect this and invoke the Project Visual Merge
screen. However, if this is the first time the project is being added to the repository then the
project status will change from offline to online in the status bar and the project will now be
converted into a repository project.

Exporting Projects
Use this option when exporting a given project to any text or structured format. Optimal Trace
ships with a number of Export Profiles. Each export profile dictates the format of the CSV
(Comma Separated Values) output file.
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NOTE
When an export is created, Optimal Trace can also automatically insert a project level link to
the generated file. If you do not wish to automatically create this link, uncheck Add Report
Link to Project (locks the project).

Table 7. Default Export Profiles

DescriptionDirectoryProfile

Export to CSV (Comma-separated) Text File. Generates a report
with all the Project details in CSV format. This report is

...\projects\exportsText Export

especially good if you wish to output the content of Optimal
Trace projects into text editing tools such as notepad or Excel
spreadsheets. Since the output is delimited by commas, an Excel
worksheet can open the output for manipulation.

Generates a report with all the Project details in CSV format
(comma delimited text). UsingOptimal Trace suppliedMapping
Rules this file may then be opened in MS Project.

...\projects\exportsMS Project
Export

This report generates CSV based text files (comma delimited
text). Generates an actor oriented text output with each actor

...\projects\exportsText Actor
Usage Export

and the steps it participates in. The intent of the report is to
showwhat actors/resources interact with given steps within the
Requirements and which steps have no actor currently defined.
This is very useful for gap analysis and redundant actor
identification. An HTML version of this export is available
under the Generation>Generate Reports… menu option.

This report generates CSV based text files (comma delimited
text). Generates a text output with e.g. current details for

...\projects\exportsText As Is/To
Be Export

administrators (As-Is processes), and projected details for
system developers (To-Be processes). The Goal-levels 'As-Is'
and 'To-Be' that ship with Optimal Trace are used as
discriminators for this export. An HTML version of this export
is available under theGeneration>Generate Reports…menu
option.

This report generates an XML file, suitable for use with
Compuware Optimal J. The output generated includes: a full
listing of Requirements and each object's steps.

...\projects\exportsOptimalJ XMI
(UML)

This report generates an XML file, suitable for use with Sparx
Enterprise Architect. The output generated includes: a full
listing of Requirements and each object's steps.

...\projects\exportsEnterprise
Architect XMI
(UML)
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NOTE
Creating Custom Exports. Export Profiles rely on the velocity scripting engine and the Optimal
Trace Plug-in SDK. Velocity ships with Optimal Trace. See http://velocity.apache.org for more
details on the Velocity scripting language. See also the Customizing Exports and Reports Using
Velocity Script Reference for more on velocity in general and building exports using velocity
script.

Import Project
Use this option to import project data either from a text file, or from an existing requirements
document in Microsoft Word.

Import Text File
This option permits the import of data from a text file into the selected project. This option is
only available if one of the following project elements is selected in the tree:

• Select the Project to import Simple Requirements or Structured Requirements into the root
Requirements Package.

• Select a Requirements Package to import Simple Requirements or Structured Requirements
into it.

• Select the Glossary to import Glossary Entries.

• Select the Actor List to import Actors.

• Select a Structured Requirement to import Steps into it.

• Select a Simple Requirement to import Items into it.

For convenience, the Import Text File option is also available in the context menu for these
project elements. Text files to import must have data arranged in fields or columns, with each
field delimited by a special character such as a comma.Microsoft Excel CSV (comma separated
value) files are saved in this format, and so this feature is ideal for importing spreadsheet data.
Each row in the file is imported as a new project element.

Table 8. Import Text File Options

DescriptionOption

Indicates the project element which will be the location for the imported elements. This
is initialized with the selected item in the project tree. Use the ... button to the right to

Import Into

change the import location. The selected import element will determine the kinds of
element that can be imported according to the list above.

Specifies the text file to import. Type in the full path, or choose the ... button to browse
to the file.

Text File

Allows you to choose the character which delimits the fields in the text file. For Excel
CSV, commas are used. Other options are period (.), tab and space. In the event that a

Delimiter

33Optimal Trace Enterprise User Guide

Chapter 2 ∙ Project Menu

http://velocity.apache.org


DescriptionOption

different character is required, choose "Custom" and type the character in the text box
to the right of the list.

Some text files have a first header line that names the fields. If this is the case, check
this option, and when the import proceeds this first line will be ignored. Click the Next

First line is a
header

button to proceed to the next stage in the process (this is enabled when a valid file is
selected) or click Cancel to abandon the process. After clicking Next, the mapping
dialog appears.

This dialog specifies how the fields found in the file should map to attributes of the
project elements to be imported. Collectively, this set of mappings is called a map.

Once a map has been specified, it is possible to save it using this drop-down box. Simply
choose "< New >" from the option list, and specify the name of the map in the box

Map Name

which pops up. The namemust be less than 20 characters in length, and shouldn't contain
any punctuation characters. After a map has been saved in this way, its namewill appear
in the drop down, and it can be automatically retrieved and applied in subsequent imports.
It should be noted that maps specify a particular type of project element, it is not possible
to apply a map that specifies a type which cannot be imported in to the chosen "Import
Into" location, and an error popup will occur if you attempt to do so.

Click to save changes to the currently applied map. This is only enabled if the field
mappings are changed after a map is applied.

Save

Deletes the currently applied map. The field mappings are not changed.Delete

Specifies the type of project element that each row in the text file represents. For most
import locations, this drop-down is disabled as there is only one valid element type that

Import As

can be imported. For example, if you choose to import into the Actor List, then the
Import As drop-down will be disabled and only Actors will be imported.
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DescriptionOption

Shows the fields found in the file and the element attributes that they map to. If "First
line is a header" was not checked in the import dialog, then the first column will name

FieldMapping

the fields "Field 1", "Field 2" etc. If "First line is a header" was checked, then the values
of the first line will be read and listed in this column instead. For each field you must
choose an appropriate attribute to map to from the "Maps to" column. Each cell in this
column is a drop-down from which attributes of the "Import As" element type can be
chosen. A special "Not Mapped" option (in italics) allows you to specify that the data
in this field should be ignored. Other choices are either in bold or regular font. Bold
specifies that one field must be mapped to this attribute, regular font indicates that one
field may be mapped to this attribute. You cannot map more than one field to the same
attribute, if you try to do this an error box will inform you.

Enabled when all of the required attributes are mapped (i.e. the bold options in the
"Maps to" list). It processes the import and displays a progress bar.

Import

Cancel the import and return to the main window.Cancel

NOTE

• When importing steps, it is possible to map a field to a scenario name. If that scenario does
not exist in the requirement, it is silently created.

• Likewise, for steps, the actor attribute may be mapped. This will silently create actors if they
do not exist already. In the same way Structured Requirement goal levels may be silently
created.

• If the element type being imported can have custom properties, they will appear in the
drop-down "Maps to" option list. If a mapping for a custom property is specified, and the
map is saved and applied later to a subsequent import for which the custom property is
invalid, the custom property mapping is ignored. Custom property bound values will be
silently created as they are encountered in the file.

• The Field Mapping table lists the fields found in the file. This is determined by the first line
in the text file only. Make sure the first line contains the correct number of fields.

• As lines are processed, only the first line's number of fields will be used. If there are more
fields on a line than found on the first line, the extra fields are ignored. If there are less fields
than found on the first line, the missing values are assumed to be blank.

• If a field on a specific line found or determined to be blank maps to a bold attribute (e.g.
Actor Name) then the value will default to "Unknown".

• If an element to be imported has the same name as an existing element, then a copy is created,
the existing element is not overwritten. For example, if an actor "System" is imported, then
actor "Copy of System" is created.

• While importing, a progress dialog appears with a Cancel button. Pressing cancel stops
further imports, any imports already processed will remain. To undo imports, either us the
undo facility, or do not save the project.
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Import Microsoft Office Word Document
Use this option to import project data from a Microsoft Office Word document. This is useful
if you would like to extract data from an existing requirements document developed outside of
Optimal Trace. Because such documents can have a wide variety of formats, Optimal Trace
does not mandate any particular document style. Instead, Optimal Trace includes a tool by which
you can annotate or markup a document indicating which parts should be associated with which
project elements.
To import a Microsoft Word Document:

1. Open the document through Optimal Trace.
2. Mark up document regions as project elements using the Doc Import Markup tool.
3. Import the document and merge the marked elements with the open project.
4. Repeat step 2 to fix any errors or omissions.

Open the Document to Import
The Import Word Document option is only available if an existing project or project element
is selected in the tree. On choosing the option, a standard file chooser dialog appears prompting
for the document that should be imported.
Navigate to the document to import and click Import.

Mark up the document
After choosing the document, Microsoft Word is launched, and the document is loaded up. A
special window called the Optimal Trace Markup tool appears floating over the document. This
wizard-like tool is a Word add-in that is used to add the markup annotations to the document.
These are special Microsoft Word comments that Optimal Trace recognizes when the document
is subsequently read by the merge process. Comments must be added by using the markup tool.
If they were added in error, or need to be altered they can be removed using the tool, or by
deleting them directly in Word.
To mark a project element, comments must be added to the document to mark:

• The element start

• The element end

• Each element attribute

The following dialog boxes facilitate marking up the document:

• Specify the type of project element to be marked up using the Element Chooser dialog box.

• Mark the boundaries of the element using the Start/End dialog box.

• Mark the attributes using the Attributes dialog box.

• For advanced use, the Find Similar dialog box is available to guess the locations of other
elements or attributes in other parts of the document based on one that has already been
marked up.
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Element-Chooser Dialog Box
The following figure and table describe the features of the Element Chooser dialog box:

Figure 6. Element Chooser dialog box

Table 9. Element Chooser Options

DescriptionItem

Click to display a floating Help screen, which contains quick instructions for
whatever dialog is currently onscreen.

Quick Help

This list shows all the different project elements that can be marked up in the
document. Choose the one you want to mark.

Select the Element
Type to Mark

Advance to the Start/End dialog box to define the boundaries of a new element.Mark New

Launches the merge process and imports the currently marked up elements into
Optimal Trace. Microsoft Office Word and the markup tool remain active and
you can return to them after the merge is done.

Merge

Launch the merge process for the last time to import the marked up elements
into Optimal Trace. Microsoft Office Word and the markup tool will shut down.

Import Complete

Forwards to the Start/End dialog box with the editing context set to the element
that is closest to the cursor.

Edit>Edit Element
at Cursor

Convenience feature to remove all Optimal Trace markup comments in the text
selected in Microsoft Office Word.

Delete>Delete
Selected Markup

Remove the markup comments for the element closest to the cursor, including
the start and end comments, and any attribute comments.

Delete>Delete
Element at Cursor

Start/End Dialog Box
This dialog box allows you to mark or move the starting and ending points of an element to be
imported. To use this dialog, move the insertion point in Microsoft Office Word to the point
that marks the start of the element and click theMark Start button. A start comment will be
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added to the document, and the starting text will appear in the area between theMark Start
andMark End buttons in the tool.

Figure 7. Start/End Dialog Box

To mark the end of the element, move the Microsoft Office Word insertion point to the ending
point of the element in the document, and click theMark End button. The tool will create an
Optimal Trace end comment at this point in the document:

Figure 8. End Comment

From the Start/End dialog box, the following other buttons and controls are available:

Table 10. Start/End Dialog Box Options

DescriptionOption

Enabled after an attribute is marked and forwards to the Find Similar dialog
box by which similar attributes of other elements are inferred in the document.

Find Similar

Mark attributes in the element that has been marked up using the Attributes
dialog box.

Next

Return to the Element-Chooser dialog box. Any start or end comments that
have been marked up already will remain marked up.

Back

Launches the merge process and imports the currently marked up elements
into Optimal Trace. Microsoft Office Word and the markup tool remain active
and you can return to them after the merge is done.

Merge

Launch the merge process for the last time to import the marked up elements
into Optimal Trace. Microsoft OfficeWord and the markup tool will shut down.

Import Complete
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DescriptionOption

Forwards to the Start/End dialog box with the editing context set to the element
that is closest to the cursor.

Edit>Edit Element at
Cursor

Convenience feature to remove all Optimal Trace markup comments in the
text selected in Microsoft Office Word.

Delete>Delete Selected
Markup

Remove the markup comments for the element closest to the cursor, including
the start and end comments, and any attribute comments.

Delete>DeleteElement
at Cursor

NOTE
You can also edit or delete marked-up elements by right clicking on the comment, and choose
Edit or Delete from the menu.

Attributes Dialog Box
After marking the start and end points of an element, the element is set to be the editing context.
This means that when Next is pressed, the attributes dialog which appears allows you mark the
attributes of that element.

Figure 9. Attributes Dialog Box

To mark an attribute, first select the attribute to mark from the list on the dialog then drag-select
the area of text in the document that represents the value of the attribute. Finally, click theMark
button on the tool. A comment will appear in the document marking the attribute. This should
be repeated for all attributes. Comments added to the document by the import tool are color
coded by element. In the following figure, for example, all comments relating to the 'Word1'
glossary entry have the same color.
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Figure 10. Attributes Selection

It should be noted that attributes need not necessarily be marked within the start and end points
of their associated element. However it is recommended as a best practice (and to avoid confusing
yourself in a large document) that the start and end points are placed so that they encompass all
the attributes of the element.
It should also be noted that the user is permitted to mark the same attribute twice. This is to
facilitate cases where the attribute is dispersed across different locations in the document. Upon
import, multiple mark-ups of the same attribute are concatenated into one single value.
The following other buttons and controls are available from the attributes dialog:

Table 11. Attributes Dialog Box Options

DescriptionItem

Enabled after an attribute is marked and forwards to the Find Similar dialog
box by which similar attributes of other elements are inferred in the document.

Find Similar

Indicates you are done marking up the element, and returns to the
Element-Chooser dialog box.

Done

Return to the Element-Chooser dialog box. Any start or end comments that
have been marked up already will remain marked up.

Back

Launches the merge process and imports the currently marked up elements
into Optimal Trace. Microsoft OfficeWord and the markup tool remain active
and you can return to them after the merge is done.

Merge

Launch the merge process for the last time to import the marked up elements
into Optimal Trace. Microsoft Office Word and the markup tool will shut
down.

Import Complete

Forwards to the Start/End dialog box with the editing context set to the
element that is closest to the cursor.

Edit>Edit Element at
Cursor

Convenience feature to remove all Optimal Trace markup comments in the
text selected in Microsoft Office Word.

Delete>Delete Selected
Markup

Remove the markup comments for the element closest to the cursor, including
the start and end comments, and any attribute comments.

Delete>Delete Element
at Cursor
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Find Similar Dialog Box
Since documents to be imported can be large and complex, it can take a long time to mark them
up by hand. For this reason, the markup tool offers the Find Similar dialog box which can
rapidly scan a document to find other candidate regions of the document that match the format
or style of an existing marked up area. This can dramatically increase the effectiveness of the
document import process.

Figure 11. Find Similar Dialog Box

It is not necessary to use the Find Similar dialog box. Everything can always be marked-up
and tagged one-by-one, using the other dialogs. It is also more complex to learn and use. But
in such cases as documents containing large tables, it can save many hours of work. There are
two different ways that the Find Similar process can be started:

• To find the boundaries of similar elements, click the Find Similar icon on the Start/End
dialog box.

• To find attributes of similar elements, click the Find Similar icon on the Attributes dialog
box.

In both cases, the dialog box can only be summoned after an element or an element attribute is
marked up. This is called the source element or the source attribute, and is the template which
is searched for in other parts of the document. There are a number of methods that the Markup
tool uses to infer or guess matching regions of the document. Depending on the source, some
methods may not apply. For instance, the "Table Row Selected" applies only if the source is a
complete table row. If this is true, then every subsequent table row is guessed as a match. For
example, the figure below shows the selected source element is a glossary item which covers
a complete row in a table:
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Figure 12. Find Similar Example

Here it is clear that the other rows in the table are also glossary entries. On clicking the Find
Similar "magic wand" button, the dialog appears and, indeed, it instantly guesses that the other
three rows are also glossary entries:

Figure 13. Find Similar Results

Here the other three rows are outlined with temporary markup comments in another colour. The
information area in the Markup tool indicates that three similar areas were found. At this point,
one of the following options can be selected:

Table 12. Find Similar Dialog Box Options

DescriptionOptions

If any temporary Candidate comments are incorrect, they can be removed
at this point by either using the 'Delete' menu or by right-clicking on

Remove Incorrect Temporary
Candidates

them and choosing Delete. Sometimes, for example, not every Row in
a table is a Glossary Item.

Accepts each of the candidate regions and converts them into full marked
up elements. The Markup tool returns to the previous dialog, either the

Mark Them

Start/End dialog box or theAttributes dialog box, depending onwhether
the source was an element or an attribute, respectively.
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DescriptionOptions

Discards the currently active candidate regions, and tries to match the
source again using the next different method, if available. The "(1 of 2)"

Try Again

text indicates how many search methods are applicable to the current
source area.

Return to the Element-Chooser dialog box. Any start or end comments
that have been marked up already will remain marked up.

Back

Launches the merge process and imports the currently marked up
elements into Optimal Trace. Microsoft Office Word and the markup
tool remain active and you can return to them after the merge is done.

Merge

Launch the merge process for the last time to import the marked up
elements into Optimal Trace. Microsoft Office Word and the markup
tool will shut down.

Import Complete

Forwards to the Start/End dialog box with the editing context set to the
element that is closest to the cursor.

Edit>Edit Element at
Cursor

Convenience feature to remove all Optimal Trace markup comments in
the text selected in Microsoft Office Word.

Delete>Delete Selected
Markup

Remove the markup comments for the element closest to the cursor,
including the start and end comments, and any attribute comments.

Delete>Delete Element at
Cursor

The Optimal Trace Markup tool uses several different methods to guess similar areas to the
source element or attribute elsewhere in the document. These candidate areas are always found
in the document beneath this source area. Depending on the style and formatting of the source,
some methods may be applicable and some may not. The following is a list of the different
methods, when they are applicable, and what they search for.

Table 13. Markup Tool Search Methods

What it will match:Applicable when the
source area matches:

Method name

All rows in the same table below the sourceAn entire table rowRow Selected in
Table
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What it will match:Applicable when the
source area matches:

Method name

All cells in the same column in the same table below
the source

A single table cellTable Cell Selected

All peer sections below the source section. For
example, if the source is section 2.2, then this method

An entire section, including
the heading

Entire Section
Selected

will match sections 2.3, 2.4, 2.5 etc., but will stop
when section 3 is encountered.

All peer section headings, as above.A heading, but no other text
from that section.

Heading Selected

All peer section contents, as for Entire Section
Selected, but excluding the headings.

An entire section, except
the heading

Heading Omitted

The nth paragraph of each peer section below the
source. For example, if the fifth paragraph of section

The nth paragraph within a
section

Nth Paragraph
Selected

5.1.2 is selected, then this method will match the fifth
paragraph of sections 5.1.3, 5.1.4, etc. until section
5.2 is encountered.

All subsequent bulleted items in the same list.A bulleted item in a listBulleted Item
Selected

All subsequent numbered items in the same list.A numbered item in a listNumber List Item
Selected

All areas in the current section with the same font.
Font is matched on font Name, Size, Bold, and Italic.

A paragraph or part of a
paragraph.

Lines With Same
Font

Collectively, these methods should cope with a wide variety of document formats and styles.
The more logical a document structure, and the simpler the layout, the more effective they will
be. In the event that documents are overly complex or poorly organized, they will be less
successful, and there may be no alternative other than manual markup.

Microsoft Office Word Import Tips
There are a number of techniques and tips which can prove useful when dealing with particular
import situations:

Marking up Project attributes
If you need to mark up project attributes such as Project Name, Description etc, you
should mark up a project element and then mark up the attributes, for example:

1. Select the entire document, using [Ctrl-A].

2. Create an element of type Project.

3. Click Start and End to mark up the start and end of the document as the start and
end of the project.

4. Click Next and proceed to mark up the project name, description etc.
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Find Similar Areas Usage
The recommended approach to use when marking up similar areas is to match the
Start/Ends first, then move on to matching each attribute. It is usually much simpler and
clearer as to what is going on. If you mark just one Start/End, and then move to the next
screen and Find Similar different Names, then you may get confusing results on import.
The tool will attempt to find an owner Element for all of the 10 Names, but there is only
one Start/End Element that it can use. The recommended approach is as follows:

1. Mark the start and end of the element you wish to mark up.

2. Click the Find Similar Areas button and mark up the areas that match the start and
end of the selected element.

3. For the element marked up in step 1, mark up an attribute.

4. Click Find Similar Areas again to mark up similar text in the document for that
attribute.

5. Repeat steps 3 and 4 for any other attributes you wish to mark up. Once you have
completed these steps, you will have successfully marked up several elements of the
same type and their attributes.

Convert Text to Table and then use Find Similar
If you are having trouble using Find Similar Areas to mark up similar areas of text, try
converting the text to a table by going to Microsoft Office Word, and click
Table>Convert>Text to Table. Then use Find Similar areas to match up the areas of
the table.

Find Similar Areas and Headings
The Find Similar Areas feature can be used to automatically mark up headings at a
similar level. However this will only work correctly if all headings in the document use
an appropriate MS Word style. For example, top level headings should have a 'Heading
1' style etc. Frequently,Word users change the font and formatting to create 'roll-your-own'
Headings. So instead of using a Heading 1 style, users apply a large font and turn on
Bold. Then the Find-Similar 'search for Headings' will fail. The solution is to hold down
Ctrl and select all the bits you want to match, then apply a proper Heading Style to all of
them. (Use the Styles dropdown in the Word menu bar, or click Format->Styles and
Formatting to display the Styles pane). Once all these areas have a proper Heading style,
find similar will detect this and match them. Note that Find Similar areas will only search
within the current chapter in the document. For example, if you mark up all of a section
in a document, and use find similar areas, it will highlight sections 5.2, 5.3, etc., however
it will not highlight sections 6, 6.1 etc. If there are no Headings in the document, you can
simply add some. It helps the Find Similar methods by giving them some structure to
work with. A large document with no headings will take the search methods a lot of time
to work through. You can delete the Headings afterwards if you wish.

Using 'LinesWithSameFont' to match otherwise unmatchable areas
Suppose you wish to match a number of sentences scattered throughout a large table. The
sentences are not consistently organized or positioned, and hence none of the Find Similar
search methods work. A very useful technique is to hold down CTRL, select the source
area, and then multi-select all the other areas you wish it to find. Then go to the Font
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dropdown in theWordmenu bar and select an unusual font, one that is not is use elsewhere
in the doc. Now click Back, if you are on the Find Similar window. Then click the magic
wand button again. This time, the 'LinesWithSameFont' method should successfully find
all the target areas.

Save your document often
It can be very useful to save copies of the document throughout your mark-up section,
e.g. "My Doc.doc", "My Doc2.doc", "My Doc3.doc". This can be useful if you wish to
import a certain section into many projects. For example you may have marked up a
section of a document to import to the glossary, if you save the document, for example
"MyDoc - Glossary.doc", you can import these markup elements into the glossary section
of many projects.

How to mark up a table column
If a user selects a column in a table and attempts to mark it up, only the final cell in the
table will be marked-up. Note this is due to a restriction in MS Word. There is a
workaround as can be seen in the following example. To mark up the contents of a column
as a requirement description:

• Mark the entire table as a requirement, i.e. mark 'Requirement Start' at the start of the
table, and 'Requirement End' at the end of the table.

• Click on 'Next>' and mark the top most cell in the target column as 'Requirement
Description'.

• Click on the 'Find Similar' button. It should highlight every cell below the top one.

• Click on the 'Mark' button to mark all these highlighted cells.

Here, we are exploiting the fact that multiple appearances of the same Attribute get
concatenated upon import. This is to allow dispersed chunks of text to be imported into
"Project Description", for instance. The text in all the marked-up cells will be concatenated
into the requirement description when the document is imported.

Sort and Split up mixed Tables
If a table contains both Requirements and Sub-Requirements (i.e. Items) interspersed
with each other on different rows, then Find Similar won't differentiate the two types.
The trick here is to sort the table, by whatever column is appropriate, so that all the
Requirements are together and all the Items are together. Then, split the table into two.
The Word menu item to do this is Table->Split Table. One new table will contain only
Requirements and the other will contain only Items. Next, Find-Similar the 2 tables and
mark up all their Rows and Cells, as Requirements, Items, and the respective attributes
for each of them. Finally, combine the two tables back into one, and sort by a column
that will recover the original ordering. (If there is no such column, it is possible to add
an extra dummy column containing the numbers 1...rowcount, before sorting and splitting
the table). This tip can generalize to any table containing mixed types.

Merging from the Markup tool
All dialogs on the markup tool provide two buttons to view the results of the marking up process:

• Merge: Show interim result in Optimal Trace.
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• Import Complete: Show result in Optimal Trace, and quit the import process.

In both cases, the marked up elements are not imported directly into Optimal Trace, instead, a
merge screen appears allowing you to preview the contents of the import before accepting it.
If you merge the same elements more than once, Optimal Trace does not create duplicate
elements, instead, it will remember the originally imported element, and apply any changes to
it.

Microsoft Office Word Security Settings
The Optimal Trace Document Import Tool requires that the Microsoft Office Word Macro
Security level is set to a maximum of Medium for versions 2007, 2003, and 2000. This can be
set in theMacro Security settings screen. For example, in Word 2003, this screen is accessed
via theTools>Options screen. ForMicrosoft OfficeWord 2000 you also need to have theTrust
all installed add-ins and templates option selected on the Trusted Publishers tab. The
Document Import Tool has been digitally signed. Upon launching, Microsoft Office Word
may ask whether it should trust the software. It will present details of the digital certificate,
which is issued in the name of Micro Focus, and indicate that the signature is OK. You can
safely click always trust content from this publisher.

Saving an Image File
Use this option to save an image file for what currently appears in the Requirement map and
Flow views. To save an image for a specific flow, select that flow and the saved image will
correspond to the currently displayed flow.

• Click the Requirement or Package you want to save an image of

• From the menu bar, click Project>Save Image and a save screen will appear.

The save file type will typically default to.jpg for a JPEG file. You may alternatively choose
to save in a number of other common formats including BMP, TIF etc.
Images can be saved as either the entire image or else for larger images you may want to split
the image across pages, creating different image files. To set this option, selectOptions>General
Options>Split Images across Multiple Pages/Files. You may save this image wherever you
want. Later, you can click on the image file in Windows Explorer and the image will appear on
your screen.

Exiting a Project
Use this option to exit Optimal Trace. Click Project>Exit to close the program.

NOTE
If changes have been made since opening any project(s) or if you have any unsaved changes,
the system will prompt you to save any outstanding changes prior to shutting down.
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C H A P T E R 3

Optimal Trace Projects

The Optimal Trace screen is split into six different views, namely the Tree view, the Thumbnail
view, the Query view, The Traceability view, the Details view and the Right Pane view. The
Tree view contains the list of currently opened Projects and their respective contents. Each
Optimal Trace Project consists of: Actors, Glossary entries, Requirement Packages and
sub-packages, StructuredRequirements comprising scenarios and steps, and Simple Requirements
comprising items.

Project Properties
When a project is first opened, its properties are displayed in the Right Pane view. Some of
these are editable and include:

• Project Name - the name of the project

• Creator - this defaults to the login name however it can be changed

• Description - a description of the project

Non-editable properties include:

• Created On - the date and time that this project was initially created

• Location - the file location on your hard disk or on a network drive

• Baseline - the current project baseline

Project Non-Functional Requirements
Non-functional requirements can apply either at the project or discrete structured requirement
level. The latter means that the quality or constraint applies just to that structured requirement,
the former means that the non-functional requirement is project wide. Non-functional
requirements fall into two categories:

• Qualities: qualities specify criteria for which the Project or Structured Requirement must
guarantee. The Withdraw cash Requirement might have the quality that the machine is
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available 24x7 with acceptable downtime or that 95% of time receipts must be capable of
being issued.

• Constraints: examples of constraints might be that the Requirement must interact with a
specific protocol for data interchange, e.g. EDI (financials), EMI (Telco billing) or newer
standards such as ebXML etc.

Non-functional requirements must be unique by Description as qualities typically fall into
categories that can be repeated.
To access these, click on theNon-Functional Requirements tab. Just as Subjectmust uniquely
identify Notes, Non-functional requirements must be uniquely identified by description. Each
Non-functional requirement comprises:

• Category: a piece of text specifying the type of Non-functional requirement

• Non-functional requirement: a description of the actual Non-functional requirement

• Priority: a text field for you to place prioritization information.

NOTE
Non-functional Requirements can have one or more associated Custom Properties defined. To
see or modify the current set of custom properties click on the button.

Project/Requirement Links
In Optimal Trace, Links can be created at a number of levels:

• Project

• Structured Requirement

• Simple Requirement

• Simple Requirement Items

Links are used to associate two types of entities at these levels.
Any file or URL references/artifacts such as documents, graphics, URLs, Visio files, Excel
spreadsheets etc. can be associated with the project or specific requirements using a link. Trace
Links can be created to set-up Traceability relationships from one Optimal Trace project element
to another either within the current project or to an element in a different local (file) or repository
based project.
Links can be associated with Simple Requirement Items. Unlike Project/Requirement Links,
Simple Requirement Links cannot be expanded in generated documents. Each Link has a name
and description. If a linked file cannot be resolved or found at the location specified, then that
link is displayed in red.

Table 14. Link Properties

DescriptionItem

The name that you wish to call this Link, each Link name must be unique.Link Name
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DescriptionItem

This is the actual file name, URL or Optimal Trace 'Traced to' Project Element
for this Link.

Link Location

This is a visual cue indicating the type of element that is stored on the links.Icon

File and URL (web) based Links
File based Links are intended as a convenient mechanism for associating miscellaneous
information pertinent to a given requirement or the project as a whole. For example, you may
wish to store a Link to domain-specific information such as a healthcare standard document, a
government web site Link, or a sample screen shot.

• Click on the Links tab to access Links associated with the current Project or selected
Requirement.

• For Simple Requirement Items, click the button to the right of the selected item.

• To create a new Link click on the button and a new blank Link is created.

• To edit the Link location you can either edit the location field directly into the text field or
click on this Link button and a file chooser will appear. Navigate to the specific area and
select the appropriate file then click on the Open button.

The Link information is then updated in Project's Links area.

Figure 14. Project Level Links
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NOTE
User Interface Storyboards. Optimal Trace is very suitable for supporting Storyboards and
generating attendant documentation. You can associate storyboards with specific Structured
Requirements.When you generate documents, the screenshots are then embedded in the generated
document providing an excellent basis for communicating to stakeholders especially on the
Business side. Note that Links attached to Items are not expanded in the generated documentation.

Traceability Links
The second category of Links that can be created are Trace Links, these are Links to Optimal
Trace project elements. These allow any requirement or project element to be referenced as a
link associated either with the project or else with a given requirement. The process of creating
a link is similar to establishing a file-based link.

• Click on the Links tab to access Links associated with the current Project.

• Create a new Link by clicking on the button.

• The Link Location now needs to reference a given Optimal Trace element. A screen appears
allowing you to specify the given element that is being linked to.

• Select the element you want to link to and hit Apply. You can also automatically create
reverse links by checking the box.
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Figure 15. Element Trace Link

NOTE
As an alternative way of creating Trace links, you can also create Trace Links between elements
by copying URIs. In this case, the reference is created by copying the element reference via the
'Copy as Link (URI)' pop up menu. Once the reference has been copied to the clipboard, then
that reference is entered (by pasting it into the field) into the Location field of the link.

Project/Requirement Notes
Notes can be created at the project or discrete requirement level (structured and simple). The
latter means that the note is associated with the selected requirement, the former means that the
note is relevant to the entire project. Each Project or Requirement can have any number of Notes
associated with it. Click on the Notes tab to access Notes. Notes contain two fields:

• Subject: A piece of text specifying the type of Note. Each Note must have a unique Subject.

• Note: A description of the Note itself.
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Custom Properties
Projects can be created with custom properties defined for all different types of elements, e.g.
Project, Package, Structured Requirement, Simple Requirement etc. They can be customized
to hold data specific to the needs of different roles or objectives. For example, project managers
might require Requirement level custom properties of Business Priority, Increment etc., while
technical architects and QA stakeholders might want to see properties such as: Technical Risk,
Functional Tests Defined etc. associated with Simple Requirement Items. Custom Properties
can be set as either freeform or 'bound', the latter meaning you can select from one of a list of
predefined values. Custom properties can be created for all major project element types covering:

• Project

• Glossary Entries

• Actors

• Packages

• Structured Requirements

• Structured Requirement Scenario Steps

• Non-functional Requirements

• Simple Requirements

• Simple Requirement Items

In Optimal Trace, Custom Property definitions are accessible from:

• The context that the Custom Property is related to, typically via a button located in a toolbar
adjacent to the relevant element

• A centralized Settings tab at package or project level.

Custom Properties can be specific to a given package, meaning that the structure of the custom
properties is particular to requirements contained in that package. So, to outline how all of this
works, let's consider Project level custom properties. In this case, a number is defined at the
project level including Business Case, etc.
Clicking on the… brings up a Custom Properties dialog box.
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Figure 16. Project Level Custom Property Settings

You can now add, remove or modify existing Custom Properties from this screen. Defining
Custom Properties for all element types in Optimal Trace works in exactly the same way using
this screen.

• To add new custom properties click on the Add Properties button. This will insert a new
custom property. When working in a repository-based project the result of adding a custom
property is that all instances of that element in the project (Requirement etc.) acquire a lock.

• To remove an existing custom property, select the custom property by clicking on the grey
square to the left of the entry and click on the button. This will remove the custom property.
When working in a repository based project, the result of removing a custom property is that
all instances of that element in the project (Requirement etc.) acquire a lock.

To define a Custom Property as Bound, click on the checkbox to the right of the property. A
… button appears in the right-most cell of the table for this custom property. You will then be
able to add or remove given bound items by clicking the buttons.
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Figure 17. Sample Bound Values

A sample set of Custom Properties at Item Level appears in the following figure showing at
Item Level indicated by the red boundary.

Figure 18. Custom Properties showing at Item Level indicated by the red boundary
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Custom Properties and Sharing
Optimal Trace provides a very flexible mechanism for customizing projects at all levels. This
is possible using Custom Properties defined either at project wide level or specific to given
packages of requirements. You may customize the definition of the set of custom properties at
package level or a given package may share it's parent package/project's Custom Property set.
Sharing of Custom Property definitions can be done by checking the 'Share Custom Properties
with...' checkbox in the settings tab of a given package.

Figure 19. Package settings

In order to do this, you select the package, click on the 'Settings' tab. On this tab there is a 'Share
Custom Properties with' checkbox, which is checked by default (except in the case of the root
package in new projects). If you uncheck this checkbox, the package will no longer use the set
of Custom Properties defined by the parent, rather it will have its own set of independent Custom
Properties that will apply to all elements within that Package and possibly all child Packages.
For example, you may have a package entitled 'Out of Scope' which contains requirements that
are out of scope for the current release. Uncheck the Share Custom Properties with check
box. You can add a Structured Requirement level Custom Property called 'Planned for Release'
to this package by clicking on the 'Structured Requirement Custom Properties' button, and
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adding the Custom Property as before. Now only Structured Requirements created in the 'Out
of Scope' Package will have this Custom Property. If you decide at a later time that you want
the 'Out of Scope' Package to share the same Custom Properties as the rest of the Project, you
can re-check the 'Share Custom Properties' checkbox. Any Custom Properties defined in the
'Out of Scope' Package that are not defined as Custom Properties in the rest of the Project will
be removed. In the example above, re-checking the 'Share Custom Properties' check box will
mean that the 'Planned for Release' attribute is removed for all Structured Requirements in the
'Out of Scope' Package.

NOTE
To previous users of Optimal Trace. By default, when you defined a set of custom properties
in previous releases, those custom properties applied to all elements of that type created within
that project. For example, if you created a custom property called 'Technical Risk' for Structured
Requirements, every Structured Requirement in the project will have an attribute called 'Technical
Risk'. In most cases, this will satisfy the needs of your project, as typically you would tend to
capture the same information for all Requirements in your project. However there may be times
when you would like to have a different set of Custom Properties for a part of your project. For
example you may have a package entitled 'Out of Scope' which contains requirements that are
out of scope for the current release. In Optimal Trace you can for example now define a Custom
Property called 'Planned for Release' that will apply to Requirements contained in the 'Out of
Scope' package only.

Modifying Custom Properties and Locking Implications
When working online, any modifications to custom properties result in all dependent elements
acquiring a lock. Consequently, you will see a green lock icon appear next to any such elements.
For Packages, Requirements and any elements that can have Custom Properties defined, since
modifying a specific element will affect the underlying structure of all instances of that element,
you must have exclusive access to those elements prior to any modification. As an example, if
you attempt to modify the Custom Property of a 'Requirement' and another user is currently
editing any requirements in that project that use that Custom Property, then you will be unable
to perform the modification and will receive a message.

Project Settings
The settings for a Project are used to apply default values for Requirements created in the Project.
For Project Templates the settings specify values that will be applied to projects created from
those templates. To access the project settings, click on the Settings tab.
There are three sets of settings available for Projects and Project Templates:

• Goal Level

• Numbering Policy

• Custom Properties
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Goal Levels Settings
To access the Default Goal Level setting click on the button adjacent to the Default Goal Level
text. You can specify settings for the Default Goal Level; this is the goal level that will be set
whenever newRequirements are created. Goal Levels are used to specify the level of abstractness
or concreteness of a Requirement; refer to Alistair Cockburn [1].

• To edit an existing goal level for a Project, select its Name/Description and change it. If an
edited level is already in use by another Requirement, the corresponding Goal Level text
will be altered accordingly.

• To add your own new goal levels click on the Add Goal button.

• To remove a Goal Level, click on the Remove Goal button.

Figure 20. Project Specific Goal Levels screen

Table 15. Project Specific Goal Levels screen

DescriptionColumn

Click the option to set as the default Project Specific Goal Level.Default

Name of the Project Specific Goal Level.Name

Description of the Project Specific Goal Level.Description
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Numbering Policy Settings
Optimal Trace projects can have one of three types of numbering policies as outlined in the
following table. Numbering Policies affect the handling of requirement numbering in a given
project.

Table 16. Numbering Policy Settings

DescriptionNumber Policy

The Package/Tag policy means that when a new package is encountered with
a different package Tag then the numbering starts at 1. This is the default policy
in Optimal Trace Project Templates

Package/Tag Based

The Project Based policy means that all Requirements are numbered uniquely
across the project and specifically across packages.

Project Based

The Package Based policy means that Requirement numbering is reset to 1
when a new Package is encountered.

Package Based

Custom Property Settings
Projects can be created with custom properties defined at all element levels. Custom properties
can be created for projects, glossary entries, actors, packages, requirements, requirement scenario
steps, non-functional requirements, simple requirements, and simple requirement items. For
more information, see Custom Properties [p. 54].

Defining Glossary Items
It is important to define Glossary Items during a requirements gathering exercise as they provide
the common definitions as understood by domain experts.

• To define Glossary entries, under the Project click the Glossary icon. A list of Glossary
entries appears in the Right Pane view.

• You can add or remove entries by clicking the buttons in the Tool bar.

• Clicking Add allows you to add an entry.

• To remove an entry, highlight the Glossary item by clicking the button to the left of the
entry (shaded grey square) and then click on the Delete button.

Each entry consists of a name (unique within a Project) and description. It is also possible to
edit entries by clicking on the text and adjusting accordingly.

NOTE
Glossary Entries can have one or more associated Custom Properties defined. To see or modify
the current set of custom properties click on the Properties button. For more information, see
Custom Properties [p. 54].
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Defining Actors
Actors are entities that interact with a system.

• To define a newActor, under the Project click on the Actor List icon. A list of Actors appears
in the Right Pane View. Optimal Trace ships with one default Actor, the system.

• You can add or remove Actors by clicking the buttons in the Tool bar. Click on the add actor
button to add an Actor.

• To remove an Actor you must highlight the Actor by clicking the button to the left of the
entry and then click on the delete actor button. If you try to delete an Actor, which is
associated with a Step in a Requirement, then Optimal Trace will confirmwhether you really
want to delete the Actor. If you clickYes, then all of the associated Steps will be disassociated
from the deleted Actor.

Each Actor consists of a name (unique within a Project) and a description. You may edit Actors
by clicking on the text of their names and descriptions, and adjusting them accordingly.

NOTE
Actors can have one or more associated Custom Properties defined. To see or modify the current
set of custom properties click on the Properties button. For more information, see Custom
Properties [p. 54].

Packages
Packages provide a way of grouping related sets of Requirements. These can be edited by
clicking on the Package Node in the tree view and modifying them in the details area to the
bottom left of Optimal Trace. There is no restriction on the number of nested Packages that can
exist. Packages are useful when segmenting a Project into logical units. They can also be used
to specify incremental delivery units for a system. Every Project always has at least one Package,
namely the default Package labeled Requirements if created from the empty project template.
This root package housing all other Packages & Requirements cannot be deleted. Packages can
contain more packages. Requirements can be either structured, meaning they are comprised of
scenarios and steps or non-structured meaning they are either a quality or constraint type
statement.

Package Details
Each Package has the following:

• Package Name - the name of the Requirement. For example:Withdraw Cash.

• Package Tag - a tag for all requirements within the package.

• Package Description - a fuller description of the objectives of the Requirement.
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Package Tags
Package level requirements can have their own specific 'Tag'. This means that each package
can be dedicated to a specific 'Type' of structured requirement indicated by the tag. For example,
you might choose to store all your Business Process flows in one package with tag 'BP', while
a sibling package might store the corresponding detailed Software Requirements with tag 'SR'.
Alternatively Product Managers might choose to place all Product Feature Requests in one
package with tag 'FR', and detailed Requirements in a second package with tag 'DR'.

Package Custom Properties
Custom properties can be defined for Packages. This means that each Package can be set up to
hold data associated with the package. Custom Properties can be set as either freeform or 'bound',
the latter meaning you can select from one of a list of predefined values. Package Level Custom
Properties behave in exactly the same way as Project Level Custom Properties. For more
information, see Custom Properties [p. 54].

Package Settings
The Package Settings area allows you to configure whether this Package shares Custom Property
definitions with its Parent package (or Project if it's the root package), or if it has its own set of
Custom Property definitions. For more information, see Custom Properties [p. 54].

Structured Requirements
Structured requirements outline objectives or goals (and their detailed scenarios and steps)
whereas non-functional requirements cover system qualities and constraints. A structured
requirement provides a mechanism for capturing functional requirements for a system in a
comprehensible and communicable way. A single structured requirement is a strand of
functionality that a system will ultimately deliver; a collection of requirements can express the
entire functional behavior of a system. Consider, for example, writing the specifications for an
Online Ordering System. You would formulate an individual requirement to satisfy each goal
for the system needs to provide for each user (an actor). Typical goals & requirements might
be: create an order, run reports, and view shipped orders. Taken together, a set of such
requirements constitutes an entire functional specification of the order system.

NOTE
Structured Requirements are an excellent way to support Agile, Use Case driven or Business
Process projects. From an Agile perspective you can think of a structured requirement as a
formalized 'Story' of how the system will provide value to the personas or users. From a use
case perspective, a structured requirement can be considered the detail of the use case. From a
Business Process perspective a structured requirement can be thought of as a documented
business process.

Structured Requirements Properties
Each Structured Requirement has a number of properties that help clarify its purpose and nature.
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Table 17. Structured Requirements Properties

DescriptionProperty Name

Name of the Structured Requirement. For example: Order GoodsName

A fuller description of the objectives of the RequirementDescription

Something that must have happened prior to someone being able to start
this Requirement. For example, in order toWithdraw Funds, the customer
(Actor) must have an ATM card to place in the machine.

Pre-condition

Something that is true on successful completion of the Requirement. For
example when withdrawing funds the success criterion is that the funds

Post-condition

are actually withdrawn and in possession of the customer and the
customer's bank account is debited.

These are automatically built as a result of specifying Actors with Steps
in the scenario.

Actors

The importance of the Requirement - this value typically reflects two
factors, one the importance of the Requirement from a customer

Priority

perspective and two the technical or logistical risk associated with this
Requirement

Level of abstractness of the Requirement. For more information, see Goal
Levels Settings [p. 59].

Goal-level

How the Requirement is started or invoked. For example for Withdraw
Cash this might be that the customer is low on cash and wants to buy

Trigger

some goods. Triggers are useful if the Actor is a non-human and represents
another system. A batch feed signal is a good example of a more common
trigger.

Requirement will guarantee to complete some functionality and this should
be specified here.

Minimum Guarantee

Structured Requirement Custom Properties
Custom properties can be defined for Structured Requirements. This means that each Structured
Requirement can be set up to hold associated data. Custom Properties can be set as either
freeform or 'bound', the latter meaning you can select from one of a list of predefined values.
Requirement Level Custom Properties behave in exactly the same way as Project Level Custom
Properties. For more information, see Custom Properties [p. 54].

Non-Functional Requirements
NOTE
In Optimal Trace 5.0, Non-Functional Requirements are deprecated. Users wishing to capture
Non-Functional type requirements, should use Simple Requirements instead.
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Each Requirement can have an arbitrary number of Non-functional requirements associated
with it. To access these, click on the Non-functional tab. Requirement related Non-functional
requirements behave in exactly the same way as Project Non-functional requirements.

Links in Structured Requirements
Links can be associated with Requirements as well as with Projects. These provide the ability
to associate documents, graphics, URLs, etc. with the Requirement. Click on the Links tab to
access the Links associated with a Requirement. Links at the Requirement level work in exactly
the same way as Project Links. For more information, see Project/Requirement Links [p. 50].

Notes in Structured Requirements
Each Requirement can have an arbitrary number of Notes associated with it. To access these,
click on the Notes tab. Requirement Notes are useful for storing miscellaneous
issues/clarifications to do with any aspect of the Requirement. They work in exactly the same
way as Project Notes. For more information, see Project/Requirement Notes [p. 53].

Requirement Main Success Scenario and Alternate
Scenarios

A Structured Requirement consists of a set of one or more scenarios each comprising a sequence
of sub-requirements or actions (Steps). Every Structured Requirement contains a Main Success
Scenario; the objective of this is to capture the Steps that will lead to successful completion of
the Requirement. For example, the Main Success Scenario of aWithdraw Funds Requirement
is that funds are successfully withdrawn. Structured Requirements may also include alternate
paths or scenarios. Alternative scenarios may result in achieving the overall requirement or may
mean that the Requirement is not successfully completed. Some examples of unsuccessful
completion might be an ATM machine being low on cash (Alt. Scenario: Machine Low on
Cash), or an account having insufficient balance (Alt. Scenario: Machine Low on Cash). In
these cases, the objective of the Requirement could not be met. Sometimes, a Structured
Requirement can complete successfully even if an Alternate scenario applies. For example, a
machine may not have appropriate denominations to satisfy the requested amount (Alt. Scenario:
Re-specify amount), but this will not prevent possible successful completion of the Requirement
namedWithdraw Cash.

Requirements Map and Flow Diagram View
The Requirement Map View shows the relationships between this Requirement and other
Requirements, including Refinement and branch relationships. A Requirement map looks similar
to the following figure. The Flow Diagram outlines the specific flow within a structured
Requirement. This is very useful for graphically outlining the scenarios, steps and distinct
sequential business rules that trigger deviations in the flow.
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Figure 21. Requirement Map with Scenarios
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Figure 22. Requirement Flow Diagram with Scenarios

Simple Requirements
Simple Requirements allow the capture of less complex Requirements, where the Requirements
tend to have a list structure. Examples where Simple Requirements would be particularly suitable
include:

• Data oriented requirements where the need exists to specify format information in a tabular
fashion.

• Marketing and other 'flat' requirements types where a tabular structure is common.

• Feature Lists for Product Managers that can be refined to more detailed structured
requirements if necessary.

• Standard non-functional requirements types such as scalability, redundancy, etc.

Simple Requirement Properties
Each Simple Requirement has a basic set of properties that help clarify its purpose. These are:

• Name - the name of the Simple Requirement
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• Description - a fuller description of the objectives of the Requirement

Simple Requirement Custom Properties
Custom properties can be defined for Simple Requirements. This means that each Simple
Requirement can be set up to hold associated data. Custom Properties can be set as either
freeform or 'bound', the latter meaning you can select from one of a list of predefined values.
Requirement Level Custom Properties behave in exactly the same way as Project Level Custom
Properties. For more information, see Custom Properties [p. 54].

Links in Simple Requirements
Links can be associated with Simple Requirements as well as with Projects. These provide the
ability to associate documents, graphics, URLs, etc. with the Requirement. Click on the Links
tab to access the Links associated with a Requirement. Links at the Requirement level work in
exactly the same way as Project Links. For more information, see Project/Requirement Links
[p. 50].

Notes in Simple Requirements
Each Requirement can have an arbitrary number of Notes associated with it. To access these,
click on the Notes tab. Requirement Notes are useful for storing miscellaneous
issues/clarifications to do with any aspect of the Requirement. They work in exactly the same
way as Project Notes. For more information, see Project/Requirement Notes [p. 53].

Requirement Item List
A Simple Requirement contains a list of zero or more Items. Items can be used to store any kind
of information related to the Simple Requirement, for example data attributes, sets of required
product features etc.
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C H A P T E R 4

Running Searches and Querying Projects

There are two core ways in which you can Query Projects:

Simple Query
Use the Simple Query to search for text within and across Projects.

Advanced Query
• Create queries based on conditions with 'And' and 'Or' support in a Query Builder

screen. You may want to display Requirements with High Technical Risk (query on
a Requirement custom property called 'Tech Risk') or show all steps that need to be
changed (querying on a custom property called 'Needs Change?')

• Clicking any query result row auto-highlights the occurrence within the context of the
loaded project for review.

• Save Queries Locally

• Share Queries with other Team members

• View Query Results as Publishable Web Reports

To perform a query, click on the Query tab or alternatively click on the button in the tool bar.
This then brings up the query tab.

Simple Query
Use the Simple Query to search for text within and across projects. The search is performed on
the currently selected project. Enter some text, "customer", to search for and then click Run.
After a few moments, the search results appear. You can also click Clear. This results in the
current result set being cleared from the Result List. The options available when running simple
queries are outlined in the following table.
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Table 18. Simple Query Options

DescriptionOption

This restricts the search to return only those results that match the case
of the text typed into the search box.

Match Case

This restricts the search to return only those results that match based
on a complete match in the attribute, e.g. if the text that is being
searched for is a partial match this would not be considered a match.

Match Exact

Checking this option means that a full search is performed across the
entire repository.

Search Repository

Checking this option means that a full search is performed across any
projects that are currently loaded.

Search All Loaded Projects

Figure 23. Running a Simple Query for 'Order'

Table 19. Query Result Columns

DescriptionColumn

The Project in which the found artifact lives. This is useful if you are
searching across multiple projects.

Project
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DescriptionColumn

The name of the element in the project where the match occurred.Name

The name of the attribute or property whose text matched the search criterion.Attribute

The text that was matched is displayed in red text.Match

This icon denotes the type of matched element (e.g. requirement, actor, etc.).Icon

Clicking on a search result line highlights the matched Project element (Requirement etc.) in
the context where it occurs. This provides an easy way to navigate straight to the results you
are interested in. This facility is useful when reviewing a number of search results where you
might want to update the Requirements for each result. In this context once a possible change
is made, you can re-run the search and a revised set of results will appear.

NOTE
Searching the repository. It is quite possible that over a period of time, reusable elements can
be identified in several different projects housed in the Optimal Trace Server repository. Typically
there can be quite a degree of similarity between several projects in a given organization. There
might for example be very similar login requirements etc. reflected as an 'Authenticate'
requirements. You may want to quickly 'bootstrap' new project initiates by reusing some
previously defined requirements (either requirements or non-functional requirements). To
facilitate this, Optimal Trace Enterprise allows searches across the entire repository and once
project hits are encountered for a given search term, then you can load the project and copy/paste
multiple elements from the found project(s).

Advanced Query
The Advanced Query capability allows you to build upmore complex queries that filter elements
in the project. Examples of the types of queries that you might create are:

• Display all Requirements that are to be delivered in Increment 1 and 2

• Show all Legal Non-functional requirements

• Show Steps that have no actors

To enable Advanced Queries: Click on the Query tab and check the Advanced check box.
You can create, edit, delete and share queries.

Creating Queries
To create a new query clickNew. At this point theQuery Builder screen displays. Every query
is comprised of the Query Name and a collection of conditions that must be met.
To add one or more conditions for the query:

1. Click on the Element list.
2. Choose one of the elements. The list of elements is all queryable elements.
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3. Choose the attribute to be queried. The element chosen in the first step causes this list to
be populated.

4. Enter the condition to check.
5. Specify the Value. For Custom Properties that are bound, the Value list is populated with

the values specified in the definition of the custom property. For the condition options
isEmpty and isNotEmpty the Value field is disabled.

6. Click Add Condition.

Once the condition is added you may also check theMatch Case orMatch Exact options.
These behave in the same way as for simple queries.

Figure 24. Query Builder for Advanced Queries

You can also build the query such that all the conditions are met (And), or only some of the
conditions are met (Or). Leaving theMatch All Conditions box unchecked means Or while
checking it denotes And. If conditions are added that make the query irresolvable then Optimal
Trace will inform you with an appropriate message. Additionally, if you have a set of conditions
and by checking 'Match All Conditions' that query becomes irresolvable then you will be told
with a specific reason for which condition makes the query invalid.
For more information, see Advanced Query Conditions [p. 72].

Advanced Query Conditions

Table 20. Advanced Query Conditions

DescriptionCondition

The value must match the attribute in the element.Is
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DescriptionCondition

The value must not match the attribute in the element.IsNot

The attribute of the element must have no value.IsEmpty

The attribute of the element must have some value.IsNotEmpty

To remove a condition: select the Condition to be removed by clicking on it in the list of
conditions and then click Remove Condition.
From the Query Builder, you can also run the query directly. This allows you to validate that
expected results show for the query without having to dismiss the Query Screen completely.
This is a convenience allowing you to make appropriate changes in the Query Screen. You can
also Save or Delete the query by clicking the respective buttons.

Editing Queries
To edit a query:

1. In the Query tab, select the Query you want to edit from the list.
2. Click Edit.
3. Add or Remove conditions. For more information, see Creating Queries [p. 71].

Deleting Queries
To delete a query:

1. In the Query tab, select the query you want to delete from the list.
2. Click Edit.
3. Click Delete.

Viewing Query Results as an HTML Report
You can view the results of the query in a Report format by clicking the View HTML button.
This creates a single page HTML file that shows the results. The query report is created as a
file (HTML formatted) each time you click View HTML. This file is created in the following
location:
<INSTALL_DIR>\Documents and Settings\<USER_DIR>My Documents\Micro Focus\Optimal

Trace Enterprise\<REL_NUM>\EN\reports\. The file name is created as follows:
<QUERY_NAME>_Output_Report_File.html. For example: High & Medium Priority

Reqs_Output_Report_File.html.
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Figure 25. Query Results as a HTML Report

Saving Query Results in a Text File
You can save the results of the query into a CSV (Comma Separated Values) formatted Text
file. Such Text files will open in Microsoft Office Excel by default if you have this loaded on
your system. To do this: click Save Results... and specify the name of the text file.
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C H A P T E R 5

Analyzing Traceability in Projects

Optimal Trace Projects are comprised of Simple Requirements and Structured Requirements
with scenarios, steps, items, branches and refinements. You can access the automatically
generated Traceability Tree enabling tracing to all dependent elements either within or across
packages/projects. Four types of Traceability relationships are allowed in Optimal Trace:

Branches
Branches allow one step (sub-requirement) in a given project. You can branch either
conditionally or unconditionally to a different step or Structured Requirement.

Refinements
Refinements allow a given step, or item, to be decomposed into a more detailed
requirement either within the same package or across packages.

File Links
File Links mean that a given requirement can be linked to any number of associated file
artifacts. For example: sample screenshots in the form of GIF or JPG files, Microsoft
Office Excel spreadsheets, Microsoft Office Visio flows can all be created as links.

Element Links
Element Links allow linking one element to another element either within/across a
project(s). Examples of this kind of Link relationship include when Test Cases are linked
back to associated Requirements.
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Figure 26. Traceability Tree with suspect Links and Linked Screenshots

Each Branch, Refinement, or Link may have the following state which is visually indicated:

Table 21.

DescriptionTrace State

This means that the branch, refinement or link is more recent than any part (any
sub-component) of the element that is 'Linked To'.

Not Suspect

This means that the branch, refinement or link is less recent than any changes
in any aspect of the element that is 'Linked To'.

Suspect

This means that the 'Linked To' element is currently not loaded and the element
text is reflected as a light Grey. To load the element, double-click on it.

Unknown

Only applicable to file based links. This means that the 'Linked To' file is not
found and is marked in red.

Unresolved
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Suspect Links
Suspect Links are best understood with some examples. The next sections outline the
options that are available in the Traceability Tree.

• Example 1: if a test has a Trace Link back to an original Requirement, then if someone
makes a change to the requirement then the link from the test will be marked as suspect.

• Example 2: if a screenshot is linked to a given requirement and the screenshot is altered
then the link is marked as suspect.

Refreshing the Trace Tree
Click the Refresh button to refresh the contents of the Traceability Tree. This re-loads all
currently loaded projects and gets the most up to date state of the elements from a Traceability
perspective.

Navigating the Trace Tree and Loading Projects
Navigating to the Previous and Next Suspect Link(s) is done by clicking the Up Arrow and
DownArrow buttons respectively.Where cross-project traces links exist you can automatically
load the traced to element (and project if not already loaded) by double clicking the link in the
Traceability Tree.
If the Traced to element is a file, Optimal Trace will resolve the link and invoke the 3rd party
tool where possible. The underlying associations inWindows are used to resolve the appropriate
tool to use and launch.

Inspecting and Clearing Suspect Links
Suspect Linksmean that some change has occurred in the element being pointed to. Such changes
may be relatively benign. In order to examine the nature of the changes made (making the link
suspect), click on the Inspect button. In this instance you are presented with a Changes dialog
box. This displays the detail of all changes made either since the link was created or else since
it was last cleared of its suspect status. As well as viewing the specific changes that make the
element suspect, you can also save the list of changes as a text file by clicking the Save as
button.
Once you have reviewed the changes you may clear either one or all suspect links. This is done
by either clicking the Clear One or Clear All buttons respectively. Once you clear the suspect
status, the element is locked to avoid conflict and multiple people editing status at the same
time.

NOTE
To View Traceability for single elements: Select the element in the tree area and click on
Traceability button. This brings up a Traceability dialog box for the selected element.
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NOTE
Trace Tree performance for large projects. If a project has a large number of suspect links,
displaying these in the Trace Tree can have a negative impact on performance. The
default.properties file in the installation folder contains a setting called 'maxDisplaySuspectLinks'.
This is by default set to 5000. The trace tree will stop searching for suspect links once it has
reached the number specified by this setting. Additionally it will ask the user if they wish to
expand all these suspect links, as doing so may take a significant amount of time.
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C H A P T E R 6

Edit and View Menus

Copy/Paste Options
You can copy and paste the following: Actors, Glossary Items, Packages, Structured
Requirements, Steps, Simple Requirements, and Items.
To copy and paste: select an item and use the Copy and Paste buttons.
If you have multiple Projects loaded, you can paste from one Project into another.
To copy multiple requirements, packages, steps or items you need to initially select multiple
elements. Optimal Trace uses the standard Microsoft Windows keys to support multiple select.
There are twomechanisms for selection. To select a range of adjacent requirements or packages,
select the beginning element in the tree and then while holding down the 'Shift' key select the
ending requirement that you wish to copy. All requirements or packages in between the initially
selected element and final element are marked for copy. Once the elements are selected then
paste into the desired new location. Alternatively to copy non-sequential single elements use
the CTRL key while selecting each desired element and paste as per normal. Requirements or
packages can be copied within the current project or into another project.
The following shortcut keys apply:

• Copy - hold down [Ctrl] and hit [C], or hold down [Ctrl] and hit [Ins] ([Insert])

• Paste - hold down [Ctrl] and hit [V], or Hold down [Shift] and hit [Ins] ([Insert])

NOTE
Copying with Custom Properties: In general when copying from one project to another, or one
package to another, if there are Custom Properties associated with the element to be copied then
the custom properties are only copied over if they are also defined in the destination. All other
standard attributes of the copied element are copied. The exception to this rule, is when the
object you are copying is a package. In this case, if there are custom properties defined on the
package then the package is pasted keeping its custom property structure. In this case the Package
Custom Property setting on the destination will have the 'Share' attribute unchecked.
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NOTE
Multiple copy of Steps and Items: Optimal Trace supports multiple copying of steps and items.
In this instance, however, the steps or items to be copied must be contiguous and individual
selection with [Ctrl] + [C] is not supported.

Copy as Link (URI)
To establish Traceability Links within or across projects you ordinarily use theAdd New Trace
Link functionality. There is, however, an alternative way to copy unique links to elements. This
is through the Copy as Link option. This creates the trace to element reference id and copies
it to the clipboard. This means that you now have a unique reference to the element. To copy
the reference to the clipboard, right-click on the specific element in the Tree.

NOTE
Starting Optimal Trace from any third-party environment is possible using copied references.
For example, if you embed the copied link reference as a link in a web page, then clicking that
reference will resolve back to the specific element in Optimal Trace. Similarly, any third-party
tool that supports invocations can make references back in the same fashion. To see an example
of this, see the generated HTML pages from the Traceability Report.

Search Option
Clicking the Search button opens the Query tab.

Undo/Redo Options
Use these options to undo/redo any actions you make, before saving. Click Edit>Undo/Redo
and Optimal Trace will undo/redo your last action.

Show/Hide Columns Option
Use this option to select specific columns to be visible while editing the project. This allows
you to focus on the specific columns that may be of interest at a given time during analysis. The
following project elements may be made visible/invisible: Non-functional Requirements, Steps,
Items, Actors, and Glossary.

Table 22. Additional Show/Hide options

DescriptionOption

Use this option to view the most recently selected Package in
your Project.

ShowCurrent Package Contents Option

Use this option to view themost recently selected Package, and
the contents of all of its sub-Packages, in your Project.

Show Current and Sub-Package
Contents Option
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DescriptionOption

Use this option to view the Requirements contained in all
Packages, in your Project, regardless of which Package you
have currently selected.

Show Contents of all Packages Option

Use this option only when you have selected either one of the
options described above.

Show Cross Package Branches and
Refinements Option

During a requirements session you may find that you are
building Requirements with large numbers of scenarios and

Expanding and Collapsing
Requirements

Steps, or a large number of Items. Optimal Trace provides a
facility for adjusting the way Requirements are displayed in
the Requirement map. When you create Requirements, they
are shown fully expanded in the Requirement Map by default.
In other words, in the case of Structured Requirements they
show all scenarios and all Steps, and in the case of Simple
Requirements they show all Items.

To collapse all structured requirements: right click on the Requirement Map and clickHide All
of the Steps in Requirements.
This will collapse the Requirements for a more manageable view. A collapsed view allows a
more convenient way of traversing the set of Requirements and highlighting specific ones for
which you can see the detailed scenarios etc. To collapse all simple requirements: Right click
on the Requirement Map and click Hide All of the Items in Requirements.

NOTE
You can also select a specific Requirement to expand by either double clicking on the
Requirement title or else clicking on its button.
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C H A P T E R 7

Requirements Menu

This allows you create, edit, delete Packages, Structured Requirements and associated Scenarios
and Steps, and Simple Requirements and associated Items. Additionally you can move and
reposition both Packages and Requirements and all associated convenience capabilities such as
Renumbering.

Creating Requirements/Packages
Choose a Package for the new requirement by selecting it in the tree view. If you have not
defined any packages, select the default Requirements Package. Click the New Structured
Requirement or New Simple Requirement button on the tool bar.
To create a new package, click the New package button on the tool bar.

Deleting Requirements/Packages
To delete a Structured or Simple Requirement, select the requirement in the tree view and click
the Delete button. If the requirement has Steps or Items you will be prompted to confirm the
deletion. If the requirement has refinements or branches associated with it, you will be prompted
to delete the requirement only or the requirement and its associated children.
To deletemultiple requirements or packages you need to initially select the requirements/packages
in the tree view. Use the standard Microsoft Windows keys to support multiple select. There
are twomechanisms for selecting. To select a range of adjacent requirements or packages, select
the beginning element in the tree and then while holding down the [Shift] key select the ending
requirements that you wish to copy. All requirements or packages in between the initially selected
element and final element are marked for deletion. Once the elements are selected then hit the
delete button. Alternatively to delete non-sequential single elements use the [Ctrl] key while
selecting each desired element and delete as per normal.
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Renumbering Requirements
During the course of the requirements gathering phase, it is important to maintain the consistency
of each requirement's number. In the course of your work, new requirements are added and
existing requirements are deleted. Optimal Trace will recycle deleted requirement numbers. For
example, if you delete a requirement SR4 from a project containing the requirements SR1, SR2,
SR3, SR4 and SR5, the next requirement created will be created as SR4.
Over time youmaywant to consolidate the numbering, perhaps prior to a project being baselined.
When renumbering is applied, all of the requirements across all the packages in the project are
numbered according to the current numbering policy. If any simple requirements have been
re-numbered, their Items will also be renumbered to reflect the new Simple Requirement number.
For more information, see Project Baselines [p. 22], and Numbering Policy Settings [p. 60].
To apply renumbering to a project, click the Renumber button. Since renumbering is an
occasional activity and considering the implications of renumbering, you will be prompted for
confirmation of this action. Once confirmed, the renumbering is applied to all requirements.

NOTE
Renumbering of scenarios is handled automatically and no gaps are allowed to appear when
deleting scenarios.

Moving Requirements/Packages
There are two ways to move Requirements and Packages:

• Drag and drop: use standards Microsoft Windows drag and drop functionality to move your
items.

• Tool bar: select a requirement in the tree view and then click theMove Requirement button
on the tool bar and theMove Requirement to Another Package dialog box displays. Select
a location and then click Apply.

NOTE
Moving and Custom Properties. When moving from one project/package to another where
Custom Properties are associated with the element(s) to be moved, the custom property values
are only moved if the Custom Properties are defined in the destination. The one exception to
this rule is when the element being moved is a package. In this case when the package is moved,
all the custom property values are moved, and the package becomes an orphan (un-shared) if
its custom property definitions are different from that of its new parent.

NOTE
Moving and Locking. When moving requirements you acquire an explicit lock on the package
that contains the Requirement. This is because you will be changing the explicit structure of
the package on moving.
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Multiple Requirement or Package Moves

To move multiple requirements or packages at the same time you need to initially select the
requirements or packages within the tree view. Use the standardMicrosoftWindows conventions
for selecting multiple items. Once the elements are selected, follow the procedures above.

Repositioning Requirements/Packages
When you add a new requirement into a package or a package as a sub-package, that item is
positioned at the end of the current list of requirements/packages. It is possible that you may
want to re-sequence or re-order it over the lifecycle of the analysis phase or beyond.
To reposition the requirement or package: select it in the tree and click the Reposition button
in the toolbar. The Reposition dialog box displays and you can then use the Up Arrow and
Down Arrow buttons to reposition it.

Branches Menu
Use the Branchesmenu to branch from step to step and from a step to a structured requirement.
In addition to branches within a given structuredrequirement, Optimal Trace allows branching
between structured requirements. The mechanism to branch to another structured requirement
is very similar to that used for branching to steps:

• Select the step that the branch originates from, click Requirements>Branches. Branches
are denoted with a directed arrow. The arrowhead indicates the step or structured requirement
that is being branched to.

Creating a Branch
Create a branch to perform the following:

• Branch from a step to an existing step or structured requirement

• Branch from a step and implicitly create a new structured requirement while branching

In the case of Withdraw Cash for example, a branch might occur when a customer requests a
certain amount from the ATM and sufficient funds are not available. Another example is if an
incorrect multiple of currency notes has been entered (typically only multiples of 20 are handled
by many ATM machines).
To create a branch:
Click a step (either in the Flow Diagram or the Requirements Map) that you want the branch
to originate from and then click on the button in the central vertical toolbar adjacent to either
the Flow Diagram or Requirements Map. This will display the Branch Properties dialog box.
If you want to create a new structured requirement to branch to, click the New Requirement
button. This will result in the new structured requirement being created and selected as the
branch destination. A condition that causes the branch to occur can also be specified if
appropriate.
A conditional branch is depicted by a diamond box connected to the step that is branching, with
the condition displayed adjacent to the connecting line on the Flow Diagram. A conditional
branch is indicated by clicking the Conditional Branch checkbox.

85Optimal Trace Enterprise User Guide

Chapter 7 ∙ Requirements Menu



If you do not branch with a condition then no diamond is shown, instead a line is drawn directly
from the originating step to the destination step.

Editing and Deleting Branches
• Editing: Select the branch line in either the Flow Diagram or Requirements Map. Do this by

clicking on the line at which point the line is colored red. You may either edit the branch
details in the bottom left branch detail area or by clicking Requirements>Branches>Edit
Branch.

• Deleting: Select the branch line either in the Flow Diagram or Requirements Map. Click
Requirements>Branches>Delete Branch. The Delete Branch dialog box appears from
which you can delete the branch and its children or only the branch.

Steps Menu
Use this menu (Requirements>Steps) for manipulation of Steps (sub-requirements). Each
scenario is composed of a number of Steps. Each individual step is a single step of the action
required to complete a structured requirement. Together, fulfilling all of the steps in a structured
requirement results in the scenario being completed. Note the steps menu is only visible when
a structured requirement is selected in the tree.
Each step has the following attributes:

• The actor that is starting or initiating the step.

• The name of the step.

• A detailed description of the step.

• Applicable branches or refinements.

The Main Success Scenario of Withdraw Cash might contain Steps such as: insert ATM card,
prompt for PIN, enter PIN, validate PIN, or choose account type.

Step Custom Properties
Custom properties can be defined for Steps. This means that each Step can be set up to hold
associated data. Custom Properties can be set as either freeform or bound. Bound means that
you can select from one of a list of predefined values. Step Level Custom Properties behave in
exactly the same way as Project Level Custom Properties. Clicking the Custom Properties
button in the toolbar to the right of the scenario brings up the Custom Property Editor screen.

Adding and Deleting Steps
1. Click the Add Step button to add a step, or
2. Click the Delete Step button to delete a step.
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Move Step Up/Down Options
Use this option to move the selected Step up or down one position at a time in a Requirement.
Effectively you are re-ordering the steps in the given scenario. To move steps, click either the
Up or Down arrow buttons.

Items Menu
Use the Requirements>Items sub-menu for manipulation of Items. Each Simple Requirement
is composed of a number of Items. Each individual Item can describe some piece of information
that complements the Simple Requirement. Note the Items menu is only visible when a Simple
Requirement is selected in the tree view.
Each Item has the following attributes:

• The Name of the Item.

• A detailed Description of the Item.

• Applicable refinements and links.

Item Custom Properties
Custom properties can be defined for Items. This means that each Item can be set up to hold
associated data. Custom Properties can be set as either freeform or bound, the latter meaning
you can select from one of a list of predefined values. Item Level Custom Properties behave in
exactly the same way as Project Level Custom Properties. Clicking the Custom Properties
button in the toolbar to the right of the item list brings up the Custom Property editor screen.

Working with Items

Table 23. Working with Items

DescriptionAction

Use theAdd Item option to add a new Item to a Requirement. Click
the Add Item button.

Add

Use the Delete Item option to delete the selected Item from a
Requirement. Click the Delete Item button.

Delete

Use theMove Item Up/Down options to move the selected Item
up or down one position at a time in a Requirement. Effectively

Move Item Up/Down

you are re-ordering the items in the given item list. To move items,
click either the Up or Down Arrow buttons.

Use the Renumber option to renumber the Items in the item list
sequentially. Moving items up/down can cause the item numbers

Renumber

to get out of sequence. Clicking on the button will renumber the
items.
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DescriptionAction

NOTE
Over a period of time, certain items may get removed. In this case
when adding new items the new item number will be set to the
maximum possible number available, allowing holes to develop in
the numbering. This is deliberately done to preserve continuity of
number especiallywhen a broader team is receiving the requirements
and used to associating a certain item number.

Refinements Menu
Use the Requirements>Refinements menu for refinements purposes. Typically many initial
Project requirements are high level, e.g. one-line descriptions of some key functionality. We
encourage these types of requirements to be captured as 'Simple Requirements' as they provide
an invaluable audit trail especially when the Project requirements are later altered or represented
as detailed Structured Requirements associated through refinement.
The Refinement concept in Optimal Trace allows high-level requirements (perhaps Simple
Requirements with one or two Items) to be detailed to a greater degree of precision while
maintaining the original requirement with no change.When defining Refinements you can refine
across Packages. It is common that Requirements at one 'level' might exist in a dedicated package
with a given 'Tag' thereby marking these requirements as being at that level. The refined to
requirements might exist in a second dedicated package with their own Tag.
The Refinement Links a Step or Item at one level to more detailed Requirements (Simple or
Structured Requirements). Refinements are denoted by solid grey straight lines connecting the
Step or Item to the refined Requirement.

Creating Refinements
Use this option to:

• Refine from a Step or Item to an existing Requirement.

• Refine from a Step or Item and implicitly create a new requirement while refining.

In the case of the Item 'Order' in the 'Order System' demo for example, a refinement relationship
occurs between Order and Line Item, indicating that the Order contains the Line Item. Multiple
Refinement Links can be created to a given Structured or Simple requirement.
To create a refinement:

1. Click on a Step or an Item in the Requirements Map view. This will be the step/item that
'refines'.

2. Now click on the Create Refinement button in the central vertical toolbar adjacent to the
Requirements Map. This opens the Create Refinement... dialog box. This dialog box
shows each of the packages and requirements where you can refine to.

3. If you want to create a new Requirement to refine to, click New Requirement. This will
result in the new Requirement being created and selected as the refined to requirement.
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Deleting Refinements
Use this option to delete an existing Refinement. To do this, first select the refinement that you
want to delete by clicking the line from the step to the requirement in the Requirement Map.
Once selected, the refinement line changes to a red color.

Figure 27. Selecting a Refinement Line

Click theDelete button. TheDelete Refinement dialog box appears from which you can delete
the refinement and its children or only the refinement. When you click the delete refinement
button you may also delete any refined to Requirements.

Figure 28. Delete Refinement Dialog Box

Refine Requirement
Use this option to create a new refinement to another Requirement when there is no sub-step
or item already created on the 'refining' Requirement. This is a convenience option that:

• Creates a new step or item in 'refining' Requirement

• Creates the refinement relationship from that new step or item to the 'refined to' Requirement.
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Scenarios Menu
Use this menu for scenario purposes. The following options are available within the Scenarios
menu.

Table 24. Scenarios Menu Options

DescriptionOptions

Use this option to create an Alternative Scenario in a Structured Requirement.
Alternative scenarios provide an optional series of Steps to the Structured

Create New
Scenario

Requirements Main Success Scenario. This is why they are referred to as an
Alternative Scenario.

Use this option to delete an Alternative Scenario.Delete Scenario

When you add a new scenario into a Structured Requirement, that scenario is
initially positioned at the end of the current list of scenarios. From time to time,

Reposition
Scenarios…

you may want to re-sequence the alternative scenarios over the lifetime of the
analysis phase. To reposition a given scenario, first select that scenario by clicking
on the relevant scenario tab. Now click the Reposition Scenario button in the
toolbar. Use theReposition Scenario dialog box to reposition the scenario within
the requirements by using the up and down arrows.
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C H A P T E R 8

Generation Menu

Use this menu for document generation purposes.
During the requirements gathering phase of a Project, formal documentation is typically required
for customer sign off. Several versions of a requirements document may be required prior to
final sign off of a Project, and indeed an updated version may well be required after final sign
off due to subsequent changes to requirements.
Requirements documents are often the home of data that stems from multiple sources; so
managing requirements documents can be a major challenge. Ideally, changes within the
requirements document should be preserved as the document evolves. Using traditional
techniques, this type of auditing is difficult to accomplish, particularly when it must be
coordinated across a large team. Optimal Trace facilitates generation of Microsoft Office Word
documents, preserving non-Optimal Trace data within these documents. Optimal Trace also
facilitates round tripping of changes made to Optimal Trace data within these same Microsoft
Office Word documents, back into the Project.

Generate Requirements Document
Use this option to generate requirements documents in Microsoft Office Word 2000, 2003 and
2007 formats.

NOTE
Prior to generating a requirements document, you must configure theMSWord security settings.
For more information, see Configuring MS Word 2000 & 2003 Security Settings [p. 93], and
Configuring MS Word 2007 Security Settings [p. 94].

To generate a Microsoft Office Word document detailing requirements using Optimal Trace
Click on theGenerate Requirements Document button and theDocumentGeneration dialog
box will appear.
Optimal Trace has the ability to ignore custom property errors that arise during document
generation. These errors occur when custom properties in the template and the project do not
match. In previous releases, document generation stopped when it encountered inconsistencies
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in custom properties between the template and the project. In this release, users have the option
to ignore the errors in order to proceed with the documentation generation process. Users can
then view the errors and trace their location to the corresponding table. An empty token appears
in the document where the error occurred.
The Document Generation screen shows the available set of document profiles (collections
of document templates used to format the generated document), and allows you to select the
one you want to use for document generation. When you select a profile Optimal Trace
automatically suggests a file name, which is created by appending the profile name to the Project
name. You can override this default suggestion by explicitly specifying a document name
yourself. These other options are available when generating:

Table 25. Generation Options

DescriptionOption

Check this box if you have a project that has Custom Properties and wish
for them all to be added automatically. If the selected Document Profile has

Automatically Generate
Custom Properties

already been customized to have some Custom Properties included, then
this option will only add the ones that are missing.

Check this box if you wish to generate a given package from the current
project. If you check this box then a selection screen will appear when you
generate allowing you to select the specific package.

Generate Partial Project

Check this box if you wish to expand all file links in the generated document.
To define the types of files to be expanded, select Options>Tool Settings,

Expand File Links in
Document

and then type the desired file types in the Expanded File Types in
Generated Docs box.

When a document is generated Optimal Trace can also automatically insert
a project level link to the generated document. If you do not wish to

Add Document Link to
Project

automatically create this link, clear the Add Document Link to Project
(locks the project) option. The impact of adding a project link is that the
project element acquires a lock.

When a document is generated Optimal Trace inserts hidden text surrounding
the document content. This is used to identify project elements within the

Remove Hidden Text

document when the document is being updated from Optimal Trace or
reversed into Optimal Trace. Additionally, on normal generation certain
Microsoft Office Word Macros are inserted into the generated document.
These power the custommenus in documents used for reversing documents.
Using this option will remove all this hidden tag/text information from the
document. It will also not include the macros thus making the document
free of any markup. This will reduce the document size.

NOTE
RemovingHidden Text is recommended if you never intend on using reversal
of documents or if your audience is high level and you are concerned about
not being able to open the documents due to security settings. By removing
the text, reversal of documents is not possible
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Click Generate to create the document.
If you attempt to generate a document with a name that already exists, Optimal Trace informs
you of this and gives you the option of either overwriting the old document or specifying a
different name. You can cancel document generation by pressing the Cancel button on the
progress screen. When the document is created, a File Link to the document is automatically
inserted into the Project's Links area, assuming the Add Document Link To Project option
was selected.

NOTE
Forms Documents:

• Microsoft Office Word Forms: These are Microsoft Office Word documents where only
certain areas are editable. For Optimal Trace, these editable areas will generally consist of
data values originating from the Project.

• Usage: In particular, these types of documents are for nontechnical users who wish to edit
Optimal Trace documents and then reverse these changes back into the project. As long as
they keep the document protected, they can safely edit the data fields without fear of doing
any damage.

• Profiles that generate Forms documents: Default Form, Default No Images Form, Overview,
and ChangeHistory.

• Issues:

◦ Navigation is different. Press TAB or PageDown to move from formfield to formfield.

◦ Clickable hyperlinks don't work, so clicking on an external link won't do anything. Neither
will clicking on the Table of Contents, which can be annoying but is default Word
behavior. However if the document is unprotected first, via the Optimal Trace menu, then
links start working.

◦ Many of the common Microsoft Office Word facilities, such as Search, won't work until
the document is unprotected.

◦ Sometimes, when tabbing through the form fields in a documents, the focus and cursor
seem to disappear. If tab is pressed a few more times, it comes back. The reason for this
is that there are hidden form fields in some areas in the Optimal Trace document, for
instance the Branches table is completely hidden but contains form fields. If 'Toggle
Hidden Text' is selected from the Optimal Trace menu, it is clear what is going on. All
these points are as per Microsoft Word design and are beyond Optimal Trace control.

Configuring MS Word 2000 & 2003 Security Settings
Prior to generating requirement documents fromOptimal Trace, you must configure the security
settings in MS Word 2000 and 2003.

1. Open a MS Word 2000 or 2003 document.
2. Click Tools>Macro>SecurityToolsMacroSecurity.

TheMacro Security dialog box appears.
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3. Select either a Low or Medium security level.
4. On the Trusted Sources tab, select both the Trust access to Visual Basic Project and

Trust All Installed Add-Ins And Templates boxes.
5. Click OK.

Configuring MS Word 2007 Security Settings
Prior to generating requirement documents fromOptimal Trace, you must configure the security
settings in MS Word 2007.

1. Open a MS Word 2007 document.
2. Click the Office button, and then clickWord Options.

TheWord Options dialog box appears.

3. In the left pane, select Save.
4. Under Save documents, select Word Macro-Enabled Document (*.docm) from the Save

files in this format list.
5. In the left pane, select Trust Center.
6. In the right pane, select the Trust Center Settings button.

The Trust Center dialog box appears.

7. In the left pane, selectMacro Settings.
8. In the right pane, underMacro Settings, selectDisable all macros except digitally signed

macros.
9. UnderDeveloperMacro Settings, select Trust access to the VBA project object model.
10. Click OK to dismiss the dialog boxes, and then close the Word document.

Opening a Document after Generation
When you generate theMicrosoft OfficeWord document you can automatically launchMicrosoft
Office Word with the generated document open. To do this, just click the Open button when
generation is completed. This will start Microsoft Office Word and you can view or edit the
document.

Update Requirements Document Option
Use this option to update a document you previously created, for example, to reflect changes
you may have made to the Project.

NOTE

• Partial Documents cannot be updated.

• Custom Properties are Read Only in terms of Document Generation. This means that changes
to Custom Properties (add, remove or edit) will not work for updating the document. Changes
to existing Custom Property values will be updated.
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Choose the document you wish to update and click on Select. It is important that you update
the correct document. If Optimal Trace detects that the document you've selected was not
originally generated from this Project then it will inform you of this and prompt you to select
a different document.
If a problem is encountered during the document update, an error screen will appear. Optimal
Trace will attempt to locate the error in the document when you click the… button. In most
cases, the error is an easy manual fix. Note however, that fixing the error may require some
knowledge of XML. When you click…, all the hidden text in the document will be displayed.
Most of this hidden text consists of XML tags.

Editing the Requirements Document
From time to time you will want to modify a generated document outside of the Optimal Trace
environment. Optimal Trace provides full support for such edits and provides a facility for
round-tripping the changes back into a Project.

NOTE
Partial Documents cannot be reversed.

Using the Optimal Trace Menu in Microsoft Office Word
When Optimal Trace-generated documents are opened in Microsoft Office Word, a special
menu is inserted into Microsoft Office Word. Optimal Trace-generated documents exist
independently of an Optimal Trace deployment. As such, they can be edited either onsite or at
a remote location. This is useful when making changes in Microsoft Office Word documents
and then reabsorbing those changes back into an Optimal Trace project.
The following table outlines each menu option, its likely usage scenario and its
purpose/description.

Table 26. Optimal Trace Options in Microsoft Office Word

DescriptionUsageOption

This turns on and off the hidden text that Optimal Trace uses
to support round-tripping and document updates. Use this

Diagnosis & RepairToggle Hidden
Tags

option for diagnosis when a document ceases to be
round-trippable or updateable. The likelihood is that a hidden
XML tag has been inadvertently deleted.

Microsoft Office Word Forms-based documents are ones
where only specific fields are available to you for editing.

Normal EditingProtect
Document

This has the welcome side effect of protecting all the hidden
text, which otherwise could be accidentally modified. In
such Forms documents, if you want to edit in other areas of
the document, you will need to unprotect the document. This
option then re-protects the document after such an editing
session.
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DescriptionUsageOption

Microsoft Office Word Forms-based documents are ones
where only specific fields are available to you for editing.

Normal EditingUnprotect
Document

In such generated documents if you want to edit in other
areas of the document, you will need to unprotect the
document. This option allows you to do that.

This option will automatically generate a unique Optimal
Trace ID for advanced customization of documentation.

Advanced EditingInsert Unique
ID

Typically, this option is used for generating new IDs when
the user is manually adding a new Requirement.

This (rarely used) option creates a reserved area for you to
wrap certain non-Optimal Trace content which otherwise

Advanced EditingCreate Reserved
Text Area

would interfere with the normal workings of the document.
An example would be a user wishing to add some text of
their own, which contained reserved XML characters such
as < or &. Note that most normal freeform text can be freely
typed anywhere in documents without problems. Also,
binary content such pictures, Microsoft Office Excel
spreadsheets, etc. can be safely inserted in documents as-is
without needing to use this option.

This allows you create new steps, glossary items, actors,
links, notes, etc by copying an existing row in the table. Use

Normal EditingDuplicate
Current Row

this to add new entities to the document, which can then be
round-tripped back into Optimal Trace.

Disabled for generated documents.Editing a ProfileInsert Custom
Property

Disabled for generated documents.Format TablesDelete Custom
Property

Disabled for generated documents.Format TablesFormat Custom
Property Tables

Disabled for generated documents.Editing a ProfileFormat Tables

Inserting/Deleting in Microsoft Office Word

Table 27. Insert/Delete Items in Microsoft Office

DescriptionInsert/Delete Type

Inserting new steps in a scenario within Microsoft Office Word can
be done very simply. Select the row in the specific scenario that you

Steps

wish to insert steps into. Once you have the step highlighted, under
the Optimal Trace menu option click Duplicate Current Row. This
has the effect of making a copy of the currently selected step and the
name becomes 'copy of xyz step' where 'xyz step' is the selected step.
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DescriptionInsert/Delete Type

To delete steps: select the row you wish to delete and click delete as
you would with any normal table.

Inserting new items in a Simple Requirement withinMicrosoft Office
Word can be done very simply. Select the row in the specific item

Items

list that you wish to insert items into. Once you have the items
highlighted, under the Optimal Trace menu option click Duplicate
Current Row. This has the effect of making a copy of the currently
selected item and the name becomes 'copy of xyz item' where 'xyz
item' is the selected item.
To delete items: select the row you wish to delete and click delete as
you would with any normal table.

Inserting new glossary items in Microsoft Office Word can be done
very simply. First select an existing glossary item that you want to

Glossary Items

use as the basis for the new item. Once you have the step highlighted,
under the Optimal Tracemenu option clickDuplicate Current Row.
This has the effect of making a copy of the currently selected glossary
item and the name becomes 'copy of xyz item' where 'xyz item' is the
selected glossary item. Both the name and description are copied.
Note: To delete glossary items, simply select the row you wish to
delete and hit delete as you would with any normal word table.

Inserting new actors in Microsoft Office Word can be done very
simply. First select an existing actor. This will become the basis for

Actors

the new item. Once you have the actor highlighted, under the Optimal
Tracemenu option clickDuplicate Current Row. This has the effect
of making a copy of the currently selected actor and the name becomes
'copy of xyz item' where 'xyz item' is the selected actor. Both the
name and description are copied.
To delete Actors: select the row you wish to delete and click delete
as you would with any normal table.

Encoding Data
When Optimal Trace generates a document it encloses each piece of generated text within
opening and closing tags. These tags are hidden. For example:
Project Creation Date: <Project_CreationDate>Monday, Oct 22, 2003</Project_CreationDate>

Optimal Trace hides the enclosing tags, denoted by angle brackets and the title delimiters,
leaving visible text, in this case Monday, Oct 22, 2003. By clicking on the button (or the
Toggle Hidden Text item in the menu) you can toggle between the hidden and non-hidden state.
So there are two distinct portions to each generated field:

• The title of the field. This is generally freeform text and is not interpreted by Optimal Trace.
It is simply copied over as-is from the skeleton

• The value of the attribute from the Project, enclosed with: <name_of_field> value

</name_of_field>
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Modifying Existing Elements
Optimal Trace works with documents using hidden tags to wrap generated data; however, it is
possible to change the values of the data within those tags.

NOTE
When running spell check in Microsoft Office Word, do not display any hidden text. Hidden
text can be displayed/hidden by clicking the Show/Hide button.

For example, with hidden text displayed, the following text appears:
<UseCase_Precondition><!(CDATA[Clerk is logged in)]><UseCase_Precondition>

If you spell check a document with hidden text displayed, numerous errors will be found.
As long as you do not adjust the enclosing tags, changes can be made to any elements within
Microsoft Office Word and subsequently saved for merging back into the Project

NOTE
About Ids: When viewing hidden text, in generated Microsoft Office Word documents, you
will see many examples of entries similar to the following:
<Requirement_Id>27205259710765</Requirement_Id> These are special numbers used to
track individual elements. Under no circumstances should you modify these numbers, as doing
so will cause failure in subsequent updates and reversing.

Reverse Requirements Document Option
Use this option to reverse a document back into your project, e.g. after you have made changes
to elements within the document. If you have unsaved changes in your project, you will be
prompted to save these changes before reversing.

NOTE

• It is important that you are reversing a document into a project that originally generated that
document. If Optimal Trace detects that the document you've selected was not originally
generated from this project, it will inform you of this and prompt you to select a different
document.

• Custom properties are Read Only in terms of document generation. This means that changes
to custom properties (add, remove or edit) will not work for reversing the document. Changes
to existing custom property values will be reversed.

• It is not possible to reverse a document that has been generated with the Remove Hidden
Text option.

Select the document, click on Reverse. If there are problems, an error screen will appear. Click
the ... button to open the document and attempt to locate the errors.
If the document has no formatting errors, the Visual Merge screen will appear and from there
you can reconcile differences between data in the Project and the reversed document. However
if merging is not required, an explanatory screen will appear. If the Ignore DocGen Custom
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Property Errors option is selected in the General Options dialog box and an inconsistency
is found between the custom properties in the document and the custom properties in the project,
a warning message appears. Click Details to view more information regarding the warning.

Generate Reports
Use this option to publish a Project's details to the web by generating HTML pages. This allows
your customers/developers to view, at will and from anywhere, your Project requirements on
a progressive and incremental basis via your web site. This is especially useful in distributed
development scenarios, where numerous and often geographically dispersed development teams,
need to view the Project requirements. Optimal Trace ships with some ready-to-use HTML
reports, which are based on Report Profiles. There are two ways to generate a report:

• Using the Optimal Trace GUI. For more information, see Generating Reports From the
Optimal Trace Client [p. 99].

• through theMicrosoftWindowsDOSCommand Prompt. For more information, see Generate
Reports from Command Line [p. 99].

NOTE
For a list of reports to generate, refer to the document Customizing Exports and Reports Using
Velocity Script.

Generating Reports From the Optimal Trace Client
To generate a report::

1. Click Generation>Generate Reports. The Report Generation dialog box appears. The
information on this dialog box includes:
a) Profiles: Displays the name of the report profile. Profiles allow you to generate certain

elements from your Project and to adjust the branding and content.
b) Description: Displays a description of the report profile.
c) Directory: Optimal Trace automatically defaults to a directory under the reports

directory. Click the ... button to change the location in which to generate the report.

2. Select the profile to use for report generation. If you want, select a different directory to
save your generated HTML file to.

3. Click Generate.

A report is created in the specified location and a link is automatically inserted into the Project
Links area.

Generate Reports from Command Line
To generate a report of a repository project from a command line, perform the following steps:

1. Ensure that the Optimal Trace Enterprise Server is running.
2. Open a Microsoft Windows DOS Command Prompt window.
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3. Type a command that includes the Optimal Trace Command Line Report utility (Optimal
Trace Command Line Report.exe) and its required parameters.
This utility is installed by default in the following folder: <INSTALL_DIR>\Program
Files\Micro Focus\Optimal Trace\Optimal Trace Enterprise Edition\

Table 28. Command Line Report Utility Parameters

DescriptionParameter

The name of the Optimal Trace project. This must be a repository project.Project name

The name of the report profile. Available profiles are as follows:Report
profile • General Report

• Tree View Report v1.8

• Swimlane Report

• Requirement Template (AC) Report

• Actor Usage Report

• As-Is To-Be Report

• Traceability Report

• Complexity and Completeness Report

The path and folder in which the report is generated.Target folder

A user name with sufficient permissions set for the given project.User name

The password of the user.Password

The command syntax is as follows:
"Optimal Trace Command Line Report.exe" “Project name” “Profile Name” “Target folder"

“User name” “Password”

For example, to generate a a General Report in the C:\temp\reports folder for a repository
project named "Insurance", type the following command:
"Optimal Trace Command Line Report.exe" "Insurance" "General Report" "C:\temp"

"Administrator" "password"

After running the command, Optimal Trace generates a report in the specified location. A large
project may take a few minutes to generate the report.

NOTE
You could use the command prompt feature to schedule report jobs from Microsoft Windows
Scheduled Tasks. Click Start>Programs>Accessories>System Tools>Scheduled Tasks to
access this tool.
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Viewing Reports
When you generate the report, you can automatically open the default viewer for that report
type with the generated report open for viewing. To do this, just click the Open button when
generation is completed. This will launch the viewer and allow you to view the report.

NOTE
Most systems will default HTML reports to be viewed in the system's default web browser.
Similarly if you have Microsoft Office Excel installed, it is likely that the text based reports
will show in Microsoft Office Excel.
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C H A P T E R 9

Options

General Options
Click Options>General Options and then select a tab to modify application settings.

Table 29. General Options

DescriptionOptionTab

Select PDF or HTML from the list as the default Help viewing
format.

Default Help Viewing
Format

Tool Settings

Select the version ofMicrosoft OfficeWord to use for document
generation. The options areMicrosoft OfficeWord: 2007, 2003,
and 2000.

Document Generation
Word Version

Tool Settings

Specify a value for empty fields when generating Microsoft
Office Word documents. The default token is ... but this can
be changed as required.

Document Generation
Empty Token

Tool Settings

This setting is used in document generation to allow file links
to be embedded in generated documents. The default settings
for this option are:

Expanded File Types
in Generated Docs

Tool Settings

• Graphic type files: jpg, jpeg, gif, bmp, png

• Document type files: pdf, rtf

• Microsoft Office Excel spreadsheets: xls

• Text files: txt

• Microsoft Office Visio files: vsd

If modifying this list ensure you separate the extension file
types with a comma.
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Select an option from the list:Default Package
Display Option

Tool Settings

• Show Current Package Contents

• Show Current and Sub-Package Contents

• Show Contents of All Packages

NOTE
Selecting this option changes the default view of new projects.
It does not modify the view of currently opened projects.

When tracking changes as part of Change History, Optimal
Trace loads a certain number of Change Events for viewing.

Max Num Change
History Events

Tool Settings

This setting specifies how many events are loaded at a given
time. Increasing this setting increases the load time when
viewing the Project or Element Change history as these are
loaded on demand.

Specify whether images (flow diagrams etc.) are split across
pages for document generation or when saving images to files.
Set this to specify single images or else split over pages.

Split Images across
Multiple Pages/Files

Tool Settings

Specify that steps should be drawn as either: Fixed Sized or
Fit to Content. When the latter option is set then the step

Flow Diagram Step
Display

Tool Settings

horizontal size is adjusted to accommodate all the text in the
step name, the former truncates the steps to be fixed to a given
size.

Specify that condition text in Flow Diagrams should be either:
Display Full Text or Truncate Text. When the latter option

Flow Diagram Branch
Display

Tool Settings

is set then the condition horizontal size is adjusted to
accommodate all the text in the step name, the former truncates
the condition text to be fixed to a given size.

This is the default template that will appear selected when
creating new projects. You will want to set this if you are using
a given specific template for your projects.

Default Project
Template

Tool Settings

Use this option to suppress custom property errors that arise
during document generation. If selected, the document will

Ignore DocGen
Custom Property
Errors

Tool Settings

generate and display warning messages when there is an
inconsistency between the document template and the project.
Clicking Details allows you to view the custom property and
the table in which the warning occurred.
If this option is not selected, document generation will not
complete and an error message displays. This option is selected
as the default. Additionally, if this option is not selected when
reversing the requirements document into Optimal Trace, the
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user will receive the Custom Property errors and the reversal
will not complete.

The default goal level for Structured Requirements. This default
can be overridden on a Project level basis by setting the Project

Default Structured
Requirement Goal
Level

Structured
Requirement
Settings default goal level. This is a drop-down menu. Select an option

from the list: Very High Summary, Summary, User Goal,
Subfunction, Too Low, As Is, To Be, Manual, or Automated.

The default Structured Requirement priority. Each new
Structured Requirement inherits this priority level. Select an
option from the list: Highest, High, Medium, Low, or Lowest.

Default Structured
Requirement Priority

Structured
Requirement
Settings

The default Non-functional requirement priority. Each
Non-functional requirement has a default priority. Select an
option from the list: P1, P2, P3, P4, or P5.

Default Non-
Functional Priority

Structured
Requirement
Settings

Enter the host name for the Optimal Trace Enterprise Server.
On a standard network, this will be the machine name where

Host Name for ServerServer Settings

the server is running. If your server is running on your local
computer, you can type localhost in place of the computer's
network name. Alternatively if you know the IP address of the
server you can enter it.

Enter the port number that the Optimal Trace Enterprise Server
is running on. Ensure that this number matches the setting on

Remote Port for ServerServer Settings

the Optimal Trace Enterprise Server. By default both the server
and client side settings are set to 5456.

This is the time setting in seconds that controls how often the
client queries the server for updates. You can adjust this

Polling IntervalServer Settings

upwards if you wish to have less frequent polling from client
to server.

Attempt a connection between the client and server using the
settings specified. If there is any issue with the connection, a

Test ConnectionServer Settings

detailed result screen is shown. Copy and paste the contents of
this screen and send it to your Optimal Trace administrator or
network administrator for further diagnosis. It is likely that the
server may not be correctly configured on your network.

This is the location where Project Templates are stored. This
can be reset by clicking the '…' button. You may wish to store

Project Templates
Directory

Default
Directories

your project templates on a central server. You can also edit
the setting directly in the text area.

This is the location where offline projects are opened from or
saved to by default. This can be reset by clicking the '…' button.
You can also edit the setting directly in the text area.

Open/Save Projects
Directory

Default
Directories
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This is the location where document templates are stored. This
can be reset by clicking the '…' button. You can also edit the
setting directly in the text area.

Document Templates
Directory

Default
Directories

This is the location where documents are generated to by
default. This can be reset by clicking the '…' button. You can
also edit the setting directly in the text area.

Generate Documents
Directory

Default
Directories

This is the location where report templates are stored. This can
be reset by clicking the '…' button. You can also edit the setting
directly in the text area.

Report Templates
Directory

Default
Directories

This is the location where reports are generated to by default.
This can be reset by clicking the '…' button. You can also edit
the setting directly in the text area.

Generate Reports
Directory

Default
Directories

This is the location where exports are generated to by default.
This can be reset by clicking the '…' button. You can also edit
the setting directly in the text area.

Export Templates
Directory

Default
Directories

This is the location where exports are generated to by default.
This can be reset by clicking the '…' button. You can also edit
the setting directly in the text area.

Generate Exports
Directory

Default
Directories

This allows you to set whether or not spelling errors are
automatically highlighted.

Hide Spelling ErrorsSpell Check

This allows you to set whether or not the spell checker uses
suggestions from the main dictionary only, or also uses
suggestions from the custom dictionary.

Suggest from main
dictionary only

Spell Check

This dictates whether or not words in UPPERCASE are ignored
during spell check.

Ignore Words with
UPPERCASE

Spell Check

Check this box if you would like the spell checker to ignore
words that contain numeric characters.

Ignore words with
numbers

Spell Check

Check this box if you would like internet and file addresses to
be ignored during spell check.

Ignore internet and file
addresses

Spell Check

This allows you to specify the location of the main dictionary
to use when checking spelling.

Main DictionarySpell Check

This allows you to specify the location of the custom dictionary
used when checking spelling. The custom dictionary contains
any words added by users.

Custom DictionarySpell Check

Spell Check and Language Support

Two dictionaries are installed with Optimal Trace: U.S. English and U.K. English. By default,
Optimal Trace is configured to use the U.S. English dictionary. Dictionaries in other languages
are supported by the Aspell spelling system and can be used with the spell check tool, however,
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these have not been tested, and are not officially supported. To install a dictionary in a different
language, follow these steps:

• Download and install the Aspell installation and specific language dictionary from the
following location: http://aspell.net/win32/.

• Start a command prompt and type: "C:\Program Files\Aspell\bin\aspell"

--master=fr_FR dump master > fr_fr.txt, where fr_FR represents the French dictionary
(replace with desired dictionary).

• Configure the main spelling dictionary to point to the file generated in the previous step:

◦ Copy the newly created fr_fr.txt file from “C:\Program Files\Aspell\bin” to
“C:\Documents and Settings\<USERNAME>\Application

Data\http://supportline.microfocus.com/\Optimal Trace <Edition>\<installed

version>\dictionary” and in theGeneral Options Dialog in Spell Check tab choose
fr_fr.txt as the Main Dictionary. Optionally, use the following method:

◦ In the General Options Dialog in Spell Check tab, choose “C:\Program
Files\Aspell\bin\fr_fr.txt” as the Main Dictionary.

Document Settings
Use the Document Settings dialog box to maintain your Project's document profiles and any
elements and templates associated with them.
A profile is a collection of templates that specifies the branding aspects of the generated document
and the exact set of data that will be output to the document. The Document Profiles pane
allows you to generate any subset of data to your documents. There is no limit to the number
of profiles you can construct and Optimal Trace ships with some ready-to-use document profiles.
Occasionally, when you are generating documents you may need to change the format of a
document that is generated. Some common situations where you might want to customize
profiles are:

• You want to place a customer's specific branding on a generated document. This might
include the customer's logo, custom header and footer.

• You want to generate only a subset of data in a given Project, for example just generate the
Actors, Glossary entries and Requirement names to the document. This is most frequently
used for overviews of the Project requirements.

The Document Profiles pane contains a list of profiles and corresponding descriptions. Click
on an item in either theName/Description columns to edit. Use theCreate,Delete, orValidate
buttons to modify existing profiles.
Adjacent to the Document Profiles pane is another pane containing the Document Elements
and Advanced (Document Templates) settings.

Document Elements

This tab contains an Incl. column and a Name column. Select the elements to include in the
selected profile by putting a check in the Incl. column next to the desired element.
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NOTE
The Incl. column does not appear when the default option is selected.

Advanced (Document Templates)

This tab contains a table with the following information:

• File: Names of the template associated with the document profile selected in the Profile pane,
e.g. Style Template. You cannot edit a template's name from here.

• Location: Displays the Microsoft Windows path to the template. To edit a path, click on its
description in the text box to select it for editing.

• Browse: This unlabelled column contains a button to navigate to a template file.

• Attach: Click the icon to edit the template.

Each profile has a set of Microsoft Office Word templates. When profiles are created the full
list of its available templates is copied into a folder, with the profile's name, which is itself
contained in the profiles directory. To omit specific areas of the profile, clear the Incl. box to
the left of the template you want to omit. The following are some of the typical reasons for
modifying a document template:

• To use a customer’s branding - within Microsoft Office Word replace the logo in Project
and adjust the header and footer in all other templates resulting in a customized set of
documents for a given customer or company.

• To limit certain data sections of data output - within the profile omit sections such as the list
of Actors, Glossary, and diagrams by unchecking the Includes box.

• To output summaries of data - within the relevant profiles omit specific data pieces wrapped
in opening and closing angle brackets.

Within each template there is a set of hidden tags. Each of these tags specifies the data that will
be generated.

• For more information, see Document Elements [p. 109].

• For more information, see Document Profile Templates [p. 108].

Document Profile Templates
The following table contains the default Document Profile Templates:

Table 30. Default Document Profile Templates

DescriptionTemplate

This generates a full requirements document with all elements of the
Project represented along with all attributes. Basically outputs all Project
data and is branded with an Optimal Trace logo.

Default

This generates a full requirements document with all elements of the
Project represented along with all attributes, usingMicrosoft OfficeWord

Default Form
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DescriptionTemplate

forms. Outputs all Project data and is branded with an Optimal Trace
logo. To navigate through Microsoft Office Word forms, press tab or
page-down. For further information on forms, please refer to Microsoft
help.

System profile without images, using Microsoft Office Word forms.Default No Images Form

Requirement summary, using Forms.Overview

Details of the changes made to a Project's documents/files.Change History

This generates a test document, with the main scenario of each
Requirement reflected as a discrete Test Case. This document is suitable

Test Specification

for projects that have been created from the QA Project Profile. It is also
used in conjunction with the Test Generation feature and is primarily used
by the QA and test stakeholders.

Document Elements
The following table describes the Document Elements and their dependencies:

Table 31. Document Element Description

DescriptionDependencyIs RequiredElement

This is used to format the Project details and
typically outputs top-level data such as the
Project's name, owner, etc.

AlwaysProject

Standard Microsoft Office Word Table of
Contents. If this element is included, the

Table Of Contents

TOC is automatically inserted on generation
of the output document.

This item is used to format the Project's
properties such as Description, or any
Custom Properties it possesses.

Introduction

This is used to format the Glossary itemsGlossary

This is used to format the Actors in the
Project

Actor List

This is used to format the Requirement Map
diagram

Requirement Map
Diagram

This is used to format the Package.Package

This is used to format the Structured
Requirement and all of its properties

Requires
Package

Dependency
exists

Requirement
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DescriptionDependencyIs RequiredElement

This is used to format the way the Main
Success Scenario is output, specifying which
parts of the Steps are displayed

Requires
Requirement

Dependency
exists

Main Success
Scenario

This is used to format the way alternate
scenarios are output, specifying which parts
of the Steps are displayed

Requires
Requirement

Dependency
exists

Alternative Scenario

This is used to format the way
Non-functional requirements are displayed
for each Requirement

Requires
Requirement

Dependency
exists

Requirement level
Non-functionals

This is used to format the way Notes are
displayed for each Requirement

Requires
Requirement

Dependency
exists

Requirement Notes

This is used to format the way Links are
displayed for each Requirement

Requires
Requirement

Dependency
exists

Requirement Links

This is used to format the flow diagram for
each Requirement

Requires
Requirement

Dependency
exists

Requirement Flow
Diagram

This is used to format the Simple
Requirement and all its properties.

Requires
Package

Dependency
exists

Simple Requirement

This is used to format the way the Item List
is output, specifying which parts of the items
are displayed

Requires Simple
Requirement

Dependency
exists

Simple Requirement
Item List

This is used to format the way Notes are
displayed for each Simple Requirement

Requires Simple
Requirement

Dependency
exists

Simple Requirement
Notes

This is used to format the way Links are
displayed for each Simple Requirement

Requires Simple
Requirement

Dependency
exists

Simple Requirement
Links

This is used to format the way
Non-functional requirements are displayed
for the Project

Project level
Non-functionals

This is used to format the way Notes are
displayed for each Project

Project Notes

This is used to format the way Links are
displayed for the Project

Project Links

This refers to the full history of the project.Change History

This is a standard Microsoft Office Word
Table Of Figures, for any images which exist
in the document.

Table of Figures

Advanced Template
Elements:
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DescriptionDependencyIs RequiredElement

This .dot file is the Microsoft Office Word
template upon which the generated

Style Template

documents are based. It contains the
front-page logo, styles, fonts, headers and
footers, etc.

This .doc file is the Microsoft Office Word
document containing skeleton versions of

Skeleton

the Document Elements. These skeletons are
copied into the output document and
populated during the generation process.

Changing the Document Logo
To change the document logo:

1. From the Document Settings screen select the profile desired.
2. Using the Advanced tab, edit the Style Template.
3. To change the logo, remove the Micro Focus logo and paste the desired logo in its place.

Subsequent documents generated using this profile will contain the new logo.

Changing the Header and Footer
To change the header and footer:

1. Edit the appropriate style template. Due to the fact that the default is to have a different
header and footer on the first page it is necessary to hit the enter key a number of time to
cause a second page.

2. Click View>Header and Footer and any changes made will be reflected in subsequent
generated documents.

3. Delete the carriage returns to revert to a one page style document

Outputting Custom Properties
Although Generation allows the convenience of automatically outputting Custom Properties on
document generation, it is likely that you will want to specify given Custom Properties to be
output with given Templates. To output Custom Properties:

1. Edit the Skeleton document by clicking on theMicrosoft OfficeWord icon in theAdvanced
tab of the selected Document Profile. You can add and remove Custom Properties from
the Profile and format tables.

2. In the skeleton document, position your cursor in the area associated with the element that
will have custom properties output. The following can have custom properties defined:
Project, Glossary Entries, Actors, Packages, Structured Requirements, Requirement Scenario
Steps, Simple Requirements, Simple Requirement Items, and Non-functional Requirements.
From a Microsoft Office Word perspective, these areas always correlate with tables. A
table exists for each of the Custom Property enabled elements.
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3. From the Optimal Trace menu, click on Insert Custom Property. If your cursor is
incorrectly positioned you will receive a message. By default, the new Custom Property
will appear either to the right of (for a column), or below (for a row), the current cursor
point.

4. Enter the name of the Custom Property in the text entry area. The name must be exactly as
it appears in the originating Optimal Trace project. Additionally please note that the name
is case sensitive and you should ensure that the names match exactly. A screen appears
prompting you to insert the name.

NOTE
Incorrect Custom Properties. If you specify an incorrect custom property, or are generating
from a project that does not happen to have specified custom properties, then the Generation
process will report an error. All Custom Properties in the skeleton document must have a
match in the project. For example if you specify a Custom Property called 'Risk' in the
Structured Requirements Table, each Structured Requirement in the project should have a
custom property called 'Risk'.

Deleting Custom Properties
To delete custom properties:

1. Position your cursor over the specific custom property that you want to remove. From a
Microsoft Office Word perspective, these areas always correlate with tables. A table exists
for each of the Custom Property enabled elements.

2. Select the Optimal Trace menu and click Delete Custom Property. You will be asked to
type in the name of the Custom Property you want removed. Again this data is case sensitive.
If your cursor is incorrectly positioned you will receive a message informing you of this.

Format Custom Property Tables
This option will re-format any tables in the document where it detects Custom Properties.
Typically, these tables will have varying width as columns are added and removed. Use this
option therefore to make adjustments as necessary to the left indent and to the width of these
tables.

NOTE
A bug has been reported in Microsoft Office Word where it has been observed that adding
Custom Properties can cause the table's width to become infinite. In effect the table's % size is
becoming greater than 100% of the available space. The table will appear to stretch off the page
to the right. This option provides the user with a convenient work-around for this bug.

Format Table(s)
This macro will re-format any tables selected by the user, or the table located at the cursor,
whether or not these tables contain Custom Properties. For instance to re-format any and all
tables in the document, hold down [Ctrl-A] and then use this option.
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Tools Menu

View All Change History Option
Use this option to audit what changes were made and by whom. This allows you to resolve
confusion or issues when dealing with any edits that may have been made to a project element.
You can view all changes made to a Project. Each change point is recorded along with the
specific detail of the actual change before and after at the level of the element, Requirement,
Actor, etc.
You can also save the change history to a CSV file. These files can then be opened in Microsoft
Office Excel so that you can perform more advanced filtering or sorting depending on your
needs. Click the Save as button to do this. The number of changes displayed can be adjusted
by setting the configurable option.

View Element History
You can also review a specific element's change history. Select the element in the Tree area and
click the View Element History button. This then brings up the specific changes made to the
selected element. Similar to the Project History, this list can be saved to a file.

View Traceability Tree
Projects are comprised of Structured and Simple Requirements with scenarios, steps, items,
branches and refinements. You can access the automatically generated Traceability Tree
enabling tracing to all dependent elements either within or across packages/projects. Select the
element in the tree area and click the View Traceability Tree button. When elements are
selected in the tree Optimal Trace automatically selects the 'traced to' element in the background
display showing the full package context for the traced to element. Optimal Trace Traceability
relationships comprise: branches, refinements, and links to given elements.
Where cross-project traces (links) exist, you can automatically load the traced to element and
project by selecting the link in the Traceability Tree and double clicking. Traces to external
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tools via links are also displayed. On clicking the Traced to element, if that element is loaded,
Optimal Trace will resolve the link and highlight the linked element in the background.

Generate Test Cases
In typical organizations, software testing accounts for between 30% and 50% of development
cost. The following capabilities are provided to support test generation:

• Generate Test Cases for each path through the Requirement (considering scenarios)

• Generate Test Cases for each Simple Requirement.

• Generate tests for Non-Functional Requirements at Project and Requirement Level

• Generate Forward and Reverse Trace Links from Business to Test Requirements.
Tests can be generated for the entire project, for individual packages or for discrete
requirements. Selecting the specific element required in the tree prior to clicking the Generate
option sets the context.

The following three test types are generated:

• Project Level Non-Functional Test: These tests result from iterating through the
non-functional Requirements defined at the project level in the originating project. Each
non-functional requirement encountered generates one test case.

• Functional Tests: These Tests result from traversing each path through a given Structured
Requirement. One Test Case is generated for each distinct path encountered.

• Associated Non-functional Tests: These Tests result from iterating through the
non-functional Requirements associated with a given Structured Requirement. Each
non-functional requirement encountered generates one test case.

Generating Test Cases for the Entire Project
To generate test cases for the full project:

1. Select the project in the tree view
2. Click on the Generate Test Cases button in the toolbar and the Generate Test Cases

dialog box appears.
3. For more information, see Generate Test Cases Dialog Box [p. 114].

Generate Test Cases Dialog Box

Table 32. Generating Test Cases with the Generate Test Cases dialog box

Action/DescriptionTest Type

Project Level
Non-Functional
Tests

• Check theGenerate test cases for project level non-functional requirements
box to generate tests for each Non-Functional Requirement defined on the
project.
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Action/DescriptionTest Type

• Specify the location where the tests will be created by clicking the… button
adjacent to theGenerate to field in the Project Non-Functional Requirements
group.

• A screen appears prompting you to specify the location you wish the tests to
be generated to. You should choose a package appropriate for the type of test
to be generated. You may also elect to create a New Project or open an existing
project at this time.

Checking the Generate test cases for project packages box means that you can
generate tests for any requirements contained within the package hierarchy. If you

Functional Tests

choose this option, the tests can be generated both for each structured requirement
encountered along with any associated non-functional requirements, and for each
simple requirement encountered.
For functional test generation you may check two additional options:

• Generate package per requirement. This allows you to categorize the resultant
Functional Test Cases grouped per originating Requirement. For cases where
you have many alternative scenarios it is useful to check this option.

• Include Step/ItemDescription. Checking this option means that on generation
each Step or Item's description is carried over to the resultant Test Case. You
may however want to use the Description to carry sample Test Data for instance
in which case you should uncheck this setting.

Check theGenerate non-functional requirement test cases box to generate tests
for each Non-Functional Requirement associated with the structured requirement.

Associated
Non-functional
Tests • Once you check this you specify the location of where the test will be created

by clicking the… button adjacent to the Generate to field

• A screen appears prompting you to specify the location you wish the tests to
be generated to. You should choose a package appropriate for the type of test
to be generated.

Trace Links from Requirements to Test and vice versa

Generating Test Cases allows Trace Links to be created from the Business Requirements to
Test Requirements (Test Cases) and vice versa. Two options exist:

• Create forward Trace Links to the generated Test Cases. Check the Automatically create
trace links to generated test cases to auto-create forward links.

• Create Reverse Trace Links from the generated Test Cases back to the originating
Requirements. Check Automatically create reverse trace links from generated test
requirements to auto-create reverse links.

Generate Button

Click Generate to generate the test cases. The Test Generation Results dialog box appears.
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Interpreting Tests from Structured Requirements
The core of the Test Generation capability revolves around generation of functional test paths.
The algorithm for generating the functional test set is:

• A Test for the Main Scenario: The Test Requirement is populated with the collection of all
steps from the main success flow. If the checkbox Include Step Description is checked,
this also includes the description for each step.

• A Test for each Alternative Scenario: The Test Requirement is populated with the collection
of all steps that comprise the Valid Path up to and including the final step of the scenario
and also the remaining steps of the main scenario if the final step of the alternate scenario
rejoins the main scenario.

• A Test for each Simple Requirement: The Test Requirement is a Structured Requirement
with each step correlating one for one with each simple requirement item.

Test Generation and Refinements
If a refinement association exists between two requirements for which tests are been generated,
a refinement association will be created between test cases that are generated from these
requirements. This allows you to define relationships between requirements, and carry them
forward to any test cases that are derived from those requirements.

Merge Two Projects
Merge can only be run for two versions of the same project. Use this option to merge Projects,
when you are:

• Merging two Projects together where you or different people have been updating different
copies of the Project. For example if going from Offline back to Online.

• Merging two Projects where two or more people might be working some distance apart from
each other, for example, offshore development scenarios where locations are not connected
by WAN and where two databases are being kept in synch.

ClickTools>Merge Two Projects and theMerge two projects dialog box appears. Select both
Projects to merge by clicking on the File button or the Repository button, depending on where
the Project is stored. Once you have selected a Project, Optimal Trace validates that the Project
is correctly formatted and places a green tick next to the name. For more information, see
Merging Projects [p. 122].

Spell Check
Click Tools>Spell Check to view the Spell Check dialog box. This allows you to check the
spelling in the current section of the project, or in the entire project. The spell check dialog will
highlight any incorrectly spelled words, and will suggest an alternative spelling. The following
options are available:

• Ignore Once tells the spell check tool to ignore this instance of this spelling.

• Ignore All tells the spell check tool to ignore all instances of this spelling in the project.
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• Add to Dictionary adds the underlined word to the custom dictionary. Once the word has
been added to the custom dictionary, it will no longer be highlighted by the spell check tool.

• Change replaces the current instance of the word with the selected word in the Suggestions
list.

• Change All replaces all instances of the word throughout the project with the selected word
in the Suggestions list.

• Options will open the Spell Check options section of the General Options.

Once the spell check tool has finished checking the current section in the project, it will, if the
user wishes, continue checking the rest of the project.
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Multi-User Support

Optimal Trace allows several users to work on the same Project simultaneously. When other
users edit or add Requirements, Actors or other Project artifacts, the changes will appear
dynamically on your screen. The Optimal Trace Enterprise Server software monitors all currently
connected clients and ensures that all project changes saved to the repository are broadcast
simultaneously to all users. When you are editing an artifact, Optimal Trace ensures that nobody
else can edit that artifact or the artifacts upon which it depends, by locking them. People are
free however to edit any Project artifacts that are not directly affected by your edits. For more
information, refer to the Optimal Trace Installation Guide.

Configuring Optimal Trace to work through Optimal
Trace Enterprise Server

To create or edit a remote Project, you must tell Optimal Trace where to find the Repository.
Click Options>General Options. For more information, see General Options [p. 103].

NOTE
If you do not already have an Optimal Trace Enterprise Server on your network, you will need
to install a copy before you can use any of the Optimal Trace collaboration facilities. Refer to
the Optimal Trace Enterprise Server Help for full details on configuring a server.

Concurrency and Locking
Typically, applications allow for only one user to edit a file at any point in time. For example,
a Microsoft Office Word document stored on a central Server is viewable by several users at
once, but only one user will have the "lock" required to make changes to the Project. This "lock"
facility prevents conflict due to multiple concurrent attempts to update the same Project.
Optimal Trace's locking mechanism, allows multiple users to access and edit a Project at the
same time while ensuring that their changes do not conflict with each other. Every Project
artifact (e.g. Requirements, Actors, etc) is monitored for edit attempts. In the event of an edit
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attempt, it and every other artifact that depends on it is locked for editing. All users can see a
locked artifact, but only the user with the lock can edit it. The lock is released when that user
saves changes back to the Repository. Parts of a Project that are not directly affected by an edit
attempt remains unlocked; any user can work on them. If you wish to work on a Project in
collaboration with other users, everyone simply opens the Project. Initially, you will not be
aware that other users are present. However, as soon as someone starts to edit a Requirement
(for example, to add a new Step), a Padlock icon will appear next to that Requirement in every
other user's tree view, symbolizing that the Requirement is locked.

NOTE
If you position the cursor over the specific locked element in the tree, a popup appears with the
user name of the person that has acquired this lock.

If you start editing a requirement, you will acquire a "lock" on the element and a padlock icon
appears next to your requirement. You can still click on the Requirement and view it in the
usual way, but its details will be grayed out and you will not be able to edit it. Once the user
who is working on that Requirement finishes and saves his work, the locks will be removed,
and the padlock icons will disappear from your screen.

Locking Rules
Whenmultiple users are working, a number of locking rules apply. This ensures that the integrity
of the Project is maintained and that there is no conflicting data.

Table 33. Locking Rules

Locked EntityAction

ProjectAttempt to edit Project properties, links,
notes and non-functional requirements

ProjectApply label to Project

Actor onlyAttempt to edit an Actors name or
definition

Actor ListAttempt to add an Actor to Actor List

The Actor, Actor List and all Packages, Requirements in
Packages and all child Requirement Packages and their
children.

Attempt to removeActor fromActor List

Glossary Entry onlyAttempt to edit a Glossary Entry name
or definition

The GlossaryAttempt to add a Glossary Entry to
Glossary

Glossary Entry onlyAttempt to remove Glossary Entry from
Glossary
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Locked EntityAction

Requirement Package. This will allow users to edit the
properties of all subordinate objects but not allow
addition/removal.

Attempt to edit a Package name or
description

Parent Requirement Package. This will allow users to edit the
properties of all subordinate objects but not allow addition /
removal.

Attempt to add a Package to a parent
package

Parent Requirement Package and all subordinate and reachable
objects. This is because the sub requirements will be deleted

Attempt to remove a Package from a
parent package

by the package delete so we don’t want to allow users to edit
any of them. Likewise with any objects reachable by the
Requirements.

Requirement onlyAttempt to edit a Requirements
properties, links, notes, NFRs, etc
(excluding graph position)

Requirement onlyAttempt to set a Steps actor

Requirement and the Actor ListAttempt to create an Actor from Step

Requirement onlyAttempt to set a Requirements goal level

Requirement and ProjectAttempt to create a GoalLevel from
Requirement

Parent Requirement Package, Requirement to be deleted and
all reachable objects (via refinement/branch relationships)

Attempt to remove a Requirement from
a Package

Parent Requirement Package. This will allow users to edit the
properties of all subordinate objects but not allow addition /
removal.

Attempt to add a Requirement to a
Package

Requirement onlyAttempt to add/modify Step/ Scenario on
a Requirement

Requirement and all reachable objects via the refinement /
branch relationships. Also lock the refined/branched to
Requirement and all reachable objects.

Attempt to add/modify
Refinement/Branch on a Requirement

Requirement and all reachable objects.Attempt to remove
Step/Item/Refinement/Branch/Scenario,
on a Requirement

Root Requirement Package and all subordinate objectsRenumber all Requirements

Destination (new parent) of the object being pasted and all
objects associated with the object being pasted

Paste

No locking required (only on paste)Copy
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Locked EntityAction

No extra locking required since any objects affected should
already have been locked.

Undo/Redo

Lock the Project objectDisplay goal levels dialog

Lock root Requirement package and all children recursivelyDelete a goal level

Project onlyDocument generation

Project onlyHTML generation

Project and all reachable objectsReverse document

Project and all reachable objectsMerge

Lock custom property type list, all affected custom property
holders and their parents. In the case of Step, Item,

Create/Delete/Edit custom property,
display Bound Value Dialog

Requirement, NFR: lock all Requirement
packages/Requirements.

Merging Projects
The merge tool takes two projects, labeled From and To and merges them into one project
labeled the Result Project. A merged Result Project can include:

• Objects in the From project but not in the To project

• Objects in the To project but not in the From project

• Objects which are common to both the From and the To project

If any objects in both the From and the To projects have different attributes, they will trigger a
decision point (or merge conflict). For example, twoActors called "user", one with the description
"The user" and the other with the description "The generic user". When two projects have the
same name, the object that was edited most recently (evaluated based on project timestamps)
is chosen.When two projects have different names (e.g. merging two different projects together),
you must choose which object to include in the merged result project using the Project Merge
dialog box.
The Project Merge dialog box shows all conflicts (differences) graphically so that you can
decide how to resolve them on a one-to-one basis. By default, the Result Project pane of the
ProjectMerge dialog box displays themost recently changed element for every conflict detected.
The following table describes the various options for resolving project conflicts.

Table 34. Project Merge Options

DescriptionOption

Navigates to the previous conflict.Previous

Navigates to the next conflict.Next
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DescriptionOption

Adds a selected element to the merged result project.Add Element to
Merged Project

Removes a selected element from the merged result project.Remove Element
from Merged
Project

Moves a selected element in the merged result project.Move Element in
Merged Project

Displays the Resolve Properties Conflict dialog box from which you can choose
the desired property to include in the merged result project.

Switch Properties
inMerged Project

Allows you to choose the desired associated element to include in the merged result
project.

Switch
Associated
Elements in
Merged Project

This means that the selected Element has a positional change. Positional Changes
happen when elements are added or removed. If the number of elements is the same

Switch Elements
Position in
Merged Projects in the From and To project, clicking this button results in the other side's positions

being adopted. Position switching is only allowed if no new elements are
added/removed and if the number of elements are the same.

Displays the properties of a selected element.View Element
Properties in
Merged Project

Once all outstanding merge conflicts have been resolved, you can save the merged project (Click
Save on the Project Merge screen).

Security and Access Control on Projects
Optimal Trace allows permissions to be set for Groups of Users and individual users on given
projects or project packages. This ensures that project stakeholders are allowed access and
editing capability on appropriate areas of the project. Some common usage scenarios where you
might consider applying permissions are:

• Allowing project stakeholders such as Business Analysts/Engineering etc. to have certain
visibility levels into a project.

• Allowing the 'QA team' to edit the Test Requirements project but have 'read-only' access to
the Business Requirements.

• Restricting Engineering teams to editing certain Packages or Groups of Requirements.

• Locking down 'reference' projects for use throughout the organization.

• Locking down the Glossary in a project.

• Locking down archived (backups) versions of projects ensuring no changes can be applied.

• Restricting 'Open' Access to sensitive projects.
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Projects or portions of projects that are non-editable are visually indicated by grey text and
accompanying icons. Full details on setting up Groups, Users, and Permissions can be found
in the Optimal Trace Administrator User Guide.
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C H A P T E R 1 2

Using the Optimal Trace Plug-in SDK

With the Optimal Trace Plug-in SDK, you can create custom plug-ins that integrate Optimal
Trace with external applications or serve as functions that automate repetitive actions for
accessing and manipulating Optimal Trace requirements data. Plug-ins are Java components
that are accessible fromwithin the Optimal Trace client. Development of Optimal Trace plug-ins
requires Java programming skills.
The Optimal Trace Plug-in SDK enables create, modify, and delete capability for the following
Optimal Trace entities:

• Project custom properties

• Glossary entries

• Actors

• Packages and their custom properties

• Structured requirements and their custom properties

• Use case steps and their custom properties including main and alternate scenarios

• Refinements

• Links

• Simple requirements and their custom properties

• Items and their custom properties

• Notes

• Branches

NOTE
Creating an Optimal Trace project or deleting an existing Optimal Trace project is not supported.
You can, however, update the project name and description.
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The Optimal Trace Plug-in API Reference provides instructions and examples for creating
custom plug-ins that create, modify, and delete Optimal Trace entities. This documentation is
available on SupportLine (http://supportline.microfocus.com/).
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A P P E N D I X A

UML Integration

This section is for people who understand UML, are familiar with tracing requirements into
system design and have some experience of using design tools. It also presumes you are using
one of the available UML design tools supported by Optimal Trace. When exporting to UML,
Optimal Trace maps elements.

Table 35. UML Optimal Trace elements mapping

NotesUML EquivalentOptimal Trace
Asset

Structured Requirements are
semantically equivalent to the Use Case
notion espoused in the UML

Use CaseStructured
Requirement

Simple Requirements are semantically
equivalent to the Use Case notion
espoused in the UML

Use CaseSimple
Requirement

PackagePackage

No UML equivalentNoneGlossary Item

ActorActor

No UML equivalentStep

No UML equivalentItem

No UML equivalent for Refinement.
Closest semantic equivalent is
Requirement generalization

Represented as a Requirement
Generalization relationship:

Refinement

• Requirement with Step = UML Super
Use Case

• Refined to Requirement = UML Sub
Use Case
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NotesUML EquivalentOptimal Trace
Asset

Represented as an <<extend>> association
between the participant Requirements:

Conditional
Branch to a
Requirement • Requirement with Step => UML

Extended Use Case

• Requirement that is branched to =
UML Extending Use Case

Represented as an <<include>> association
between the participant Requirements:

Non-conditional
Branch to a
Requirement • Requirement with Step = UML Use

Case that is including

• Requirement that is branched to =
UML Included Use Case
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A P P E N D I X B

Troubleshooting

When Optimal Trace encounters problems a screen appears outlining the detail of the problem.
When a problem does occur, Optimal Trace recommends that you save any open Projects and
close the application: Click OK on the Error dialog box and then click Save in the tool bar.
Optimal Trace performs its own verification of the structure of underlying data when opening
and saving of Projects, so for the majority of problems that occur, the integrity of your data will
be guaranteed simply by saving any changes made to your Project. Simply start again, and open
the Project, and normally you can be confident that your application has recovered. An Optimal
Trace Enterprise_log is always maintained in the <INSTALL_DIR>\Documents and

Settings\<USER_DIR>\Application Data\Micro Focus\<OT_EDITION>\<RELEASE_NUM>

directory. This is a text file generated and used to collect useful information and error conditions.
In all instances where an error screen appears, you should report the circumstances and
description of the failure to Micro Focus Customer support.
You should also include, if possible, the Project.ctl file causing the problem. If the project
is a repository project take the project offline.

NOTE
If you are working with Optimal Trace Enterprise Server, ask your System Administrator to
check the Server logs and to send them also.
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A P P E N D I X C

Shortcut Keys

Table 36. Shortcut Keys

Shortcut KeyOption

[Alt+Shift+A]Insert a new Step/Item

[Alt+Shift+C]Create a new Alternative Scenario

[Alt+Shift+D]Delete a selected Refinement

[Alt+Shift+E]Refine the selected Step to an existing Requirement

[Alt+Shift+O]Delete an Alternative Scenario

[Alt+Shift+R]Refine the selected Step to a new Requirement

[Alt+Shift+S]Delete a Step

[Alt+Shift+U]Refine the selected Requirement to a new
Requirement

[Ctrl+Alt+C]Create a new Package

[Ctrl+Alt+D]Document Settings

[Ctrl+Alt+E]Renumber all Requirements

[Ctrl+Alt+I]Save an image in JPEG format

[Ctrl+Alt+K]Delete a Package

[Ctrl+Alt+O]General Options for the Tool

[Ctrl+C]Copy

[Ctrl+E]Exit
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Shortcut KeyOption

[Ctrl+F]Search within a Project

[Ctrl+K]Layout diagram

[Ctrl+M]Merge two Projects

[Ctrl+N]Create a new Project

[Ctrl+O]Open an existing Project

[Ctrl+S]Save a Project

[Ctrl+Shift+A]Apply a Label to the Project

[Ctrl+B]Branch the selected Step to new Requirement

[Ctrl+Shift+C]Create a new Requirement

[Ctrl+Shift+R]Create a new Simple Requirement

[Ctrl+Shift+D]Delete a Requirement

[Ctrl+Shift+V]View Change History

[Ctrl+V]Paste

[Ctrl+Y]Redo

[Ctrl+Z]Undo

[Alt+P+A]Save Project As

[Alt+P+T]Save Project As Template

[Alt+P+P]Apply Template to Project

[Alt+P+M]Open Project Template

[Alt+T+I]View Element History
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Glossary

Actor
An Actor is an entity that is outside the scope of a system but which interacts with the system. Actors may
be either human beings or other systems.

Alternative Scenario
This is a different flow of events within a Requirement that may lead to a successful outcome of the
Requirement. This may be invoked due to some fault or alternative provision in the Requirement.

Branch
Branching allows for a Requirement to jump from one Step within the Requirement to another, generally
due to some check passing or failing. In addition to branches within Requirements, Optimal Trace Enterprise
allows branching between Requirements.

Concrete Step
A concrete Step is a Step that does not have any refinements.

Document Profile
A profile is a collection of Templates that specifies the branding aspects of the generated document and
the exact set of data that will be output to the document. Optimal Trace ships with ready-to-use document
profiles.

External Requirement
A Requirement that is triggered by an external Actor.

Goal Level Requirements
Requirements can be classified as being of a certain goal-level thus clarifying to a large extent the audience
of the Requirement. The concept of Goal-Levels is borrowed from the work of Alistair Cockburn [1].

Internal Requirement
ARequirement that is not triggered by an Actor and is invoked by either an extends or includes relationship.

Item
An Item is essentially a name and a description. Items allow for a tabular set of information associated
with a simple requirement.

Local Project
A Project that is stored locally, normally used for a single user installation.

Main Success Scenario
This is theMain Flow of events within a Requirement leading to a successful outcome. Every Requirement
has one and only oneMain Success Scenario. TheMain Success Scenario of a Project could be considered
the critical path of a Project.

Offline Project
A Repository Project, not requiring a live connection to the Repository. An offline Project can at a later
point in time be reconciled with its Repository Project.

Package
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A group of related sets of Requirements. Used to segment a Project into logical units. The mandatory
minimum number of Packages per Project is one, namely the default Package labeled Requirements; this
Package, which houses all other Packages, cannot be deleted.

Project
A set of requirements (collections of Requirements, Actors, Glossaries, Notes, Links, functional
requirements, or Non-functional requirements).

Refinement
A refinement is a relationship between a Step and a Requirement, wherein the net-effect of the Step is
exactly equivalent to the net-effect of the Requirement.

Repository Project
A Project that is stored in the Repository requiring a live connection to it. It may be in another country.
Typically provides for multiple concurrent users with a common goal.

Round-tripping
If you have beenworkingwith copies of generated documents, away from the Project, you can re-incorporate
any changes you have made into the Project copies. This is called round-tripping.

Scenario
Any sequence of actions (Steps). Optimal Trace allows for two types of scenario: Main Success Scenario
(MSS) and Alternative Scenario (AS).

Simple Requirement
Simple Requirements are unstructured requirements and at the highest level are essentially a name and
description. Examples of Simple Requirements might be data oriented requirements where the need exists
to specific format information in a tabular fashion or marketing and other 'flat' requirements types where
a tabular structure is more suited.

Step
An action within a scenario that achieves an effect. You may branch from any Step in a Requirement to
another Step within the same Requirement, or to another Requirement, e.g. Branching (B) may be due to
some check passing or failing. You may refine from any Step in a Requirement to another Requirement,
e.g. Refining (R) links a Step at one level to a more detailed Requirement.

Structured Requirement
A Requirement is a descriptive narrative describing a specific functional objective of a system. It is
comprised of one or more Scenarios, each comprising a sequence of actions (Steps). The purpose of a
Requirement is to achieve an agreeable objective. Typically, Actors interact with Requirements.
Requirements come in two forms: internal and external. Every Requirement contains only one Main
Success Scenario (MSS). Requirements may also include multiple Alternate Scenarios (AS).

Template
Generate Project documents using preformatted templates, via the documents Profiles facility.
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