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C H A P T E R 1

Introduction

Optimal Trace Overview
Optimal Trace is a requirements capture, documentation and modeling suite for teams of Business
Analysts, Systems Analysts, Software Architects/Designers, QA Leads, QA Testers, and Project
Managers. It provides an easy to deploy, intuitive interface for capturing, viewing, and managing
customer requirements and a sophisticated collaboration mechanism that enables multiple
analysts to work concurrently on one or more projects.
There are two versions of Optimal Trace:

• Optimal Trace Enterprise. This is a fully functional version for multiple users that use the
benefits of a server. The Optimal Trace Enterprise Server component provides access to a
centralized repository of projects and manages communication between multiple users. A
computer that hosts the server software is referred to as a repository server. The Optimal
Trace Enterprise Server controls access to the database, manages concurrent editing of
projects by multiple users, and ensures the integrity of data being written to the database. If
you wish to make use of the collaboration features, you will need at least one repository
server on the network. Optimal Trace Enterprise Server requires a dedicated server machine
on the network to act as the repository server. This machine should be connected to the
network and should be accessible from every workstation on which you will be running
Optimal Trace Enterprise. Optimal Trace Enterprise Server connects to a database running
locally on the repository server or on another machine available on the network.

• Optimal Trace Professional. This is a streamlined version of Optimal Trace Enterprise and
works from the desktop.

Optimal Trace Administrator is installed as part of both the Optimal Trace Enterprise Server
and Optimal Trace Enterprise installations. This tool provides a highly flexible approach to
access control allowing permissions to be set for groups of users and individual users on given
projects and project baselines. This ensures that project stakeholders are allowed access and
editing capability on appropriate areas of the project or baseline.
Some common usage scenarios include:
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• Allowing project stakeholders such as Business Analysts/Engineering to have visibility into
a project.

• Allowing the QA team to edit the Test Requirements project but have 'read-only' access to
the Business Requirements.

• Restricting Engineering teams to editing certain packages and groups of requirements.

• Locking down reference projects for use throughout the organization.

• Locking down a project's Glossary, backups, baselines, and restricting access to sensitive
projects.

Specific product functionality includes:

• The ability to security-enable specific projects and baselines.

• The ability to create Groups, Users and Permissions for specific Projects, Packages, the
Project Glossary and Custom Properties for different parts of a project.

• The ability to configure certain users as Optimal Trace Administrators.

• The ability to use the same User Group structures for multiple projects.

• The ability to work offline and merge projects back to the repository, obeying appropriate
permissions.

• The ability to monitor users connected to specific projects.

• The ability to purge log files on the server.

Groups of users can be set up with specific permissions for given projects (or baselines) allowing
them to view or edit projects and sub-components. Projects can also be set as secure or not.
When the user attempts to open a security-enabled project, the permissions are validated by the
server software which resides on the Optimal Trace Enterprise Server. Levels of permissions
dictate the perspective the client has and the level of access permitted. Clients working with
offline projects can change them at will, however, permissions are checked on initiating a merge
to a corresponding repository project.

Who Should Read This Guide
The Optimal Trace Installation Guide is intended for administrators who are installing the
following:

• Optimal Trace Enterprise

• Optimal Trace Enterprise Server

• Optimal Trace Professional

Additionally, this guide contains information for configuring supported databases to work with
Optimal Trace.
For reference and usage information, refer to the specific Help documentation, which is installed
with each product and its components.

Optimal Trace Installation Guide6
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Getting Help
If ever you have any problems or you would like additional technical information or advice,
there are several sources. In some countries, product support from Micro Focus may be available
only to customers who have maintenance agreements.
If you obtained this product directly from Micro Focus, contact us as described below. If you
obtained it from another source, such as an authorized distributor, contact them for help first.
If they are unable to help, contact us as described below.
However you contact us, please try to include the information below, if you have it. The more
information you can give, the better Product Support can help you. But if you don't know all
the answers, or you think some are irrelevant to your problem, please give whatever information
you have.

• The name, release (version), and build number of the product.

• Installation information, including installed options, whether the product uses local or network
databases, whether it is installed in the default directories, whether it is a standalone or
network installation, and whether it is a client or server installation.

• Environment information, such as the operating system and release on which the product is
installed, memory, hardware/network specifications, and the names and releases of other
applications that were running.

• The location of the problem in the product software, and the actions taken before the problem
occurred.

• The exact product error message, if any.

• The exact application, licensing, or operating system error messages, if any.

• Your Micro Focus client, office, or site number, if available.

Contact

Our web site gives up-to-date details of contact numbers and addresses. To connect, enter
www.microfocus.com in your browser to go to the Micro Focus home page, or go to
http://supportline.microfocus.com.

7Optimal Trace Installation Guide
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C H A P T E R 2

Getting Started

Before Installing
Prior to installation, carefully review the following information:

Release Notes

Review the Release Notes for information about new features, technical notes, and known issues
that may enhance or impact your product’s performance. Release Notes contain recent changes
that may not be included in the product documentation.
Release Notes can be viewed from the installation media or on SupportLine
(http://supportline.microfocus.com), the Micro Focus Customer Care Web site. The Release
Notes on SupportLine are periodically updated as new information becomes available.

System Requirements

Review the system requirements to ensure that the system meets the prerequisites for the
successful installation and operation of the product. System requirements are listed in the Release
Notes as well as in the Installation Guide.

System Requirements for Optimal Trace Enterprise
Hardware

• Pentium 4-class processor equivalent or higher

• 256 MB RAM (minimum), 512 MB or higher (recommended)

• 175 MB of available hard disk space

Operating System
• Microsoft Windows 7

• Microsoft Windows Vista

9Optimal Trace Installation Guide
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• Microsoft Windows Server 2003

• Microsoft Windows XP

Other Software
• Adobe Reader 5.0 or later for Help files

Software Compatibility

• Microsoft Word 2000, 2003, 2007

NOTE
Support for Word 2000 will be dropped in the next release of Optimal Trace.

• Microsoft Project 2000, 2002

• Enterprise Architect 6.5

• VMWare Workstation 6.5.2

• Citrix Presentation Server 4.0 with service pack 2005.04

• Citrix Client 8.0, 9.0, 9.15, or 9.23

NOTE
Optimal Trace does not support Citrix Client 9.20 since there are known issues with running
Java applications.

System Requirements for Optimal Trace Enterprise
Server

Hardware
• Pentium 4-class processor equivalent or higher

• 512 MB of RAM (minimum), 1 GB (recommended)

• 250 MB of available hard disk space

Operating System
• Microsoft Windows 7

• Microsoft Windows Vista

• Microsoft Windows Server 2008 (32-bit & 64-bit)

• Microsoft Windows Server 2003 (32-bit & 64-bit)

• Microsoft Windows XP Professional

Database
• Microsoft SQL Server 2008

Optimal Trace Installation Guide10
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• Microsoft SQL Server 2005

• Oracle 11g Release 1

• Oracle 10.2 Release 2

• MySQL 5.0

• MySQL 4.1

NOTE
There is a known issue with MySQL version 5.0.42, which should be resolved for future
MySQL releases. Optimal Trace Enterprise does not support MySQL 5.0.42 and
recommends using version 5.0.37.

System Requirements for Optimal Trace Professional
Hardware

• Pentium 4-class processor equivalent or higher

• 256 MB RAM (minimum), 512 MB or higher (recommended)

• 150 MB of available hard disk space

Operating System
• Microsoft Windows 7

• Microsoft Windows Vista

• Microsoft Windows Server 2003

• Microsoft Windows XP

Other Software
• Adobe Reader 5.0 or later for Help files

Software Compatibility

• Microsoft Word 2000, 2003, 2007

NOTE
Support for Word 2000 will be dropped in the next release of Optimal Trace.

• Microsoft Project 2000, 2002

• Enterprise Architect 6.5

• VMWare Workstation 6.5.2

• Citrix Presentation Server 4.0 with service pack 2005.04

• Citrix Client 8.0, 9.0, 9.15, or 9.23

11Optimal Trace Installation Guide
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NOTE
Optimal Trace does not support Citrix Client 9.20 since there are known issues with running
Java applications.

Prerequisites
If the User Access Control (UAC) feature is enabled, you must ensure that you have elevated
privileges prior to installing Optimal Trace.
When installing Optimal Trace on Windows Vista, you must as a user with administrator
permissions. For Windows 7, you must log in using the built-in Administrator account to install
Optimal Trace.
If you attempt to install Optimal Trace without sufficient user permissions, the installation may
fail to configure several files. For more information, see Fixing the .lap and .conf Files [p. 35].

Optimal Trace Installation Guide12
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C H A P T E R 3

Installing Optimal Trace

Installing Optimal Trace Enterprise and Professional
These installation procedures apply to both Optimal Trace Enterprise and Optimal Trace
Professional. There are separate instructions for installing the server component of Optimal
Trace Enterprise. For more information, see Installing Optimal Trace Enterprise Server [p. 13].
To installOptimal Trace Enterprise or Optimal Trace Professional:

1. Navigate to Optimal Trace on the installation media. Click the release to install. The Open
File dialog box appears.

2. Click Open. The Installation Wizard appears.
3. Click Next. The License Agreement screen appears.
4. Read the license agreement. If you consent with the agreement, select the option to accept

the terms, and then click Next. The Customer Information screen appears.
5. Type a name in the User Name box and a company name in the Organization box.
6. Click Next. The Destination Folder screen appears.
7. Click Change to choose a destination folder or click Next to accept the default folder. If

changing the destination folder, the Change Current Destination Folder screen appears.
Browse or type a new directory and click OK. The Destination Folder reappears. Click
Next. The Ready to Install the Program screen appears.

8. Click Install. The Installation Status screen appears.
9. Click Next after the installation completes. The Installation Complete screen appears.
10. Click Finish. Optionally, select the Visit Micro Focus SupportLine for Product News

and Technical Alert box to open a browser and display the SupportLine home page.
11. Click Finish.

Installing Optimal Trace Enterprise Server
To install Optimal Trace Enterprise Server, perform the following steps:
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NOTE
An installation of Optimal Trace Enterprise Server also includes Optimal Trace Administrator.

1. From the installation media, navigate to the Optimal Trace Server installation directory.
Double click OptimalTraceServer.msi.
The installation wizard appears.

2. Click Next. The License Agreement screen appears.
3. Read the license agreement. If you consent with the agreement, select the option to accept

the terms, and then click Next. The Customer Information screen appears.
4. Type a name in the User Name box and a company name in the Organization box.
5. Click Next. The Destination Folder screen appears.
6. Click Change to choose a destination folder or click Next to accept the default folder. If

changing the destination folder, the Change Current Destination Folder screen appears.
Browse or type a new directory and click OK. The Destination Folder reappears. Click
Next. The Ready to Install the Program screen appears.

7. Click Install. The Installation Status screen appears.
8. Click Next after the installation completes. The Installation Complete screen appears.
9. Click Finish. Optionally, select the Visit Micro Focus SupportLine for Product News

and Technical Alertbox to open a browser and display the SupportLine home page.

Once the installation is complete, you can access the server component of Optimal Trace
Enterprise by selecting Start>All Programs>Micro Focus>Optimal Trace
Enterprise>Optimal Trace Server>Optimal Trace Server.

NOTE
Optimal Trace Administrator is accessible from the same menu.

After verifying the installation of Optimal Trace Enterprise Server, you must create a database
in which to store Optimal Trace remote projects. For more information, see Configuring MySQL
[p. 23], Configuring Microsoft SQL Server [p. 29], and Configuring Oracle [p. 27].
Refer to the Optimal Trace Enterprise Server Help for usage and additional configuration
information. This documentation is available both from the Start menu and from the Help menu
on the Optimal Trace Enterprise Server menu bar.

Installing Optimal Trace Silently
A Silent install of Optimal Trace allows you to run the Optimal Trace installer from a command
line and suppress the installer wizard. You must uninstall a previous release of Optimal Trace
prior to performing the following steps.

1. Open a command prompt window.
2. If a previous release of Optimal Trace is installed, you must uninstall it as follows:

msiexec.exe /x <ProductCode>

The <ProductCode> is a unique identifier for each release of Optimal Trace. The
<ProductCode> for each release is as follows:

Optimal Trace Installation Guide14
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• Enterprise: {88DB43F7-681D-48ED-8AF4-F0D887CC62F8}

• Enterprise Server: {94D17E9A-5CA4-42FE-B6D2-01CF4C0CD8F7}

• Enterprise Server (x64): {1A95AD0E-922B-4B17-B02E-5FEB3F164200}

• Professional: {DEA4C373-B7E1-4C3E-BB71-D2304F637C90}

The following example shows how to uninstall the Enterprise edition silently and create a
log:
msiexec.exe /x {88DB43F7-681D-48ED-8AF4-F0D887CC62F8} /qn /l *v <log file

name>

NOTE
For a complete list of msiexec.exe installation options, type msiexec ? from a command
prompt.

3. Install the desired product using one of the following installation commands:
• msiexec.exe -I OptimalTraceEnterprise.msi>

• msiexec.exe -I OptimalTraceServer.msi>

• msiexec.exe -i OptimalTraceProfessional.msi>

Optimal Trace Document Import Tool
Optimal Trace contains a document import tool which enables you to mark up Microsoft Word
documents and import them into Optimal Trace. This tool uses a plug-in in Microsoft Word. In
order to use this plug-in, a dll file must be registered. This file will be registered automatically
when Optimal Trace is installed. If you are experiencing difficulty running the document import
tool it may be because the plug-in is not registered correctly.

IMPORTANT
You must perform this procedure if you have installed Microsoft Word after Optimal Trace.

To register the tool manually:

1. Shut down Word and Outlook.
2. Shutdown any Winword.exe processes that may be running using the Task Manager.
3. Click Start>Run. The Run dialog box appears.
4. Type cmd in the Open field, and click the [Return] key. The Command Prompt dialog

box appears.
5. At the command prompt change directory to the Optimal Trace installation folder. For

example: cd c:\Program Files\Micro Focus\Optimal Trace\Optimal Trace

Enterprise Edition.
6. At the command prompt type: regsvr32 OptimalTraceWordDocImport.dll.

15Optimal Trace Installation Guide
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Uninstalling Optimal Trace
To uninstall Optimal Trace Enterprise or Professional:

1. Open Add or Remove Programs from the Control Panel.
2. Select the appropriate product and click Remove.

Uninstalling will leave project files, generated documents and change logs on your hard disk.
This allows you to preserve any previously created project documentation if migrating to a new
version.

Optimal Trace Installation Guide16
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C H A P T E R 4

Upgrading Optimal Trace

You can upgrade from Optimal Trace 5.1 or 5.2 to the current version of Optimal Trace. When
upgrading a release of Optimal Trace, the following custom data is automatically copied to the
user folder of the new release:

• Custom project templates

• Custom queries

• Admin tool settings, tool settings, & server settings

NOTE
If the User Access Control (UAC) feature is enabled, you must have elevated privileges for
these objects to automatically copy. If you do not have appropriate Windows privileges, the
objects will not copy.

The following data is not automatically copied. If desired, you can manually copy this data to
the user folder of the new release.

• Custom spell check dictionaries

• Custom document profiles

• Custom report templates

• Document generation templates

• Generated requirements documents

• Generated reports

• Generated local projects

• Updated demo projects
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C H A P T E R 5

Migrating Projects and Databases

About Migrating an Optimal Trace Database
When upgrading to the current release of Optimal Trace, you may need to migrate your Optimal
Trace database depending on which Optimal Trace release it was created in. The list below
describes the different considerations for migrating an Optimal Trace database.

Prior to Optimal Trace 5.0
When migrating databases created in an Optimal Trace release prior to 5.0, you must
perform an incremental migration. For more information, see Migrating Databases Created
Prior to 5.0 [p. 19].

Optimal Trace 5.0
If your database was created in Optimal Trace 5.0, you must use the Migration utility.
For more information, see Migrating Databases from 5.0 [p. 20].

Optimal Trace 5.1
If your database was created in Optimal Trace 5.1, you are prompted to migrate the
database when you start Optimal Trace Enterprise Server. For more information, see
Migrating Databases from 5.1 to 5.3 [p. 21].

Optimal Trace 5.2
For SQL Server databases created in Optimal Trace 5.2, you are prompted to migrate the
database when you start Optimal Trace Enterprise Server. You do not have to migrate an
Oracle or MySQL database created in Optimal Trace 5.2.

Migrating Databases Created Prior to 5.0
To migrate remote projects stored in a database created in an Optimal Trace release prior to 5.0,
you must perform an incremental migration. First, you must migrate the projects or databases
to 5.0, and then proceed with the migration from 5.0 to the current release of Optimal Trace.
For more information, see Migrating Databases from 5.0 [p. 20], and Migrating Databases from
5.1 to 5.3 [p. 21].
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Migrating Databases from 5.0
To migrate remote projects stored in an Optimal Trace 5.0 database to work with the current
release of Optimal Trace, you must use the Migration utility. Prior to migrating your existing
database, you must create a new database in which to migrate data.

NOTE
Depending on the size of your database, it may take several hours to migrate your data from
5.0. Additionally, the database transaction log may grow to approximately 5 times the size of
the database. Make sure you allocate enough space for the database transaction log. For SQL
Server databases, you can reduce the size of the transaction log. For more information, see
Reducing the Transaction Log Size for a SQL Server Database [p. 20].

This topic describes how to use the Migration utility to migrate a 5.0 database to work with
the current release of Optimal Trace.

1. Stop your Optimal Trace server. For more information, see Stopping the Server [p. 22].
2. Back up your database. For more information, see Backing Up an Optimal Trace Database

[p. 21].
3. Create a new database in which to migrate your data. Click Start>Programs>Micro

Focus>Optimal Trace Enterprise>Optimal Trace Server>Optimal Trace Migration
Utility. The Optimal Trace Migration Utility appears.

4. In the Database Host Name box, type the database host name.
5. Select the database type (MySQL, SQLSERVER, or Oracle) from the Database Type list.
6. Type the database port number if not using the default port in the Database Port box.
7. Under Source Database, type the name of the database to migrate and specify the user

name and password in the appropriate boxes.
8. UnderDestinationDatabase, type the new name of the database and specify the user name

and password in the appropriate boxes.
9. Click Migrate.

The Migration utility runs and migrates remote projects stored in the database to work with
the current release.

Reducing the Transaction Log Size for a SQL Server Database
To reduce the size of the transaction log created during the migration of a SQL Server database,
perform the following steps prior to starting the Optimal Trace Migration utility:

1. Open the server.properties file from the following location:
<INSTALL_DIR>\Program Files\Micro Focus\Optimal Trace\Optimal Trace Server

Edition\

2. Change the value of useSingleTransaction to false.
3. Save and close the file.
4. In SQL Server EnterpriseManager, openDatabase Properties set theRecovery model

option to Simple.
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5. Start the Optimal Trace Migration utility.

NOTE
After migrating your database, remember to reset the Recovery model option to its original
value.

Migrating Databases from 5.1 to 5.3
To migrate remote projects stored in an Optimal Trace 5.1 database to work with the current
release of Optimal Trace, perform the following steps:

1. Back up your database. For more information, see Backing Up an Optimal Trace Database
[p. 21].

2. Install the current release of Optimal Trace Enterprise Server.
3. Start Optimal Trace Enterprise Server and open your existing Optimal Trace 5.1 database.

A message box appears prompting you to migrate your database.

4. Click Yes to migrate the database.

Migrating Local Projects
When attempting to open an Optimal Trace local project created prior to the current release,
you will receive a message asking you to confirm that you want to migrate your project to the
current release. Click Yes to open the project. When you click Save or you choose File>Save,
the project is migrated to the current release of Optimal Trace.

Backing Up an Optimal Trace Database
Before upgrading from a previous release, Micro Focus recommends backing up your database.
This is recommended to safeguard your data in the rare case where an error occurs during the
migration process that leaves your data in a half-migrated state.

Backing up a MySQL Database
To backup a MySQL database:

1. Open a command prompt.
2. Change directory to c:\mysql\bin or wherever MySQL is installed.
3. Type mysqldump -q optimaltrace > c:\temp\OptimalTrace-data-backup.sql. You

may need user/password included in the command line for this.
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This creates a backup file called OptimalTrace-data-backup.sql in the c:\temp\ directory.
You can move this somewhere else for safe keeping.

Backing up an Oracle Database
Creating a backup of the tablespace which contains the Optimal Trace schema is beyond the
scope of this document. Please contact your Oracle Database Administrator or refer to Oracle
documentation. To avoid a potential problem with Oracle's OPEN_CURSORS setting that you
may encounter when migrating, it is best to set this Oracle setting now. To do this, change the
value of OPEN_CURSORS to 20000 in the following files:

• init.ora in <oracle_install_dir>\admin\OEMREP\pfile

• init.ora in <oracle_install_dir>\admin\Oracle\pfile

• init.ora in <oracle_install_dir>\admin\prod\pfile

And then reboot the machine. For more information on this Oracle issue, see:
http://www.praetoriate.com/oracle_tips_mamt_parameter_file.htm.

Backing up a MS SQL Server 2005/2008 Database
To backup a SQL Server database:

1. Start Microsoft SQL Server Management Studio.
2. Navigate to the Optimal Trace database to back up, and then right-click.

A context-sensitive menu appears.

3. Select Tasks>Back Up.
The Back Up Database dialog box appears.

4. Enter the required information, and then click OK.

Stopping the Server
If the server is running from the GUI, click Stop. If the server is running as a windows service,
stop it as follows:

1. Open the Windows Control Panel and launch Administrative Tools>Services.
2. Navigate to Micro Focus Optimal Trace Server <RELEASE_NUM>.
3. Right-click and choose Properties from the menu.
4. Select Stop.
5. Change the Startup type to Manual.
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C H A P T E R 6

Configuring MySQL

This section describes how to configure a MySQL database to work with Optimal Trace
Enterprise Server.

About MySQL
MySQL is a popular open source database. Full details can be found at http://www.mysql.com.
Optimal Trace Enterprise does not support MySQL 5.0.42 and recommends using 5.0.37. When
finished downloading, you should have the MySQL installationfile: mysql-5.0.X-win.zip,
where X is the minor version number. For example, mysql-5.0.37-win32.zip.

Installing MySQL
To install MySQL:

1. If running an earlier version of MySQL, shut down the service before upgrading. Type
>NET STOP mysql at a command prompt to shut down the service.

2. Unzip mysql-5.0.37-win32.zip to a directory. For example, C:\Mysql.
3. Run setup.exe from the directory. For example, C:\Mysql.
4. When prompted for installation type, choose Typical.
5. When finished installing, set up MySQL as a Windows service. For more information, see

Install MySQL as Service [p. 23].

Install MySQL as Service
To install MySQL as a service:

1. Create a file named my.cnf, which must reside in the root drive where the MySQL
installation has been placed. For example, if you installed to c:\mysql then the my.cnf file
would be located at c:\my.cnf. If you installed to an e: drive, then the cnf file would be
located at: e:\my.cnf.
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2. Place the following entries into the my.cnf file, or, alternatively, see the note below on
using a copy of the sample MySQL configuration file shipped with Optimal Trace Enterprise
Server.
# The MySQL server

[mysqld] basedir=c:/mysql

datadir=c:/mysql/data

set-variable = max_allowed_packet=100M

innodb_data_file_path = ib:200M:autoextend

innodb_data_home_dir=c:/mysql/ibdata

set-variable = innodb_mirrored_log_groups=1

innodb_log_group_home_dir=c:/mysql/iblogs

set-variable = innodb_log_files_in_group=3

set-variable = innodb_log_file_size=30M

set-variable = innodb_log_buffer_size=8M

innodb_flush_log_at_trx_commit=1

innodb_log_arch_dir=c:/mysql/iblogs

innodb_log_archive=0

set-variable=innodb_buffer_pool_size=80M

set-variable=innodb_additional_mem_pool_size=10M

set-variable=innodb_file_io_threads=4

Optimal Trace Enterprise ships a sample MySQL configuration file, called my.cnf.txt,
which can be found after you install Optimal Trace Server, in the Scripts folder in your
Optimal Trace Server installation folder. You can copy this file to the root drive and rename
it to my.cnf. To edit a file’s extension string using Windows Explorer:

• In Windows, choose Tools>Folder Options>View.

• Clear the Hide file extensions for known file types box.

• Rename the file to remove .txt from the file name.

For the file name example above (my.cnf.txt), Windows may hide the string .cnf and
the file name may appear simply as my.. MySQL also ships with a sample .cnf file called:
my-example.cnf. This file contains many other additional parameters that can be configured
for MySQL. For more information, refer to http://dev.mysql.com/doc/.

3. If the installed version of MySQL requires transactional tables to be manually enabled then
you must create two sub-directories in the MySQL install directory. Name the newly created
directories ibdata and iblogs. Your Mysql directory structure should now look something
like the following:
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4. To complete the procedure for installing MySQL as a service, open a command window,
change the directory to your MySQL installation folder (c:\mysql\bin), and then run:
mysqld-max-nt --install. mysqld-max is used because it provides support for symbolic
links, BDB tables and InnoDB tables. This allows the use of transactional tables, which
are used by Optimal Trace Enterprise Server.

5. Now that MySQL is installed as a service it can be started and stopped, from anywhere on
the command screen, using the NET command as follows: NET START mysql. Upon a
successful start, a message confirming the MySQL service was started successfully appears
on the screen. NET STOP mysql MySQL may take 5 minutes to stop. When it successfully
stops, a message confirming the MySQL service was stopped appears. MySQL can also
be started from the Services directory by choosing Start>Settings>Control

Panel>Administrative Tools>Services>MySQL.

Create the Database and Server tables
1. Move to location where you have installed Optimal Trace Enterprise Server and copy

mysql_OptimalTrace_install.sql from the <INSTALL_DIR>\scripts directory into your
<MySQL install directory>\scripts.

2. Type the following line to create the database tables:
C:\MySql\bin>mysql -uroot < ..\scripts\mysql_Optimal Trace_install.sql

Upon successful completion there will be no response, only the prompt C:\Mysql\bin.
By default the root user has no password so the above command should work without
modification. If the root user’s password has been modified then you will get the following
error message: ERROR 1044 at line 1: Access denied for user: '@localhost' to

database 'optimaltrace'

If this is the case, an additional password argument must be supplied after the user name.
For example, C:\Mysql\bin>mysql -uroot -ppassword < ..\scripts\mysql_Optimal

Trace_install.sqlYou now have a user with SELECT, INSERT, UPDATE and DELETE
privileges on the 'optimaltrace' database with username ‘optimaltrace’ and password
‘otpassword’.

Uninstalling MySQL
To uninstall MySQL:

1. Click Start>Settings>Control Panel>Add/Remove Programs and click on the version
of MySQL to remove.

2. Click Change/Remove and an Install Anywhere Uninstaller screen will appear.
3. Click Uninstall. This will completely remove all components installed. It will not remove

files and folders created after the installation.
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C H A P T E R 7

Configuring Oracle

This section describes how to configure an Oracle database to work with Optimal Trace Enterprise
Server.

Oracle Prerequisites
• Oracle database administration experience.

• The Oracle software is installed. This includes setting up various environment variables
unique to your operating system and establishing the directory structure for software and
database files.

• You need to have the operating system privileges associated with a fully operational database
administrator. You must be specially authenticated by your operating system or through a
password file, allowing you to start up and shut down an instance before the database is
created or opened.

• Ensure that there is sufficient memory available to start the Oracle instance, and that there
is sufficient disk storage space for the planned database on server.

Configuring an Oracle Database
You can either create a new Oracle database or reuse an existing Oracle database. For instructions
on creating a new Oracle database, refer to your Oracle system administrator or to Oracle
documentation.
To configure an existing Oracle database to use with Optimal Trace Enterprise Server, change
the following settings in the Character Set tab of the Wizard:

• Select Use Unicode (AL32UTFR) checkbox.

• Select UTF8-Unicode 3.0 OTF8 Universal Character Set from the National Character Set
list.

Optimal Trace Enterprise Server provides installation scripts to create tablespaces, tables, and
users. Copy the scripts from the following location of the installation directory
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(<INSTALL_DIR>\Program Files\Micro Focus\Optimal Trace\Optimal Trace Server

Edition\scripts\\oracle_Optimal Trace_install.sql) to the Oracle default location
(ORACLE_HOME\database).
To configue Optimal Trace database objects, start SQL*Plus and connect to your Oracle instance
AS SYSDBA:
SQL> CONNECT SYS/password AS SYSDBA

Create a tablespace, tables, indexes, sequences and a user. From SQL*Plus command line, type
the following:
SQL> @"<INSTALL_DIR>\scripts\oracle_Optimal Trace_install.sql"

This script will create a table space for your Optimal Trace Enterprise Server called
optimaltrace, as well as user optimaltrace with password otpassword. After the initial
configuration, you can change this username and password.
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C H A P T E R 8

Configuring Microsoft SQL Server

This section describes how to configure a SQL Server database to work with Optimal Trace
Enterprise Server.

Prerequisites
• Microsoft SQL Server software is installed. For installation instructions, refer to the Microsoft

SQL Server installation guide.

• Documentation, support, and downloads for SQL Server are available from the following
location: www.microsoft.com/sql/ .

• You need to have the privileges associated with a fully operational database administrator
and be allowed to start up and shut down an instance of Microsoft SQL Server before the
database is created or opened.

• Ensure that there is sufficient memory available to start the Microsoft SQL Server instance,
and that there is sufficient disk storage space for the planned database on server.

Optimal Trace Enterprise Server provides installation scripts for creating a SQL Server database
to use with Optimal Trace Enterprise Server. For more information, see Microsoft SQL Server
2005/2008 Database [p. 29].

Microsoft SQL Server 2005/2008 Database
Perform the following steps to create a SQL Server 2005 or 2008 database to use with Optimal
Trace Enterprise Server.

1. Start Microsoft SQL Server Management Studio.
2. Click File>Open>File, and browse to <INSTALL_DIR>\Program Files\Micro

Focus\Optimal Trace\Optimal Trace Server Edition\scripts.
3. Select mssqlserver_optimaltrace_install.sql, and then click Open.
4. Select the Execute option from the toolbar. This will invoke all queries within the script.

For example, the create database, tables and user/privileges queries.
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Invoking this script creates the database optimaltrace and all the required tables, as well as
user optimaltrace with password otpassword. You can change this username and password
after the database is created. After the script completes, close the opened script file and exit the
Management Studio.

Removing a SQL Server 2005/2008 Database
1. Start Microsoft SQL Server Management Studio.
2. In theObject Explorer, browse to MS SQL Server\Database, and then select the database

to remove.
• Select optimaltrace to remove an Optimal Trace 5.1 or later database.

• Select catalyze3 to remove an Optimal Trace database created prior to 5.1.

3. Right-click the database to remove, and then select Delete. This will remove the database.
4. To remove the created user, browse to MS SQL Server\Security\Logins, and then select

the created user.
• Select optimaltrace to remove the created user for an Optimal Trace 5.1 or later

database.

• Select catalyze3 to remove the created user of an Optimal Trace database created prior
to 5.1.

Microsoft SQL Server Notes
Using the following command, you can change the default database settings of the
mssqlserver_Optimal Trace_install.sql script.
Create database [optimaltrace] ON (NAME = N'optimaltrace',

FILENAME = N'<INSTALL_DIR>\Program Files\Microsoft SQL Server\MSSQL\data\optimaltrace.mdf'

,

SIZE = 100, FILEGROWTH = 10%) LOG ON (NAME = N'optimaltrace_log',

FILENAME = N'<INSTALL_DIR>\Program Files\Microsoft SQL

Server\MSSQL\data\optimaltrace_log.LDF' ,

SIZE = 30, FILEGROWTH = 10%)

To use the second command, comment out the first, and then uncomment the second. Both are
given in the script with the second commented out. The administrator can change the specified
values given as required.

• A login called 'optimaltrace' is created and given a 'db_owner' role on the database.
exec sp_addlogin 'optimaltrace', 'otpassword' ,'optimaltrace'

exec sp_grantdbaccess 'optimaltrace'

exec sp_addrolemember 'db_owner', 'optimaltrace'

The administrator can amend this, but read/write access to the database is required.
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C H A P T E R 9

Running Optimal Trace

This section describes how to run Optimal Trace Enterprise. To run Optimal Trace Enterprise
Server, refer to the Optimal Trace Enterprise Server User Guide.

Connecting to Optimal Trace Enterprise Server
Before using Optimal Trace Enterprise to create and edit repository based projects, you must
configure it to connect to Optimal Trace Enterprise Server. It is possible to load Optimal Trace
offline (file based) projects into Optimal Trace Enterprise without having the remote connection
set up.
Additionally, to create local file-based projects without setting up the remote connection:

1. Click Start>Programs>Micro Focus>Optimal Trace Enterprise>Optimal Trace
Server>Optimal Trace Server.

2. Enter your server settings.
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Figure 1. General Options – Server Settings screen

Table 1. General Options – Server Settings screen

DescriptionItem

Enter the host name for the repository server. On a standard
network this will be the machine name where Optimal Trace

Host Name for Server

Enterprise Server is running. If your repository server is
running on your local computer, you can type ‘localhost’ in
place of the computer’s network name. Alternatively, type
the IP address of the server.

Enter the port number that the repository server is running
on. Ensure that this number matches the setting on the

Remote Port for Server

Optimal Trace server. By default, both the server and client
side settings are set to 5456.

This is the time setting that controls how often the client
queries the server for updates. You can adjust this upwards
if you wish to have less frequent polling from client to server.

Polling Interval

If you want to test the connection to the server hit theTest Connection button. This will attempt
a connection between the client and server using the settings specified. If there is any issue with
the connection, a detailed result screen is shown. Copy and paste the contents of this screen and
send it to your Optimal Trace administrator or network administrator for further information.
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NOTE
A given client can be set to point at a different server by adjusting the server setting in the
Options screen.

User Support in Optimal Trace Enterprise
Optimal Trace Enterprise allows several users to work on the same Project simultaneously.
When other users edit or add Requirements, Actors or other Project artifacts, the changes will
appear dynamically on your screen. The Optimal Trace Enterprise Server software monitors all
currently connected clients and ensures that all project changes saved to the repository are
broadcast simultaneously to all users. When you are editing an artifact, Optimal Trace Enterprise
ensures that nobody else can edit that artifact or the artifacts upon which it depends, by locking
them. People are free however to edit any Project artifacts that are not directly affected by your
edits.

Licensing
Table 2. Licensing Options

This table describes licensing options for both Optimal Trace Enterprise and Optimal Trace Professional.

DescriptionOption

Optimal Trace can be evaluated for a specific period of time without
a license key. When you first run the product, you do not require a

Evaluate Optimal Trace

license. The evaluation period is calculated from the time of first
usage, in other words from the initial running.
Once this period of time elapses you must either purchase a full license
or else apply for an extension key.

Aside from the initial evaluation period as outlined in the previous
section, Optimal Trace requires a license to run. It ships with a License

License the application fully or
use an extended evaluation
license key Administration utility called the LAU (License Administration Utility).

For full details on how to license Optimal Trace, please run the LAU
and refer to the LAU help file under the Help.

If upgrading from a previous release of Optimal Trace, you will need
to install a new license.

Upgrading from a previous
release
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C H A P T E R 1 0

Troubleshooting

This section provides details for fixing common installation issues.

Fixing the .lap and .conf Files
If you attempt to install Optimal Trace with the User Account Control feature enabled and you
do not have elevated privileges, the installation will fail to configure several files properly.
If the installation fails, the following files must be fixed according to the edition of Optimal
Trace installed. The Optimal Trace edition is noted next to the files affected.

• Optimal Trace Server.lap (Enterprise Server Edition)

• Optimal Trace Admin Tool.lap (Enterprise & Enterprise Server Editions)

• Optimal Trace Migration Utility.lap (Enterprise Server Edition)

• Optimal Trace Professional.lap (Professional Edition)

• Optimal Trace Enterprise.lap (Enterprise Edition)

• Optimal Trace Command Line Report.lap (Enterprise Edition)

• Wrapper.conf (Enterprise Server Edition)

1. In Windows Explorer, navigate to the installation directory.
For example, the default installation directory is <INSTALL_DIR>\Program Files\Micro

Focus\Optimal Trace\Optimal Trace Enterprise.

2. Select one of the .lap files to configure and open with a text editor.
3. Search for the placeholder called DLMLOCPLACEHOLDER and

DLMJARPLACEHOLDER and replace this text with the correct Optimal Trace library
and class paths as shown in the following example.
-Djava.library.path=C:\Program Files\Common Files\Compuware;

-Djava.class.path=C:\Program Files\Common Files\Compuware\DLM40JNI.jar;

4. Repeat steps 2 and 3 for the remaining .lap files.
5. In Windows Explorer, navigate to the installation directory.
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For example, the default installation directory is <INSTALL_DIR>\Program Files\Micro

Focus\Optimal Trace\Optimal Trace Enterprise.

6. Open the Wrapper.conf file in a text editor.
7. Search for the placeholders called SERVICELOGPLACEHOLDER,

DLMLOCPLACEHOLDER, and DLMJARPLACEHOLDER and replace this text with
the correct path as shown in the following example.
wrapper.logfile=C:\Documents and Settings\All Users\Application Data\

Micro Focus\Optimal Trace Server\5.3\service.log

wrapper.java.library.path.1=C:\Program Files\Common Files\Compuware

wrapper.java.classpath.1=C:\Program Files\Common Files\Compuware\DLM40JNI.jar
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