
Print out a
printer wh

DevPart
Use the lin
DevPartne

More Inf
Use the De
ner Studio 

Commo
The DevPa

• DevPart
• DevPart
• DevPart
• Comma

Toolbar
r menu or toolbar in Visual Studio.

 slightly in Visual Studio 6.0.

To solve 

Diagnose r

Locate perf

Ensure cod

lbar item To
Perform run-time error detection using 
BoundsChecker technology 

Perform run-time code coverage analysis

age Analysis Perform run-time error detection with code 
coverage analysis

Execute run-time performance analysis 

Access error detection rules management, 
used to filter or suppress detected errors

tion Perform compile-time instrumentation for: 
Error detection, Coverage analysis, Error 
detection and coverage analysis , 
Performance analysis 

anager Access the Instrumentation Manager

Correlate performance or coverage files

Merge coverage analysis sessions

Access DevPartner options
Choices include: Analysis, Code review, 
Error detection
ll or portions of this document and keep it handy for quick reference (use a color 
en available).

ner Features
ks in the left column in the following table to locate reference information about 
r features.

ormation
vPartner online help to obtain “how to” information. See the Understanding DevPart-
manual for an overview of the DevPartner software.

n Elements
rtner software provides these common elements, regardless of feature.

ner Toolbar
ner Menu
ner File Extensions
nd Line Instrumentation Options

DevPartner Menu and 
Accessed from the DevPartne

Note: Options and icons vary

this problem Use this DevPartner 
feature

un-time errors in the source code Error Detection

ormance bottlenecks in the application Coverage and Performance 
Analysis

e base stability throughout development and testing phases Coverage Analysis Session Data

Choose this menu or too
 Error detection

 Coverage Analysis

 Error detection and Cover

 Performance Analysis

Error Detection Rules

 Native C/C++ Instrumenta

Native C/C++ Instrumentation M

Correlate

Merge Coverage Files

 Options
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Common Elements

DevPartne
File extension

Command

NMCL Opt
The following
(native) Visua
Visual C++ co
aged code, w
executes.

Note All NMC
hyphen, follo

he directory containing these utilities to your path. For exam-
 into the default directory, add the following directory to your 

s\Compuware\NMShared 

Running th
Code coverag

Code coverag

Error detection

Performance a

Use...
/NMbcpath:b

/NMclpath:cl-

/NMhelp or /?

/NMignore:so
/NMignore:so

/NMlog:log-fi

Ignore the CL /Gm (minimal rebuild) option if it appears on 
the command line. You can use this option to avoid a 
known conflict between the NMAKE /A and CL /Gm 
options.

Specify a single source file that should be instrumented

Specify an option file (an ASCII file containing individual 
command-line options, each on a separate line)

Specify pass-through mode, which instructs NMCL to call 
CL without intervention. In this case, no instrumentation 
takes place.

Stop NMCL if an error occurs during instrumentation. If this 
option is not specified, the default behavior is to fall back to 
a standard CL compile.

Use DevPartner Error Detection instrumentation. This is the 
default setting.

Specifies instrumentation for performance and coverage 
analysis.

Instruments methods that are marked as inlineable if inline 
optimizations are enabled (using the /O1, /O2, /Ob1, or 
/Ob2 option)

Instruct DevPartner not to collect line information. When 
you use this option, DevPartner does not display any line 
data in the Source tab. You can also use this to improve the 
time required to instrument and run your application.

Specify the directory location of the performance and 
coverage analysis library files if you do not have the 
directory that contains NMCL on your path.

To...
r File Extensions
s for session files.

 Line Instrumentation Options

ions
 table lists the NMCL options that you can use to instrument your unmanaged 
l C++ code from the command line. Use NMCL.EXE only to compile unmanaged 
de with DevPartner error detection instrumentation. NMCL is not used with man-
hich DevPartner instruments as it is passed to the common language runtime as it 

L options must begin with a forward slash (shown in the following list) or 
wed by the letters NM. For example: /NMoption or –NMoption.

Note: When using NMCL, add t
ple, if you installed the product
path: 

C:\Program Files\Common File

is DevPartner feature Creates this session file (extension)
e .dpcov

e merge files .dpmrg

.dpbcl

nalysis .dpprf

To...
c-path Specify the directory location of bcinterf.lib if you do not 

have the directory that contains NMCL on your path.

path Specify the directory location of cl.exe. You can use this 
option to bypass the installed location of DEVENV, or if 
DEVENV is not installed.

Display help text

urce-file or 
urce-file:method source-file

Specify a source file or a method in a source file that should 
not be instrumented

le Specify a log file for NMCL messages (default: stdout)

/NMnogm

/NMonly:source-file

/NMopt:option-file or 
/NM@option-file

/NMpass

/NMstoponerror

/NMbcOn

/NMtxOn

/NMtxInlines

/NMtxNoLines

/NMtxpath:tx-path

Use...
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Common Elements

NMLINK O
The following
code) Visual C

Note: All NM
hyphen, follo

MLINK, add the directory containing these utilities to your 
ed the product into the default directory, add the following 

s\Compuware\NMShared

Use...
/NMbcOn

/NMbcpath:b

/NMhelp or /?

/NMlinkpath:l

Specify pass-through mode, which instructs NMLINK to call 
LINK without intervention.

Specifies instrumentation for performance and coverage 
analysis.

Specify the directory location of the performance and 
coverage analysis library files if you do not have the 
directory that contains NMCL on your path.

To...
ptions
 table lists the NMLINK options that you can use to link your unmanaged (native 
++ application to DevPartner.

LINK options must begin with a forward slash (shown in the following list) or 
wed by the letters NM. For example: /NMoption or –NMoption.

Note: When using NMCL and N
path. For example, if you install
directory to your path:

C:\Program Files\Common File

To...
Use DevPartner Error Detection instrumentation. This is the 
default setting.

c-path Specify the directory location of bcinterf.lib if you do not 
have the directory that contains NMCL on your path.

Display help text

ink-path Specify the directory location of LINK.EXE. You can use this 
option to bypass the installed location of DEVENV, or if 
DEVENV is not installed.

/NMpass

/NMtxOn

/NMtxpath:tx-path

Use...
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Coverage and Performance Analysis

Coverage
Determine ap

General an
The following

ons for Coverage and Performance

Property
Automatically

Collect inform

Collect COM 

Exclude Othe

Instrument in

Instrumentat

Track System

Performance Analysis

Set DevPartner Options

age Analysis Session Toolbars
ntext menu to compare sessions and view a call graph.

View Call Graph

Find method in source code

Choose instrumentation type
 and Performance Analysis
plication test coverage and profile application performance.

d Data Collection Properties
 data collection properties apply to Performance and Coverage. 

DevPartner toolbar butt

Default setting
 Merge Session Files Ask me if I would like to merge it

ation about .NET assemblies True

Information True

rs True

line functions True

ion Level Line

 Objects True

Select analysis preference
Coverage 

Error Detection with Coverage

Native C/C++ Instrumentation
Enable/disable instrumentation

Performance and Cover
In Visual Studio 6.0, use the co

Performance Session toolbar

Compare sessions

Coverage Session toolbar
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Coverage Analysis

Coverage

Coverage 

Filter the data

e sessions and record merge history

View statistics for sessions or merge file

r Coverage Analysis in Visual Studio or in the Coverage Analysis 
ata in tabbed format, including the following tabs:

y

 Analysis

Analysis Session Data

 view View coverage metrics for methods

View execution data for 
lines of source code 

Merge coverag

Results Summaries
DevPartner displays results fo
Viewer. Session files present d

• Method List
• Source Code
• Merge History
• Session or Merge Summar
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Performance Analysis

Performa

Performan

Filter the data v

Compare session data to 
assess impact of code 
changes

Performance Analysis in Visual Studio or in the Performance 
esent data in tabbed format, including the following tabs:
nce Analysis

ce Analysis Session Data

iew 

View performance metrics for methods View session statistics
Locate methods in source code

Explore calling 
sequence of methods 
and identify critical path

Results Summaries
DevPartner displays results for 
Analysis Viewer. Session files pr

• Method List
• Source Code
• Session Summary
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Using DPAnalysis.exe

Using DPA
Use DPAnalys
mand line, or

Command
Use this synta

DPAnalysis

DPAnalysis.ex
optional.

The following

Category
[a] Analysis T

{b} Data Colle

Specify the session file output directory and/or filename

ir] - Specify working directory for the process or service

ecify the target’s host machine

Do not wait for the process to exit, just wait for it to start

le] - Run the process in its own command window

rces profiling for coverage or performance of applications written 
naged code or CTI.

5 - Disables excluding time spent on other threads

OD_GRANULARITY - Sets data collection granularity to method-level 
 default)

SYSTEM_DLLS - Excludes data collection for system dlls (Perf only)

_INLINING - Enable run-time instrumentation of inline methods

OKS- Disable collection of COM

_SYSTEM_OBJECTS - Track system object allocation (Memory only)

rget to follow as either a process or service. Pick only one. All arguments 
he target name/path will be arguments to the target

pecify a target process (followed by arguments to process)

pecify a target service (followed by arguments to service)

ath to configuration file
nalysis.exe
is.exe to run Coverage and Performance sessions launched directly from the com-
 through a configuration file called through the command line.

 Line Operations
x to run Coverage and Performance sessions from the command line:

 [a] {b} {c} {d} [e] target {target args}

e requires Analysis Type and Target Type switches. Use of other switches is 

 table lists the switches used with DPAnalysis.exe:

Switches
ype /Cov[erage] - Sets analysis type to DevPartner Coverage Analysis

/Perf[ormance] - Sets analysis type to DevPartner Performance Analysis

ction /E[nable] - Enables data collection for the specified process or service

/D[isable] - Disables data collection for the specified process or service

/R[epeat] - Profiling will occur any time you run the specified process until you use 
the /D switch to disable profiling.

{c} Other Options /O[utput] - 

/W[orkingD

/H[ost] - Sp

/NOWAIT - 

/N[ewconso

/F[orce] - Fo
without ma

{d} Analysis Options /NO_MACH

/NM_METH
(line-level is

/EXCLUDE_

/NM_ALLOW

/NO_OLEHO

/NM_TRACK

[e] Target Type Identifies ta
that follow t

/P[ocess] - S

/S[ervice] - S

/C[onfig] - P

Category Switches
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Using DPAnalysis.exe

Configura
Use this synta
through a co

DPAnalysis

The following

Element
AnalysisOptio

Arguments

ExcludeImage

 each Process or Service, zero or one. No default if omitted. Sets the host 
e target process or service. No attributes.

for each service. Provides the name of the service as registered with the 
l manager. This is the same name you would use for the system's NET 
nd. No attributes.

for each process. Specify a fully qualified or relative path to the 
u can specify the executable name without the path if the executable 
rrent directory. No attributes.

tion file must contain at least one Process or one Service element. 
et executable.

lectData, Spawn, NoWaitForCompletion, NewConsole 

 only. Defines the type of performance and maximum session time.

tion file must contain at least one Process or one Service element. 
et service.

lectData, Start, RestartIfRunning, RestartAtEndOfRun

 only. Begins a block of one or more Process or Service entries. Target 
 services are started in the order they are listed in the configuration file.
InParallel
tion File
x to run Coverage, Memory, Performance, or Performance Expert sessions 
nfiguration file: 

 /config c:\temp\config.xml

 table briefly describes the XML elements. See the online help for more details.

Description
ns (Optional) For each Process or Service, zero or one. Defines runtime attributes for the 

specified target process or service. Attributes correspond to DevPartner properties 
accessible from the Properties Window in Visual Studio. 
Attributes: SESSION_DIR, SESSION_FILENAME, NM_METHOD_GRANULARITY, 
EXCLUDE_SYSTEM_DLLS, NM_ALLOW_INLINING, NO_OLEHOOKS, 
NM_TRACK_SYSTEM_OBJECTS, NO_MACH5

(Optional) For each Process or Service, zero or one. Defines runtime attributes for the 
specified target process or service. Attributes correspond to DevPartner Coverage, 
Memory, and Performance properties accessible from the Properties Window in Visual 
Studio. 
Attributes: SESSION_DIR, SESSION_FILENAME, NM_METHOD_GRANULARITY, 
EXCLUDE_SYSTEM_DLLS, NM_ALLOW_INLINING, NO_OLEHOOKS, 
NM_TRACK_SYSTEM_OBJECTS, NO_MACH5

s (Optional) For each Process or Service, zero or one. No default if omitted. Defines 
images (at least one, no maximum) which, if loaded by the target process or service, 
will not be profiled. No attributes.

Host (Optional) For
machine of th

Name One required 
service contro
START comma

Path One required 
executable. Yo
exists in the cu

Process The configura
Specifies a targ
Attributes: Col

RuntimeAnalysis Required; one

Service The configura
Specifies a targ
Attributes: Col

Targets Required. One
processes and
Attributes: Run

Element Description 

•
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Error Detection

Error Det

File Extens

Default Op
Default value

Extension
.dpbcl

.dpbcc

.dpbcd

.dpsup

.dpflt

.dprul

Category
General

Data Collectio

Enable API call reporting. All selections are unavailable until you select this 
item.

Collect window messages - Default when active: Off

Collect API method calls and returns. - Default when active: On

View only modules needed by this application - Default when active: On

All modules (tree view). - Default when active: All selected 

Enable call validation. All selections unavailable until you select this item

Enable memory block checking - Default when active: Off

Fill output argument before call - Default when active: Off

COM failure codes - Default when active: On

Check for COM “Not Implemented” return code - Default when active: 
On

API failure codes - Default when active: On

Check invalid parameter errors: API, COM - Default when active: both On

Category: Handle and pointer arguments - Default when active: On

Category: Flag, range and enumeration arguments - Default when 
active: On

Check statically linked C run-time library APIs - Default when active: On

DLLs to check for API errors (failures or invalid arguments) - Default 
when active: All items selected

Enable COM method call reporting on objects that are implemented in 
the selected modules

Report COM method calls on objects implemented outside of the listed 
modules - Default when active: On

All components tree view - Default when active: All selected 

Enable COM object tracking

All COM classes tree view - Default when active: All selected

Settings
ection

ions Used by Error Detection

tions (Visual Studio) or Settings (Visual C++)
s vary slightly between Visual Studio 6.0 and Visual Studio .NET 2003 and 2005.

File Type Description
Error Detection Session File This is the Error Detection log for the user's program 

execution.

Error Detection Settings File This file contains the various settings for Error 
Detection. The .dpbcd extension refers to the default 
settings file created, while .dpbcc refers to a custom 
settings file that has been saved separately.

Error Detection Suppressions File This file contains the various suppressions for the user's 
program.

Error Detection Filters File This file contains the various filters for the user's 
program.

Error Detection Rules File This is a database of the user's suppressions and filters.

Settings
On Log events

On Display error and pause

Off Prompt to save program results

Off Show memory and resource viewer when application exits

On Source file search path - based on the location of the .EXE (standalone), 
.DSW (Visual C++), or .SLN (Visual Studio). 

- Override symbol path - Default: empty

- Working directory (standalone only) based on the location of the .EXE 

- Command line arguments (standalone only) - Default: empty

n On Call parameter coding depth = 1

On Maximum call stack depth on allocation = 5

On Maximum call stack depth on error = 20

On NLB file directory is based on the location of the .EXE (standalone), 
.DSW (Visual C++), or .SLN (Visual Studio). 

On Generate NLB files dynamically

API Call Reporting Off

-

-

-

-

Call Validation Off

-

-

-

-

-

-

-

-

-

COM Call Reporting Off

-

-

COM Object Tracking Off

-

Category
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Error Detection

in Visual Studio

in Visual C++ 6.0

Deadlock Ana

Memory Track

.NET Analysis

.NET Call Repo

Resource Track

Category

Set DevPartner Options

Start with Error Detection
Start with Coverage Analysis
Start with Error Detection and Coverage Analysis
Start without debugging with Performance Analysis
Note: The arrows next to each button allow you to start with or without 
debugging, depending on the default action of the button.

Build with Performance
Build with Coverage
Build with Error Detection

artner Integrated Error Detection
Error Detection Toolbar 

Error Detection Toolbar 

lysis Off Enable deadlock analysis

- Assume single process - Default when active: On

- Enable watcher thread - Default when active: Off

- Generate errors when: A critical section is re-entered - Default when 
active: Off

- Generate errors when: A wait is requested on an owned mutex - Default 
when active: Off

- Number of historical events per resource - Default when active: 10

- Report synchronization API timeouts - Default when active: Off

- Report wait limits or actual waits exceeding (seconds) - Default when 
active: 60

- Synchronization Naming Rules - Default when active: Don’t warn about 
resource naming

ing On Enable memory tracking

On Report leaks immediately

Off Show leaked allocation blocks

Off Enforce strict reallocation semantics

On Enable FinalCheck

On Enable guard bytes; Pattern = FC; Count = 4 bytes

- Check heap blocks at runtime: On free

On Enable fill on allocation; Pattern = FB

On Check uninitialized memory; Size = 2 bytes

On Enable poison on free; Pattern = FD

Off Enable .NET analysis

- Exception monitoring - Default when active: On 

- Finalizer monitoring - Default when active: On

- COM interop monitoring - Default when active: On

- PInvoke interop monitoring - Default when active: On

- Interop reporting threshold - Default when active: 1

rting Off Enable .NET method call reporting

- All types (tree view node) - Default when active: Selected.

- .NET User Assemblies (tree view node) - Default when active: Selected

- .NET System Assemblies (tree view node) - Default when active: Not 
selected

ing On Enable resource tracking

On Resources tree view. All listed resources are selected by default

Settings

Native C/C++ Instrumentation
Enable/disable instrumentation
Choose instrumentation type

DevP

Log Events
Display Error and Pause
Show filtered messages
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Error Detection

Error Dete  Pane

 Pane

Re
Su
Pe
ove

So

Dis
det

Appears in...
Summary, Memory Leaks, and Transcript tabs

Summary, Other Leaks, and Transcript tabs

Summary, Errors, and Transcript tabs

Summary, .NET Performance tabs

Summary, Modules, and Transcript tabs

Transcript tab

Event Transcript tab

Transcript tab

Transcript tab

Transcript tab

r data types

pes
ction Window Icons Used in the Results

Icons Used in the Details

Details Pane
Displays long description of detected 
error; call stack information; reference 
count graph (see inset below).

sults Pane
mmary, Memory Leaks, Other Leaks, Errors, .NET 
rformance, Modules, Transcript tabs provide 
rview and detail about detected errors.

urce Pane

plays source code for the 
ected error, if available.

Details Pane - Reference Count Graph
Displays Reference Count View and Object Identity 
View tabs when you select an Interface Leak in the 
Results pane.

Icon Description
Memory Leaks

Other Leaks

Errors

.NET Performance

Module Load Event

Subroutine call

Garbage Collection 

Event Begins

Event Resumes

Event Ends

Icon Description
Subroutine call

Entry Parameters

Exit Parameters

Return Value

Property (default) fo

Property for data ty
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Error Detection

Reference

Program E

ewer Dialog Box

Horizo
Horizo

Error de

Memory Contents Pane
e, and Summary tabs

e 

Stack Pane

Mark and Close
Click to mark existing allocations and close the 
dialog box. Marked items will not be shown when 
Memory and Resource viewer reappears. 
 Count Graph Toolbar

rror Detected Dialog Box

Memory and Resource Vi

Scale to Size
Select Viewing Area

Vertical Zoom Out
Vertical Zoom In 

ntal Zoom Out
ntal Zoom In

scription

Call stack information Source code for the detected error

Tabs for multiple call stacks

Results Pane
Displays Memory, Resourc

Source Pane
Displays source code for th
detected error, if available.
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Error Detection

ActiveChe

ActiveChe
ActiveCheck™
well as the dy
your program
detection.

 Instrumentation - Deepest Error Detection
umentation (CTI) enables Error Detection to find more errors 
ata corruption errors, and so on) as they occur in real time. 

errors plus all found with ActiveCheck.

Deadlock-r
Deadlock

Potential dead

Thread deadlo

Critical section

Semaphore er

Resource usag

Suspicious or 

Handle errors

Event errors

Mutex errors

Windows even

.NET Errors
Finalizer errors

GC.Suppress f

Dispose attrib

Unhandled na
code

y block

Pointer and Leak Errors
Array index out of range

Assigning pointer out of range

Expression uses dangling pointer

Expression uses unrelated pointers

Function pointer is not a function

Leak due to leak

Leak due to module unload

Leak due to unwind

Memory leaked due to free

Memory leaked due to reassignment

Memory leaked leaving scope

Returning pointer to local variable
ck and FinalCheck Error Detection

ck
 analyzes your program and searches for errors in your program executable as 

namic-link libraries (DLLs), third-party modules, and COM components used by 
. The following tables list the types of errors found with ActiveCheck error 

FinalCheck Compile Time
FinalCheck™ compile time instr
(memory leaks, pointer errors, d
FinalCheck finds these types of 

elated Errors API and COM Errors
COM interface method failure

lock Invalid argument

cked Parameter range error

 errors Questionable use of thread

rors Windows function failed

e and naming errors Windows function not implemented

questionable resource usage Invalid COM interface method argument

t errors

Pointer and Leak Errors
Interface leak

inalize not called Memory leak

utes errors Resource leak

tive exception passed to managed 

Memory Errors
Dynamic memory overrun

Freed handle is still locked

Handle is already unlocked

Memory allocation conflict

Pointer references unlocked memor

Stack memory overrun

Static memory overrun

Memory Errors
Reading overflows buffer

Reading uninitialized memory

Writing overflows buffer
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Error Detection

List of Ava d Commands - Visual C++ 6.0

Command
Ctrl+Shift+O

Ctrl+Shift+N

Ctrl+S

Ctrl+Shift+S

Ctrl+Shift+F

Ctrl+Shift+H

Alt+F12

Ctrl+Alt+L

Ctrl+Shift+C

Ctrl+Alt+S

Ctrl+Shift+E

F4

Ctrl+Alt+X

Shift+Alt+Ente

Shift+F4

Ctrl+Shift+B

F5

Ctrl+F5

Ctrl+Alt+E

F11

F10

Ctrl+B

Ctrl+F1

Ctrl+Alt+F1

Ctrl+Alt+F2

Ctrl+Alt+F3

Shift+Alt+F2

Shift+Alt+F3

lace

To

kmarks

kpoints

Members

meter Info

plete Word

ssWizard

rkspace

tput

perties

mpile filename

ild application_name

rt Debug > Go

rt Debug > Step Into

rt Debug > Run to Cursor

urce Browser

cord Quick Macro

y Quick Macro
ilable Keyboard Commands - Visual Studio List of Available Keyboar

Action
File > Open > Project

File > New > Project

File > Save Project

File > Save All

Edit > Find in Files

Edit > Replace in Files

Edit > Find Symbol

View > Solution Explorer

View > Class View

View > Server Explorer

View > Resource View

View > Properties Window

View > Toolbox

r View > Full Screen

View > Property Pages

Build > Build Solution

Debug > Start

Debug > Start Without Debugging

Debug > Exceptions

Debug > Step Into

Debug > Step Over

Debug > New Breakpoint

Help > Dynamic Help

Help > Contents

Help > Index

Help > Search

Help > Index results

Help > Search results

Command Action
Ctrl+F Edit > Find

Ctrl+H Edit > Rep

Ctrl+G Edit > Go 

Alt+F2 Edit > Boo

Alt+F9 Edit > Brea

Ctrl+Alt+T Edit > List 

Ctrl+Shift+space Edit > Para

Ctrl+Space Edit > Com

Ctrl+W View > Cla

Alt+0 View > Wo

Alt+2 View > Ou

Alt+Enter View > Pro

Ctrl+F7 Build > Co

F7 Build > Bu

F5 Build > Sta

F11 Build > Sta

Ctrl+F10 Build > Sta

Alt+F12 Tools > So

Ctrl+Shift+R Tools > Re

Ctrl+Shift+S Tools > Pla
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Export DevPartner Data: Command Line Use

Export De
You can use D
Coverage An
(*.dpprf) files

Note: DevPa
Partner Data 
DevPartner.

mand line options for DevPartner.Analysis.DataExport.exe.

 space to separate an option from the value or values you spec-

scription

ecify the output directory for exported XML files. 

arch subdirectories for DevPartner Session Files. 

ow all session file data regardless of analysis type. For 
ample, if you export a coverage session file with this option, 
e resulting XML file will contain both coverage and coverage 
ta fields. 

ait for input before closing console window. 

 not display the logo or copyright notice. 

splay help in the console window. 
vPartner Data: Command Line Use
evPartner.Analysis.DataExport.exe from the command line to convert DevPartner 

alysis (*.dpcov), Coverage Analysis Merge (*.dpmrg) and Performance Analysis 
 to XML files.

rtner.Analysis.DataExport.exe is the command line executable for the Export Dev-
command, a separately licensed feature. 
Analysis.DataExport.exe [sessionfilename|pathtodirectory] {options}

Options
The following table lists the com

Use an equal sign, a colon, or a
ify. 

Switch De

/out[put]=<String> Sp

/r[ecurse] Se

/showAll Sh
ex
th
da

/w[ait] W

/nologo Do

/help or /? Di


