DPVC Quick Reference

Print out all or portions of this document and keep it handy for quick reference (use a color
printer when available).

DevPartner Features

Use the links in the left column in the following table to locate reference information about
DevPartner features.

Use this DevPartner
feature

To solve this problem

Diagnose run-time errors in the source code Error Detection

Locate performance bottlenecks in the application Coverage and Performance

Analysis
Ensure code base stability throughout development and testing phases Coverage Analysis Session Data

More Information

Refer to the DevPartner online help or to the Understanding DevPartner manual for more
information.

Common Elements

The DevPartner software provides these common elements, regardless of feature.
e DevPartner Toolbar

¢ DevPartner Menu

e DevPartner File Extensions

e Command Line Instrumentation Options

DevPartner Menu and Toolbar

Accessed from the DevPartner menu or toolbar in Visual Studio..

Choose this menu or toolbar item

To

x Error detection

& Coverage Analysis
*
% Error detection and Coverage Analysis

#-5 Performance Analysis
A
Error Detection Rules

& . Native C/C++ Instrumentation

Native C/C++ Instrumentation Manager
Correlate
Merge Coverage Files

& Options

Perform run-time error detection using
BoundsChecker technology

Perform run-time code coverage analysis

Perform run-time error detection with code
coverage analysis

Execute run-time performance analysis

Access error detection rules management,
used to filter or suppress detected errors

Perform compile-time instrumentation for:
Error detection, Error detection with
coverage, performance or coverage analysis

Access the Instrumentation Manager
Correlate performance or coverage files
Merge coverage analysis sessions

Access DevPartner options
Choices include: Analysis, Code review,
Error detection




DevPartner File Extensions
File extensions for session files.

Running this DevPartner feature Creates this session file (extension)

Code coverage .dpcov
Code coverage merge files .dpmrg
Error detection .dpbcl
Performance analysis .dpprf

Command Line Instrumentation Options

NMCL Options

The following table lists the NMCL options that you can use to instrument your unmanaged
(native) C++ code from the command line. Use NMCL.EXE only to compile unmanaged C++
code with DevPartner performance and coverage or error detection instrumentation. NMCL is
not used with managed code, which DevPartner instruments as it is passed to the common lan-
guage runtime during execution.

Note All NMCL options must begin with a forward slash (shown in the following list) or
hyphen, followed by the letters NM. For example: /NMoption or -NMoption.

Use... To...
/NMbcpath:bc-path

Specify the directory location of bcinterf.lib if you do not
have the directory that contains NMCL on your path.

/NMclpath:cl-path Specify the directory location of cl.exe. You can use this
option to bypass the installed location of DEVENYV, or if

DEVENV is not installed.

/NMhelp or /? Display help text

/NMignore:source-file or Specify a source file or a method in a source file that should
/NMignore:source-file:method source-file not be instrumented

/NMlog:log-file Specify a log file for NMCL messages (default: stdout)

/NMnogm Ignore the CL /Gm (minimal rebuild) option if it appears on
the command line. You can use this option to avoid a
known conflict between the NMAKE /A and CL /Gm
options.

Use...

Common Elements

To...

/NMonly:source-file

/NMopt:option-file or
/NM@option-file

/NMpass

/NMstoponerror

/NMbcOn
/NMtxOn

/NMtxInlines

/NMtxNoLines

/NMtxpath:tx-path

Specify a single source file that should be instrumented

Specify an option file (an ASCII file containing individual
command-line options, each on a separate line)

Specify pass-through mode, which instructs NMCL to call
CL without intervention. In this case, no instrumentation
takes place.

Stop NMCL if an error occurs during instrumentation. If this
option is not specified, the default behavior is to fall back to
a standard CL compile.

Use DevPartner Error Detection instrumentation. This is the
default setting.

Specifies instrumentation for performance and coverage
analysis.

Instruments methods that are marked as inlineable if inline
optimizations are enabled (using the /O1, /02, /Ob1, or
/Ob2 option)

Instruct DevPartner not to collect line information. When
you use this option, DevPartner does not display any line
data in the Source tab. You can also use this to improve the
time required to instrument and run your application.

Specify the directory location of the performance and
coverage analysis library files if you do not have the
directory that contains NMCL on your path.

When using NMCL, add the directory containing these utilities to your path. For example, if
you installed the product into the default directory, add the following directory to your path:

C:\Program Files\Common Files\Compuware\NMShared
Note: For installs on 64-bit versions of Windows, add the following directory to your path:
C:\Program Files (x86)\Common Files\ Compuware\NMShared
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Common Elements

NMLINK Options Use... To...
The following table lists the NMLINK options that you can use to link your unmanaged (native /NMpass Specify pass-through mode, which instructs NMLINK to call
code) C++ application to DevPartner. LINK without intervention.
Note: All NMLINK options must begin with a forward slash (shown in the following list) or /NMtxOn Spe;:ifi.es instrumentation for performance and coverage
hyphen, followed by the letters NM. For example: /NMoption or -NMoption. analysis.

/NMtxpath:tx-path Specify the directory location of the performance and

coverage analysis library files if you do not have the

Use... To...

directory that contains NMCL on your path.

/NMbcOn Use DevPartner Error Detection instrumentation. This is the

default setting. When using NMCL and NMLINK, add the directory containing these utilities to your path. For

/NMbcpath:bc-path Specify the directory location of bcinterf.lib if you do not example, if you installed the product into the default directory, add the following directory to
have the directory that contains NMCL on your path. your path:
/NMhelp or /? Display help text C:\Program Files\Common Files\Compuware\NMShared
/NMlinkpath:link-path Specify the directory location of LINK.EXE. You can use this . . . . . .
P P ogtior{to bypass ch installed location of DEVENV, or if Note: For installs on 64-bit versions of Windows, add the following directory to your path:
DEVENV is not installed. C:\Program Files (x86)\Common Files\ Compuware\NMShared
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Coverage and Performance Analysis
Determine application test coverage and profile application performance.

General and Data Collection Properties
The following data collection properties apply to coverage and performance analysis.

Property Default setting
Automatically Merge Session Files Ask me if | would like to merge it
Collect information about .NET assemblies True

Collect COM Information True

Exclude Others True

Instrument inline functions True

Instrumentation Level Line

Track System Objects True

Coverage and Performance Analysis

DevPartner toolbar buttons for Coverage and Performance

/

-~

Select analysis preference Performance Analysis

\

Coverage Analysis

Error Detection with Coverage

-
.
"{\ Set DevPartner Options

Native C/C++ Instrumentation —— &
el Performance or coverage a -

Enable/disable instrumentation
Choose instrumentation type

Performance and Coverage Analysis Session Toolbars

View Call Graph
Performance Session toolbar

/@1 ==y | SpeedBumnp.Driver.Forml,.ctor -
Compare sessions o \

Find method in source code

Coverage Session toolbar

' SpeedBump.Driver.Forml. . char -
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Coverage Analysis

Coverage Analysis Results Summaries

DevPartner displays results for coverage analysis in Visual Studio or in the Coverage Analysis
Viewer. Session files present data in tabbed format, including the following tabs:

* Method List

e Source Code

* Merge History

Session or Merge Summary

Coverage Analysis Session Data

Filter the data view View coverage metrics for methods

lines executed [96.1%)
= %urce(sm%( of 205 hn:.s Merge coverage sessions and record merge history
= Driver exe ( 95.4% of &

%% SpeedBump.Driver.F

20 of 22 methods called [90.9%]

Method List | S urcelDriver.cs] | Merge History | Merge Summary

=~ csharp.dil { 96.4% of 14

g SpeedBump.Coharp. e | wcovered | cated | ELE
Methods Not Covered tare
[E] Methods Less Than 20% Covered SpeedBump, CSharp.Formi ClearTimingivoid) 0.0 oo 52 of B5 lines executed [95.4%)]
Gver 30 Lines, Less Than 10% Cove Speedsump, Driver Form.NativeCppBtn_Click{Object, EventArgs) 0.0
] Removed Methads SpeedBump. CSharp.Form1 Dispose{Boolean) 600 | e— E of 7 methods called
SpeedBump, Driver Farm1,Dispose(Boolean) 80,0 . _ .
SpeedBump. CSharp.FormL .QSart(Intz, nkaz) .7 View statistics for sessions or

| Method List | Sowrce(Driver cs]_; Merge Histo | Merge Surnmary|
a0

100.0
100.0

SpeedBump, CSharp.Form1., .ctar{void)
SpeedBump. CSharp.Form1 Initislize Component {void)

merge file

SpeedBump, CSharp.Formi . Farm1_Load(Chject, Eventargs) 100.0
SpeedBump, CSharp.Forml DoRandomizedyvaid) 100.0 a0
100.0
I 135 of 140 lines executed [96.4%) 100.0 a0
2 100.0
I 14 of 15 methods called (93.3%) (Object, Eventargs) 100.0 7
. Jbject, Eventargs) 100.0
Method List| SourcelSpeedBump.cs] | Merge History | Merge Summary 100.0. =
Count| Source ~ | (Object, EventArgs) 10 | B0 Method List | Source[Diivercs] | Merge History | Merge Summary
Lo0.8 DevPartner - Coverage Rnalysis Session Summary -~
| — 100.0 50
waid) 100.0 soarced: 2/28/2009 5:32:17 DK
100.0: 40 Ended: 2/23/2009 §:33:17 PN
= sl act, Eventargs) 100.0
& private Pen whitelPen = new PeniColer.White, 117 Ewentargs) 100.0 30 Exscutable: C:ySpeedBunp.Net\Driveribin\Release\Driver.exe
£ private Pen blackPen = new Pen{Color.Elack, 1); Command Args:
a0 Bxit Code: 0
Processor Speed: 2992 Mhz
10 # of Processors: 1
08 Version: Microsoft Uindows XP
o
. public Tormi() driver3. dpcoy £ driver] dpcov driver2 dpcov driversnag " -
erge History
i i Driver3.dpeov
View execution data for 272872000 5:60:50 M Administrazar
5 InitializeComponent () ; . DriverZ.dpeov 2/28/2008 5:40:50 PN Admimistrator
~ lines of source code DriverSnapl.dpeow 2/E8/2008 5:42:00 P Administrater v
< * < >
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Performance Analysis

Performance Analysis Results Summaries
. . DevPartner displays results for performance analysis in Visual Studio or in the Performance
Performance Analysis Session Data Analysis Viewer. Session files present data in tabbed format, including the following tabs:

e Method List
e Source Code

Filter the data view Locate methods in source code e Session Summary
View performance metrics for methods View session statistics _
Method List | Source [SpeedBump.cs] | Session Summary,
U]
Drlvert, dpprf® ” Driver.dpprfa = Basis session; C:\SpeedBump etiDriveribin|RelzaseiDriver dpprf =
% in Methad 9% with Childran Average  Average with Children
All { Madules: 30 Methar | b ethad ist | Source [SpeedBump.cs] || Session Summary
DIwlibii03 10 Method % in with 3
3 Source (0.3% ] Mame Method Chigren | Called | Average (us) R n il _TEEEE
T jg';hamldl:( SpeedBurkp. CSharp.Forml Updateslot{Int32) 0.1 3.7 e e v | cated | average sy =
peedBl | speedsump. Coharp. Form? SwapEm(Int32, Int32) 0.1 3.2 Hons e o I8 el
= 1 piveroce | Sheadiunk Corar o Subtesorin Cicichi.. 03 B
“% Speedf | Speedsurmpl Drtver. Form 1. ctor(void) 0.0 1 45,462.6 SpeedBump. Csharp, Form1 BubbleSortBtn Click(Object, Eventirgs) 0.0 4 mams
- 3] Systemn { 99.7% | SpeedBump\CSharp.Farmi . .ctor(void) - = Driver.Forml. . cton{vaid) 0.0 L 46,4994
Top 20 Source Methods | SpeedBump.{sharp Form 1, QSort(Intz, Method List| Saurce [SpeedBump.cs] | Sessiot,Summary. ) SpeedBump. Coharp. Form1..ctor(void) 0.0 3 BSE2L
Top 201 Methods speedsurnp. Qriver. Form 1. InitializeCorpo Count | % with Childien Time [us] \ Source 5 SDEEdB“mp‘gib:”;m','Ssu‘i'tor"‘izn’ In”t:f/imd) gg Z‘SQT 5 663‘2
Ton 20 Called Source M SpeedBump. Coharp.Farmi DoRandamize Csharp.Form1 D " 0.0 5 555,7
P lod o SpeedBump, C3harp, Form1, Updateall{yvail private void QuickS8ortBtn Click(object\sender, System SpeedBump, Csharp. Form 1. InitializeComponent| void) 0.0 % 893.8
Top 20 Called Methods - SpeedBump. Driver Form1 MativeCppBin_Click{Object, Eventargs) 0.0 2 1,241.5
Speedfump. C arp'mel‘I”'t_'al'ZECDmD g i SpeedBump, CSharp, Form1 EndTiming(String) 0.0 8 2934
SpeedBurnp. CSRarp Form?, QuickSortBtn 4 0.0 33,1804 false; SpeedBump. Csharp. Form1 . QuickSartBtn_Click{Obiect, Eventrgs) 0.0 4 566.2
SpeedBump, CShisrp.Form 1, EndTiming Sty 4 0.0 23,748.4 BubbleSortBtn. Enabled = false; SpeedBump.CSharp, Form1 UpdateAllfvoid) 0.0 12 192.8
SpeedSump. Driver.Formi . CSharpBin_Clic] 4 Dl 34,4230 QSorti0, mmElems-1}; SpeedBump.Driver.Forml.CSharpBtn_Click(Dbject, Eventa... 0.0 3 688.1
SpeadBump. Driver Form1 Ma\n(void)_ a 0.0 71,2109 if (bHeedlpdate) UpdateAll(); ’h;'SriS value 0.0 1 1,984.6
4 : s 4 0.0 24,211.8 Rand Etn.Enabled H S oerence z 2
SpeedBurnp, Driver,Form 1, NativeCppBtn_| 4 0.0 iSesin E:T::ii;:;m:k Sirt: ..:"f“g = percent change 0% 200% 2
SpeedSump. CSharp.Form1 . RandomizeBtr| 4 0.0 6.3 3 Shona fneal - o0 =
SpeedBurnp, CSharp.Farm1 Formi_Load(
SpeedBump. CSharp.Form1 , StartTiming(s| private woid BubbleSortBtn_Click(object sender, Skste .
SpeedBump. Driver. Form1.Dispose(Boales 5 4 § t Start Timing { *Tima] HethodList Souce Drivercs] Gession Sulymary | Compare session data to
SpeedBurnp, Dri : : f
p 2 QuickSortEen. Enay e Sesston Sumary Al assess impact of code changes
i BubbleZortEBtn. Eng
Int32 i, ji Starced: 21972010 5:19:01 AM
fori{i = nunElenms ||Ended: 21972010 9:21:18 AM
4 = SpeedBump.Driver.... 50.3 % System.Windows.Form... 35.8 % f:
0.0% 0i% 4 for{j = 0; iq|Erecucanle: C:\SpeedBunp. Net\Driveribin\Releass)\Dri
{ Command Args:
9.1% 00% if {(Elems|Exit Code: o
< SwapH
T Processor Speed: 299% Mhz
00% SpeedBump.CSharp.Fo... T # of Processors: 1
S if (bHeedUpdate) ||0% Version: Microsoft Windows XD
- LR # of Called Methods (with thread starts): 3,725
# of Calls: 12,069,842
i R Total Timing: 325,693,589, 8 Microseconds
X, 100.0 %
DTWLIE4M-053 - 1116 (Driwer)
0.0% . Muuber of Called Methods: 3,726
Explore calling Percent of Time Spent on Nachine: 100.0
o S st sequence of methods Instrunsnted Source Inages
109.0% . . .
and identify critical path E i
@ 0.0% 0% | 5 Mumber of Called Methods: 14 o]
= < ¥
< B < >
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Using DPAnalysis.exe

Use DPAnalysis.exe to run coverage or performance analysis sessions from the command line.

DPAnalysis.exe accepts command line switches or an XML configuration file.

Command Line Operations

Use this syntax to run coverage or performance sessions from the command line:

DPAnalysis.exe [a] {b} {c} {d} [e] target {target args}

DPAnalysis.exe requires Analysis Type and Target Type switches. Use of other switches is

optional.
The following table lists the switches used with DPAnalysis.exe:

Category Switches

Category

Using DPAnalysis.exe

Switches

[a] Analysis Type /Cov[erage] - Sets analysis type to DevPartner coverage analysis
/Perf[ormance] - Sets analysis type to DevPartner performance analysis
{b} Data Collection /E[nable] - Enables data collection for the specified process or service
/Dlisable] - Disables data collection for the specified process or service
/R[epeat] - Profiling will occur any time you run the specified process until you use

the /D switch to disable profiling.

{c} Other Options

{d} Analysis Options

[e] Target Type

/O[utput] - Specify the session file output directory and/or filename
/W[orkingDir] - Specify working directory for the process or service
/H[ost] - Specify the target’s host machine

/NOWAIT - Do not wait for the process to exit, just wait for it to start
/N[ewconsole] - Run the process in its own command window

/F[orce] - Forces profiling for coverage or performance of applications written
without managed code or CTI.

/NO_MACHS - Disables excluding time spent on other threads

/NM_METHOD_GRANULARITY - Sets data collection granularity to method-level
(line-level is default)

/EXCLUDE_SYSTEM_DLLS - Excludes data collection for system dlls (performance
analysis only)

/NM_ALLOW_INLINING - Enable run-time instrumentation of inline methods
(coverage and performance analysis only)

/NO_OLEHOOKS- Disable collection of COM

/NM_TRACK_SYSTEM_OBJECTS - Track system object allocation (memory analysis
only)

Identifies target that follows as either a process or service. Pick only one. All
statements that follow the target name/path are considered arguments to the target

/P[ocess] - Specify a target process (followed by arguments to process)
/S[ervice] - Specify a target service (followed by arguments to service)
/C[onfig] - Path to configuration file
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Configuration File

Use this syntax to run coverage or performance analysis sessions through a configuration file:
DPAnalysis.exe /config c:\temp\config.xml

The following table briefly describes the XML elements. See the DevPartner online help or the
Understanding DevPartner manual for more information.

Element

Description

Using DPAnalysis.exe

AnalysisOptions

Arguments

Excludelmages

(Optional) For each Process or Service, zero or one. Defines runtime attributes for the
specified target process or service. Attributes correspond to DevPartner properties
accessible from the Properties Window in Visual Studio.

Attributes: SESSION_DIR, SESSION_FILENAME, NM_METHOD_GRANULARITY,
EXCLUDE_SYSTEM_DLLS, NM_ALLOW_INLINING, NO_OLEHOOKS,
NM_TRACK_SYSTEM_OBJECTS, NO_MACH5

(Optional) For each Process or Service, zero or one. Defines runtime attributes for the
specified target process or service. Attributes correspond to DevPartner Coverage,
Memory and Performance Analysis properties accessible from the Properties Window in
Visual Studio.

Attributes: SESSION_DIR, SESSION_FILENAME, NM_METHOD_GRANULARITY,
EXCLUDE_SYSTEM_DLLS, NM_ALLOW_INLINING, NO_OLEHOOKS,
NM_TRACK_SYSTEM_OBJECTS, NO_MACH5

(Optional) For each Process or Service, zero or one. No default if omitted. Defines
images (at least one, no maximum) which, if loaded by the target process or service,
will not be profiled. No attributes.

Element Description

Host (Optional) For each Process or Service, zero or one. No default if omitted. Sets the host
machine of the target process or service. No attributes.

Name One required for each service. Provides the name of the service as registered with the
service control manager. This is the same name you would use for the system's NET
START command. No attributes.

Path One required for each process. Specify a fully qualified or relative path to the
executable. You can specify the executable name without the path if the executable
exists in the current directory. No attributes.

Process The configuration file must contain at least one Process or one Service element.

RuntimeAnalysis
Service

Targets

Specifies a target executable.
Attributes: CollectData, Spawn, NoWaitForCompletion, NewConsole

Required; one only. Defines the type of analysis and maximum session time.

The configuration file must contain at least one Process or one Service element.
Specifies a target service.
Attributes: CollectData, Start, RestartlfRunning, RestartAtEndOfRun

Required. One only. Begins a block of one or more Process or Service entries. Target
processes and services are started in the order they are listed in the configuration file.
Attributes: RuninParallel
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Error Detection

File Extensions Used by Error Detection

Category

Error Detection

Settings

Extension  File Type Description

.dpbcl Error Detection Session File This is the Error Detection log for the user's program
execution.

.dpbcc Error Detection Settings File This file contains the various settings for Error

.dpbcd Detection. The .dpbcd extension refers to the default
settings file created, while .dpbcc refers to a custom
settings file that has been saved separately.

.dpsup Error Detection Suppressions File This file contains the various suppressions for the user's
program.

.dpflt Error Detection Filters File This file contains the various filters for the user's
program.

.dprul Error Detection Rules File This is a database of the user's suppressions and filters.

Default Options (DevPartner Studio Professional and Enterprise Editions)
or Settings (Visual C++ BoundsChecker Suite)

Category Settings
General On Log events
On Display error and pause

Data Collection

Prompt to save program results
Show memory and resource viewer when application exits

Source file search path - based on the location of the .EXE (standalone),
.DSW (C++), or .SLN (Visual Studio).

Override symbol path (standalone only) - Default: empty

Working directory (standalone only) based on the location of the .EXE
Command line arguments (standalone only) - Default: empty

Call parameter coding depth = 1

Maximum call stack depth on allocation = 5

Maximum call stack depth on error = 20

NLB file directory is based on the location of the .EXE (standalone),
.DSW (C++), or .SLN (Visual Studio).

API Call Reporting

Call Validation

COM Call Reporting

COM Object Tracking

Off

Off

Off

Enable API call reporting. All selections are unavailable until you select this
item.

Collect window messages - Default when active: Off

Collect API method calls and returns. - Default when active: On

View only modules needed by this application - Default when active: On
All modules (tree view). - Default when active: All selected

Enable call validation. All selections unavailable until you select this item
Enable memory block checking - Default when active: Off

Fill output argument before call - Default when active: Off

COM failure codes - Default when active: On

Check for COM “Not Implemented” return code - Default when active:
On

API failure codes - Default when active: On
Check invalid parameter errors: API, COM - Default when active: both On
Category: Handle and pointer arguments - Default when active: On

Category: Flag, range and enumeration arguments - Default when
active: On

Check statically linked C run-time library APIs - Default when active: On

DLLs to check for API errors (failures or invalid arguments) - Default
when active: All items selected

Enable COM method call reporting on objects that are implemented in
the selected modules

Report COM method calls on objects implemented outside of the listed
modules - Default when active: On

All components tree view - Default when active: All selected
Enable COM object tracking
All COM classes tree view - Default when active: All selected
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Category

Settings

Deadlock Analysis

Memory Tracking

.NET Analysis

.NET Call Reporting

Resource Tracking

Off

Enable deadlock analysis
Assume single process - Default when active: On
Enable watcher thread - Default when active: Off

Generate errors when: A critical section is re-entered - Default when
active: Off

Generate errors when: A wait is requested on an owned mutex - Default
when active: Off

Number of historical events per resource - Default when active: 10
Report synchronization API timeouts - Default when active: Off

Report wait limits or actual waits exceeding (seconds) - Default when
active: 60

Synchronization Naming Rules - Default when active: Don’t warn about
resource naming

Enable memory tracking

Enable Leak Analysis Only

Show leaked allocation blocks

Enforce strict reallocation semantics

Enable FinalCheck

Enable guard bytes; Pattern = FC; Count = 4 bytes
Check heap blocks at runtime: On free

Enable fill on allocation; Pattern = FB

Check uninitialized memory; Size = 2 bytes

Enable poison on free; Pattern = FD

Enable .NET analysis

Exception monitoring - Default when active: On

Finalizer monitoring - Default when active: On

COM interop monitoring - Default when active: On
PInvoke interop monitoring - Default when active: On
Interop reporting threshold - Default when active: 1
Enable .NET method call reporting

All types (tree view node) - Default when active: Selected.
.NET User Assemblies (tree view node) - Default when active: Selected

.NET System Assemblies (tree view node) - Default when active: Not
selected

Enable resource tracking
Resources tree view. All listed resources are selected by default

Error Detection

Error Detection Toolbar in Visual Studio
Start with Error Detection

Start with Coverage Analysis

Start with Error Detection and Coverage Analysis
Start without debugging with Performance Analysis

Note: The arrows next to each button allow you to start with or without
debugging, depending on the default action of the button.

M = @ = &‘: = @. . @ Error Detection - | Fy

Native C/C++ Instrumentation Set DevPartner Options——|

Enable/disable instrumentaton ~——

Choose instrumentation type
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Error Detection

Error Detection Window Icons Used in the Results Pane
— Results Pane — Details Pane Icon Description Appears in...
Summary, Memory Leaks, Other Leaks, Errors, NET Displays long description of detected & Memory Leaks Summary, Memory Leaks, and Transcript tabs
Perfo_rmance, Mod_ules, Transcript tabs provide error; call stack |nformat|on, reference s Other Leaks Summary, Other Leaks, and Transcript tabs
overview and detail about detected errors. count graph (see inset below). L]
x Errors Summary, Errors, and Transcript tabs
e Sl e 2| P R e U A .NET Performance Summary, .NET Performance tabs
= ¥ Movste aros o : e e e :
? | Module Load Event Summary, Modules, and Transcript tabs
X Monzero lack count 1 API_Fre Painter_ArayParamE <Fange
X Dangling pointer 1 Pointer_ ;I
i 1 Current Cal Stack - Thiead 0 [0+0108] =l & Subroutine call Transcript tab
¥ Poiter Unrelated Function ‘ Filz ;I
Dmue' Imtej =2 i ; 7 Forter | |FonteArayParamErRange  FTRERR.CPP [ ﬁ Garbage Collection Event Transcript tab
X' Unrelated pairter comparison = ExecuteFunction BugBench?Dlg cpy
X Fle:ad Overrun 1 OnTest BuaBench7Dlg.cp . .
- X Wiite Overrun 1 - | | _AfxDispatchCmdisg cmdtarg.cpp o Event Begins Transcript tab
1| | T OnCmdMsg cmdtarg.cpp
OnCrmdhzq digeore.cop =5
El Summary | $ Memary Leaks I $4 Otherleaks 3¢ Ervors I s ]l 1 _>|_I *T Event Resumes Transcript tab
c:hprogram fileshmicra focushdevpartner studichexamples\bugbench?\mainkptier.cpp =
— Event Ends Transcript tab
{ = i P
TTHY Rieference CountView | Object Identiyiew |
int ab[ i s
= = | e N .
EL a’B,‘ A anay index out of range il e ] Icons Used in the Details Pane
3L—u—u—n—u—n—n—\_ —
CaTCH - )
123456789 11 13 15 Icon Description
\ hd| Y Subroutine call
L AdHRief - Thread 0 [0<0070] |
Source Pane Fupction | Fie || Line  Dttet] | Entry Parameters
olez2dI ODDDTEDEF [lr]
Displays source code for the o A o .
if availabl ExpouteFunction bugbench7dig.cpp 695 ik Exit Parameters
detected error, if available. Orfrest bugbench7d cpp san L)}
_alDispatchCmdMsg  emekarg.cpp e
Orfmdisg cmdtarg.cep B | O Return Value
' Details Pane - Reference Count Graph % Property (default) for data types
Displays Reference Count View and Object Identity
View tabs when you select an Interface Leak in the i Property for data types

Results pane.
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Error Detection

Reference Count Graph Toolbar Memory and Resource Viewer Dialog Box

Vertical Zoom Out — Results Pane Memory Contents Pane
Vertical Zoom In Scale to lSiz.e Displays Memory, Resource, and Summary tabs
Horizontal Zoom Out Select Viewing Area Stack Pane
Horizontal Zoom In —I - DevPartner Erron Detection Memorny and Resource Viewer =1
= | 3o |5

I:E:JI'C Location [combined] Thread |D Eyte Count Address ggg%gggg gggggﬁg% d.»
- TA— B . 5410 4b2af | folEE1CDAD| 0524180 4
IFALE. dil atlcom b, ATL:: ClomCreator<class Unllrd 40 D:D5elcdt| nlcE1CDA4| FEEFEEEE iy
o 1ATL:CComObjectCacheds class
Pl’ogl’am Error Detected Dlalog Box {ATL:D0omClassFactony> >::Createlnstance - ine ggg%ggig gggggggg
1801 ! ! DSEICDEO| 00000000
- . IFACE.dll aticom.h, ATL: CComCreator<class 0x0574 160 | 0x05elcde| fncE1cpeE4| oooooooo
Error description Tabs for multiple call stacks AL BLomObeel class EYiewo: Breatalnstances: DSEICDES| fbfbfb0l _@ad
line: 1801 ! ! DSEICDEC| 04b91fc3 &.?
B Program Error Detected - BugBench.exe
F :Memory Leak Due to Free] Calling free causes (a leak of address 0:029E 2868 [10) allocated by |
mallac. | Function F.  Line/0Of.
| | ATL:CComCreatorecla.. at 1801
| Current Call Stack - Thread 0 [040408] | Allocation Dall Stack - Thiaad 0 [0x0403] | i e g
Elinction Fils Line / Offset ATL:CComCreatorccla...  at 1801
Leak_LeakFromFrees leakerr.cpp E& __‘ | >
ExecuteFunction bugbench?dlg.cpp B35 & Memory | %9 Resources | Bl summary
OnTest bughench?dig.cpp B33 Q
mfc70.dl 0+00078420 citprogram files‘microsoft wisual studio 9,.0%wvohatlmichinclude\atlcom.h
#pragma warning(push) 5
P fpragwa warningi(disable: 6014)
PE * ; — /* prefast noise VSW 459351 */
Bl ATLTRY(p = new T1ipv)
p = (PE *)malloc [ =izecf [ PE ) | #prhome warning (pop)
p->ptr = (char *jmalloc( 10 1 ; == if (p !'= NULL)
free ( p ) : { b
< >
| CATCH
. : . v Lirfe Murmber: 1801 [ Showing al ters vl [ Hep | [ save | [ Makpndiiose | [ Ciose
[ Egplain ] [ Memory/Resource Yiewsr ] [ Copy ] [ Suppress... ] L— Source Pane Mark and Close —
[71 Dt show this enor diskon | This Frun v Displays source code for the Click to mark existing allocations and close the
A [ ] detected error, if available. dialog box. Marked items will not be shown when
Ditable event loggin Thiz Run v Debu Halt Continue .
oging | vl [ a_J | ) | Memory and Resource viewer reappears.
— Call stack information — Source code for the detected error
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ActiveCheck and FinalCheck Error Detection

ActiveCheck

ActiveCheck™ analyzes your program and searches for errors in your program executable as
well as the dynamic-link libraries (DLLs), third-party modules, and COM components used by
your program. The following tables list the types of errors found with ActiveCheck error

detection.

Deadlock-related Errors

API and COM Errors

Error Detection

Memory Errors

Dynamic memory overrun

Freed handle is still locked

Handle is already unlocked

Memory allocation conflict

Pointer references unlocked memory block
Stack memory overrun

Static memory overrun

Deadlock

Potential deadlock

Thread deadlocked

Critical section errors

Semaphore errors

Resource usage and naming errors
Suspicious or questionable resource usage
Handle errors

Event errors

Mutex errors

Windows event errors

COM interface method failure

Invalid argument

Parameter range error

Questionable use of thread

Windows function failed

Windows function not implemented
Invalid COM interface method argument

Memory Errors

FinalCheck Compile Time Instrumentation - Deepest Error Detection

FinalCheck™ compile time instrumentation (CTI) enables Error Detection to find more errors
(memory leaks, pointer errors, data corruption errors, and so on) as they occur in real time.
FinalCheck finds these types of errors, plus all errors found with ActiveCheck.

Pointer and Leak Errors

.NET Errors

Pointer and Leak Errors

Finalizer errors
GC.Suppress finalize not called
Dispose attributes errors

Unhandled native exception passed to managed
code

Interface leak
Memory leak
Resource leak

Reading overflows buffer
Reading uninitialized memory
Writing overflows buffer

Array index out of range
Assigning pointer out of range
Expression uses dangling pointer
Expression uses unrelated pointers
Function pointer is not a function
Leak due to leak

Leak due to module unload

Leak due to unwind

Memory leaked due to free
Memory leaked due to reassignment
Memory leaked leaving scope
Returning pointer to local variable
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List of Available Keyboard Commands - Visual Studio

Command Action

Ctrl+Shift+O File > Open > Project
Ctrl+Shift+N File > New > Project
Ctrl+S File > Save Project
Ctrl+Shift+S File > Save All
Ctrl+Shift+F Edit > Find in Files
Ctrl+Shift+H Edit > Replace in Files
Alt+F12 Edit > Find Symbol
Ctrl+Alt+L View > Solution Explorer
Ctrl+Shift+C View > Class View
Ctrl+Alt+S View > Server Explorer
Ctrl+Shift+E View > Resource View

F4 View > Properties Window
Ctrl+Alt+X View > Toolbox
Shift+Alt+Enter View > Full Screen
Shift+F4 View > Property Pages
Ctrl+Shift+B Build > Build Solution

F5 Debug > Start

Ctrl+F5 Debug > Start Without Debugging
Ctri+Alt+E Debug > Exceptions

F11 Debug > Step Into

F10 Debug > Step Over
Ctrl+B Debug > New Breakpoint
Ctrl+F1 Help > Dynamic Help
Ctrl+Alt+F1 Help > Contents
Ctrl+Alt+F2 Help > Index

Ctrl+Alt+F3 Help > Search
Shift+Alt+F2 Help > Index results
Shift+Alt+F3 Help > Search results

Export DevPartner Data: Command Line Use

Export DevPartner Data: Command Line Use

You can use DevPartner.Analysis.DataExport.exe from the command line to convert DevPartner
coverage analysis (.dpcov), coverage analysis merge (.dpmrg), and performance analysis
(.dpprf) session file data to XML.

Use this syntax to export session data to XML:

DevPartner.Analysis.DataExport.exe [sessionfilename|pathtodirectory] {options}

Options
The following table lists the command line options for DevPartner.Analysis.DataExport.exe.

You can use an equal sign, a colon, or a space to separate an option from the value or values
you specify.

Switch Description

/out [put]=<String> Specify the output directory for exported XML files. Creates the
directory if the directory does not exist.

/r[ecurse] Search subdirectories for DevPartner session files.

/f[ilename]=<String> Specify the name of the XML output file. Appends .xml to the name
specified.

/showAll Shows all performance and coverage session file data available in a

performance or coverage session file.
For example, if you export a performance session file with this option,
the resulting XML file contains both performance and coverage data

fields.
/wlait] Wait for input before closing console window.
/nologo Do not display the logo or copyright notice.
/help or /? Display help in the console window.

DevPartner Studio Quick Reference - 14




<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /None
  /Binding /Left
  /CalGrayProfile (Dot Gain 20%)
  /CalRGBProfile (sRGB IEC61966-2.1)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /Error
  /CompatibilityLevel 1.4
  /CompressObjects /Tags
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages true
  /CreateJDFFile false
  /CreateJobTicket false
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /ColorConversionStrategy /LeaveColorUnchanged
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /SyntheticBoldness 1.00
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 1048576
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize true
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo true
  /PreserveCopyPage true
  /PreserveEPSInfo true
  /PreserveHalftoneInfo false
  /PreserveOPIComments false
  /PreserveOverprintSettings true
  /StartPage 1
  /SubsetFonts true
  /TransferFunctionInfo /Apply
  /UCRandBGInfo /Preserve
  /UsePrologue false
  /ColorSettingsFile ()
  /AlwaysEmbed [ true
  ]
  /NeverEmbed [ true
  ]
  /AntiAliasColorImages false
  /DownsampleColorImages true
  /ColorImageDownsampleType /Bicubic
  /ColorImageResolution 300
  /ColorImageDepth -1
  /ColorImageDownsampleThreshold 1.50000
  /EncodeColorImages true
  /ColorImageFilter /DCTEncode
  /AutoFilterColorImages true
  /ColorImageAutoFilterStrategy /JPEG
  /ColorACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /ColorImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasGrayImages false
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Bicubic
  /GrayImageResolution 300
  /GrayImageDepth -1
  /GrayImageDownsampleThreshold 1.50000
  /EncodeGrayImages true
  /GrayImageFilter /DCTEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG
  /GrayACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /GrayImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasMonoImages false
  /DownsampleMonoImages true
  /MonoImageDownsampleType /Bicubic
  /MonoImageResolution 1200
  /MonoImageDepth -1
  /MonoImageDownsampleThreshold 1.50000
  /EncodeMonoImages true
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects false
  /PDFX1aCheck false
  /PDFX3Check false
  /PDFXCompliantPDFOnly false
  /PDFXNoTrimBoxError true
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile ()
  /PDFXOutputCondition ()
  /PDFXRegistryName (http://www.color.org)
  /PDFXTrapped /Unknown

  /Description <<
    /ENU (Use these settings to create PDF documents with higher image resolution for high quality pre-press printing. The PDF documents can be opened with Acrobat and Reader 5.0 and later. These settings require font embedding.)
    /JPN <FEFF3053306e8a2d5b9a306f30019ad889e350cf5ea6753b50cf3092542b308030d730ea30d730ec30b9537052377528306e00200050004400460020658766f830924f5c62103059308b3068304d306b4f7f75283057307e305930023053306e8a2d5b9a30674f5c62103057305f00200050004400460020658766f8306f0020004100630072006f0062006100740020304a30883073002000520065006100640065007200200035002e003000204ee5964d30678868793a3067304d307e305930023053306e8a2d5b9a306b306f30d530a930f330c8306e57cb30818fbc307f304c5fc59808306730593002>
    /FRA <>
    /DEU <>
    /PTB <>
    /DAN <>
    /NLD <>
    /ESP <>
    /SUO <>
    /ITA <>
    /NOR <>
    /SVE <>
  >>
>> setdistillerparams
<<
  /HWResolution [2400 2400]
  /PageSize [612.000 792.000]
>> setpagedevice


