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Enterprise Analyzer Release Notes -
Version 6.0

These release notes contain a summary of the major features of Enterprise Analyzer Version 6.0, as well
as late-breaking information about the product.

Before using Enterprise Analyzer, please read the Getting Started manual in the online help to gain an
understanding of the user interface and tool metaphor. For more detail on the behavior, usage and
limitations of Enterprise Analyzer, please refer to the online help.
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What's New

Enterprise Analyzer Product Enhancements

REST API and Jenkins Plugin
A REST API has been added for administrating workspaces, running searches against the repository, and
generating reports. A Jenkins plugin to use the REST API is included for easy integration with the popular
continuous integration system.

For details, see Appendices II, III, and IV in this document.

Business Rules in EA Web
The viewing and editing of business rules is now available in EA Web. Any rules created in the desktop
application will be shown in the Web client interface under a new Business Rules tab at the top of the page.
The display in EA Web matches the display from Interactive Analysis in the desktop application. Rules can
be viewed in the Grouping or Triggering tree views, the attributes are shown and can be edited, and the
source view highlights the selected rule's source code.

There is also a feature to show all rules associated with a selected line in the source. To use this feature
while in the Business Rules section of EA Web, right-click a construct in the source view and choose Find
Rules. A pane labeled Found Rules will be shown under the rules tree with all the rules that cover the
selected code segment.

Homonyms Search Method Options
New options have been added to specify the rules that are used when resolving references to include files.
The three new options can be found in the Project Options > Homonyms Support tab.

The first option is Search all, use the provided paths as preference. This is the default behavior and is
the same as the default behavior in previous versions. It will search the entire workspace to complete the
reference. If more than one instance of the referenced file is found, the provided list of homonyms paths will
be used to determine which version to use.

The second option is Search only in the provided paths. When this option is selected only the paths
specified as homonyms paths will be used as a location for finding include files, and the entire workspace
will not be searched.

The last option is Search in common location and only the same subsystem. This option may help
when there is a large number of applications/subsystems. It is designed to allow the folder structure in the
file system to define the boundaries between subsystems and to restrict retrieval of include files based on
the physical folder structure. This could allow all files to be included in a single project without the need to
specify the search paths in the homonyms options.

This option requires you to identify two key levels in the source folder structure:

1. All common libraries to be located inside the same root folder, for example C:\Sources\Common. Files
in folders located here will be "visible" to all programs being analyzed.

2. All subsystems roots to have a common root folder. For example, if you have 2 subsystems, BATCH and
ONLINE, they need to be children of the same folder (e.g. C:\Sources\Subsystems).
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Therefore, in this example the structure will be:

C:\Sources
    Common
        LIB1
        LIB2
    Subsystems
        BATCH
        ONLINE

In this case, you should specify:

Common Folder: C:\Sources\Common

Subsystems root level: C:\Sources\Subsystems

Then the BATCH application will not get copybooks from ONLINE and vice versa. But both can get
copybooks from folders LIB1 and LIB2.

Refresh Registered Source Paths
A new feature allows the location of registered source files to be changed. This feature is available from the
Refresh Registered Source Paths menu item in the Enterprise Analyzer Administration tool as well as
from the Source Synchronization window in the main tool when a registered root folder that contains
sources is not found. In the main tool it is accessible in the Source Synchronization window from the
Change Registered Source Paths button in Removed folders/subfolders when it is available.

This feature is useful in cases where sources have been moved to another location, a folder that contains
sources has been moved, a folder that contains sources has been renamed, or when sources were
registered from a non-shared location and the location has since been shared.

Support for SQL Statements in JCL
Support has been added for processing JCL control card data containing SQL statements. Various SQL
relationships such as Reads Table, Updates Table, etc. can be generated from jobs. The check for
SQL statements is done whenever there is a Uses Control Cards File relationship present for JCL.

Convert Missing Programs to System Programs
The ability to convert missing programs into a system program has been added. When viewing a missing
program in the Repository Browser, right-click the Program Entry Point and choose Convert Unresolved
Entry Point To System Program from menu. All calling relationships for the program will automatically
change to calls to a system program of the same name. This is useful when the source base includes
references to third party programs for which we do not have the sources to load into the repository.

A dialog is also provided to convert multiple unresolved program entry points without having to find them
each separately in the Repository Browser. To access this dialog, click View > Entire Workspace in the
main window. Then switch to the Types view in the browser, expand the Workspace node at the top of the
browser, and right-click the Program Entry Point folder and choose Convert Unresolved Entry Points To
System Programs....

Deleting a system program is possible by selecting it in the Repository Browser and choosing Delete
System Program from the right-click menu. When the system program is deleted it will be converted back
to an unresolved entry point and all calling relationships to it will be automatically updated accordingly.

Note that the System Programs are no longer managed in the Workspace Options.
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Search Results Report in the Repository Browser
A new report to save the search results in the Repository Browser has been added. This report can be
executed from the results of any Search Assistant or Find search by right-clicking any node and choosing
Search Report.

Usability

Reference Reports

• A new option called Show Relation Path has been added to the View menu for the Cross Reference
Report. When selected, the report is refreshed and the Relation column will then include details for
composite relationships. It shows the full path of relationships between the left and right entities.

• Four new composite relationships have been added to make the results in the Cross Reference Report
more understandable.

• [Invokes System Program] Job -> Has Data Connector -> Is read in system program -> System
program

• [Invokes System Program] Job -> Has Data Connector -> Is written in system program -> System
program

• [File is accessed by Program] Data Connector -> Refers to File -> Data port is inserted in Program -
> Program

• [File is read in Program] Data Connector -> Refers to File -> Data port is read in Program ->
Program

• If a program, program entry point, or file originates from a JCL, it will not be included in the Cross
Reference Report.

• The columns in the Cross Reference, Unresolved, and External Reference reports have been adjusted
to improve their readability. The order of the columns has been changed to:

Referred By
Referring Object Type
Relationship
Object Name
Object Type
Legacy Object
Object Description

• The object properties window is now sensitive to which cell has been clicked so it will either show the
referred or referring object. If the Relation field is selected, the properties will show the referred object.
Certain relationships that showed irrelevant objects are no longer included.

Other Enhancements and Changes
• The performance of showing the Source Synchronization dialog has been improved. The Source

Synchronization count of invalidated files is no longer calculated before the dialog window opens. The
dialog opens faster and the count of total objects to be invalidated will be calculated and continuously
updated without blocking the UI. The count is based on the selections of added and updated files.

• Support for general regular expressions in patterns in NewBatchProgs elements has been added in
Legacy.xml to allow more complex regular expressions to be specified to match text. To do this, add
regex='full' as an attribute to any element to use the extended regular expression syntax. If regex
is not set to full, then the previously existing functionality is used.

• Project options are now available only to Master users or the owner of the project.
• The Import, Copy, and Assign buttons in the Options Manager are now enabled for master users only.
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• The ProcessEmbedments list has been added to Legacy.xml to exclude certain JCL PGMs from
having their control cards be processed for embedded languages such as SQL.

• The Micro Focus compiler compatibility level verification option for the Micro Focus COBOL dialect
has been updated with values for MFLEVEL 19, 20, and 21. The default value remains level 15.

• A message has been added to the BRP logs indicating how many objects are not included in any
projects and therefore cannot be verified.

Example: "Selected XXX object(s) (XX object(s) not connected to any project and cannot be verified)."
• Some batch scripts have been restricted to be run by a master user only. When a non-master user

attempts to run the batch job, a message like the following will be shown in the log: "The user does not
have privileges to run source synchronization."

• A new checkbox option called Show empty columns has been added to the Configure Report Options
dialog for the Business Rule Report. If the option is selected, empty columns for Business Description,
Technical Description and Rule Description will appear in the report.

Nonfunctional Changes
• Windows Server 2019 is now supported.
• Microsoft SQL Server 2019 is now supported.
• DB2 9.5 is no longer supported. DB2 10.5 or higher is now required.
• Windows Server 2008 is no longer supported.
• Microsoft SQL Server 2008 is no longer supported.
• When saving diagrams the .vsdx format is now available instead of .vsd when the installed Visio

version is 2013 or higher.
• On startup rescuent.exe will be added to the trusted sites Internet Explorer options to prevent

obtrusive popup messages and to make charts visible in the Chart Viewer on Windows Server
Operating Systems.

• The Adopt OpenJDK version included with the product has been updated to 8.0.242.08.
• The Apache Tomcat version included with the product has been updated to 9.0.33.
• Microsoft .NET Framework Redist Package 4.6.1 is now installed by the product as a prerequisite.
• Microsoft .NET Framework Redist Package 3.5 SP1 is no longer installed by the product.
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Upgrades from Previous Versions
Enterprise Analyzer 6.0 supports upgrades of workspaces from Enterprise Analyzer version 5.0 GA or 5.0
with any HotFix and version 4.0 GA or 4.0 with any HotFix.

Upgrading workspaces that use non-inplace registration (starting from version 4.0 GA) is not
recommended. If upgrading from a version earlier than 4.0, creating new workspaces is recommended.

Important: All workspaces must be upgraded after installing EA 6.0. Before upgrading, we
recommend you contact SupportLine for the latest Enterprise Analyzer updates. SupportLine is also
available to give guidance on best practices for workspace upgrades. Before performing the upgrade
on important workspaces, be sure to back up the database and the workspace folder along with
the .rwp file. If you experience any issues or errors with the workspace upgrade process, please
contact SupportLine with a description of the problem and include the contents of the Upgrade folder
from the workspace as an attachment.
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Updating the EA Web Client
After installing Enterprise Analyzer 6.0, follow these steps to continue using the EA Web client. If
Enterprise Analyzer was installed with the Install Web Client option selected, steps 1 through 6 below can
be skipped.

1. Stop the Apache Tomcat service.
2. Delete EAWeb.war and the EAWeb folder from C:\Program Files (x86)\Apache Software

Foundation\Tomcat\webapps.
3. Delete everything in the ...\Tomcat\temp folder.
4. Delete everything in the …\Tomcat\work\Catalina\localhost folder.
5. Copy the EAWeb.war file from [EA install directory]\Web Client into the …\Tomcat

\webapps folder.
6. Start the Apache Tomcat service.
7. In the properties for the Enterprise Analyzer Web Service, go to the Log On tab, choose This account

and enter the account of a user with access to EA and the workspace.
8. Restart the Enterprise Analyzer Web Service.

Note: The browser clients might need to hard refresh the EA Web page with Ctrl+R to get the
latest version.

Note: When using EA Web in Internet Explorer, disable compatibility mode.
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Updating the Eclipse Plugins
Follow these steps after installing EA 6.0 to continue using the Clipper View and Search Assistant plugins
in the Eclipse IDE.

1. On the EA server, in the properties for the Enterprise Analyzer Web Service, go to the Log On tab,
choose This account and enter the account of a user with access to EA and the workspace. Restart
the Enterprise Analyzer Web Service.

2. Open Eclipse or Enterprise Developer on the client machine.
3. Go to Help > Install New Software.
4. Click the Add button next to the Work with list.
5. Click Archive and point to the EAIntegration.repository.zip file in [EA install

directory]\Bin. Then add a name in the Name field and click Add.
6. In the Install window, check the box for Enterprise Analyzer Access. Click Next.
7. Click Next again.
8. Accept the license agreement and when prompted, restart Eclipse.
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Silent Install
The following command can be used to perform a silent install of the product. This command will execute
the installation to the default location with the default selections of SQL Server Express install enabled,
Install Web Client disabled, Install MFA enabled, and the Administration tool enabled:

start EnterpriseAnalyzer60.exe ShowConfig=0 /s /v"/qn"

The following command will install with the default options plus the Install Web Client will be enabled:

start EnterpriseAnalyzer60.exe TomcatCheckbox=1 ShowConfig=0 /s /v"/qn"

The parameters to disable the default selections are SQLExpressCheckbox=0, MFACheckbox=0, and
EAAdminCheckbox=0. These are shown in the following command as an example of how to disable these
default selections and can be used along with the TomcatCheckbox parameter:

start EnterpriseAnalyzer60.exe SQLExpressCheckbox=0 MFACheckbox=0 
EAAdminCheckbox=0 ShowConfig=0 /s /v"/qn"

The install location can be changed with the InstallFolder parameter. The following command shows
an example of using the InstallFolder parameter to install to any location:

start EnterpriseAnalyzer60.exe InstallFolder="D:\Install\Micro Focus
\Enterprise Analyzer" ShowConfig=0 /s /v"/qn"
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Important Notes
• After installing EA version 6.0 with the Install Web Client option selected, if the Apache Tomcat service

does not start automatically, it can be started from the Services application. There you can also set the
Startup Type to Automatic if it is set to Manual.

• When installing EA version 6.0 over 5.0 with the Install Web Client option checked, newer versions of
the Adopt OpenJDK JRE will be installed and the older version left untouched by the EA installer. For
Apache Tomcat, if an older version is present Tomcat will continue to use the older version of the JRE.
Note that the latest version of the JRE will always be used by default for verification of Java files in a
workspace.

• When using EA on Windows Server 2019 it may be necessary, depending on the security settings, to do
one of the following in order to access a workspace local to that machine:

• Before creating a workspace share the folder or a parent folder that will contain the .rwp file and
workspace folder.

• Before creating a workspace add security permissions for the user account to the folder where the
workspace will be created.

• Add security permissions for the user account to the workspace folder that is on the same level as
the .rwp file.

• Enterprise Analyzer can be used with either an Analyzer Client license or a Developer Client license
installed in the Micro Focus License Administration application. The Analyzer Client license gives
access to all features of the desktop client. The Developer Client license gives access only to features
needed to build a workspace. The purpose of the Developer Client license is to allow one installation of
Enterprise Analyzer to create a workspace and deploy the Web client for end users to access the
workspace. Note that Business Rule Manager is licensed separately and also requires an Analyst Client
license.
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Resolved Issues
The numbers that follow each issue are the Support Incident Numbers followed by the Reported Problem
Incident (RPI) number (in parentheses).

• EA - Administration
• EA - Analysis
• EA - Analysis - Diagrammer
• EA - Analysis - HyperView - Clipper
• EA - APM
• EA - Backend
• EA - Backend - Analysis
• EA - Backend - Analysis - Cobol
• EA - Backend - Analysis - Cobol - Advanced
• EA - Backend - Analysis - DDL
• EA - Backend - Analysis - JCL
• EA - Backend - Parsing - Assembler
• EA - Backend - Parsing - Cobol
• EA - Backend - Parsing - Cobol/ACU
• EA - Backend - Parsing - Cobol/Cobol 390
• EA - Backend - Parsing - Cobol/MicroFocus
• EA - Backend - Parsing - Cobol/OSVS
• EA - Backend - Parsing - Cobol/Unisys 2200
• EA - Backend - Parsing - Cobol/Unisys MCP
• EA - Backend - Parsing - DDL
• EA - Backend - Parsing - EmbeddedSQL
• EA - Backend - Parsing - IMS Definition
• EA - Backend - Parsing - JCL
• EA - Backend - Verification
• EA - Batch Application Viewer
• EA - Batch Refresh Process
• EA - Business Rules
• EA - Change Analyzer
• EA - Common
• EA - Decision Resolution
• EA - Diagrammer
• EA - Documentation
• EA - EAWeb
• EA - Eclipse Plugins
• EA - ED/VC Integration
• EA - Homonyms
• EA - HyperView
• EA - HyperView - Callie
• EA - HyperView - Clipper
• EA - HyperView - Context
• EA - HyperView - Execution Path
• EA - IDE
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• EA - IDE - Activity Log
• EA - IDE - Options
• EA - IDE - Project Operations
• EA - IDE - Repository Browser
• EA - IDE - Workspace Operations
• EA - Installation
• EA - Inventory
• EA - Reports
• EA - Reports - Executive Report
• EA - Reports - Portability Assessment
• EA - Reports - Reference
• EA - Tag Manager
• Licensing
• MFA Client API

EA - Administration

• An issue where the provider was not automatically switched when needed has been fixed.

3216933 (1119231)

EA - Analysis

• An invalidation issue on MS SQL Server workspaces has been fixed.

3198867 (1118067)

EA - Analysis - Diagrammer

• An issue with the expansion of relationships for entity-based diagrams in Diagrammer has been fixed.

3218061 (1119324)
• When saving diagrams the .vsdx format is now available instead of .vsd when the installed Visio version

is 2013 or higher.

3211880 (1118800)

EA - Analysis - HyperView - Clipper

• Searches for variables no longer return declarations.

3206497 (1118280)

EA - APM

• An issue that caused some charts in Enterprise View to display incorrect object counts has been fixed.

3214608 (1119154)
• An issue causing charts to not include all objects has been fixed.

3193642 (1117673)
• The length of EV panes for editing Business Attributes has been increased.

3163608 (1114702)

EA - Backend

• Using the Invalidate Workspace feature from the administration tool will no longer clear the list of default
system programs.

3224812 (1120005)
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• Database error logging for the invalidation process has been improved.

3202326 (1117898)

EA - Backend - Analysis

• A problem causing non legacy objects to be selected when starting the Find feature from the Types view
of the Repository Browser has been fixed. This will improve the performance of opening the Find and
executing it.

3225832 (1120117)
• An issue where files were not resolved to data store names in the CRUD Report for a specific

Legacy.xml case has been fixed.

3169670 (1115271)

EA - Backend - Analysis - Cobol

• A problem causing the instances of declarations from COPY REPLACING copybooks to be
unrecognized has been fixed.

3207919 (1118398)
• A message will now be shown in the Activity Log when the Micro Focus COBOL parser license is

missing.

3206267 (1118249)
• The ability to convert missing program entry points into a system program has been added. When

viewing a missing entry point in the Repository Browser, right-click the entry point and choose "Convert
Unresolved Entry Point To System Program" from the context menu. All calling relationships for the
entry point will automatically change to calls to a system program of the same name. A dialog is also
provided to convert multiple unresolved program entry points without having to find them each
separately in the Repository Browser. To access this dialog, select the View menu in the main window
then choose Entire Workspace. Then switch to the Types view in the browser, expand the Workspace
node at the top of the browser, and right-click on the Program Entry Point folder and choose "Convert
Unresolved Entry Points To System Programs..." from the context menu. Note that the System
Programs are no longer managed in the Workspace Options.

3203915 (1118148)

EA - Backend - Analysis - Cobol - Advanced

• Generic API support for CICS SEND and RECEIVE statements has been added.

3178930 (1115989)

EA - Backend - Analysis - DDL

• An issue when using the "Use Database Schema" option that could cause tables from deleted DDL files
to remain in the repository has been fixed.

3226022 (1120061)
• DBD PSINDEX access without DATASET is now allowed.

3224514 (1119920)
• An issue with stored procedure relationships not being produced when verifying certain DDL files has

been fixed.

3162272 (1114588)
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EA - Backend - Analysis - JCL

• You can now specify PSB and IMS status for JCL verification by adding relationships to the
NewBatchProgs tag in the Legacy.xml.

3223345 (1119906)
• Adding a new configuration for a batch program in JCL using Legacy.xml will now correctly identify

passed DD's.

3213856 (1118946)
• Support has been added for general regular expressions in patterns in NewBatchProgs elements in

Legacy.xml.

(644902)

EA - Backend - Parsing - Assembler

• 'ALC' as a valid value for LANG in BMS has been added.

3217675 (1119295)

EA - Backend - Parsing - Cobol

• EasyTrieve verification now supports macro calls with a dot at the end.

3226737 (1120150)
• The SQL command ROW_NUMBER OVER is now supported.

3224662 (1119931)
• The OVER() function of ROW_NUMBER() no longer requires parameters. Nested SELECT statements

support has been enhanced.

3224662 (1119973)
• Square brackets in embedded SQL are now supported.

3202698 (1117949)
• Support has been added for terminating comma separators in the column list in SQL DECLARE TABLE

statements.

3202687 (1117948)
• A verification failure when 'occurs to' starts from zero and has 'depending on' specified has been fixed.

3202507 (1117923)

EA - Backend - Parsing - Cobol/ACU

• A parser error for values in the comment area for ACUCOBOL has been fixed.

3220491 (1119531)
• An issue with memory access violation caused by incorrect handling of INSPECT syntax was fixed.

3220286 (1119521)
• An issue when converting underscores to hyphens in ACUCOBOL identifiers has been fixed.

3219566 (1119453)

EA - Backend - Parsing - Cobol/Cobol 390

• An issue where a reference to a stored procedure from a COBOL file was not resolved correctly has
been fixed.

3213555 (1118938)
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EA - Backend - Parsing - Cobol/MicroFocus

• An issue with using the NoOdoslide compiler directive has been fixed.

3201862 (1117865)
• An issue where copybooks without an extension were not found has been fixed.

3201650 (1117847)
• An issue with hyphens and underscores in variable names being treated as the same character during

COBOL verification has been fixed.

3196348 (1117796)
• An issue where missing declarations for items used in display statements could result in certain COBOL

programs failing verification has been fixed.

3193838 (1117150)

EA - Backend - Parsing - Cobol/OSVS

• A verification failure for a specific program with the OS/VS COBOL dialect has been fixed.

3217527 (1119276)

EA - Backend - Parsing - Cobol/Unisys 2200

• An issue with the correct copybooks not being used for DASDL databases has been fixed.

3198401 (1117558)

EA - Backend - Parsing - Cobol/Unisys MCP

• An issue with a verification error for a duplicate identifier "TERMINATED" has been fixed.

3200560 (1117753)

EA - Backend - Parsing - DDL

• Various DDL verification errors have been fixed.

3226331 (1120099)
• Various DDL verification errors have been fixed.

3225890 (1120050)
• Support has been added to handle IDENTITY options without commas between them.

3225199 (1119983)
• An issue with the backquote character being used as a terminator has been fixed.

3217692 (1119294)
• Support for DB2 table clones with a new "defines" relationship has been added. Support for PCTFREE

5 FOR UPDATE 0 in Create Table has been added.

3189213 (1117687)
• Support for the XMLTABLE function has been added.

3188970 (1117667)

EA - Backend - Parsing - EmbeddedSQL

• The SQL parser has been improved to allow keywords to be used as identifiers in the case of
correlation clauses.

3218680 (1119382)
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• An issue with parsing the alter session SQL command in COBOL files has been fixed.

3201770 (1117850)
• Support for the XMLTABLE function has been added.

3198693 (1117682)

EA - Backend - Parsing - IMS Definition

• GSAM files used with the IMS CBLTDLI driver will now report direct data access to the file.

3225628 (1120024)

EA - Backend - Parsing - JCL

• Support has been added for processing JCL control card data containing SQL statements and
producing various SQL relationships such as "Reads Table", "Updates Table", etc. The check for SQL
statements is done whenever there is a "uses control card" relationship present for JCL.

3225190 (1120113)
• An issue with JCLLIB card not being honored for JCL Procedures when there are duplicate files located

on shared drives has been fixed.

3224677 (1119927)
• CA7 JCL override statements (#JI, #JO, #HLD, #JEND, etc.) will no longer return errors with JCL

verification, but these statements are ignored and not represented in the repository.

3224675 (1119926)
• An issue with JCL verification that prevented the generation of some relationships to programs has

been fixed.

3222599 (1119743)
• JCL verification with control cards now handles comment lines starting with ' *', '/*' between statements,

as well as comment lines starting with '*' within the definition of parameters.

3218369 (1119365)
• An issue with the verification of certain linkdeck files has been fixed.

3207652 (1118428)
• The error "Assertion Failed" no longer occurs when the option "Import instream data from DSN" is

enabled or disabled for verification.

3203157 (1117991)
• Support for leading TABs in JCL control cards has been improved.

3202695 (1117957)
• The ProcessEmbedments list has been added to Legacy.xml to exclude certain JCL PGMs from having

their control cards be processed for embedded languages such as SQL.

(644793)

EA - Backend - Verification

• Legacy.xml NewBatchProgs Level 1 relationships from jobs to files are now only created when
relationship="Runs" is specified in the add element.

3225773 (1120111)
• The stability of the product when the MSSQL broker is disabled has been improved.

3200452 (1117870)
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EA - Batch Application Viewer

• An error in Batch Application Viewer that resulted from the length of the step name exceeding the size
limit in the database has been fixed.

3222050 (1119753)
• An issue where the diagram view was only showing one instance of a system program that was

executed multiple times in a JCL has been fixed.

3197098 (1117476)
• BAV reports now show the fully qualified step/proc name.

3197009 (1117450)

EA - Batch Refresh Process

• A message has been added to the BRP logs indicating how many objects are not included in any
projects and therefore cannot be verified. Example: "Selected XXX object(s) (XX object(s) not
connected to any project and cannot be verified)"

3219394 (1119452)
• Some batch scripts have been made to be run by master users only. When a non-master user attempts

to run the batch job, the following message will be shown in the log: "The user does not have privileges
to run source synchronization."

3218519 (1119592)
• An issue that could cause queue processors to hang when waiting for dead tasks to finish has been

fixed.

3215690 (1119112)
• An issue with ApplyPCF.bj that could cause an error for certain duplicated records has been fixed.

3214180 (1119059)
• An issue with case sensitivity when using ApplyPCF.bj has been fixed.

3210150 (1118660)
• An issue that could cause an error when generating some flowchart diagrams in batch has been fixed.

3209381 (1118859)
• An issue with additional queue processors opening during BRP has been fixed.

3209254 (1118675)
• Source Synchronization will now correctly update a changed file even if the modified date on the file is

older than that of the previous version.

3209147 (1118523)
• A problem with PCF file creation and Obsolete handling has been fixed.

3198355 (1117557)
• An issue where sources registered through BRP in a non-inplace workspace could get flagged as not

found during Source Synchronization has been fixed. In some cases the Source Synchronization
message may still appear even if Source Synchronization has been disabled in the workspace. To
bypass the message, place a file called BRPFolders.cfg in the workspace folder. The BRPFolders.cfg
file should contain a line for every folder that should be ignored by the Source Synchronization
message. For example: \\machine-name\Workspaces\BRP_Workspace1\Staging
\20190620_1558\source

3196585 (1117532)
• A situation where a workspace RWP file could be overwritten as a log file because of an incorrect

Brave.exe command has been addressed. If an RWP file is passed as a Brave log, a message will be
shown to the user to avoid overwriting it.

(642394)
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EA - Business Rules

• An issue with empty condition handling in Rules Autodetect has been fixed.

3223536 (1119853)
• The "Statements From" prefix has been removed from the rule name of rules from Rules Autodetect that

contain multiple lines.

3223509 (1119915)
• An issue with importing an exported list of rules from Rules Autodetect has been fixed.

3217079 (1119323)
• The indication for which rules are selected in a rule set has been improved. If not all rules from a rule

set are selected, then the rule set will not show as checked and only the selected rules will be exported.

3216794 (1119540)
• An issue where the technical description for an SQL statement was incorrect has been fixed.

3216612 (1119215)
• An issue where an incorrect technical description was captured for a compute statement with Rules

Autodetect has been fixed.

3216609 (1119214)
• Variable names are now replaced with business names in the technical description for rules from Rules

Autodetect.

3216433 (1119305)
• An issue where rules were pointing to the wrong line in Rules Autodetect has been fixed.

3215823 (1119130)
• An issue with Rules Autodetect not including the full text of a condition in the technical description has

been fixed.

3215352 (1119089)
• The business rule report no longer repeats the same business function for different rule sets.

3212896 (1118849)
• An issue with Rules Autodetect not working with specific sources has been fixed.

3212409 (1118797)
• An issue with the line selection for a rule from the Rules Autodetect for a particular program has been

fixed.

3207887 (1118410)
• An issue with the Rules Autodetect feature for certain programs has been fixed.

3206921 (1118305)
• The Rule Set is now shown in the properties for a Rule in the Rules pane.

3206380 (1118331)
• An issue where rules could not be generated for a specific source has been fixed.

3200580 (1117750)
• A new checkbox option called "Show empty columns" has been added to the Configure Report Options

dialog for the Business Rule Report. If the option is selected, empty columns for Business Description,
Technical Description and Rule Description will appear in the report.

3206382 (1118290)

EA - Change Analyzer

• The correct message is now displayed when running step 2 for an empty list in Change Analyzer.

3215670 (1119199)
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• An issue that caused Change Analyzer to run only the selected program when choosing to run for all
programs has been fixed.

3201327 (1119176)

EA - Common

• An issue where the Export Source from Workspace feature from the Workspace menu was saving with
extra parent folders instead of just the registered folder has been fixed.

3215808 (1119168)
• Workspace and project options now have a single set of options assigned instead of being user-

specific. The workspace and project options are now the same for all users. This fixes situations where
users had different workspace and project option sets that could result in workspace corruption and
confusion. The User Options will continue to be user-dependent. When upgrading existing workspaces,
the workspace and project options will all be migrated to the options that belong to the master user that
upgrades the workspace.

3197338 (1117494)
• The option to disable Source Synchronization has been removed. Source Synchronization is always

enabled for in-place registration workspaces and always disabled for non-inplace workspaces.

(640855)
• The Source Synchronization count of invalidated files is no longer calculated before the dialog window

opens. The dialog opens faster and the count of total objects to be invalidated will be calculated and
continuously updated without blocking the UI. The count is based on the selections of Added and
Updated files.

(642650)

EA - Decision Resolution

• Support for procedure pointers in COBOL has been added to improve the resolving of some decisions.

3224803 (1119947)
• An issue where the checked objects in the "Available Objects" list were not shown in the "Decision List"

has been fixed.

3199925 (1117711)
• An issue causing Decision Resolution to sometimes not show the first "resolved to" item has been fixed.

3197682 (1117519)

EA - Diagrammer

• An issue with turning off the "Auto Expand" option in the Diagrammer has been fixed.

3208268 (1118518)

EA - Documentation

• The following note has been added to the Installation Guide: "The Administration tool will prompt to be
run with elevated privileges. This is required because some features of the tool require write access to
the Program Files directory."

3218180 (1119314)
• A note about the commits to the database has been added to the Invalidating Files Before Reverification

topic.

3202574 (1118418)
• Reports are now listed under Reports in the documentation.

3199136 (1117623)
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• The Viewing Inventory Reports topic has been updated.

3198984 (1117621)
• ImpExBav.bj has been removed from the documentation.

3198895 (1117603)
• Information about expanding copybooks has been removed from the documentation.

3180043 (1116148)
• A new ACU COBOL section has been added to the Support Notes.

3116529 (1110667)
• The documentation on the different types of searches has been updated.

2828276 (1100408)
• The EA Web reports have been documented.

2818999 (1099251)

EA - EAWeb

• A display issue with the Project Name selection list for Code Search has been fixed.

3206271 (1118258)
• The error message shown when failing to connect to a workspace has been improved.

3204332 (1118171)
• The correct source is opened when opening source from relations.

3191476 (1117408)

EA - Eclipse Plugins

• The Search Assistant plugin now works for remote workspaces.

3207459 (1118361)
• An issue causing the wrong editor to open has been fixed.

3205351 (1118209)

EA - ED/VC Integration

• A change has been made to allow DFHEIBLK to appear as an input and output parameter to extracted
components created in Logic Analyzer.

3226429 (1120119)
• 1. Registration of generated components in EA 6.0 is now performed in the Sources\COBOL folder

instead of the Components folder. 2. If you wish to perform component generation using CICS, find the
CICSSlice option in the project options file (Options.Project.xml or p00000X.xml) and change
VALUE="false" to VALUE="true". After the regeneration, you will get instead of a CALL statement an
EXEC CICS LINK PROGRAM statement. If the CICSSlice option is left in its default state (false), the
generated slice will include in the generated structure BRE-INP-INPUT-STRUCTURE the DFHEIBLK
members.

3226425 (1120121)
• The structure slice no longer generates unnecessary copybooks.

3226424 (1120105)
• Display statements now support the vertical bar symbol (|).

3217022 (1120020)
• An issue with a fall through in Program Control Flow when a program has multiple program entries has

been resolved.

Resolved Issues | 23



(638382)
• An issue with fall through in Program Control Flow when the program has multiple program entries has

been fixed.

(638381)
• An issue with fall through in Program Control Flow when the program has multiple program entries has

been fixed.

(638387)
• An issue that caused incorrect code generation for variable-formatted COBOL in Logic Analyzer has

been fixed.

(642709)

EA - Homonyms

• An issue that could cause a duplicate member error for a parm card in two different PDS files has been
fixed.

3224945 (1119953)
• An issue causing homonym search path not to work in an unshared workspace has been fixed.

3219376 (1119463)
• An issue that could lead to programs appearing to be verified with the wrong project options when using

the VerifyX.bj script to specify separate project verifications has been fixed.

3210507 (1118620)
• The subsystems root level selection in the Homonyms project options now takes precedence over the

common folder when resolving copybooks.

3208879 (1118479)
• New options have been added to specify the rules that are used when resolving references to include

files. See the Supplementary Information section of this readme for details.

(640991)

EA - HyperView

• The default option for resolving Component Convertor Conflicts of Logic Analyzer has been changed
from 'Keep old legacy files' to 'Replace old legacy files'.

3219837 (1119541)
• There is no longer a crash when selecting a file from the context pane over a JCL Procedure.

3203049 (1118037)
• The CA-7 object type has been removed from the Objects list pane in Interactive Analysis.

3188882 (1116836)
• An issue that resulted in a Logic Analyzer slice reporting a verification error due to variable names

exceeding 30 characters has been fixed.

3168352 (1115190)

EA - HyperView - Callie

• The Program Control Flow diagram is now generated for the first section when clicking on the
PROCEDURE DIVISION in Interactive Analysis.

3197001 (1117442)
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EA - HyperView - Clipper

• An issue with opening code search reports saved as .csv format has been fixed. If the number of
characters per cell in a spreadsheet reaches the limit of allowed characters, the value will be cut and
ellipses "..." will be appended.

3218516 (1119367)
• New indexes have been added to improve the performance of certain Code Search queries.

3206752 (1118287)

EA - HyperView - Context

• An issue where a large DDL file could not be opened in Interactive Analysis has been fixed.

3200060 (1117782)

EA - HyperView - Execution Path

• An issue where incorrect expressions for conditional statements were shown in Execution Path has
been fixed.

3216290 (1119186)
• A problem with displaying WHEN or WHEN NOT in PERFORM-UNTIL statements in Execution Path

has been fixed.

3198343 (1117792)

EA - IDE

• The loading time of Chart Viewer charts has been improved significantly.

3223947 (1119883)
• An issue caused by having a single quote in a file search string has been fixed.

3217494 (1119272)
• An issue where certain master user-only menu items were available for non-master users has been

fixed.

3216899 (1119279)
• An issue where search results from the Find feature were not showing the correct project when objects

were assigned to multiple projects has been fixed.

3197824 (1117640)
• An issue where a workspace could not be opened after an upgrade has been fixed.

3197339 (1117974)
• It is now possible to create a project from search results in the Repository Browser.

3194269 (1117177)

EA - IDE - Activity Log

• An issue with an incorrect message when reaching the MS SQL Server Express database size limit has
been fixed.

3207995 (1118527)

EA - IDE - Options

• The Import, Copy, and Assign buttons in the Options Manager are now enabled for master users only.

3201998 (1118160)
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• Project options are now available only to Master users or the owner of the project.

3223944 (1119871)
• The Systems Program tab in the Workspace Options has been removed. The System Programs

functionality is now handled from the Repository Browser.

(645645)

EA - IDE - Project Operations

• An issue with non-standard dates causing crashes has been fixed.

3199206 (1117723)

EA - IDE - Repository Browser

• An issue causing the incorrect line to be shown for relationships in repository searches has been fixed.

3214094 (1119269)
• An issue with the Is CRUD By relationship in the browser showing all relationships correctly for

homonyms has been fixed.

3208388 (1118659)
• The relationship from program to stored procedure is now shown from the COBOL file in the browser.

(642943)

EA - IDE - Workspace Operations

• SetChangeDate.bj now works as expected.

3216040 (1119145)
• A display issue with the Source Synchronization Changes dialog has been fixed.

3206273 (1118257)
• An issue where data was not being fully removed during invalidation on some SQL Server workspaces

has been fixed. It is recommended to have Asynchronous Procedure Execution under the service
broker enabled for SQL Server workspaces to improve the performance of the invalidation process.
Cases where Asynchronous Procedure Execution is disabled will now be handled correctly to execute
synchronous invalidation.

3189649 (1117336)

EA - Installation

• The HotFixes are now compatible with Japanese Windows operating systems.

(635425)
• On startup rescuent.exe will be added to the trusted sites Internet Explorer options to prevent obtrusive

popup messages and to make charts visible in the Chart Viewer on Windows Server Operating
Systems.

(640887)

EA - Inventory

• An issue with the Find feature for large projects in Oracle workspaces has been fixed.

3194160 (1117461)
• The performance of showing the Source Synchronization dialog has been improved.

(644340)
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EA - Reports

• Support has been added for excluding entities when running reference reports in the Portability
Assessment report.

3222571 (1119733)

EA - Reports - Executive Report

• An issue where the source in the Executive Report used the wrong encoding has been fixed.

3203854 (1118147)

EA - Reports - Portability Assessment

• The "Types of Data COBOL Sequential" report for Portability Assessment has been updated.

3227322 (1120216)
• The Embedded Hex code search query for the Portability Assessment report has been updated.

3224183 (1119888)
• Adjustments to the "Usage - JCL - Create (Variable Length Files)" report in Portability Assessment have

been made.

3222465 (1119719)
• Adjustments to the "Usage - JCL - Create (Outbound)" report in Portability Assessment have been

made.

3222463 (1119718)
• Adjustments to the Inbound Interface Files report in Portability Assessment have been made.

3222462 (1119717)
• An issue that could prevent all section headers from appearing in the report has been fixed.

3208730 (1118460)
• An issue with the width of columns in IE has been fixed.

3206137 (1118242)
• An issue where charts might not be shown in a saved PA report has been fixed.

3202013 (1117882)
• An issue with the formatting of long values in table columns in the report has been fixed.

3195413 (1117347)

EA - Reports - Reference

• An issue that could cause the Reference Reports window to not be visible has been fixed.

3224417 (1120014)
• The order of the columns in the Unresolved and External Reference reports has been changed to

match the same order in the Cross Reference Report.

3207300 (1118342)
• An issue where the Cross Reference Report was showing the full path in the source name for the

referred objects when the "Show Source Path In Reports" option in Workspace Options > Homonyms
was disabled has been fixed.

3200858 (1117804)
• The Cross Reference report has been adjusted to improve its readability. The order of the columns has

been changed to: Referred Object, Referred Type, Relation, Object Name, Legacy File, Object Type,
Source, Description. A new option called "Show Relation Path" has been added to the View menu for
the Cross Reference Report. When selected, the report is rebuilt and the Relation column will now
include details for composite relationships. It shows the full path of relationships between the left and
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right entities. The object properties window is now sensitive to which cell has been clicked so it will
either show the referred or referring object. If the Relation field is selected, the properties will show the
referred object. Certain relationships that showed irrelevant objects are no longer included.

3200195 (1117740)
• An issue with running the Reference Reports on very large workspaces has been fixed.

3200156 (1117721)
• An issue where relationships that no longer existed were being included in the Unreferred Report has

been fixed.

3199769 (1117709)
• The memory consumption and the overall performance of the Reference Reports have been improved.

3196055 (1117340)
• An issue where incorrect relationships between jobs and programs were being shown in the Cross

Reference Report has been fixed.

3195384 (1117294)

EA - Tag Manager

• The behavior of the Untagged Objects query has been adjusted to recognize the selected filters.

3205749 (1118254)

Licensing

• Several licensing changes have been made to match the expected behavior.

3222938 (1119757)
• Improvements have been made to license handling. Licenses no longer timeout after 5 minutes so they

will remain checked out. Queue Processors no longer use a license.

3218924 (1119716)
• The Activity Log message displayed when a license for the Micro Focus COBOL parser is not present

has been improved.

3216007 (1119143)

MFA Client API

• MFA Client now rounds any mainframe time difference to the nearest time zone block where a block
consists of 30 minutes.

3223202 (1119813)
• MFDAS secchk is now handling negative time differences correctly.

3223202 (1120059)
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Updates and SupportLine
Our Web site provides up-to-date information of contact numbers and addresses.

Contacting Micro Focus
Micro Focus is committed to providing world-class technical support and consulting services. Micro Focus
provides worldwide support, delivering timely, reliable service to ensure every customer's business
success.

All customers who are under a maintenance and support contract, as well as prospective customers who
are evaluating products, are eligible for customer support. Our highly trained staff respond to your requests
as quickly and professionally as possible.

Visit http://supportline.microfocus.com/assistedservices.asp to communicate directly with Micro Focus
SupportLine to resolve your issues, or email supportline@microfocus.com.

Visit Micro Focus SupportLine at http://supportline.microfocus.com for up-to-date support news and access
to other support information. First time users may be required to register to the site.

Information Needed by Micro Focus SupportLine
When contacting Micro Focus SupportLine, please include the following information if possible. The more
information you can give, the better Micro Focus SupportLine can help you.

• The name and version number of all products that you think might be causing an issue.
• Your computer make and model.
• System information such as operating system name and version, processors, and memory details.
• Any detailed description of the issue, including steps to reproduce the issue.
• Exact wording of any error messages involved.
• Your serial number.

To find out these numbers, look in the subject line and body of your Electronic Product Delivery Notice
email that you received from Micro Focus.
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Copyright and Disclaimer
© Copyright 2020 Micro Focus or one of its affiliates.

The only warranties for this product and any associated updates or services are those that may be
described in express warranty statements accompanying the product or in an applicable license agreement
you have entered into. Nothing in this document should be construed as creating any warranty for a
product, updates, or services. The information contained in this document is subject to change without
notice and is provided "AS IS" without any express or implied warranties or conditions. Micro Focus shall
not be liable for any technical or other errors or omissions in this document. Please see the product's
applicable end user license agreement for details regarding the license terms and conditions, warranties,
and limitations of liability.

Any links to third-party websites take you outside Micro Focus websites, and Micro Focus has no control
over and is not responsible for information on third party sites.
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Appendix I: Enterprise Analyzer Features
per Client

The Web client provides a subset of the features available in the Windows desktop application. The table
below shows the features that are available in each client. Note that this is not a full feature list for the
desktop application.

Capability Desktop Application Web Interface

System Level Objects

Repository Browser Yes Yes

Search Assistant Yes Yes

Repository Queries Yes Yes

Reference Reports Yes No

Diagrammer (project) Yes No

Diagrammer (object) Yes Yes

CRUD Report (project) Yes No

CURD Report (object based) Yes Yes

Complexity Metrics Yes Overview charts only

Syntactical Analysis

Code Search Yes Yes, execute only

Source pane with navigation Yes Yes

Program Control Flow Yes No

Code Search Reports Yes Yes, execute only

Migration Reports Yes Yes, execute only

Quality Reports Yes Yes, execute only

Business Rules Yes, licensed separately Yes, view and edit only

Advanced Analysis Options

Change Analyzer (full) Yes No

Change Analyzer (single data item) Yes Yes

Impact Analysis Yes Yes

Execution Path Analysis Yes No
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Appendix II: First Steps with the REST API
Before using the REST API or EA Jenkins Plugin make sure that the Micro Focus Enterprise Analyzer Web
Service is running with the Logon User set to your Windows user.

To make a GET request, you can use any browser like Chrome, Firefox or Internet Explorer. For the other
HTTP requests such as PUT, POST or DELETE you can use any tool like Postman or Fiddler.

To register a new workspace, use either the REST API or Enterprise Analyzer Administration >
Administer > Configure Web Service.

If you want to use the REST API, you need to make a POST request with the name of the workspace and
the Path of the workspace as a parameter: http://localhost:1248/api/workspaces/NewWorkspace?Path=C:
\MicroFocus\Workspaces

{
  "status": "success",
  "message": "Workspace 'NewWorkspace' is registered successfully!"
}

Next you can list all registered workspaces: http://localhost:1248/api/workspaces

[
  {
    "name": "NewWorkspace",
    "directory": "D:\\MicroFocus\\Workspaces",
    "default": true,
    "url": "http://localhost:1248/api/workspaces/NewWorkspace"
  }
]

Then you can list all available APIs for the selected workspace: http://localhost:1248/api/workspaces/
NewWorkspace

[
  {
    "url": "http://localhost:1248/api/workspaces/NewWorkspace/Projects",
    "description": "List all available projects for the workspace"
  },
  {
    "url": "http://localhost:1248/api/workspaces/NewWorkspace/Inventory",
    "description": "The report shows high-level statistics for source file 
types in the current workspace",
    "parameters": [
      {
        "name": "Format",
        "description": "Report formats: json(default), html, htm, xls, rtf, 
doc, txt, csv",
        "required": false,
        "example": "format=txt"
      }
    ]
  },
…
]

In the list of available APIs you will find the full details needed to use each API. Descriptions, parameters,
supported formats, etc. are all shown.
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Appendix III: Getting Started with the EA
Jenkins Plugin

1. Ensure that the Micro Focus Enterprise Analyzer Web Service is running with the Logon User set to
your Windows user.

2. Install Jenkins with the default settings on your local machine: https://jenkins.io/download/
3. Go to Manage Jenkins > Manage Plugins > Advanced > Upload Plugin. Select the

EAJenkinsPlugin.hpi from the EA installation \Bin directory.

4. Go to Home Page > New Item > Create Freestyle Project.
5. Go to Project Configuration.

6. Go to the Build section and choose Enterprise Analyzer.

7. Now you can add a valid address and test the connection. If there are configured workspaces, they will
be loaded. Otherwise, this can be done either from the REST API or from Administrator > Configure
Web Service in EA Administration.
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8. Now you can start the build. If the build fails, you will see report results like the following:

Note: There are three links on the sidebar:

1. Opens EA Web for the selected workspace.
2. Shows summary page with additional information.
3. Shows the report itself

34 | Appendix III: Getting Started with the EA Jenkins Plugin



Appendix IV: Adding the Next Generation
Warnings Plugin

https://plugins.jenkins.io/warnings-ng/

1. Go to Manage Jenkins > Manage Plugins > Available > Search for "Warnings Next Generation".
2. Install the plugin and restart Jenkins.
3. Go to Project Configuration.
4. In Post Build Action select Record compiler warnings and static analysis results.

5. Set up the following configuration:

6. The plugin is now configured.
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