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Micro Focus Modelling Support 6.0 for
Eclipse Release Notes

These release notes contain information that might not appear in the Help. Read them in their entirety
before you install the product.

/ Note:

» This document contains a number of links to external Web sites. Micro Focus cannot be
responsible for the contents of the Web site or for the contents of any site to which it might link.
Web sites by their nature can change very rapidly and although we try to keep our links up-to-date,
we cannot guarantee that they will always work as expected.

» Check the Product Documentation section of the Micro Focus SupportLine Documentation Web
site for any updates to the documentation which might have been uploaded.

Product Overview

Application Workflow Manager (AWM) is a framework integrated with Enterprise Developer that provides a
seamless customer-specific application development workflow for the Eclipse IDE workbench views.

AWM includes a number of function packages that provide tool sets for specific application or functional
area. For example, a function package is provided that enables you to work specifically with Eclipse
resources. Another function package provides tools that enable you to work with RESTful Web
applications. AWM enables you to integrate application development tools into the user interface, along
with specifying the information flow between tools.

See the Application Workflow Manager chapter in the Enterprise Developer product help available from the
Micro Focus SupportLine Website, https://www.microfocus.com/documentation/enterprise-developer/.

Note: The MVS and ISPF function packages are included in this product. However, as a prerequisite
they require a Micro Focus MFA Server installation. Alternatively, you can use a server on z/OS that
implements the Micro Focus API, such as IBM's RSE daemon (RSED) which is shipped with an RDz
installation.

Micro Focus Modelling Support 6.0 for Eclipse Release Notes


https://www.microfocus.com/en-us/support/documentation/
https://www.microfocus.com/en-us/support/documentation/
https://www.microfocus.com/documentation/enterprise-developer/
https://www.microfocus.com/documentation/enterprise-developer/

Installation

Before Installing

Downloading the Product

1. Use the download links in your Electronic Product Delivery email.

For more information follow the links for the installation instructions and the End User License
Agreement.

2. Alternatively, you can download the product from the Product Updates section of the Micro Focus
SupportLine Web site.

System Requirements

Hardware Requirements

Modelling Support has the following requirements in addition to the requirements of Eclipse. See the
Eclipse documentation for details of its requirements.

In general, most modern machines will have the required processor and available RAM to run the Micro
Focus products under Windows effectively. For planning purposes, you should consider having a minimum
of 2GB of RAM though Micro Focus recommends at least 4GB of RAM for optimal performance.

The disk space requirements for Windows are, approximately 200 MB.

Note: This includes the space needed to cache information locally so that you can modify the
installation without the original source media.

Operating Systems Supported

For a list of the supported operating systems, check the Product Availability section on the Micro Focus
SupportLine Web site: http://supportline.microfocus.com/prodavail.aspx.

y Note:

* Modelling Support for Eclipse installs fully on both 32 and 64-bit Windows platforms.
» This product can be installed on earlier versions of Windows but it has not been tested on them.

Software Requirements
The setup file will check your machine for whether the prerequisite software is installed and will install any
missing prerequisites and the product components.

Eclipse requirements

* The setup file installs Modelling Support into Eclipse.
* Modelling Support for Eclipse installs fully on both 64-bit and 32-bit Windows platforms.
* Modelling Support for Eclipse supports both the 32-bit and the 64-bit Eclipse.

Software requirements on Windows

Modelling Support for Eclipse requires:
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A 32-bit Java installation if using the 32-bit Eclipse.
A 64-bit Java installation if using the 64-bit Eclipse.

See Java Support Restrictions in the product help for any considerations when using Eclipse and Java.

Other Requirements

Note: This release requires version 10000.2.990 or later of the Micro Focus License Administration
tool. For local servers, you do not need to install it separately, as the setup file installs a new
Modelling Support for Eclipse client and a new licensing server on the same machine.

If you have a network server, you must update the license server before installing the product as the
client is not able to communicate with license servers of versions older than 10000.2.660. On
Windows, you can check the version of your license server by clicking Help > About in the Micro
Focus License Administration tool.

You can download the new version of the license server software from the Micro Focus SupportLine
Web site: http://supportline.microfocus.com.

Installation Restrictions and Requirements

Before starting the installation you should consider the following:

Visual COBOL and Enterprise Developer cannot coexist on the same machine.

You need to be logged in with a user-ID that has write access to the registry structure under
HKEY_LOCAL_MACHINE, HKEY_CLASSES ROOT, and HKEY_CURRENT_USER so the installation
software can set the environment appropriately. You also need to be logged on with Administrator
privileges.

Various actions and operations within your COBOL development environment depend on certain
Microsoft files distributed in the following packages: the Windows SDK package and the Microsoft Build
Tools package. By default, a standard product installation downloads and installs these. Refer to
Microsoft Package Dependencies to see if these packages are required. If you do not plan to use your
development tool in a way that will depend on any of these packages, you can run a non-standard
installation, which will skip their download and installation, thus saving disk space and time taken for
installation. Refer to Advanced Installation Tasks for details on the available installation options.

If you already have Microsoft Build Tools for Visual Studio 2017 installed, you must ensure that it
contains the Visual C++ build tools workload (or at least the individual components contained in that
workload) before you run this installation.

Installing

To install Modelling Support for Eclipse as a plug-in to an Eclipse IDE:

Installation

1.

Run the nodsupp_60. exe file and follow the wizard instructions to complete the installation.

Note: The supported versions of Eclipse are 4.7 and 4.8. Visual COBOL and Enterprise Developer
cannot coexist on the same machine.

Start Eclipse, and then click Help > Install New Software

This opens the Install dialog box.
Click Add.

This opens the Add Repository dialog box.

In the Name field, type Model | i ng Support for Eclipse.

Click Archive, and browse to C. \ Program Fil es (x86)\ M cro Focus\ Model |i ng Support
for Eclipselinstaller\files\MdelingSupportUpdateSite.zip.

Click Open.


http://supportline.microfocus.com

9.

Click OK.
« If you are installing into Eclipse:

* At the Available Software stage, expand Micro Focus, and then check all options except AWM
IDz Integration.
» If you are installing into IBM Developer for z Systems (IDz):

* Atthe Available Software stage, check Micro Focus.
Click Next.

The installation process calculates requirements and dependencies.

« If a component cannot be installed, a solution is presented at the Install Remediation Page stage,
click Next.
At the Install Details stage, click Next.

10.Accept the license agreement, and then click Finish.
11.Click Restart Now when prompted to restart Eclipse to finish the installation.

Installation

7



Licensing Information
i Note:

This product requires a Micro Focus Enterprise Developer Connect license.
» If you have purchased licenses for a previous release of this product, those licenses will also
enable you to use this release.

« If you are unsure of what your license entitlement is or if you wish to purchase additional licenses,
contact your sales representative or Micro Focus SupportLine.

Installing licenses

You need either a license file (with a . nf | i ¢ extension) or an authorisation code which consists of a string
of 16 alphanumeric characters.

If you have a license file

1. Start Micro Focus License Administration.
2. Click the Install tab.
3. Do one of the following:

« Click Browse next to the License file field and select the license file (which has an extension
of.nflic).

« Drag and drop the license file from Windows Explorer to the License file field.

* Open the license file in a text editor, such as Notepad, then copy and paste the contents of the file
into the box below the License file field.

4. Click Install Licenses.

If you have an authorization code

Authorizing your product when you have an Internet connection

f Note:

e Itis not possible to install licenses remotely. You must be logged into the machine on which you
are installing the licenses.

The following procedure describes how to authorize your product using a local or network license server.
The license server is set up automatically when you first install the product.

Start Micro Focus License Administration.

Click the Install tab.

Type the authorization code in the Enter authorization code field.
4. Click Authorize.

whN e

If you change the name of the machine running your license server after it has granted licenses, the
licenses stop working.
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Authorizing your product when you don't have an Internet connection

This method of authorization is required if the machine you want to license does not have an Internet
connection or if normal (automatic) authorization fails.

Start Micro Focus License Administration.

On the Install tab, click Manual Authorization.

Make a note of the contents of the Machine ID field. You will need this later.
Do one of the following:

PR

< If your machine has an Internet connection, click the SupportLine Web link in the Manual
Authorization Information window.

< If your machine does not have an Internet connection, make a note of the Web address and type it
into a Web browser on a machine that has an Internet connection.

The Micro Focus SupportLine Manual product authorization Web page is displayed.

5. Type the authorization code in the Authorization Code field. The authorization code is a 16-character
alphanumeric string supplied when you purchased your product.

Type the Machine ID in the Machine ID field.

Type your email address in the Email Address field.

Click Generate.

Copy the generated license string (or copy it from the email) and paste it into the box under the License
file field on the Install page.

10.Click Install Licenses.

© x® N

start Micro Focus License Administration

Windows 8.1 From the Windows Start screen, click the License Administration tile.

Windows 10 and Later From your Windows desktop, click Start > Micro Focus License Manager >
License Administration.

obtain more licenses

If you are unsure of what your license entitlement is or if you wish to purchase additional licenses for
Modelling Support for Eclipse, contact your sales representative or Micro Focus SupportLine.

Licensing Information
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Updates and SupportLine

Our Web site provides up-to-date information of contact numbers and addresses.

Further Information and Product Support

Additional technical information or advice is available from several sources.

The product support pages contain a considerable amount of additional information, such as:

« The Product Updates section of the Micro Focus SupportLine Web site, where you can download fixes
and documentation updates. Go to Micro Focus Product Updates

e The Examples and Utilities section of the Micro Focus SupportLine Web site, including demos and
additional product documentation. Go to https://supportline.microfocus.com/examplesandutilities/
index.aspx.

« The Support Resources section of the Micro Focus SupportLine Web site, that includes troubleshooting
guides and information about how to raise an incident. Go to https://supportline.microfocus.com/
supportresources.aspx

To connect, enter https://www.microfocus.com/en-us/home/ in your browser to go to the Micro Focus home
page, then click Support & Services > Support. Type or select the product you require from the product
selection dropdown, and then click Support Login.

f Note: Some information may be available only to customers who have maintenance agreements.

If you obtained this product directly from Micro Focus, contact us as described on the Micro Focus Web
site, https://www.microfocus.com/support-and-services/contact-support/. If you obtained the product from
another source, such as an authorized distributor, contact them for help first. If they are unable to help,
contact us.

Also, visit:

« The Micro Focus Community Web site, where you can browse the Knowledge Base, read articles and
blogs, find demonstration programs and examples, and discuss this product with other users and Micro
Focus specialists. See https://community.microfocus.com.

« The Micro Focus YouTube channel for videos related to your product. See Micro Focus Channel on
YouTube.

Information We Need

However you contact us, please try to include the information below, if you have it. The more information
you can give, the better Micro Focus SupportLine can help you. But if you don't know all the answers, or
you think some are irrelevant to your problem, please give whatever information you have.

* The name and version number of all products that you think might be causing a problem.

* Your computer make and model.

* Your operating system version number and details of any networking software you are using.

e The amount of memory in your computer.

» The relevant page reference or section in the documentation.

* Your serial number . To find out these numbers, look in the subject line and body of your Electronic
Product Delivery Notice email that you received from Micro Focus.

On Windows, if you are reporting a protection violation you might be asked to provide a dump (. dnp) file.
To produce a dump file you use the Unexpected Error dialog box that is displayed when a protection
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violation occurs. Unless requested by Micro Focus SupportLine, leave the dump setting as Nor rral
(recommended), click Dump, then specify a location and name for the dump file. Once the dump file has
been written you can email it to Micro Focus SupportLine.

On Windows, you can use the Micro Focus SupportLine Support Scan Utility, MFSupportinfo, to create
either:

* a. | ogfile that contains the details about your environment, Micro Focus SupportLine products, and
settings.

e a. zi p archive that includes the same information as the . | og file plus some product configuration
files from c:\ProgramData and the product installation log files.

MFSupport | nf 0. exe is stored in <i nstal | -di r >\ bi n.
To run MFSupportinfo:

1. Start a 32-bit Enterprise Developer command prompt.
2. Enter MFSupporti nf o at the command prompt to start the utility.
3. Create a .| ogfile ora. zi p archive as follows:

a. To create a . | og file, click File > Save.

This prompts to save the . | og file, MFSupport | nf o_Log_Machi neNane_YYYY- VMM DD_HH M\
SS. | 0g, in the % enp%directory.
b. To create a . zi p archive, click Tools > Create Zip Package.

This creates a . zi p archive, M-Support | nfo_Log Machi neNanme_YYYY- M DD_HH MVt
SS. zi p, in the % enp%directory.
4. Send the diagnostic information to your Micro Focus SupportLine representative:

The following requires an Internet connection and an Email client:

a. Click Tools > Email Log to SupportLine to open the Email Log dialog box.
b. Fill in the required fields and click Send.

If the machine is not connected to the Internet or if there are no Email clients installed, copy either

the . | og file or the . zi p archive to a machine that is connected to the Internet. Use your Email client
to email the files to Micro Focus SupportLine at supportline@microfocus.com together with the Support
Incident (SI) number, if available, and any additional details that might be useful to diagnose the issues
that you are experiencing.

Creating Debug Files

If you encounter an error when compiling a program that requires you to contact Micro Focus SupportLine,
your support representative might request that you provide additional debug files (as well as source and
data files) to help us determine the cause of the problem. If so, they will advise you how to create them.
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Copyright and Disclaimer

© Copyright 2020 Micro Focus or one of its affiliates.

The only warranties for this product and any associated updates or services are those that may be
described in express warranty statements accompanying the product or in an applicable license agreement
you have entered into. Nothing in this document should be construed as creating any warranty for a
product, updates, or services. The information contained in this document is subject to change without
notice and is provided "AS 1S" without any express or implied warranties or conditions. Micro Focus shall
not be liable for any technical or other errors or omissions in this document. Please see the product's
applicable end user license agreement for details regarding the license terms and conditions, warranties,
and limitations of liability.

Any links to third-party websites take you outside Micro Focus websites, and Micro Focus has no control
over and is not responsible for information on third party sites.
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