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Preface
� About This Guide

� Product Enhancements

� Related Publications

� World Wide Web Information

� Getting Help

About This Guide
The TrackRecord User’s Guide is intended for users of TrackRecord. It 
includes information designed to aid users by providing information 
about TrackRecord’s concepts and user interface, instruction on entering 
information into TrackRecord, using predefined reports to display the 
contents of the TrackRecord database, and formatting custom Track-
Record reports. You can find additional information in the online help 
facility and documentation set. See “Related Publications” on page 8.

Compuware assumes that you are familiar with basic Microsoft Windows 
navigation. If this is not the case, familiarize yourself with the documen-
tation for Microsoft Windows before reading this guide.

Product Enhancements
For a detailed listing of product enhancements made in TrackRecord 
Release 06.02.01, refer to the “What’s New” in the TrackRecord Release 
Notes. In addition to the most recent release, the Release Notes also list 
enhancements included in several previous releases for your reference.
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Related Publications
The TrackRecord documentation set contains:

� Installation Guide— PDF file containing system requirements and 
instructions for installing and configuring Compuware products.

� Licensing Guide— PDF file containing licensing procedures and over-
view.

� TrackRecord Administrator’s Guide— Description of various administra-
tive tasks that must be performed before TrackRecord can be used and 
the actions required to create and maintain the TrackRecord database 
and AutoAlert. It also includes reference material for programmers 
writing modules to access the TrackRecord databases.

� The TrackRecord online help— Field descriptions, operating proce-
dures, and reference information relating to TrackRecord. In the Web-
Server, click Help to see an outline of available topics. In the 
Windows Client, click Help or press F1.

� TrackRecord Release Notes— HTML file that contains technical 
information that may affect how you use the product and known 
issues related to the current release of TrackRecord. You can find the 
Release Notes in the TrackRecord program files.

� TrackRecord Guided Tour— A quick tour of the product containing 
product overview information, user interface descriptions, and an 
overview of the basic tasks that can be performed with the product. 
You can access the tour by choosing Guided Tour from the Track-
Record program files or from the Help menu within the product.

You can access the online versions of the PDF files from the installation 
bookshelf on the TrackRecord CD browser or from Compuware’s Front-
Line technical support Web site at: http://frontline.compuware.com.

Viewing and Printing Online Books

TrackRecord’s online books are provided in PDF format, so you need 
Adobe Acrobat Reader to view them. It is recommended that you install 
Acrobat Reader 4.0 or above to get the best results when viewing the 
online books. To install the Adobe Acrobat Reader, go to Adobe’s Web site 
at www.adobe.com.

Because PDF is based on PostScript, a PostScript printer is the most 
reliable way to print the online books. In most cases, you can also print 
PDF files to PCL printers. If you cannot print the PDF files to your printer, 
refer to Adobe’s Web site for trouble-shooting information.
8     TrackRecord User’s Guide
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World Wide Web Information
To access Compuware Corporation’s site on the World Wide Web, point 
your browser at http://www.compuware.com. The Compuware site 
provides a variety of product and support information.

FrontLine Support Web Site

You can access online technical support for Compuware products via our 
FrontLine support Web site at http://frontline.compuware.com. Front-
Line provides fast access to critical information about your TrackRecord 
product. You can read or download documentation, frequently asked 
questions, and products fixes, or email your questions or comments. The 
first time you access FrontLine, you are required to register and obtain a 
password.

Getting Help
At Compuware, we strive to make our products and documentation the 
best in the industry. Feedback from our customers helps us maintain our 
quality standards. If you need support services, please obtain the follow-
ing information before calling Compuware’s 24-hour product support 
hotline:

Tip: To display the 
TrackRecord About 
window, choose 
Help>About Compuware 
TrackRecord. Click OK 
when you are finished.

� The name and release (version) number of the TrackRecord product. 
This information is found on the covers of the product documenta-
tion or the About Compuware TrackRecord window. 

� Installation information including:
� Installed options
� Whether the product uses local or network databases
� Whether it is installed in the default directories
� Whether it is a standalone or network installation
� Whether it is a client or server installation

� Environment information, such as the operating system and release 
on which the product is installed, memory, hardware/network speci-
fications, and the names and releases of other applications that were 
running.

� The location of the problem in the TrackRecord product software, 
and the actions taken before the problem occurred.

� The exact product error message, if any.

� The exact application, licensing, or operating system error messages, 
if any.
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� Your Compuware client, office or site number if available.

TrackRecord Technical Support

Compuware Corporation

One Campus Martius

Detroit, MI 48226-5099

(800) 538-7822
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Chapter 1

Introducing TrackRecord
� Overview of TrackRecord

� Process at a Glance

� About the TrackRecord Database

� Understanding Data Type Inheritance

Overview of TrackRecord
Note: This chapter provides a summary of Compuware TrackRecord®. 

Because it provides an overview of TrackRecord functions and 
concepts, you should read this chapter carefully before you use 
TrackRecord for the first time. 

Compuware TrackRecord is a defect and project tracking tool designed to 
record and report information about products being developed or 
supported. TrackRecord records all the information relating to a project- 
project Team Members and testers, schedules and milestones, bug reports 
and feature requests- in a database. You can then use TrackRecord’s query 
and reporting features to retrieve and format the information you need 
to keep your project on track.

TrackRecord is very customizable and can adapt to virtually any environ-
ment. With TrackRecord, you can track many types of information, 
implement full workflow to ensure a repeatable process, create multiple 
reports, and even generate graphs.

Product Integration

TrackRecord is part of the Compuware DevPartner Studio suite of 
software debugging tools and the Compuware QACenter family of 
automated testing tools. Interaction with these families of products is 
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described in Chapter 8, “Integrating TrackRecord with Other Applica-
tions”.

Types of Users

Figure 1-1 illustrates how TrackRecord users, administrators, and 
WebServer users interact with the TrackRecord server and database. 

If you have a license to use TrackRecord on multiple PCs, you can install 
TrackRecord on a dedicated PC to act as your server. The server will house 
the database and will share it with the client workstations.

As information is entered in TrackRecord, the information is stored in a 
database. Interaction with this database occurs through queries and 
reports, as described in “Process at a Glance” on page 13. For more infor-
mation about the database, see “About the TrackRecord Database” on 
page 15.

Figure 1-1. TrackRecord Users and Components

There are three types of TrackRecord users:

� TrackRecord Administrator — TrackRecord includes administrative 
functions that can only be performed by authorized users, such as 
setting up user groups, importing and exporting information to and 
from other applications, and editing the data types used by Track-
Record. When a TrackRecord administrator logs in, he or she sees an 
additional menu (the Administrator menu) on the TrackRecord menu 
bar. For additional information, refer to the TrackRecord Administra-
tor’s Guide.
12     TrackRecord User’s Guide



� TrackRecord Windows Client User — A user running the Track-
Record client software accesses the TrackRecord database by logging 
in from client machines anywhere on your network. Whether a user 
can add or modify database information, including items and 
reports, depends on the groups to which the user belongs. The 
administrator determines the access and editing privileges of each 
user.

� TrackRecord WebServer User — WebServer users access the database 
by logging in using standard Web browsers, such as Microsoft Inter-
net Explorer. Refer to Chapter 6, “Using TrackRecord’s WebServer” for 
information on the WebServer interface.

Process at a Glance
TrackRecord can be used to enter information about projects and to 
retrieve and view that information. This section provides an overview of 
those fundamental tasks. The example shown in Figure 1-2 depicts a 
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visual overview of task to create a report of all defects in the database that 
are assigned to Your Project and have a priority of 1 (Critical) or 2 (High).

Figure 1-2. Process at a Glance. Note that your screens may be different than shown.

1. Enter data by opening 
a Defect Item View (a 
form on which you enter 
or modify information 
about a item such as a 
defect or a person). This 
defect is for Your Project 
and is a priority 1. For 
more information, refer 
to Chapter 3, “Entering 
and Editing Data”.

2. Retrieve data by 
creating a query. 
This query is set to 
retrieve data for 
Your Project that is 
a priority of 1 or 2. 
See Chapter 4, 
“Retrieving Data” 
for more informa-
tion.

3. View data that has been 
retrieved by a query. Four 
formats are available: Outline 
Report, Graph, Milestone Status, 
or a Calendar. In this example, an 
Outline Report has been used to 
display the information. Refer to 
Chapter 5, “Viewing Data” for 
complete information.
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About the TrackRecord Database
Understanding how the TrackRecord database records, links, and displays 
information is an important step toward using the product more effec-
tively.

When you enter information using TrackRecord, the information is 
stored in a database. TrackRecord automatically opens its database when 
you start the program, and automatically closes your connection to the 
database when you exit. You interact with this database through item 
views, queries, and report views, as described in “Process at a Glance” on 
page 13.

Types, Items, Links, and Fields

The TrackRecord database organizes information into types, such as 
Person, Company, Defect, or Project. For each type of information stored 
in the TrackRecord database — defects, tasks, Team Members, and so on 
— you will want to store different pieces of information.Each data type 
functions like a database table, establishing the properties (fields) Track-
Record expects for an item of that type. Visually, a data type is a form, 
with fields and controls to enter or display information. These types are 
extremely customizable and many different fields can be added or 
removed very easily. For example, you might want to store a name and 
phone number for a Team Member and a summary and description for a 
defect. 

A data item is one record of a specific type that has its own data entry 
form, which is composed of fields appropriate to that item type. For 
example, Abraham Lincoln and Harry Truman would be two items of the 
type Person in a TrackRecord database.

Each data item consists of fields and links. Fields hold specific facts about 
an item, such as a person’s address or the name of a project; links connect 
one item in the TrackRecord database to another to capture the relation-
ships between items. For example, a Team Member item (John Doe) 
might be connected to Project items (as a Team Member), Defect items 
(as the person reporting them or responsible for fixing them), and 
Company items (as an employee).

Figure 1-3 illustrates how a Team Member item links to a Company item 
and to several Project items. These links make it easy to retrieve informa-
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tion, such as all Team Members assigned to a Project or all Projects with 
open defects.

Figure 1-3. Links Between Database Items

When an object is entered in a field, that field is automatically linked to 
the original item. When you change the item, no matter where it 
appears, all references to that item change automatically. For example, if 
you change the spelling of the Person’s name, that change is reflected in 
all other items that contain a link to that Person.

In addition to the obvious information types, such as Projects or People, 
the TrackRecord database can store special types of information, such as 
executable commands and database queries.

The limit on the maximum number of "Types" a TR database can hold is 
485 user defined types. There are 27 reserved types, eg. query, outlines, 
etc. in addition to this number. 

Change History

As database items are created and modified, TrackRecord captures the 
time and date of each change, the person adding or changing the item, 
and the information that was added or changed. For more information 
regarding change history, refer to “Change History Tab” on page 43.

Client-Server Technology

The TrackRecord database resides on a central server on your network. 
The TrackRecord server software accepts simultaneous input from multi-
ple users on client machines; the TrackRecord server periodically checks 
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the database for new information during a session and forwards updated 
information to clients when necessary.

Understanding Data Type Inheritance
TrackRecord information types, such as the Person type, Defect type, and 
so on, provide the framework on which the TrackRecord database is built 
and is organized into a data hierarchy.

When one type inherits from another, the inheriting type (the child) 
receives all the attributes of the original type (the parent). In the example 
(Figure 1-4, Data Type Inheritance, on page 17), Bugs is the parent of 
Open Bugs, and Open Bugs is the parent for Priority 1 and Priority 2; 
Open Bugs and Closed Bugs are the child of Bugs, and Priority 1 and 
Priority 2 are the child of Open Bugs.

Figure 1-4. Data Type Inheritance

“Open Bugs” inherits 
attributes of “Bugs”

Children of “Open Bugs” 
and inheritors of its 
attributes
“Closed Bugs”, the child 
type, inherits attributes of 
“Bugs”, the parent type

After the child inherits fields from the parent, it can add fields of its own. 
Figure 1-5 illustrates how the Person data type is the parent to the Devel-
oper and Beta Tester data types; each child type starts with the fields it 
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inherits from the Person type, and adds its own fields below the inherited 
fields.

Figure 1-5. Child Items Inherit Fields from Parent

The Developer and Tester 
types inherit from the 
Person type, taking all of 
the fields from Person 
before adding others.

This type of inheritance allows items of any child type to be used 
anywhere in TrackRecord where an item of its parent type is expected. 
For example, Figure 1-5 illustrates that the Team Member type inherits 
from the Person type, so all Team Member items are also Person items. 
Therefore, Team Members and Testers can be used to fill fields where 
Person items are expected. Note, however, that the reverse is not gener-
ally true: Person items that are not Team Members cannot be used in 
fields where Team Members are required. 

One of the benefits that type inheritance provides is the ability to add 
another identity to an item of one type. For example, a person in a 
database changes roles on a project and must be changed to a Team 
Member. If Team Member is a child type of the Person type, an adminis-
trator does not need to remove and reenter information about that 
individual. 

Type inheritance also permits querying on a parent type to retrieve infor-
mation about all items of that type, including its child types. For 
example, a query that looks for defects will retrieve items of the parent as 
well as the child.

Where to Go Next

Now that you have a general understanding of TrackRecord concepts, 
you are ready to get up and running with TrackRecord. Refer to Chapter 
2, “Getting Started” for more information.
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Chapter 2

Getting Started
� Before You Begin

� Starting TrackRecord

� Exploring TrackRecord’s User Interface

� Working With the Item Browser

� Accessing TrackRecord Online Help

� Using TrackRecord’s Default and Sample Databases

� Searching the TrackRecord Database

� Customizing User Preferences

Before You Begin
Before you begin using TrackRecord, you will need to obtain the follow-
ing information from your TrackRecord administrator:

� What user name and password should you use? 

Before you can log in to TrackRecord, you must have a valid user 
name and password.

� What database should you use? 

If your site has several development projects running concurrently, 
your TrackRecord administrator might create separate databases. You 
will need the name of your database.

� What project should you use? 

A database can include multiple projects. Your TrackRecord adminis-
trator can tell you what project name you should use to display and 
enter project information.
 19



Note: TrackRecord Administrators should refer to the TrackRecord Adminis-
trator’s Guide for information about setting up the database before 
users begin creating items.

Note: For information on using the TrackRecord WebServer, refer to 
Chapter 6, “Using TrackRecord’s WebServer”.

Starting TrackRecord
Follow the instructions below for quickly getting started with Track-
Record.

1 Open TrackRecord by clicking the task bar’s Start button on your 
Windows desktop and choosing TrackRecord from the program files. 

The TrackRecord Login dialog box (Figure 2-1) appears. If your Track-
Record user information has been set to automatically log in to Track-
Record, the dialog box will not be displayed.

Figure 2-1. TrackRecord Login Dialog Box

2 On the TrackRecord Login dialog box, 

� Enter your TrackRecord login name and password. Note that they 
may be different from your Windows login name and password. 
Passwords are case-sensitive.

� Identify the database you want TrackRecord to use in the Data-
base field by selecting a name from the drop-down list or by 
entering a new name.

If you have used TrackRecord before, the names of the databases 
you have used previously appear in the Databases list. You do 
not need to enter the path to the database, just the database 
name.

3 Click OK. The main TrackRecord window (Figure 2-3) appears and 
displays any subwindows left open from your previous session. If 
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your TrackRecord Administrator has created a Home page, the Home 
page appears. 

Changing Your Login Password

To ensure the security of the information in a TrackRecord database, the 
first task you should perform with TrackRecord is to change your login 
password. 

Note: If you or your Administrator has created your user profile to allow 
you to automatically log in when you start TrackRecord, this task is 
not necessary.

You can change your TrackRecord login password at any time. To change 
your password:

1 From the Tools menu, choose Change Password. The Change Pass-
word dialog box (Figure 2-2) appears.

Figure 2-2. Change Password Dialog Box

2 Enter your new password in the New Password field and the Con-
firm New Password field.

Tip: If you do not wish to 
use a password, leave the 
password fields blank.

To prevent anyone from observing what you type, TrackRecord 
displays an asterisk for each character you enter. Passwords are case-
sensitive.

3 Click OK. Your new password takes effect immediately.
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Exploring TrackRecord’s User Interface
Before you begin using TrackRecord, you should take a few minutes to 
explore its windows, tool bar, and status bar. 

Figure 2-3. TrackRecord Main Window. Since various aspects of this window can be 
customized, yours may vary from the example.

Menu bar

Toolbar

Display area

Status bar

User name

Server name

User name

Menu Bar

The main TrackRecord window (Figure 2-3) displays a menu bar below 
the window title.

Table 2-1. TrackRecord Menu Bar

Menu Item Functionality

File Create new items and reports, open and manage predefined 
reports, queries, and templates, and lists items you have 
recently worked with. Also includes standard File menu entries, 
such as Print Setup, Print, and Exit.

Edit Copy and paste text and graphs from one place to another. 
Availability depends upon which window is active within Track-
Record.

Administrator (Displayed only if you log in with Administrator access). Create 
users and user groups, edit data types and user defaults, and 
import and export data and type descriptions.
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Toolbar

The tool bar (Figure 2-4) contains shortcuts to your most commonly 
performed tasks. It lets you create a new item or view, open an existing 

Favorites Specify frequently used reports. After adding a report to the 
Favorites menu, run it by choosing its name from the menu. 
Also specify one report as your Home Page to open automati-
cally when you log in.

Tools Search the database for items that meet specified criteria, log 
in as another user, browse items, and modify options.

Window Position windows and switch from one window to another.

Help Access online documentation, the Guided Tour, and the About 
TrackRecord dialog box, which displays registration and soft-
ware release information.

Table 2-1. TrackRecord Menu Bar

Menu Item Functionality
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item, display the Item Browser, open your Home Page, or search for 
items.

Figure 2-4. Toolbar

New Item

Open Item

Item Browser

Open Home Page

Search

Table 2-2. TrackRecord Tool bar

Toolbar Item Functionality

New Item • Create a new item or view. The item types listed on the 
drop-down list are determined by your Favorite Types list (as 
described in the TrackRecord Administrator’s Guide).

• Control the new item type shown on the Toolbar with your 
Favorite Types list. For example, if you most often create 
new Tasks, you would move Task to the top of your Favorite 
Types list and the Toolbar would show New Task rather than 
New Defect, which is the default.

Open Item Open an existing item or view. The Open dialog box is 
described in “Opening, Modifying, and Deleting Views” on 
page 62.

Item Browser Displays the Item Browser. The Item Browser is described in 
“Working With the Item Browser” on page 25.

Open Home 
Page

Opens your Home Page report. Setting a Home Page is 
described in “Identifying Favorite Reports and Home Pages” on 
page 37.

Search Search items in the TrackRecord database for a specified string. 
Control whether TrackRecord displays the Search tool by right-
clicking anywhere in the Tool bar area and toggling Search off. 
To display the Search tool, right-click in the Tool bar area and 
toggle Search on. Refer to “Searching the TrackRecord Data-
base” on page 33 for additional information on searching.
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Status Bar

The left side of the Status bar (Figure 2-3) provides suggestions for the 
actions you can perform with a tool or on a selected object. If you are 
working in an Outline Report, the status bar identifies the sequence 
number of the item you have selected and the number of items in the 
sequence. 

The right side of the status bar displays the database name, server name, 
and the login name of the current user. For example, the database 
"default", the server name “sfa10072”, and the username "Admin" would 
appear as: default|sfa10072:Admin

Working With the Item Browser
The Item Browser window (Figure 2-5) provides access to information in 
your TrackRecord database. With the Item Browser, you can access exist-
ing database items of any type or create new items. 

Figure 2-5. Item Browser Window

Types 
List

Items 
List

The Item Browser window includes two lists:

� The Types list identifies the basic types of information in the Track-
Record database. If one type of information is a subtype of another, it 
appears indented below that type. For example, Team Member is a 
subtype of the Person data type in Figure 2-5.

� The Items list identifies all of the items of the selected type. When 
you select a type that has subtypes, the names of all the members in 
the subtypes appear. For example, if you choose Person, the Items list 
will include the names of all Team Member items (subtype of Person) 
as well as all Person items.
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Note: The list of types that you see might be a subset of the types available. 
The administrators control your access to types. 

Using the Item Browser

To use the Item Browser, perform the following steps:

1 Click the Item Browser button (Figure 2-6) on the tool bar to open 
the Item Browser window.

Figure 2-6. Locating Item Browser Button on Toolbar

Tip: TrackRecord often 
presents several ways to 
accomplish a task. For 
example, you can open 
the Item Browser with the 
Tool bar button, from the 
Tools>Item Browser 
option, or from the 
File>Open>Other option.

2 Select the type of item about which you want information.

For example, select Person to see the list of all Person items in the 
TrackRecord database. Note that the list will include all items linked 
to the type you selected; therefore, selecting Person will show a list of 
Persons, Customers, and Team Members in the Item list.

3 Double-click an entry in the Items list to display the item’s contents.

For example, double-clicking the name of a Person in the Items list 
opens the appropriate item view, letting you view and modify the 
information recorded for that Person. 

Note that if you select an item that belongs to a child type of the data 
type you chose, TrackRecord opens the item view for the child. For 
example, if you choose Person and then double-click the name of 
someone who is a Team Member (child of Person), TrackRecord 
opens the Team Member item view instead of the Person item view.

Accessing TrackRecord Online Help
TrackRecord’s online help facility is a convenient way to find informa-
tion about a task you are performing, a feature you would like to know 
more about, or a command you want to use. It also contains complex 
information for an administrator that is not contained in the Track-
Record User’s Guide.

� While performing certain tasks, you may press the F1 key to open the 
online help system and display a help topic appropriate for the task 
you are performing.

� Selecting the TrackRecord Help option on the Help menu displays a 
window containing TrackRecord’s help system. You can located infor-
mation quickly through the Contents, Index, or Search tabs.
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Topics may contain links to other topics or links to popup frames. To 
close a popup frame, click anywhere inside the popup.

Using TrackRecord’s Default and Sample Databases
A default database is installed with TrackRecord and is accessible immedi-
ately for tracking defects and issues. In addition, a sample database is 
shipped with TrackRecord. This must be installed first. 

These databases can be modified and customized. A database administra-
tor must configure the default database before it can be accessed and a 
defect can be created. For information regarding configuring databases 
see “Creating and Maintaining TrackRecord Databases” on page 23, and 
“Administering TrackRecord” on page 63 of the TrackRecord Administra-
tor’s Guide. Administrator privileges to the database are required to 
create and modify databases. 

To access the default database, open and log in to TrackRecord. See 
“Before You Begin” on page 19. Select Default from the drop-down list in 
the Database field and click OK. Click New Defect. A defect item appears.

The sample database is simpler than the default database and is shipped 
with TrackRecord. The sample database must be installed. For informa-
tion on installing the sample database, see "Creating a New Database" on 
page 30 of the TrackRecord Administrator’s Guide. 

After the database is installed, log in to TrackRecord. Select Sample from 
the drop-down list in the Database field and click OK. Click New Defect.A 
defect Item appears. 

Defect Item Fields

The following lists the fields and drop-down lists used in both the 
Default and Sample defect items. They are listed here in alphabetical 
order: 

Field Description Field Instructions

Action Controls the Status. The Sta-
tus details what stage defect 
is in. This is set to Unre-
viewed as a default.

Click Action and choose 
Close to close the defect. 
Choose Review to change the 
status to Open. This indicates 
that the item is open and 
must be reviewed.
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Assigned to Person responsible for a 
defect.

Choose from the drop-down 
list. A project must be 
entered in the Project field to 
enable this field.

Attachments Attach a design document, 
defect etc. associated with a 
defect. 

Click the Add button to 
browse directories for the 
appropriate attachment. The 
attachment is added to the 
field. 

Build/Release 
Fixed

The name or number of the 
build and/or release in which 
a defect is resolved.

Click the drop-down list to 
select an item. Right click 
inside the field to create an 
item. Build/Release Found: 
Click the drop-down list to 
select an item. Click the Add 
button, or right click inside 
the field, to create an item.

Configuration The PC system that recreates 
the defect.

Click the drop-down list to 
select an item. Click the Add 
button, or right click inside 
the field, to create an item.

Date Tested Date QA testing is per-
formed verifying that this 
defect is resolved.

Enter the date or click on the 
calendar and choose the 
appropriate date.

Date Entered Date that this defect is 
entered.

Enter the date or click on the 
calendar and choose the 
appropriate date.

Description Description of the defect 
including any pertinent info-
mration necessary for its 
eventual resolution.

Describe any necessary infor-
mation such as the nature of 
the defect, how it can be rec-
reated, and suggested resolu-
tions, etc.

Documenta-
tion ID#

An ID number previously 
assigned to a document that 
may have to be modified to 
resolve a defect

Enter a number for the docu-
mentation.

Duplicate 
Defects

Defect already has a defect 
assigend to it

Click the Add button to add 
an item, or right click within 
the field to create an item.

Entered by Name of person entering a 
defect

Choose from the drop-down 
list.

Field Description Field Instructions
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Fix by Mile-
stone

The project milestone by 
which a defect must be 
resolved

Choose from the drop-down 
list.

Functional 
Areas

Major area of the product 
affected such as Help, Data-
base, GUI, etc.

Click the Add button to add 
an item, or right click within 
the field to create an item.

Integration 
Resource:

 The resources performing 
the resolution integrations.

Click the drop-down list to 
select an item. Right click 
inside the field, to create an 
item

Identifier This is the defect number. A 
defect can be searched by 
this number within Track-
Record.

A distinct number automati-
cally assigned to the defect 
beginning with 000001

Impacts Docu-
mentation

To resolve a defect documen-
tation must be created or 
modified.

Check this box if the defect 
requires documentation 
modifications.

Imported ID# An ID # assigned from a pre-
vious database.

Enter any related numbers 
associated with defect.

Integration 
Project

A project for a product that is 
also effected by a defect.

Click the drop-down list to 
select an item. Right click 
inside the field, to create an 
item.

Notes Any further information nec-
essary for the resolution of a 
defect. 

Enter any notes for the issues 
or defect.

Keywords A word or phrase entered on 
a defect so that all defects 
with this keyword can be 
grouped together by sorting. 
For example, Beta Required 

Click the Add button to add 
an item, or right click within 
the field to create an item.

Known Issues A defect which has been pre-
viously acknowledged by the 
appropriate parties.

Known Issues: Check this box 
if the defect is a known issue.

Operating Sys-
tem

The Operating System of the 
machine on which the applic-
aiton is running. For exam-
ple, Windows 2000 or 
Windows XP

Click the drop-down list to 
select an item. Right click 
inside the field, to create an 
item.

Field Description Field Instructions
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Priority A number or letter expressing 
the decet’s order of prece-
dence.

Choose a priority 

Project The name or number, etc. of 
the project with which a 
defect is associated. 

Choose the appropriate 
project, or add a project by 
clicking the Add button.

Project 
Resource

The resources performing the 
project resolution.

Click the drop-down list to 
select an item. Click the Add 
button, or right click inside 
the field, to create an item.

Related 
Requirements

Any related requirement 
affected by a defect. For 
example, test cases to be 
added, documentation, etc.

Click the Add button to add 
an item, or right click within 
the field to create an item.

Release 
Resolved

The release number associ-
ated with the resolution of a 
defect. 

Click the drop-down list to 
select an item. Right click 
inside the field, to create an 
item.

Reported by The client who reported a 
defect.

Click the Add button to add 
an item, or right click within 
the field to create an item

Resolution The actions performed to 
resolve a defect.

Click the drop-down list to 
select an item. Right click 
inside the field, to create an 
item. 

Resolution 
Details

Explanation of the work per-
formed to resolved defect.

Enter details of the work per-
formed.

Service Pack The system service pack 
installed. For example, Win-
dows XP SP1, etc.

Click the drop-down list to 
select an item. Right click 
inside the field, to create an 
item. 

Source Files Files containing the resolu-
tion for a defect.

Click the Add button to add 
an item, or right click within 
the field to create an item.

Summary A summary of a defect add-
ing pertinent information 
necessary to its resolution.

Enter the summary

Status The current status of a defect. This automatically reflects the 
same status that is in the 
Action section.

Field Description Field Instructions
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Using the Workflow

A defect, task, or other item can pass through a series of states between 
the time it is entered and the time it is closed. For example, when a 
defect is entered it is generally in an Unreviewed state. It might then be 
assigned to someone, resolved, and validated. This series of actions, and 
the states resulting from these actions, is called a workflow.

To view the workflows for the default and sample items, select Edit 
Workflow from the Administrator Menu. 

The following is an example of a workflow created in TrackRecord.

Severity Determine the impact of a 
defect.

Choose from the list of sever-
ity terms

Test Case ID # A number or letter, etc. of a 
test case with which a defect 
is associated.

Enter a test case number.

Test Resources The resources performing  
QA testing

Click the drop-down list to 
select an item. Click the Add 
button, or right click inside 
the field, to create an item

Type Code The type of issue. For exam-
ple, Bug, Enhancement, etc.

Click the drop-down list to 
select an item. Right click 
inside the field, to create an 
item. 

WorkAround 
Instructions

Instructions that make it pos-
sible to complete a task 
bypassing the defect associ-
ated with this task.

Enter detailed instructions for 
the workaround 

Field Description Field Instructions
 Getting Started     31



This workflow illustrates the movement of the defect, through various 
stages of development. The following examples uses the above workflow 
to move a defect through various actions and states:

1 Joe Developer enters a defect. State: Unreviewed.

2 Jane QA Manager reviews the defect. Action: Review. State: Reviewed.

3 Jane QA Manager assigns the defect to Dave Development Lead who 
assigns the defect to Debbie Developer. Action: Assign. State: Assigned.

4 Debbie Developer determines that the defect requires more informa-
tion for its resolution. She assigns it back to Dave Development Lead. 
Action: Need More Info. State: Pending Information.

5 The necessary information is retrieved and Dave Development Lead 
reassigns the defect back to Debbie Developer. Action: Assign. State: 
Assigned.

6 Debbie Developer works on the defect’s resolution. Action: Working 
On. State: In Progress.

7 Debbie Developer may decide more information is needed. Again, 
she may give the defect back to Dave Development Lead. Steps 4- 6 
are repeated. Action: Need More Info. State: Pending Information.

Or

8 Debbie Developer may work on the defect until its resolution when 
QA will test it. Action: Resolve. State: Ready To Test. 
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9 QA tests and the test fails. Jane QA Manager again reviews the defect 
and steps 3 on are repeated. Action: Fail. State: Reviewed.

Or

10 QA tests and the test passes. Action: Pass. State: Closed.

11 The defect may be reopened if necessary. Action: Reopen. State: Reopen.

12 Jane QA Manager reviews the defect again. Action: Review. State: 
Reviewed. It may enter the process again and repeat steps 3 on.

For information on workflows, see “Workflow Administration” on page 
66 of the TrackRecord Administrator’s Guide. 

Searching the TrackRecord Database
To find database information quickly, you can perform a search rather 
than create a query and view. Simple searches find text strings that occur 
in an item; advanced searches find text strings in specific fields.

Performing a Simple Search

A simple search lets you find items of a specified type that contain a 
specified text string. For example, you can search for all defect items that 
contain a specific name in any field.

1 From the Tools menu, choose Search to open the Search dialog box 
(Figure 2-7).

You can use the Search tool on the main TrackRecord window to 
perform the same function as the Search menu option.

Figure 2-7. Search Dialog Box

2 To search for a specific type of item, select the type from the Search 
for Items of Type drop-down list.

To search through the entire database, select All Items from the 
Search for Items of Type drop-down list.

3 Enter the text string you want to find in the That Contain field.

Any item that contains the specified text string in any field will be 
displayed. You can enter partial words to find wording variations. For 
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example, you can enter veri to find all items that include the words 
verification, verify, verified, or unverified.

4 Click the Search button. A counter displays in the left corner of the 
status bar, indicating the progress of the search. As items containing 
the search text are identified, they are listed in the Search Results dia-
log box (Figure 2-9). If the desired item appears, click Stop to end the 
search. Click on the desired item and click Open, or double click on 
the item, to display its contents.

5 When you are finished, click Close.

Performing an Advanced Search

Advanced searches let you refine the criteria you want TrackRecord to use 
to search in the database. Unlike a standard search, an advanced search 
lets you specify the fields to check for text strings and lets you construct 
multiple search criteria. For example, you can perform an advanced 
search to find all defects where the project name is YourProject, the sever-
ity level is 3, and the description includes the phrase “only happens.”

Complete the following procedure to perform an advanced search:

1 From the Tools menu, choose Advanced Search. The Choose a Type 
dialog box (Figure 2-8) displays your list of standard database types.

Figure 2-8. Choose Type Dialog Box

2 Select the type of information you want to find and click the Search 
button.

TrackRecord opens the form associated with the type of information 
you selected. For example, if you selected Defect, TrackRecord would 
open the Defect form.
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3 Use the fields and controls on the item form to specify your search 
criteria.

For example, you can use the Project list to select the project for 
which you want to find Defect items. Similarly, you can enter a text 
string in the Description field to find all defects whose description 
starts with those words. If you specify more than one search criterion, 
TrackRecord finds all items that meet all of the search criteria.

4 Click the Search button. TrackRecord displays the Search Results dia-
log box (Figure 2-9), which lists the items that meet your search crite-
ria.

Figure 2-9. Search Results Dialog Box

5 As items containing the search text are identified, they are listed in 
the Search Results dialog box. If the desired item appears, click Stop 
to end the search. Click on the desired item and click Open, or dou-
ble click on the item, to display its contents.

6 Click Close to close the dialog box.

Customizing User Preferences
After you become familiar with TrackRecord, you will probably want to 
customize your user options to suit your style of work. TrackRecord user 
preferences fall into three categories:

�  Configuring General Options — Configure your system to control 
how TrackRecord behaves at startup, database-polling frequency, and 
how it interacts with DevPartner tools.
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�  Identifying Favorite Reports and Home Pages — Information on add-
ing reports to a favorites menu and changing a home page.

�  Specifying Favorite Data Types — Simplify data entry by setting up a 
list of your favorite data types.

Configuring General Options

The General tab on the TrackRecord Options dialog box controls how 
TrackRecord behaves at startup and how frequently it polls its database. 
To configure general options, execute the following procedure:

1 From the Tools menu, choose TrackRecord Options. The TrackRecord 
Options dialog box (Figure 2-10) appears.

Figure 2-10. TrackRecord Options Dialog Box – General Tab

2 On the General tab, specify what TrackRecord should do when you 
open a new session.

� To preserve your window layout from one session to the next, 
select the Open the windows that were open at the end of the 
last session option.

� To display your Home Page at the start of a session, select the 
Open the current Home Page option.

3 If you want to log in to TrackRecord without entering your user name 
and password, select the Automatically log in at startup checkbox.

If you activate this checkbox, whenever you start TrackRecord you 
will be automatically logged in and, since you will not be prompted 
for a database name, you will always access the same database. 
Anyone running TrackRecord on your computer will automatically 
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be logged in to the last TrackRecord account and database that you 
used from TrackRecord or from one of the integrated tools.

4 Use the Check the Database for Changes slider to specify how fre-
quently TrackRecord should poll its database for changes.

Polling the database frequently ensures that TrackRecord is working 
with current information but may slow other operations on your 
computer. If your network link is slow or if you are using Outline 
Reports that are not likely to change frequently, you may want to 
check the database less often.

5 Click OK.

Identifying Favorite Reports and Home Pages

Favorite Reports are reports or views that you use frequently. Identifying 
a view or report as a Favorite Report lets you open it from the Favorites 
menu instead of through the File menu.

A Home Page is a report that opens automatically when you start Track-
Record, and can be accessed quickly through the Home Page button on 
the Tool bar. If you are using the WebServer browser interface, your 
Home Page is accessible through a button in the control area.

Project administrators can create one or more favorite views for new 
users during TrackRecord setup and can set default Home Pages. You can 
modify these settings.

Adding a Report To Your Favorites Menu

1 Open the report or view you want to identify as a favorite.

2 With the Report dialog box active, from the Favorites menu, choose 
Add to Favorites. The title of your report appears on the Favorites 
menu.

Changing Your Home Page

1 Open the report or view you want to identify as your Home Page.

2 With the Report dialog box active, from the Favorites menu, choose 
Set as Home Page.

Specifying Favorite Data Types

TrackRecord lets you create a list of your favorite data types to simplify 
data entry. It controls which data types appear in the File>New 
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submenu, in the New list on the tool bar, and in the Search Types list. 
The list of your favorite types appears in three places in TrackRecord:

� When you choose File>New, your list of favorite types appears at the 
top of the resulting submenu.

� When you use the New Item list on the Toolbar, your list of favorite 
types appears at the top of the resulting list.

� When you use the Search Types list, your list of favorite types lets 
you select a specific type to search.

Tip: Do not confuse 
Favorite Data Types with 
the Favorites menu, which 
lets you save shortcuts to 
frequently used views and 
reports. For information 
on the Favorites menu, 
refer to “Identifying 
Favorite Reports and 
Home Pages” on page 37.

Perform the following procedure to identify a data type as a favorite:

1 From the Tools menu, choose TrackRecord Options.

2 When the TrackRecord Options dialog box appears, click the Favorite 
Types tab. The Favorite Types tab (Figure 2-11) appears.

Figure 2-11. TrackRecord Options Dialog Box – Favorite Types Tab

3 Identify the data types you want to appear in your Favorite Types list.

� To use the default list of favorite data types, select the Use the 
types defined by the TrackRecord administrator option.

� To customize your favorite types list, select the Use these types 
option. Select each data type you want in your list from the list 
on the left, and click the Add > button. To remove an entry from 
your list of favorite types, select its name in the list on the right 
and click the <Remove button.

4 Specify the order for favorite types by dragging entries in the list on 
the right up and down. The first entry in the Favorite Types list 
appears as the label for New Item on the tool bar.

5 When you are finished, click OK.
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Where to Go Next

You use TrackRecord to enter information about projects and to retrieve 
and view that information. Although there are many tasks performed 
with TrackRecord, the three primary tasks – entering, retrieving and 
viewing data -– provide the framework for all other tasks. For a descrip-
tion of each of these tasks, consult the following chapters:

� Chapter 3, “Entering and Editing Data”

� Chapter 4, “Retrieving Data”

� Chapter 5, “Viewing Data”
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Chapter 3

Entering and Editing Data
� Using TrackRecord Forms

� Entering TrackRecord Data

� Changing Item Status

� Merging Items

Using TrackRecord Forms
For each type of information stored in the TrackRecord database —
Defects, Tasks, Team Members, and so on — you will want to store differ-
ent pieces of information. For example, you might want to store a name 
and phone number for a Team Member and a summary and description 
for a Defect. Each item type has its own data entry form, which is 
composed of fields appropriate to that item type.

Figure 3-1. Tab Location on Defect Form

Item 
Tab

Links 
Tab

Change History 
Tab

To make data entry even easier, you can create item templates that store 
default values for fields. Information about how to construct and use 
templates is provided in Chapter 7, “Working With Templates”.

Although the Team Member form contains additional tabs, most Track-
Record forms include three tabs: Item, Links, and Change History.
 41



Item Tab

To enter or change information, you open an item view, a form on which 
you can enter or modify information about one item, such as one Defect 
or one Person. Each type of item uses a different form, since each type 
requires different information.

Tip: For additional 
information on opening 
an Item tab, see “Entering 
TrackRecord Data” on 
page 46.

Item views use standard Windows controls, such as text fields, drop-
down lists, scrolling lists, check boxes, and radio buttons, to display and 
update information about specific items. They also use some unique 
controls, such as the Calendar and Add Item buttons.

The Item tab on a TrackRecord form (Figure 3-2) lets you enter informa-
tion about the item you are adding or updating. The fields displayed on 
the item tab depend on the type of item with which you are working.

Figure 3-2. Item Tab for Task Item

Enter descrip-
tions and other 
text in fields.

Drop-down 
lists let you 
link one 
database item 
to another.

Scroll to display 
more fields.

To clear a drop-down list, click the 
Delete key or choose <None>.

Retrieve items 
in the database 
by date or 
other fields.

Links Tab

As you add information to the database, TrackRecord creates a network of 
links between items. The Links tab (Figure 3-3) displays a list of all the 
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items in the TrackRecord database that refer to the item with which you 
are currently working.

Figure 3-3. Links Tab allows you to navigate through your network of linked items by 
selecting a link. 

Opens item in new window

Follows link to determine 
what other database items 
are linked to that item

Returns to previous item

Change History Tab

The Change History tab (Figure 3-4) provides an audit trail of the changes 
made to an item over time. When an item is created, modified, or 
deleted, an entry is added to the change history list for that item. If a 
person made several changes to an item during a single session, each 
change will be noted separately.

Note: For information about the WebServer’s change history window, refer 
to the “Viewing Change History” on page 97.

Figure 3-4. Change History Tab in the Windows Client

Modified 
item

Date and time of 
change

Login name of 
user
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Expand Item Button

As you learned earlier, fields in one type of item can be links to other 
items in the database. For example, in a Defect item the Project field 
might be a link to an item of the Project type. The Project field’s drop-
down list would display a list of all Project items in the database, allow-
ing you to select an existing Project. The selected Project would then be 
“linked” to this defect.

The Expand Item button lets you expand a link to another item. You can 
display and update the fields belonging to that linked item. For example, 
clicking the Expand Item button beside the Priority list in Figure 3-5 
causes the window to display more fields for the selected Priority. If you 
have appropriate privileges, you can add new items or modify the items 
displayed. If you make changes, these changes will be reflected in all 
other items that are linked to the changed item.

Figure 3-5. Using Expand Item Button

Clicking the 
Expand 
Item 
button 
beside an 
item...

...lets you see the 
fields associated 
with that linked 
item.

Calendar Button

The Calendar button (Figure 3-6) lets you specify dates from a graphical 
calendar instead of entering a date with the keyboard. Click the Calendar 
button to open the calendar and double-click a date to select the day you 
want to enter. 
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To choose a date on a past or future month, click the left (past) or right 
(future) arrows at the top of the calendar. The single triangles move one 
month at a time. The double triangles move one year at a time.

Figure 3-6. Using Calendar Button

Clicking the 
Calendar button 
beside a date 
field...

...lets you choose a date from 
a graphical calendar.

Add and Delete Item Buttons

The Add and Delete Item buttons (Figure 3-7) let you add and delete 
items in the TrackRecord database in the course of maintaining other 
types of items. For example, if you want to enter a new telephone 
number while adding or editing a Person item, you would click the Add 
Item button beside the Phone Number field, create the item you want, 
and click Save and Close. (Note that the behavior of the button is config-
urable. Some fields display a list of existing items, allowing you to pick 
one or to click New Item to create a new item of that type.)

Clicking the 
Add Item (+) 
button...

...lets you 
link a new 
item with 
the one you 
were updat-
ing.

Figure 3-7. Using Add Item Button

To delete an item from one of these lists, select the item and click the X 
button. Depending on how this field was defined when the type was 
created, deleting an item from a list may remove it from the database. 
You will be prompted to confirm the deletion. If the field was not defined 
to allow deletion from the database with the X button, you can delete it 
from the database by right-clicking on the item and choosing Delete 
itemname from the shortcut menu.
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Expand Text Field Button

The Expand Text Field button (Figure 3-8) identifies resizeable text fields. 
When you click the Expand Text Field button, the text field area expands 
to the bottom of the window to let you display the complete text of an 
extended description or note about an item. You can click the Collapse 
Text Field button to collapse the text field to its original size.

Figure 3-8. Using Expand Text Button

Clicking the 
Expand Text 
button above 
a text field...

...expands the 
text field to fill 
the available 
window space.

Clicking the Collapse Text button collapses the expanded field.

Entering TrackRecord Data
1 From the File menu, open a new form using one of the following 

methods:

� Click the drop-down arrow next to the New Defect button on the 
Toolbar. If you or your Administrator has changed your Favorite 
Types list, it may not be displayed. In this case, use the Toolbar’s 
New Item drop-down list to select the appropriate form.

� Open the Item Browser (see “Working With the Item Browser” on 
page 25 for more information), right-click on a applicable item, 
and select the New optionname from the shortcut menu (“Open-
ing New Project Using the Item Browser” on page 47).
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Figure 3-9. Opening New Project Using the Item Browser

� Select the appropriate form from the File>New menu.

� Choose File>New>Other. When the Choose a Type dialog box 
(Figure 3-10) appears, select the appropriate form and click the 
New button.

Figure 3-10. Choose Type Dialog Box

2 When the form appears, enter information in the appropriate fields.

Required: If you are using the WebServer, be sure to review “Notes about 
the WebServer” on page 91 to avoid errors when opening your 
Web page.

Note the following when entering defect data:

� A single line text field can contain up to 255 characters.
� A multi-line text field can store up to 65,535 characters of infor-

maiton.
� A numeric field can store a number between between 0 and 

4,294,967,295.
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� The display format of a Date field is based on the regional settings 
on the same client machine.

� Attempt to limit the amount of text to below 800 characters in 
the Description field. If the characters exceed this amount the 
partial display may appear as a garbage overlay of characters.

If your site has implemented templates, TrackRecord may fill in some 
of the fields for you. Refer to Chapter 7, “Working With Templates” 
for information on how to establish and use TrackRecord templates.

3 If you are finished entering data, click Save and Close on the toolbar. 
The drop-down menu next to the Save and Close button offers two 
additional save options:

� If you want to add an unrelated item, choose Save and New from 
the toolbar. 

� If you want to duplicate the current information as part of a new 
item, select Save and Duplicate.

Changing Item Status
From the time an item is opened to the time it is officially closed, it 
typically undergoes a series of status changes; these changes are collec-
tively known as a workflow. For example, a new Defect typically starts 
with a status of Unassigned. A project manager assigns the Defect to a 
developer, updating its status to Assigned. If the developer confirms that 
the problem exists and fixes the appropriate software, he or she would 
move the Defect into a Pending Validation status, flagging it for testing 
and verification.

A workflow defines the states an item goes through and the privileges 
each user has to move an item from one state to another. Your Track-
Record administrator defines the workflow for items. For example, an 
administrator might specify that a someone in Quality Assurance can 
move a Defect with a status of Unresolved to a status of Needs More 
Information or to Resolved. 

Not all items follow a workflow. The Person type, for example, might 
undergo a series of changes over time, but these changes do not consti-
tute a change in the status of the item. Your TrackRecord administrator 
establishes which types of items will follow a workflow by placing a 
Status field on the type form. The Person type does not follow a workflow 
and does not contain a status field.
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To change the status of an item, follow these steps:

1 Open the appropriate item and enter any changes in the fields on the 
form.

2 Use the Action button on the toolbar to select an action. You can 
only select actions that your group is authorized to perform. 

3 When you are finished, click Save and Close.

Merging Items
If you discover that your TrackRecord database includes duplicate items, 
you can merge them to remove the redundant information. When you 
merge one item, the source, into another, the target, TrackRecord replaces 
all references to the source item with references to the target item 
throughout the TrackRecord database, ensuring that database links are 
preserved. When the merger is complete and the appropriate informa-
tion from the source item is moved to the target item, TrackRecord 
deletes the source item. 

If the two items you merge contain lists of information, such as 
telephone numbers, the contents of the source item’s lists are added to 
the corresponding list for the target.

Perform the following procedure to merge items:

1 Open the target item and the source item. You can open items from 
the File menu, from the Item Browser, or from an Outline Report.

2 Click inside the dialog box of the target item to make it active.

3 From the Edit menu, choose Merge with Another Item. The Target 
dialog box (Figure 3-11) appears displaying the type and name of the 
item to which information will be transferred.

Figure 3-11. Target Dialog Box

4 Click inside the dialog box of the source item to make it active.

5 Click the Merge into Target button in the Target dialog box.
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If the source item has information in lists that can be transferred to 
the target item, the Merge Items dialog box (Figure 3-12) appears. 
Click Yes to transfer the item’s list contents.

Figure 3-12. Merge Items Dialog Box

6 When the Merge Complete dialog box is displayed, click OK.

TrackRecord merges the two items, closes the dialog box for the 
source item, and deletes the source item from the database.

7 Close the target item and the dialog box.
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Chapter 4

Retrieving Data
� Understanding Queries

� Composing Queries- Guidelines to Follow

� Creating a Query

� Opening, Modifying, and Deleting Queries

Understanding Queries
To use information that has been entered into the TrackRecord database, 
you must first identify the information in which you are interested and 
create a query to retrieve that data. A query defines what is displayed. It 
lets you formulate requests for specific data from the database. 

Tip: If you are new to 
TrackRecord and want to 
create simple reports 
quickly, you can use the 
Header Wizard to display 
data without creating a 
query. See “Using the 
Header Wizard” on 
page 72.

Queries let you specify criteria for retrieving information in the Track-
Record database and are building blocks for Outline Reports. An Outline 
Report consists of one or more queries that are formatted to display infor-
mation that is returned by queries. You select the type of item you want 
to find and add parameters to make your query as specific (or general) as 
necessary.
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The query shown in Figure 4-1 returns all Defect items in which the 
Current Build field is equal to 42.

Figure 4-1. Simple Query

List of types

Drag a field from the list 
to use it in the query

List of search-
able fields 
within the 
selected type

Search criteria to set specific 
search parameters

When you create a query, you select:

� Type of item you want to find (Defect in the example)

� Fields you want the query to search on (Project and Build Number in 
the example)

� Parameters to make your query as specific as necessary

You can create your own queries or use queries that have been 
constructed for you by your TrackRecord Administrator.

Tip: For date fields, you 
can use relative dates 
(Today, 1 week from 
today) to make reuse of 
queries easier.

Each selection criterion is represented graphically as an arrow. Including 
more than one arrow in a query allows you to filter database information 
using several fields as selection criteria. The output from one arrow 
becomes the input set for the next arrow, until the end of the query 
chain is reached.

Composing Queries- Guidelines to Follow
While TrackRecord provides great flexibility in the creation of queries, 
you should follow a few simple rules to ensure that your queries perform 
satisfactorily.

� Begin your query with the type of item you want to find. For exam-
ple, if you want to find all the Defects for a particular Project, start by 
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selecting the Defects data type, then add a query element for the 
Project field. If you start your query by asking for all Project items, 
the query would check all Projects, rather than Defects that relate to 
a given Project.

� To create an AND specification (Figure 4-2), place related queries side-
by-side; to create an OR specification (Figure 4-3), place queries top-
to-bottom.

Note: Using the OR statement within a query will nullify the desired results 
if the types are the same, such as status or priority.

Figure 4-2. An AND Specification for Search Criterion

Query will search for defects relating to 
Fault Manager AND were entered by the 
current user. Items that meet both crite-
ria will be selected.

Figure 4-3. An OR Specification for Search Criterion

Query will search for defects relating to Fault 
Manager OR defects entered by the current user. 
Items that meet either condition (as well as other 
elements in the query) will be selected.

� Create many simple queries. You can later combine these queries into 
more complex data extraction operations by creating Outline Reports 
and attaching simple queries. (Refer to “Using Outline Reports” on 
page 63 for more information.)

� Avoid complex queries and queries that return very large data sets.

� In a sequence of query elements (arrows), start with the query ele-
ments you expect to return the fewest items.

� The fastest queries are often the ones that run on the entire database.

� To create a query based on a specific date, do not use the GUI date 
selector. Simply type in the date in the date field.

Query Execution Order

TrackRecord executes queries from left to right, then top to bottom 
following the arrows in the queries.

Example One

In the example shown in Figure 4-4, the query would be executed in the 
following manner:
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1 The database will search for defects related to Your Project.

2 The database will search for Critical defects relating to Your Project.

3 The database will search for High priority defects relating to Your 
Project.

4 The results of step 1–3 are combined and can be displayed with the 
Run Query Now button.

Figure 4-4. Example One

Arrow A

Arrow B

Arrow C

Arrows (A and B) 
or (A and C)

Example Two

In the example shown in Figure 4-5, the query will retrieve data in the 
following order:

1 The database will search for items assigned to <CurrentUser> AND are 
assigned a priority of Critical.

2 The database will search for items assigned to Matt Johnson AND are 
assigned a High priority.

3 The results of step 1–2 are combined and can be displayed with the 
Run Query Now button.

Figure 4-5. Example Two

Arrow 
B

Arrow 
D

Arrow C

Arrow A

Arrows (A and B) 
or (C and D)

Example Three

In the example shown in Figure 4-6, the query will execute in the follow-
ing order:
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1 The database will search for items with a Critical OR High priority.

2 The database will search for items assigned to <Current User> AND a 
Critical OR High priority.

3 The database will search for items assigned to Matt Johnson AND a 
Critical OR High priority.

4 The results of step 1–3 are combined and can be displayed with the 
Run Query Now button.

Figure 4-6. Example Three

Arrow AB

Arrow C

Arrow D

Arrows ((A or B) 
and C) or ((A or B) 

Creating a Query
To create a query, perform the following procedure:
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1 On the toolbar, choose Query from the New Item drop-down list. 
Alternatively, you can open a new Query from the File menu. Choose 
New>Query (Figure 4-7).

Figure 4-7. Query Form

Sort options

Search criteria 
fields

Field list

Query area

Type list

Query name

Find list

Run Query 
Now button

Options buttonCreate Outline Report 
button

2 Enter a name for this query in the Query Name field. Query names 
can contain up to 39 characters.

3 From the Type drop-down list, select the type of item you would like 
to find. For example, if you want to find all Defects in the Track-
Record database relating to a specific development project, you 
would choose Defect.

4 In the Field drop-down list, select a primary search criterion and drag 
it to the Query area (Figure 4-7). For example, to find the Defects 
relating to a specific project, drag Project to the Query area. An arrow 
identifying the search field (the query element) will appear in the 
Query area.

5 Use the Find drop-down list to specify whether child types should be 
retrieved. 

Normally, if you query a parent type such as Defect, the results 
include child types, such as Unassigned Defect. If you want to 
exclude child types from the query results, select Excluding child 
types. Refer to “Understanding Data Type Inheritance” on page 17 
for additional information on parent-child relationships.
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6 Specify search criteria.

� Use the Where drop-down list to specify the search criteria you 
want the query to use. For example, to find Defects associated 
with the Colossus project you would select Is Equal To and then 
enter Colossus in the field below. As you specify selection crite-
ria, TrackRecord updates the text in the query element (the 
arrow).

� In the Return drop-down list, specify what you want TrackRecord 
to do when it finds an item that matches the search criteria. Typ-
ically, you want the query to return all items that meet the search 
criteria you have entered. Alternatively, you can retrieve all items 
that link to anything meeting your search criteria.

Tip: When using multiple 
query elements, the 
search criteria fields will 
reflect the currently 
selected element. See 
“Composing Queries- 
Guidelines to Follow” on 
page 52. for information 
on structuring queries.

� Optionally, use the Sort drop-down list to specify how the query 
should sort the items it retrieves.
� If you choose Ascending, TrackRecord sorts the selected 

items by the selection field you specified in alphabetical order 
(1, 2, 3,…x, y, z). 

� If you choose Descending, TrackRecord sorts the selected 
items by the selection field you specified in reverse 
alphabetical order (z, y, x,…3, 2, 1).

� If you choose None, TrackRecord does not sort the selected 
items.

Note: Sorting in outlines are done by field and not based upon the sorting 
defined in the Query. If creating a compound query, and using differ-
ent sort conditions on each, the query will be sorted using the last 
sort condition that was applied. 

Repeat step 3–6 to add additional query elements.

7 If you want to share this query with other users or be notified when 
new items meet the selection criteria, click the Options button to dis-
play the Query Options dialog box (Figure 4-8).

Figure 4-8. Query Options Dialog Box

� To share the query with other users, click the Sharing button. 
When the Sharing dialog box appears, click the Share To button 
and select the share groups with whom you want to share the 
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query. If you choose Not Shared, no one other than you can use 
the query. 

� To receive notification through electronic mail when a new item 
meets the selection criteria for this query, select the Email Me 
check box. Note that your TrackRecord administrator must con-
figure AutoAlert and record your electronic mail address as part of 
your user profile for this feature to take effect.

Note: If you choose to share a query and also click the Email Me check 
box, the email will only be sent to you, not to members of Share 
Groups.

� Click OK to close the Sharing dialog box.

8 Optionally, click the Run Query Now button on the toolbar. 

Running the query from within the Query dialog box allows you to 
test your query. A search results dialog box will display all items from 
the database that match your query. If the results do not match your 
expectations, modify the query.

9 Optionally, click the Create Outline Report button in the toolbar.

Since queries are most often used to create Outline Reports, this 
button provides a shortcut to that feature. 

Tip: Outline Reports are 
described in “Using 
Outline Reports” on page 
63.

The new query is automatically saved and entered as a header in a 
new Outline Report. (This option is not available on Queries created 
from within Outline Reports.)

10 Save the new query by clicking Save and Close or by choosing 
File>Save. 

Opening, Modifying, and Deleting Queries
TrackRecord makes it simple to open, modify, and delete queries.

Opening and Modifying Queries

To open and/or modify an existing query, perform the following steps:

1 From the File menu, choose Open>Query.

2 After making modifications, click the Save and Close button.

Deleting Queries

To delete a query, perform the following steps:
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1 From the File menu, choose Manage.

2 From the displayed list, select the type of query to be deleted. The 
Manage dialog box appears.

3 Select the query to be deleted and click the Delete button.
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Chapter 5

Viewing Data
� Understanding Views

� Opening, Modifying, and Deleting Views

� Using Outline Reports

� Working with Graphs

� Using the Milestone Status View

� Utilizing the Calendar View

Understanding Views
After you identify the information in which you are interested by creat-
ing a query, you must determine what format in which you want the 
information displayed. A view defines how data is displayed. Track-
Record’s four types of views present information in an organized, easy-to-
use way and contain the most current information in the database:

� Outline Reports— Dynamic reports that allow you to view summa-
ries of the TrackRecord data returned by a query or set of queries, 
select what fields appear in columns in the report, and change the 
order in which the columns and headers are displayed. For more 
information, refer to “Using Outline Reports” on page 63.

� Graphs— Displays a graphical summary of the information in an 
outline report. Depending upon the type of information, you can 
generate pie charts, bar graphs, trend graphs, and more. For more 
information, refer to “Working with Graphs” on page 78.

� Milestone Status— Provides a concise summary of project status that 
captures a broad range of project status indicators, including how 
much automated error detection has been performed. See “Using the 
Milestone Status View” on page 82 for additional information.
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� Calendars— TrackRecord automatically categorizes and displays a 
simple list of your appointments and tasks or a tick-marked schedule 
of each day. You can maintain and display multiple calendars simul-
taneously. Refer to “Utilizing the Calendar View” on page 85 for 
more information.

Opening, Modifying, and Deleting Views
TrackRecord makes it simple to open, modify, and delete views.

Opening and Modifying Views

There are several ways to open an existing views: the Open button on the 
Toolbar, File>Manage, or File>Open, which is the method used in the 
following steps.

To open and/or modify an existing view, perform the following steps:

1 From the File menu, choose Open.

2 From the displayed list, select the type of view to be opened.

3 After making modifications, click the Save and Close button.

Deleting Views

To delete a view, follow these steps:
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1 From the File menu, choose Manage.

2 From the displayed list, select the type of view to be managed. The 
Manage Outline Reports dialog box (Figure 5-1) appears.

Figure 5-1. Manage Outline Reports Dialog Box

3 Select the view to be deleted and click the Delete button.

Using Outline Reports
Outline Reports (Figure 5-2) let you selectively retrieve information from 
the TrackRecord database through dynamic reports that select, sort, and 
format summaries. When you create an Outline Report, you insert 
headers into the report and associate a query with each header. Queries 
are building blocks for Outline Reports. When you run the report, the 
queries are run and the matching information is displayed in columns in 
the report. 
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Tip: If you are new to 
TrackRecord and want to 
create simple reports 
quickly, you can use the 
Header Wizard to display 
data without creating a 
query. See “Using the 
Header Wizard” on page 
72.

While you are viewing an Outline Report, TrackRecord periodically runs 
the queries associated with the report to ensure the contents of the report 
reflect the most current information in the database.

Figure 5-2. Sample Outline Report

Columns (fields from 
the items found by 
the query attached 
to this header)

Parent headers 
with queries 
attached

Sibling of Your 
Project Priorities 1; 
Child of Your 
Project Priorities 1 
or 2

Outline Reports are not outlines in the tradition sense; you cannot use an 
Outline Report to enter data in a hierarchical format. Rather, Outline 
Reports are a mechanism for generating a dynamic report by querying 
the database. The queries associated with the Outline Report act like 
smart filters, letting through only the applicable data, and presenting 
that data in an outline-like format.

The headers on an Outline Report are hierarchical. A child header can 
display only data that meets the Query conditions of all of its parent 
headers. Refer to “Using Headers in Outline Reports” on page 71 for more 
information.

Tip: You can specify what 
data is to be displayed in 
the columns of the report, 
rearrange the columns, 
and rearrange the 
headers in the report.

To collapse or expand a header, click the bullet to the left of the header’s 
title. When a header is expanded to show its child headers and data 
items, its bullet appears as a white circle with a minus (-) sign inside it. 
When a header is collapsed, concealing its child headers and contents, its 
bullet appears as a black circle with a plus (+) sign inside and the number 
of items it contains appears to the right of the header text. You can use 
this feature to create numeric summary reports that identify data catego-
ries and item counts within each category.

Tip: The TrackRecord 
sample database provides 
several Outline Reports 
that demonstrate the use 
of headers and queries.

When you view a list of existing Outline Reports, the list shows both 
your privately owned reports plus all other Outline Reports you are 
permitted to share. 
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Creating a New Outline Report

There are five steps to creating an outline report:

�  Defining Queries
�  Adding Report Headers
�  Configuring New Items Options
�  Setting Report Columns
�  Specifying Print Options

Defining Queries

If the queries you want to use in your Outline Report do not already 
exist, you should create them before you establish the Outline Report. 
Alternatively, you can create them as you add report headers. Refer to 
Chapter 4, “Retrieving Data” for information on setting up queries.

Adding Report Headers

1 From the File menu, choose New>Outline Report. An untitled Out-
line Report (Figure 5-3) appears.

Figure 5-3. Blank Outline Report Form

2 Click the Insert Header button and select the As a Sibling Header 
option. The Header Properties dialog box (Figure 5-4) appears.
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Tip: If you are new to 
TrackRecord or have not 
created queries to be used 
in this report, you may 
prefer to use the Header 
Wizard. This option is 
described in “Using the 
Header Wizard” on page 
72.

Figure 5-4. Header Properties Dialog Box

3 On the General tab, select the query you want for your top-level 
header or click the New button to create a new query.

To review the contents of an existing query, click the Open button.

If you create a new query and use the Run Query Now button, note 
that the query results will not reflect the filters of the parent headers.

4 Click a Header Text option to use the query name or to enter more 
descriptive text for the header.

5 Click OK or click another tab to continue setting up the header.

Configuring New Items Options

The options on the New Items tab are used to define custom behavior 
when a user right-clicks on a displayed header. It adds a New Item option 
to a header’s right-click menu and allows you to specify a template to be 
used for new items. If you are new to creating Outline Reports, you do 
not have to enter anything on this tab. 

1 Right-click in the Outline Report and select Set Template.

2 On the New Items tab, select the type of item to be added.

3 Select a template to be used when items are added. To learn about 
templates, refer to “Working With Templates” on page 103. Click OK 
or click another tab to continue setting up the header.

Setting Report Columns

Use the Column tab to specify what columns are to be displayed for this 
header. 
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1 Right-click in the Outline Report and select Set Columns to display 
the Columns tab (Figure 5-5) on the Header Properties dialog box.

Figure 5-5. Columns Tab in Header Properties Dialog Box

Columns to 
be Displayed 
list

Types 
list

Show As 
list

Column 
name field

Column width setting

Add 
button

Remove 
button

2 Select one of the following options for column display:

� Show the Same Columns as the Parent Header—Displays the 
same columns as are displayed under the parent header.

� Show These Columns— Allows you to customize the column 
display for the selected header.

3 Select the type of data in the header from the Type drop-down list. 

4 Select a field you want to display in the Outline Report and click the 
Add> button to move the field name into the Columns To Be Dis-
played list.

The Default Abbreviation is always displayed. It is established by your 
Administrator and cannot be eliminated from the report. To display 
multiple lines in the description field, select Descriptions and then 
Full Notepad from the Show As drop-down list. Repeat this step for 
all columns to be displayed.

5 Specify the order in which you want columns displayed by dragging 
field names up and down within the Columns To Be Displayed list. 

For example, if you want Project to be displayed in the first column, 
drag it to the top of the list.

� Use the Column Name field to change the label the Outline 
Report displays at the top of the column.

� Use the Show As drop-down list to specify how you want the col-
umn displayed.
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� The available options vary depending on the field type. For a 
Name field, for example, you could choose to display the full 
name, initials, name and address, and so on.

� Specify how wide you want the selected column to be within the 
Outline Report.
� If you want TrackRecord to determine how much space to 

use, select the As wide as possible option.

� If you want the column to be a specific width within the 
report, select the Exactly option and enter the number of 
inches for the column width in the Inches text box.

6 When you have finished adding and formatting columns for the 
header, click OK or click another tab.

Specifying Print Options
Tip: When you print an 
Outline Report, 
TrackRecord prints items 
within open headers. If 
you collapse a header, the 
items under that header 
will not be printed.

You can specify print options for an Outline Report to override your 
default print option settings, and you can specify print options for 
specific headers within the report.

� To set print options for the whole report, click the Options button on 
the Outline Report toolbar and select the Print Options tab (Figure 5-
6).

� To set print options for individual headers, right-click on the header, 
choose Properties, and select the Print Options tab.

The following steps are common to both report and individual header 
print options.

Figure 5-6. Print Options for Individual Header

Change Font 
buttons

Print listHeader 
styles list

Sets 
verti-
cal 
space

Item styles list

1 Select the typeface and size you want to use to print report headers 
and data items by clicking the Change Font button. When the Font 
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dialog box appears, select the typeface, style, and size you want to 
use. When you are finished, click OK.

Required: Headers and items must use the same type size, even if they use 
different typefaces.

2 From the Print drop-down list, select Headers and Items or Headers 
Only to print the items belonging to report headers.

3 If you are printing data items, use the Item Style drop-down list to 
select the lead-in character for item entries.

� Select the Leading Bullet option if you want each item to be pre-
ceded with a bullet (•). 

� Select the Leading Number option if you want each item to be 
preceded with a sequence number. Sequence numbers restart 
within each header.

� Select the Leading check box option if you want each item to be 
preceded with an empty check box. Check boxes simplify track-
ing which items within a list have been discussed or completed.

Select whether to print with or without a line following each item.

4 Use the Header Style drop-down list to specify how you want head-
ers on the report printed.

Tip: For additional 
information on printing 
Outline Reports, see 
“Printing from Outline 
Reports” on page 77.

� Select Header Text Only or Header Text and Item Count.

� Select whether to print with or without a line following each 
header.

5 In the Space After Each Item and Space After Each Header fields, 
type a number to specify how much vertical space you want between 
lines.

6 If you are setting print options for an individual header, choose 
whether to start this header on a new page and, if this is a child 
header, whether to use the parent headers print options.

7 When you are finished, click OK. The changes will not be reflected 
on your screen display; they are used only when reports are printed.

Customizing Outline Reports

The Outline Reports tab on the TrackRecord Options dialog box controls 
the default typeface and size for new Outline Reports and what headers 
in a report do when you double-click them. You can override these 
default settings for specific reports or for specific headers within a report. 
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If you are new to TrackRecord, read “Using Outline Reports” on page 63 
before customizing the Reports.

1 From the Tools menu, choose TrackRecord Options.

2 When the TrackRecord Options dialog box appears, click the Outline 
Reports tab. The Outline Reports dialog box (Figure 5-7) appears.

Figure 5-7. TrackRecord Options Dialog Box – Outline Reports Tab

3 To change the font used to display report headers or items in an Out-
line Report:

Tip: You can use different 
typefaces and styles for 
headers and items, but 
the header font and the 
item font must use the 
same type size. Resetting 
the size for one 
automatically changes 
the size for the other.

� Click the Change Font button.

� When the Font dialog box appears, select the typeface, type style, 
and size you want TrackRecord items to use.

4 In the Header Handling drop-down list, specify what you want 
TrackRecord to do when you double-click an Outline Report header.

� Select Expand and collapse section if you want TrackRecord to 
display and hide the entries under a header when you double-
click it.

� Select Open Header Properties if you want TrackRecord to dis-
play the property form for a header when you double-click it.

� Select Open Query if you want TrackRecord to display the query 
associated with a header when you double-click it.

5 Click OK.
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Using Headers in Outline Reports
Tip: If you are new to 
TrackRecord or have not 
created queries to be used 
in this report, you may 
prefer to use the Header 
Wizard. This option is 
described in “Using the 
Header Wizard” on page 
72.

Headers are the building blocks of Outline Reports. They are used to 
isolate and filter project data by associating database queries with 
Outline Reports. Headers have properties that you can modify such as 
data view options, use of templates, column content and format, and 
print and displaying fonts. 

Creating a Report Header

For information on adding a report header to an Outline Report, refer to 
“Adding Report Headers” on page 65.

Adding Multiple Headers

To add more headers to your reports, select a header in the report and 
click the Insert Header button.

Tip: For information on 
Parent, Child, and Sibling 
relationships, refer to 
“Understanding Data 
Type Inheritance” on 
page 17.

� To add headers at the same level as the one you selected, choose 
Insert Header>As a Sibling Header.

� To add child headers, choose Insert Header>As a Child Header. 
Child headers act to further segment the data selected by the parent 
header. The selection criterion of the parent header limits the data 
available for selection by the child header.

Dragging Headers in an Outline Report 

You can easily rearrange your Outline Report by dragging headers from 
one location to another within the report. When the cursor is over an 
area where the header can be dropped, the dragged image will snap in, 
showing you where the dropped header will appear. You can drag one 
header above or below another as a sibling, which puts them at the same 
level within the report. You can also drag one header below another to 
position it as a child or drag one header above another to make the 
dropped header a parent header.

If it is not possible to drop a header at a given location, the header will 
not snap in at that location, or will snap to the closest alternative.

Employing the Remainder Header

TrackRecord includes a special header called Remainder, which acts as a 
None of the Above summary item. When you include a Remainder header 
as a child header, it gathers and summarizes all the items belonging to 
the parent header that have not been listed in the child headers above it. 
The Remainder header is typically used to identify items belonging to a 
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parent header that fail to match all criteria pertaining to sections under 
that parent header. 

By moving the Remainder header within a parent header, you can 
summarize the none of the above items quickly and easily. Figure 5-8 
illustrates how you can move the Remainder header from one location to 
another within an Outline Report to obtain different summaries. 

Figure 5-8. Using Remainder Header

The first screen summarizes all defects, sorted by status, with the number 
of defects of each status shown in parentheses beside the sibling header. 
The Remainder header indicates that the product has 19 defects whose 
status is not Open or Fixed.

When the Remainder header is moved above the Fixed Defects header in 
the second screen, the item count for Remainder changes from 19 to 28. 
The Remainder header is now counting the Open Defects it was counting 
before (19), plus the Fixed Defects (9). Similarly, when the Remainder 
header is moved above the Open Defects header, the item count for 
Remainder changes to 30, representing the number of items of Open 
Defects (2) in addition to the number of items of Fixed Defects (9), and 
the number of items it represented in the first screen (19). 

Using the Header Wizard

The Header Wizard is a TrackRecord utility that simplifies the creation of 
Outline Reports. The Header Wizard is most useful in two situations:

� When you are a new TrackRecord user unfamiliar with creating que-
ries and inserting headers

� When you want to create Outline Reports that would require multi-
ple, repetitious queries

For example, to create a report listing tasks assigned to certain Team 
Members, you would have to create a query element for each person 
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(AssignedTo=Bob, AssignedTo=Mary, AssignedTo=Joe, etc.). To group 
the tasks under separate headers would be even more tedious, since 
you would have to create separate queries. With the Header Wizard, 
you could identify all Team Members at one time by selecting them 
from a list and specifying how you want the tasks grouped.

To use the Header Wizard, follow these steps:

1 From the File menu, choose New>Outline Report. 

2 Choose the Insert Header>Using Header Wizard. The Introduction 
dialog box (Figure 5-9) appears.

Figure 5-9. Header Wizard Introduction Dialog Box

Tip: Click Back to back 
up one step. Click Next to 
move to the next step.

Read the instructions on the Introduction dialog box. If you want to 
skip this dialog box when you run the Header Wizard in the future, 
select the Don’t Show This Introductory Screen check box. When 
you are finished, click the Next button.

3 In the Select Item Types dialog box (Figure 5-10), select the check box 
corresponding to each type of item you want to retrieve from the 
TrackRecord database.

Figure 5-10. Select Item Types Dialog Box
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The Header Preview pane displays the name of each type you select. 
When you are finished, click Next.

4 In the Choose Field to Query On dialog box (Figure 5-11), specify the 
option you want to use as your query criterion.

Figure 5-11. Choose Field to Query On Dialog Box

Click on one of the following options:

� Find All Items— Searches for all items. Click Next and skip to 
step 5.

� Query On Field Named— Finds items that have a specified value 
in a field. Select the field you want to use. For example, if you 
want to look for Defects associated with a specific project, you 
would choose Project as the query field. If you choose more than 
one type in step 3, the option may not be available. Click Next 
and continue to step 5.

5 If you selected a query field in step 4, use the Choose Specific Values 
To Find dialog box (Figure 5-12) to specify the values you want the 
query to find.

Figure 5-12. Choose Specific Values to Find Dialog Box
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If you want the query to search for more than one value, click each 
value you want. For example, if you want to look for Defects associ-
ated with three specific projects, you would click each project name. 
To deselect an entry, click it again. When you are finished, click Next.

6 In the Grouping dialog box (Figure 5-13), specify how you want the 
query results to be grouped by selecting the associated option.

Figure 5-13. Grouping Dialog Box

� To group selected items under separate headers, select the Group 
Them Under Multiple Headers option. Click Next and continue 
to step 7.

� To group selected items under one header, select the Put Them 
All Under a Single Header option. Click Next and skip to step 8.

7 If you specified in step 6 that you wanted selected items grouped 
under multiple headers, use the Grouping Options dialog box (Figure 
5-14) to specify how TrackRecord should group items.

Figure 5-14. Grouping Options Dialog Box

The following options are available:

� Group by Type— Places all items of the same type together, but 
do not sort them.
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� Group by Value—Places all items with the same value together, 
but do not sort them.

� Group by Type, Then By Value— Places all items of the same 
type together and sort them by value.

� Group by Value, Then By Type— Places all items with the same 
value together and sort them by type.

When you are finished, click Next.

8 In the Placement Options dialog box (Figure 5-15), specify where the 
new headers should appear on the Outline Report.

Figure 5-15. Placement Options Dialog Box

� If new headers should appear at the same level as the current 
header, or if these are the only headers in the report, select the 
Insert as a Sibling option.

� If new headers should appear as subheaders within the current 
header, select the Insert as a Child option.

9 When you are finished, click Finish. TrackRecord formats the Outline 
Report with the new headers, retrieves the items that meet the header 
search criteria, and displays the selected items under the appropriate 
headers.

You can use the Header Wizard to insert as many headers as desired in 
your report.

Opening Items in an Outline Report

Each item entry in an Outline Report represents an item in the Track-
Record database. To open an item, double-click its entry in an Outline 
Report. If you want to update the information displayed for the item, 
make the appropriate changes and close the form; click Yes to save your 
changes.
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Creating New Items from an Outline Report

You can create new items from within an Outline Report. Refer to 
“Configuring New Items Options” on page 66 for information about 
establishing the type of items that will be created and the template to be 
used. To create a new item from within an Outline Report, perform the 
following steps:

1 Select the header under which the item will be created.

2 Right-click and select the New itemtype option. The item type is the 
default type of item included in this header. An item form appears, 
allowing you to create a new item. 

Utilizing the Shortcut (Right-Click) Menu

When you are working in an Outline Report, you can use the shortcut 
menu to perform a variety of functions. To open the shortcut menu, 
right-click an outline header or item.

As Figure 5-16 illustrates, the contents of the shortcut menu change 
according to the type of header or item you right-click.

Figure 5-16. Shortcut Menus for Headers and Items

Shortcut 
menu for a 
header in 
an Outline 
Report view

Shortcut menu for an 
item in an Outline Report

Printing from Outline Reports

There are three methods available to print multiple defects in an outline 
view:

For information on specifying print options for an Outline Report to 
override your default print option settings, and you can specify print 
options for specific headers within the report.
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� Hold the keyboard’s Shift key while right-clicking a defect. An option 
will appear on the menu allowing you to print the defect and the rest 
of the set. Left-click this option while holding the Control key (Ctrl).

Tip: When you print an 
Outline Report, 
TrackRecord prints items 
within open headers. If 
you collapse a header, the 
items under that header 
will not be printed.

� Hold the keyboard’s Control key (Ctrl) while right-clicking a defect. 
This allows you to print that defect as well as the next 15 when this 
option is left-clicked in conjunction with the Ctrl key. Please note 
that this command will create a separate print job for each defect and 
will create 15 print jobs with one defect each.

� Hold the keyboard’s Control key (Ctrl) + C to copy the result of the 
header. Open an application you will be displaying the report in (e.g. 
Microsoft Word) and use the Ctrl + V keystrokes. Multiple header 
results can be displayed on a single document using this method.

To create printed copy that looks like the screen format of Outline 
Reports:

1 Hold down the keyboard’s Shift key, right click on the first item 
under a header in your Outline Report.

2 Select Print from the menu. This command will print out all of the 
items in the list until the next parent header is reached. Repeat the 
process if desired.

Working with Graphs
The Graph view displays a visual summary of the information in an 
Outline Report. Graphs can be used to effectively:

� Convey information quickly

� Identify trends which may not be apparent

� Display relationships that may exist between groups or series of num-
bers

Note: Graph availability is governed by the number of parameters in the 
query that resides in the header.

Tip: Reports with 
symmetric, hierarchical 
headers produce the most 
meaningful graphs.

After a graph is generated, TrackRecord updates it automatically when its 
underlying data changes. However, the graph does not change if you 
modify the Outline Report view from which the graph was generated.

You can print and save Graph views just as you do any other view. You 
can copy graphs generated by TrackRecord into graphics applications, 
such as Microsoft Paint, or into text editors, spreadsheet programs, and 
electronic mail applications that can accept bitmap images, such as 
Microsoft Word, Microsoft Excel, or Microsoft Outlook. For more infor-
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mation, refer to “Integrating TrackRecord with Other Applications” on 
page 113.

Types of Graphs

Depending on the information in the Outline Report, you can generate 
the following graphs: pie, bar, stacked bar, and trend (line and area). 

Pie Graphs
Tip: The graph style 
toolbar buttons become 
active when the style is 
appropriate for the data 
being graphed. Pie graphs 
require two or more 
parameters.

A pie graph (Figure 5-17) is a pictorial summary that displays the number 
of items matching a particular set of queries in an Outline Report. The 
results of each query represent a single pie slice (percentage) on the 
graph. They are useful in seeing the percentage relationship between 
components. Show the change in component proportion at different 
times using two pie graphs.

Figure 5-17. Pie Graph— Defects by Team Member and Priority

Bar Graphs
Tip: The graph style 
toolbar buttons become 
active when the style is 
appropriate for the data 
being graphed. Bar 
graphs require two or 
more parameters.

A bar graph (Figure 5-18) is a pictorial summary that displays the number 
of items matching a particular set of queries in an Outline Report. The 
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results of each query represent a single bar on the graph. A bar graph is 
useful when comparing the magnitude of, or differences between items.

Figure 5-18. Bar Graph— Defects by Status and Priority

Stacked Bar Graphs
Tip: The graph style 
toolbar buttons become 
active when the style is 
appropriate for the data 
being graphed. Stacked 
bar graphs require three 
or more parameters.

A stacked bar graph (Figure 5-19) displays the results of queries, which 
are used to calculate all the bars on the graph. Each point is the number 
of items matching a particular value for a field in that query. A stacked 
bar graph shows bars on top of one another to convey relative propor-
tions of parts to the whole, and to each other. Data is presented in 
segments and bars.

Figure 5-19. Stacked Bar Graph— Defects by Team Member and Priority for the Bolts 
‘N Things Application
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Trend Graphs
Tip: The graph style 
toolbar buttons become 
active when the style is 
appropriate for the data 
being graphed. Trend 
graphs require two or 
more parameters, one of 
which must be time-
related.

A trend graph is used to show rates of change over time, especially if data 
quantities differ greatly. It is useful for comparing two series of data if 
large quantities are involved, or when quantities differ greatly between 
two series. There are two types of trend graphs in TrackRecord (Figure 5-
20):

� Line graphs — Used to show trends in data over equally spaced 
intervals of time. It is useful for a long series of data, or comparison 
of two or more series of data.

� Area graphs — Used to show trends in data over time. It is useful for 
emphasizing the magnitude of changes of time. An area graph is the 
equivalent of a stacked bar graph, for continuous data.

Trend graphs use the results of a single query to calculate all the points/
bars/slices on the graph, and each point is the number of items matching 
a particular value for a field in that query.

Figure 5-20. Example of a Line and Area Graph

Line 

Area 

Creating Graphs From Outline Reports

To create a graph from an Outline Report, select the appropriate header 
in the report and click the Graph button on the toolbar (Figure 5-21). 
Alternatively, right-click the appropriate header and choose Graph from 
the shortcut menu.
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If the information in the header is not appropriate for graphing, the 
Graph button and option will not be active.

Figure 5-21. Creating Graph from Outline Report

Select a 
header 
in an 
Outline 
Report...

...then 
click the 
Graph 
button...

... or 
choose 
Graph 
from the 
shortcut 
menu.

Formatting Graphs

TrackRecord automatically selects a graph style based on the structure of 
the Outline Report and the contents of the queries in the outline. You 
can override the default graph style by choosing a different graph icon 
from the Graph toolbar. The graph style toolbar buttons become active 
when the style is appropriate for the data being graphed.

� To select a different graph style, click a graph style button on the 
Graph toolbar or choose a graph style entry from the View menu.

� For line graphs, you can add a line identifying the overall trend by 
choosing View>Best Line Fit. Similarly, you can insert vertical bars 
connecting graph points to the baseline by choosing View>Draw 
Bars to Points.

� To choose whether to display a legend for your graph, choose View 
>Legend.

Using the Milestone Status View
When project plans are developed, typically the project is broken into 
manageable segments or development cycles, target dates are identified, 
and criterion for each milestone is defined. Once development is under-
way, milestones become the focus of the team efforts; Team Members 
work to perform the tasks associated with upcoming milestones. 
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Tip: Some parts of the 
Milestone Status view are 
product-specific. If you are 
not using the tool that 
populates a particular 
section of the view, that 
section will not contain 
data.

The Milestone Status view (Figure 5-22) identifies where a development 
project stands with respect to a predefined milestone, such as an Alpha or 
Beta release date. Individual developers can use the Milestone Status view 
to identify the specific assignments they have to complete to meet an 
upcoming deadline. By adding database queries identifying which tasks 
and bugs have been assigned, individual developers can use a personal-
ized Milestone Status view as a To Do list that highlights tasks remaining 
to be performed.

Similarly, project managers can use the Milestone Status view to get a 
summary of the overall project status. They can leverage code statistics to 
identify how much of the project source code has been tested. By adding 
queries to the standard report, a project manager can determine critical 
information, such as the status of the project’s requirements and software 
defects.

A Milestone Status view consists of two types of information:

Figure 5-22. Sample Milestone Status View

Header Informa-
tion

Queries

Tip: Milestone Status 
views depend on certain 
internal tags. If these tags 
have been removed or 
altered, the Milestone 
Status option might not 
be available. 
Administrators should 
refer to the TrackRecord 
Administrator’s Guide for 
more information on 
ActiveLink Tags.

Table 5-1. Milestone Status Components

Section Description

Header Information Identifies the project, milestone and date due.

Queries Results of queries included in the Milestone Status.
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Creating a New Milestone Status

To create a new milestone status view, perform the following procedure:

1 From the File menu, choose New>Milestone Status to create a blank 
Milestone Status view.

� Use the Project drop-down list to select the project you want to 
profile. Optionally, click the Open button to display the project 
details.

� Use the Milestone drop-down list to select the project milestone 
you want to profile. Optionally, click the Open button to display 
the milestone details.

2 Click the Options button on the Milestone Status toolbar to open the 
Milestone Status Options dialog box (Figure 5-23).

Figure 5-23. Milestone Status Options Dialog Box

3 To share your Milestone Status view with other users, click the Shar-
ing button.

Click the Share To button on the dialog box that appears and click 
the check box beside each share group with whom you want to share 
the report. Click OK when you are finished.

4 Use the Project list to select the project you want to summarize in 
the Milestone Status view.

5 To prohibit other users from changing the project being displayed, 
select the Lock Project field option from the drop-down list.

6 Enter a brief description of the report in the Description field. 

7 To display the report description on the report, select the Descrip-
tion check box.
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8 To include queries in the Milestone Status view, select the Queries 
check box. 

To add a query to a Milestone Status view, click the Add button. 
When the Open Query dialog box appears, choose the query you 
want to include in the Milestone Status view and click Open.

To change the sequence in which queries are displayed in the 
Milestone Status view, select a query and click the Move Up or Move 
Down buttons. 

To delete a query from the Milestone Status view, select it and click 
the Remove button.

9 When you are finished, click OK.

Utilizing the Calendar View
To view project information in the context of some span of time, use 
TrackRecord’s Calendar view. The Calendar view (Figure 5-24 and Figure 
5-25) functions as an appointment book and To Do list, where Track-
Record automatically categorizes and displays the appropriate data by 
date and time. 

By default, TrackRecord displays all uncompleted items for a given day or 
week. Timed Tasks are displayed according to their scheduled start date/
time, and Tasks (including Defects and Feature Requests) are displayed 
according to their due date. Timed Tasks take place at specific times and 
for specific periods. Regular Tasks may have deadlines, but are otherwise 
open-ended. 

The data displayed in a calendar is determined by the query run by the 
calendar view. You can customize the information displayed by your 
calendar by changing the query. Refer to Chapter 4, “Retrieving Data” for 
more information on queries.

Depending on your preferences, the daily or weekly Calendar view 
displays a simple list of your appointments and tasks or a tick-marked 
schedule of each day. By changing the Calendar view’s query, you can 
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display different data or dates. You can also maintain and display multi-
ple calendars simultaneously.

Figure 5-24. Sample Calendar by Day Views

Drag open a 
new time 
bar to 
create a 
new item 
for a 
selected 
day; also 
works in 
Week view

Displays list 
of appoint-
ments and 
items or 
daily calendar

Displays appoint-
ments (Timed Tasks) 
and To Do items 
(Tasks)

Figure 5-25. Sample Calendar by Week Views
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item to see its 
Item view; right-
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Change 
appointment 
times dynami-
cally by 
dragging 
handles or 
entire time bar

Creating Your Default Calendar

The items displayed in a calendar are determined by the query run by the 
Calendar view. Before setting up your default calendar, create a query for 
the items that you want displayed. Refer to “Understanding Queries” on 
page 51 for information about creating queries.

To configure your default calendar, perform the following procedure:

1 From the File menu, choose New>Calendar.

2 Click the Options button. The Calendar Preferences dialog box (Fig-
ure 5-26) appears.

3 Specify your calendar preferences:
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Tip: Refer to Chapter 4, 
“Retrieving Data” for 
additional information on 
queries.

Figure 5-26. Calendar Preferences Dialog Box
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displays all incom-
plete tasks and timed 
tasks due each day)

Description 
of calendar

4 Click OK to display the Calendar view.

TrackRecord stores your Calendar view settings and uses them any 
time you display a new calendar.

Adding Tasks to the Calendar
Note: If the query specified in your Calendar Preference dialog box does 

not search for date and time fields, you will not be able to enter an 
appointment in this way. The default calendar query uses appropri-
ate fields.

Perform the following procedure to add a task to a calendar:

1 Open your TrackRecord calendar. 

2 From the File menu, choose New>Calendar. TrackRecord uses your 
default calendar settings to display your current calendar.

3 Click the point on the time bar representing the starting time of the 
task or appointment, and drag across to the ending time. Release 
your mouse button.
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For example, if you are entering an appointment scheduled to start at 
9 AM and end at 10 AM, you would drag from the 9 to the 10 on the 
time bar. The Timed Task form (Figure 5-27) appears.

Figure 5-27. Timed Task Form

4 Enter information about the appointment, such as a one-line sum-
mary (which will appear in your calendar), in the form fields. Track-
Record fills in the starting and ending date and time fields for your 
appointment automatically.

5 When you are finished, click the Save and Close button. The new 
appointment appears on your calendar.
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Chapter 6

Using TrackRecord’s WebServer
� Understanding the WebServer

� Exploring the WebServer Interface

� Creating a New Item

� Working with File Attachments

�  Searching With WebServer

� Opening an Outline Report

Understanding the WebServer
TrackRecord’s WebServer allows you to access the TrackRecord database 
through a Web browser, such as Microsoft Internet Explorer.

Tip: Refer to the 
TrackRecord 
Administrator’s Guide for 
administrative 
information.

When you log in to TrackRecord through the WebServer, TrackRecord 
accesses your user information in the database just as though you had 
logged in through the TrackRecord Windows client. If you have set 
preferences such as a Home Page or favorite reports through your 
Windows client, those items will be maintained in the WebServer client 
as well. The WebServer also recognizes your membership in Groups and 
Share Groups and allows you to run the same reports you run through 
the Windows client.

While using the WebServer, you can create new items, view and modify 
existing items, and view existing Outline Reports. You cannot create new 
queries, Outline Reports, or other reports.

Notes about the WebServer

The WebServer uses the same item form as the TrackRecord Windows 
client, but has a few important differences.
 91



Entering Information

You enter information just as you would in the Windows client with 
these exceptions:

� For any date fields in the Web client, always enter date information 
using the same date format as that used by the computer running the 
WebServer. This information is displayed next to the Date field label. 
For example, if the WebServer machine is configured to use dates in 
the format dd/mm/yyyy, you should enter a date as 28/09/2001, not 
09/28/2001. To ensure that the correct format is used when selecting 
dates, click the Calendar button to specify dates from a graphical cal-
endar instead of entering a date with the keyboard. This will open 
the calendar and you can double-click a date to select the day you 
want to enter. Note that alphabetic characters are not supported in 
dates.

� To update an existing TrackRecord item from the WebServer inter-
face, you must open an Outline Report that includes that item and 
then click the item’s link.

� Do not use an ampersand (&), a quote sign (“), a greater than sign (>), 
or a less than sign (<) in any of your fields that are going to be dis-
played on the Web. If you do, you will not be able to open up the 
Web page.

� Do not use field names greater than 40 characters in length.

� Ensure that there are no spaces at the end of a field name.

� Information entered into TrackRecord will not be available in the 
WebServer for about one minute.

Outline Reports

When accessing an Outline Report through the WebServer, note the 
following differences from Outline Reports in the Windows client.

� You can open and close all headers at once with the Expand All and 
Collapse All buttons in the Status Bar (Figure 6-2). Note that Expand 
All may take a some time to complete, depending on the contents of 
the headers.
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� If a report contains more than ten items in a header, when the header 
is expanded the first ten items are displayed. Figure 6-1 illustrates 
how the arrows are used to display the returned items. 

Figure 6-1. Navigation Arrows for Viewing Returned Items

Shows All 
Returned Items

Shows Last 
10 Items

Shows First 10 
Items

Shows Next ItemsShows Previous Items

Number of 
Results

� When you open a header, the report scrolls to position the open 
header at the top of the Work Area.

� If you click on a drop-down list that causes TrackRecord to run rules, 
TrackRecord must access the database to run those rules. The item 
will be partially saved when the database is accessed. Once the item 
has been partially saved, clicking the Cancel button will display a 
message that a version of the item has been saved and you cannot 
cancel your changes. You must manually restore the values that you 
want saved.

Entering and Exiting the WebServer

Required: A non-admin user is prevented from a login to the WebServer if 
they have not previously performed a login to the full TrackRecord 
client.

Logging In to WebServer

To log in to TrackRecord WebServer:

1 Run a Web browser such as Microsoft Internet Explorer.

2 Enter http://<your servername>/trackrecord/welcome.html 
in the Destination field of your Web browser and click Enter.

Note: Ask your TrackRecord administrator what value to enter for <your 
servername>. 

For example, if your server was named sfa10072, you would enter 
http://sfa10072/trackrecord/welcome.html.
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The TrackRecord WebServer Login page (Figure 6-2) appears.

Figure 6-2. TrackRecord WebServer Login Page

3 Enter a user name, password, and the name of a TrackRecord data-
base. Alternatively, enter the name of the server, followed by a colon, 
and the name of a TrackRecord database. For example, 
trdb1:qacenter.

4 Click OK. The TrackRecord WebServer main window (Figure 6-3) 
appears.

Logging Out of WebServer

To log out of TrackRecord, click the Logout link in the Control Area of 
the WebServer window. 

You should use this browser window exclusively for TrackRecord tasks. 
Use another browser window to access other URLs.

Changing the Database Name Appearing on Login Screen

To change the database that appears on the login screen:

1 Click Start > Run.

2 Type Regedit in the Open field. Click OK.

3 Navigate to the following path: H_KEY_LOCALMACHINE>SOFTWARE>Com-
puware>TrackRecord.

4 Right-click on databaseDir and choose Modify.

5 In the Edit String dialog box, change the value data from Default to 
the name of your database.
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Exploring the WebServer Interface
The WebServer window (Figure 6-3) is your Web interface to the Track-
Record database. Use this window to create and modify items and view 
reports. The WebServer window consists of three areas that are explained 
in the following sections: 

� “Control Area” on page 95
� “Status Bar” on page 96
� “Work Area” on page 96

Figure 6-3. TrackRecord WebServer Main Window. The links are shortcuts to your 
most common tasks. The links on your screen may differ from the illustration since 
they depend on your user settings. 

Work 
Area

Status 
Bar

Control 
Area

Control Area

The Control Area of the WebServer Main Window includes the following 
options: 

� From the New dropdown menu at the top, create a new item. The 
default for this is New Defect. 

� From the Open dropdown menu, open a list of existing items. 

� Shortcut to your Home Page report if you or your administrator has 
specified a Home Page in TrackRecord. If a Home Page has not been 
specified, this link is not displayed.

� Use the Search dialog to search for information through the Web-
Server.

� The Manage link is available for administrators. This link is not dis-
played if not logged on as an Administrator.

� The User Options link displays the TrackRecord WebServer version 
number, the name of the database and username. Change a pass-
word, and email address here.
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� The Help icon displays information about using the WebServer.

� The Logout icon logs out of the WebServer. 

Status Bar

The Status bar may contain a status message, such as an error or a 
message indicating communication with the server, or a series of dots 
that are displayed to indicate that the WebServer is performing an action. 
It may also contain information about an item or report currently on 
view, including the title of the page and buttons that operate on the 
current item or report.

The contents of this area vary. For example, when you are working on a 
Defect, the status bar contains a Cancel button and a Save button.

Work Area

The Work Area displays the selected item or report. When you first access 
the WebServer, your TrackRecord Home Page is displayed in the work 
area by default. If you have not set a Home Page, the work area will be 
empty.

Database and User Name

The database name and user name appear on the browser's title bar. For 
example, the database "default" and the username "Admin" would appear 
as (default:Admin). If different from the WebServer name, the database 
server name will also be displayed. For example:

Compuware TrackRecord on WebServername (servername| 
databasename:username)

WebServer Window Notes

Note the following when using the WebServer window:

� TrackRecord launches a separate browser window in which to run the 
Web application. This window should be used exclusively for run-
ning TrackRecord. If you use this window to access another URL or if 
you close the window, your TrackRecord session will be terminated. 

� The context menu (right-click menu) Open Item in New Window 
option is not supported. Although a window will be opened, it will 
not be functional. To display two items simultaneously, open another 
browser window, enter the URL for the welcome.html page, and log 
into TrackRecord from this window.
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Viewing Change History 

At the bottom of most item forms is a Recent Change History section. To 
see all the changes associated with an item, click the View All link. A 
change history window appears (Figure 6-4) if there are five or more 
changes associated with this item. This provides an audit trail of the 
changes made to an item over time. When an item is created or modified, 
an entry is added to the change history list for that item. If items are 
change several times during a single session, each change is noted 
separately.

Figure 6-4. WebServer Change History Window
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Printing A Page

Click the Printable Page button to display the item in a printer friendly 
format (Figure 6-5). 

Figure 6-5. Printable Page Window

Creating a New Item
You can use the WebServer interface to create new TrackRecord items.

Caution: Compuware recommends that you review the “Notes about the 
WebServer” on page 91 before beginning this procedure.

To create a new TrackRecord item, execute the following procedure:

1 Open the TrackRecord WebServer main window as described in 
“Entering and Exiting the WebServer” on page 93.

2 From the New drop-down menu, select the type of item you want to 
create. The Work Area displays a form allowing you to enter the new 
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item. The Status Bar displays buttons appropriate for this item, such 
as Cancel and Save.

Figure 6-6. New Defect Form in WebServer Window

3 Complete the fields in the form. Required fields are identified with 
red field labels. Note the following items:

� A single line text field can contain up to 255 characters.
� A multi-line text field can store up to 65,535 characters of infor-

mation.
� A numeric field can store a number between between 0 and 

4,294,967,295.

4 Click the Save or Cancel button on the Status Bar, when the form is 
complete.

Working with File Attachments
Note: This function will not work unless you are running Microsoft Internet 

Explorer and your Web server is Microsoft Internet Information Server 
(IIS) 4.0 or higher or iPlanet Web server 4.x with an ASP plug-in.

In TrackRecord’s WebServer client, attach files, open attached files, and 
delete attachments.

The TrackRecord limit on file attachment size per item is 12 MB. After 
attaching, these files are compressed, stored in attach.dat, and can only 
be viewed through the TrackRecord client or WebServer. Their 
compressed physical size when stored in the database can be notably 
smaller than the original file size.
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Furthermore, attachments are only read into memory when viewing or 
extracting them, so the fact that the attachment table can become rather 
large on disk has no affect on performance or memory usage.

Working With List Boxes On a WebServer Form

Insert, create, open, or delete items in a list box using the buttons 
described below. 

Figure 6-7. Adding to a List Box on Form

To insert a previously existing item, click the insert button.

To create a new item, click the new item button.

To select an existing item from the displayed list, 
highlight the item and click the existing item button. 

To delete an item from the displayed list, highlight the item and 
click the delete button. 

If you make any changes to an item, be sure to click the Save button. If 
you have not made any changes to the attachment, click Cancel to 
return to the browser.
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Searching With WebServer
To find database information, perform a search rather than create a view. 
The WebServer offers a simple search to find items that contain a speci-
fied text string. For example, search for all defect items that contain a 
specific name in any string field. To search the WebServer, follow these 
steps:

1 Open the TrackRecord WebServer main window as described in 
“Entering and Exiting the WebServer” on page 93.

2 Select the Search link from the WebServer menu. The TrackRecord 
Search window appears.

3 Enter a text string in the Search Criteria field.

Any items that contain the specified text string in any field are 
displayed. Enter partial words to find wording variations. For 
example, enter veri to find all items that include the words verifica-
tion, verify, verified, or unverified.

4 Click the Search button. The Search Results window lists all items 
that meet the search criteria.

Figure 6-8. Search Results Window

5 To display the contents of one of the items, click the appropriate 
entry.

6 Close the window. 

Opening an Outline Report
Any Outline Report that is available to you through the Windows client 
is also available through the WebServer.
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Caution: Compuware recommends that you review the “Notes about the 
WebServer” on page 91 before beginning this procedure.

Complete the following procedure to open an Outline Report:

1 Open the TrackRecord WebServer main window as described in 
“Entering and Exiting the WebServer” on page 93.

2 Select an Outline Report from the Open list. If you have identified a 
Home Page report, you can open your Home Page by clicking on the 
link in the Control Area.

3 Click a report header to show the items within that header. If you 
have enabled the Show Count on Un-Expanded Outlines feature in 
WebServer Administration, each header is followed by an item count.

You can click the Expand All button to display all items in the 
report, or click Collapse All to hide items. You cannot collapse 
individual headers.

To view the entire text of a field, click Show Details.

4 To update an item in the TrackRecord database, click its reference in 
the Outline Report. 

5 To close the report, open another item or report.
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Chapter 7

Working With Templates
� Understanding Templates

� Creating Templates

� Setting the Default State

� Associating Templates with a Header

Understanding Templates
Templates simplify data entry in TrackRecord by automatically entering 
information in specified fields when you create a new item. This preset 
format is used as a starting point for a particular application so that 
format does not have to be recreated each time it is used. For example, 
you can create a template for new Defect items that enters your name, 
your computer configuration, and other information in the appropriate 
fields in the Defect form. You can create templates for any TrackRecord 
data type, such as Team Members, Tasks, or Defects. 

Caution: When creating a template, be careful to leave blank any auto-
incrementing or auto-initialized fields. Otherwise, the contents of the 
template will override the automatic value inserted by TrackRecord.
 103



Figure 7-1 illustrates how TrackRecord enters information in a Defect 
form when it is first opened.

Figure 7-1. Templates Prefill Information in Forms
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� The user’s personal Defect template specifies that “J. Doe” should be 
automatically entered in the Reported By field on the Defect form.

� The global template specifies that the default status for new Defects is 
“Unreviewed”. Note that the user’s personal template does not spec-
ify a value for that field. TrackRecord automatically enters “Unre-
viewed” in the Status field on the Defect form.

� The global template specifies that the default project name for new 
Defects is “Vertigo”. However, the user’s template, which overrides 
the global template, specifies that new Defects should default to 
“Millennium” for the project name, so TrackRecord enters “Millen-
nium” in the Project field on the Defect form.

Templates can be global, shared to selected work groups, or private. 
Private templates are applied after global and shared templates and can 
therefore be used to override global and shared templates.
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When Are Templates Applied?

TrackRecord applies templates in two circumstances: when you create 
new items directly and when you create new items from within an 
Outline Report.

When Creating Items Directly

When you create an item, TrackRecord automatically inserts values from 
templates for that type of item. Templates use the principles of data type 
inheritance determining how to populate fields (Refer to “Understanding 
Data Type Inheritance” on page 17 for more information). The values 
that will be inserted are determined by a nested set of sources, which are 
applied in the following order:

1 Global template for a parent of the new item

2 Template for a parent of the new item shared with the user’s work-
group(s)

3 User’s personal template for a parent of the new item

4 Global template for that type of item

5 Template for that type of item shared with the user’s workgroup(s)

6 User’s personal template for that type of item

When a value for a field is found at one level, TrackRecord ignores values 
specified at lower levels. For example, if a user’s personal template speci-
fies “Colossus” as a project name and the global Defect template specifies 
“Millennium,” TrackRecord uses “Colossus” because it is a higher prior-
ity.

Templates and Items Created from an Outline Report

Templates provide a context-sensitive formula for items created in an 
Outline Report section. When you use templates to create items from 
within an Outline Report, you can specify as many templates as you 
require to prefill the item’s fields.

For example, Figure 7-2 illustrates an Outline Report that lists Defects by 
status (Unfixed bugs, Fixed bugs), with separate child headers for each 
Defect priority (1, 2, 3) under each status header. If you add a Defect 
template to the Unfixed bugs status header, the phrase Unfixed bugs will 
automatically be inserted into the Status field when a new Defect is 
created from within that header. You could then add a Defect template to 
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each child header under Unfixed bugs to insert the appropriate value in 
the Defect Priority field.

Figure 7-2. Adding Templates to Headers Simplifies Data Entry

A template attached 
to the Unfixed bugs 
header would insert 
a status of Unfixed 
bugs into new 
Defects
A template attached 
to each Priority 
header would insert 
a different priority 
into new Defects

When someone using this Outline Report wants to add a new Defect, he 
or she would right-click the appropriate child header and choose New 
Defect from the shortcut menu. TrackRecord would automatically fill the 
Status field with the information supplied by the parent header’s 
template and the Priority field with the information from the child 
header’s template.

Templates associated with child headers override templates associated 
with parent headers. For example, if the template linked to the parent 
header inserts “Millennium” in the Project field of a new Defect and the 
child header inserts “Vertigo,” TrackRecord would insert “Vertigo” 
whenever a new Defect is created from within the child header.
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Figure 7-3 illustrates how TrackRecord fills fields in a new item with 
information supplied by templates attached to headers within an Outline 
Report.

Figure 7-3. Precedence of Templates From Within an Outline Report
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Creating Templates
To create a new template, follow these steps:
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1 From the File menu, choose Manage>Templates. The Manage Tem-
plates dialog box (Figure 7-4) appears.

Figure 7-4. Manage Templates Dialog Box

2 Click the New button to display the Choose a Type dialog box.

3 Select the type of item for which you want to create a template and 
click the New button.

An Item form (Figure 7-5) for the selected type appears. The Identifier 
and Summary fields display a blue key icon beside the label to signify 
that these fields are not part of the template.

Figure 7-5. Template Form for Build Item

Blue key 
indicates field 
identifies or 
describes the 
template 
instead of 
establishing 
default infor-
mation for a 
field in a new 
item

4 Enter a description for this template in the Summary field. The Sum-
mary field is used to identify the template in the Manage Templates 
dialog box (that is, the Summary becomes the template name).

5 Enter information in the fields you want the template to prefill.
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6 Click the Options button to open the Template Options dialog box 
(Figure 7-6).

Figure 7-6. Template Options Dialog Box

7 Optionally, specify whether you want to share this template with 
other users.

� Click the Sharing button to open the Sharing dialog box (Figure 
7-7). Click the Share To button and then select the check box 
next to each group with which you want to share the template.

Figure 7-7. Sharing Dialog Box

Template is shared with Team 
Members in the Colossus and 
Millennium workgroups, but 
not Team Members in the 
Accounting workgroup.

� If you have opened the Sharing dialog box, click OK to return to 
the Template Options dialog box.

� If you want to use this template whenever you open a new item 
of this type, select the Apply This Template to New Items check 
box.

� When you are finished, click OK to return to the template form.

8 Click Save and Close.
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Setting the Default State
To set the default state through the use of a template, perform the follow-
ing steps:

1 From the File menu, choose Manage>Templates. The Manage Tem-
plates dialog box appears. If necessary, use the Show drop-down 
menu to view a subset of templates.

2 If an appropriate template already exists, select it and click the Edit 
button to make any modifications. If an appropriate template does 
not exists, click the New button and select the type.

3 In the Summary field, enter a descriptive name for this template. 
This name will identify this template in the Manage Templates dialog 
box.

4 In the Status field, select a default value for Status, such as Unre-
viewed or Open.

5 Click the Options button to open the Template Options dialog box.

6 Ensure that the Apply This Template to All New Items option is 
selected.

7 Click the Sharing button and select the Share to All option. Click 
OK.

8 When all template items have been set, click Save and Close. When 
a user creates a new item of this type, the initial status will be set.

Associating Templates with a Header
To associate a template with an Outline Report header, follow these steps:
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1 Open the Outline Report to which you want to link a template.

2 Right-click the header to which you want to add a template and 
choose Set Templates. The New Items tab on the Header Properties 
dialog box (Figure 7-8) appears.

Figure 7-8. Header Properties Dialog Box – New Items Tab

3 In the New Item Type section, specify the item types that you want 
to be able to add by right-clicking the header.

� Select the Of type option and choose the data type from the list 
on the right.

� To open the same types from this header as you can from the par-
ent header, select the Of type <type>, as specified in the parent 
header button.

4 Identify the templates you want to use when creating new items from 
within the selected header.

Use the Type drop-down list to select the type of item for which you 
want to create templates. When TrackRecord displays the list of 
templates applicable to the type you select in the Available templates 
list, select the one you want to use and click the Add> button. 

You can use more than one template when you create items from 
within an Outline Report header. For example, construct one 
template to insert your name and a second template to insert a 
project name. This lets you reuse the first template when you set up 
templates for other headers in the Outline Report.
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When you create more than one template for an Outline Report 
header, information from the templates at the top of the list is used 
before information from lower templates. For example, if the first 
template in the list specified a project name of “Colossus” and a 
lower template specified a project name of “Millennium,” Track-
Record would use “Colossus” when creating a new item.

5 When you are finished, click OK.
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Chapter 8

Integrating TrackRecord with 
Other Applications
� Integrating QACenter Products

� Using TrackRecord with Text Editors

� Integrating TrackRecord with Graphics Applications

� Synchronizing TrackRecord with Microsoft Outlook

� Connecting TrackRecord to Microsoft Project

� Integrating TrackRecord With Visual Basic

� Using TrackRecord With Visual C++

� Utilizing TrackRecord with Version Control Systems

� Integrating TrackRecord With Compuware Products

� Using TrackRecord in a CARS Engagement

Integrating QACenter Products 
QACenter tools help companies achieve consistent, dependable applica-
tion performance. 

QACenter delivers automated testing products and solutions designed to 
validate applications running in the full spectrum of environments, to 
isolate and correct problems, and to ensure that systems can handle 
anticipated load before applications go live. These include: 

� Requirements Management

� Test Planning

� Test Execution Management
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� Functional Test Automation

� Load Testing

� Mainframe Test Automation

� Defect Management

� Test Data Management

As shown in the following figure, QACenter products work together to 
successfully meet all enterprise needs.

File-Aid CS

File-AID/CS is a comprehensive data management tool designed to help 
developers, testers and quality assurance teams work efficiently with data 
as they develop, test and support their applications. With File-AID/ CS, it 
is possible to extract, load, copy, convert, transform, compare, and edit 
data without having to be an expert in each database environment. File-
AID/CS supports the major distributed databases (Oracle, DB2 UDB, 
Microsoft SQL Server and Sybase), in addition to a wide range of data 
types including mainframe data.

File-Aid/CS integrates with the following QACenter applications:
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QADirector: Launch File-AID/CS from within QADirector, and avoid 
searching through the Windows Explorer Start menu. Also from QADirec-
tor, access the File-AID/CS Convert and Compare facilities. Use the File-
AID/CS Convert facility to create specifications that contain all the data 
necessary to convert an existing data file to a new target data file. The 
File-AID/CS Compare facility creates specifications that compare the 
expected and actual contents of output files. From QADirector, create 
File-AID/CS tool domains for processing File-AID/CS test scripts within a 
test suite. 

QARun: QARun works with File-AID/CS to execute compare specifica-
tions. Within QARun, create Checks containing File-AID/CS compare 
specifications. 

QADirector

Testing is a major undertaking that requires the coordination of many 
tasks, many testers, large suites of test scripts, and multiple versions of 
different applications. QADirector provides a framework for managing 
the entire testing process—from design, to execution, to analysis. 

QADirector works with testing, requirement, and defect tracking tools, 
organizing tests and results in one location. Specifically, QADirector 
integrates with the following QACenter applications:

QACenter Portal: QADirector reports can be published in QACenter 
Portal. View these reports from any workstation with a supported version 
of Microsoft Internet Explorer installed. QADirector does not have to be 
installed on the computer. Also, manual tests can be viewed or run from 
the QACenter Portal.

File-AID/CS: Launch File-AID/CS from within QADirector and avoid 
searching through the Windows Explorer Start menu. Also from a 
QADirector menu, access the File-AID/CS Convert and Compare facilities. 
Use the File-AID/CS Convert facility to create specifications that contain 
data necessary to convert an existing data file to a new target data file. 
Use the File-AID/CS Compare facility to create specifications that 
compare the expected and actual contents of output files. From QADirec-
tor, create File-AID/CS tool domains for processing File-Aid/CS test scripts 
within a test suite. In addition, analyze test data by comparing test logs 
that are accessible through QADirector. 

QAHiperstation: From within QADirector, browse QAHiperstation scripts 
on the mainframe, add scripts to test procedures, launch QAHiperstation 
to play back the scripts, and view details about failed QAHiperstation 
scripts.
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QAHiperstation+: With QAHiperstation+ installed on a computer, edit 
and create QAHiperstation scripts from QADirector.

QALoad: Launch QALoad Conductor, Analyze, and Player modules from 
a convenient QADirector menu. Add, find, execute, and abort scripts that 
can stress a distributed system by simulating thousands of users simulta-
neously performing different operations. Also, view results of QALoad 
tests from within QADirector.

QARun: Launch QARun from within QADirector to add, create, edit, find, 
execute, and abort scripts that test native Windows applications, distrib-
uted applications with a Windows client, or host based (mainframe) 
applications accessed via a Windows terminal emulation program. 
Additionally, view results and logs to analyze QARun test data.

Reconcile: Use QADirector with Reconcile to generate test plans in accor-
dance with changing requirements. Integration between QADirector and 
Reconcile accelerates test planning and ensures end-user needs are met. 
Plan tests between Reconcile and QADirector through QAC Portal

TestPartner: Launch TestPartner from within QADirector to add, create, 
edit, find, execute, and abort scripts that test Java, Visual Basic, and 
Visual C++ applications, as well as browser-based Web applications. View 
results and logs from within QADirector. 

TrackRecord: Launch TrackRecord, submit defects, and view defects 
from a center within QADirector and avoid searching through the 
Windows Explorer Start menu. Load failed test results into TrackRecord 
defect reports. Store the defect ID with the test procedure for easy follow-
up.

QACenter Mainframe Solutions

QACenter mainframe solutions are a suite of products that automates 
mainframe server testing. QACenter helps measure, manage, and 
minimize the risk in mainframe servers by simplifying frequent 
mainframe server application testing. Solutions include: 

� QAHiperstation to streamline the testing of traditional VTAM appli-
cations.

� QACenter for IBM Enterprise Servers to test IBM WebSphere applica-
tions using HTTP, HTTP/S and APPC communications.

� QACenter for IBM WebSphere MQ to test MQSeries applications.
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QALoad

Today's distributed systems must perform reliably under loads ranging 
from hundreds to thousands of simultaneous users. Organizations must 
perform repeatable load testing and determine the ultimate performance 
and potential limits of a system. Using loads that mimic realistic business 
usage, QALoad validates that the system meets acceptable service levels.

QALoad integrates with the following QACenter applications:

QADirector: Launch QALoad Conductor, Analyze, and Player modules 
from a convenient QADirector menu. Add, find, execute, and abort 
scripts as well as view results of QALoad tests from within QADirector.

QARun

The time consuming and labor intensive task of testing e-commerce, ERP 
or distributed applications is difficult to perform accurately and 
thoroughly using only hit-or-miss, manual methods. QARun provides 
automation capabilities necessary to quickly and productively create and 
execute test scripts, verify tests, and analyze test results. 

Programmers create scripts that imitate the actions of a human tester. 
This keeps testing in sync with accelerated release cycles, improves the 
return on testing investment, and delivers the quality applications end 
users and management expect.

QARun integrates with the following applications:

File-Aid/CS: Create, verify and restore data using the integration 
between QARun and File-AID/CS. Use File-AID/CS to create datapools for 
data entry during testing. Invoke File-AID/CS's Compare feature directly 
from QARun's built-in file check function. View the comparison results 
from the QARun log files, the central point for verifying test results. 
Restore test databases using File-AID/CS, ensuring repeated tests are run 
without data modification. 

QADirector: Launch QARun from within QADirector. Add, create, edit, 
find, execute, and abort scripts to test native Windows applications, and 
distributed applications. Access these applications with a Windows 
client, or host based (mainframe) applications accessed via a Windows 
terminal emulation program. Additionally, view results and logs to 
analyze QARun test data.

Reconcile

Reconcile helps accurately assesses a project’s status by keeping planning, 
development, and testing activities in sync. With Reconcile, test all 
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requirements, and include development or testing changes, within the 
confines of a tight schedule.

Reconcile shares information with other tools that support the project 
lifecycle. This eliminates having to document similar information in 
multiple sources. Specifically, Reconcile integrates with the following 
QACenter applications:

QADirector: From within Reconcile, launch QADirector and import test 
results. Use QADirector with Reconcile to generate test plans in accor-
dance with changing requirements.

TrackRecord: From within Reconcile, launch TrackRecord to synchro-
nize requirements. 

TestPartner

TestPartner is an automated functional testing tool specially designed for 
testing complex applications based on Microsoft, Java, and web based 
technologies. TestPartner’s unique features allow testers and developers 
to create repeatable tests through visual scripting and automatic wizards. 
Users also have access to the full capabilities of Microsoft's Visual Basic 
for Applications (VBA), allowing tests to be as high level or detailed as 
necessary. From within TestPartner, submit defects to TrackRecord.

TrackRecord

TrackRecord is a defect tracking application that records and reports 
information about developed and supported products. TrackRecord 
records project information including project team members and testers, 
schedulers and milestones, bug reports, and feature requests in an Object 
database. TrackRecord’s query and reporting features retrieve and format 
the information necessary to keep a project on track.

TrackRecord integrates with the following QACenter applications:

Reconcile: From within Reconcile, launch TrackRecord to synchronize 
requirements. 

QACenter Portal

The initial and primary focus of QACenter Portal is to provide a 
comprehensive reporting facility that is consistent among the QACenter 
point products. This will enable users, with various roles and 
responsibilities, to create and view detail, summary, and cross-product 
reports. The QACenter Portal reporting engine ties together requirements 
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planning, test planning, test execution, and defect tracking to provide 
users with a centralized view of application quality. 

In addition to the report features, QACenter Portal provides the 
framework for web-based views and functionality to the QACenter point 
products. QACenter Portal supports defect tracking, as well as manual 
test execution and test planning.

QACenter Portal integrates with the following QACenter applications:

QADirector: Publish QADirector report data in QACenter Portal. View 
these reports from any workstation with a supported version of Microsoft 
Internet Explorer installed. QACenter Portal also provides the 
functionality to execute manual tests.

Because QADirector and QACenter Portal share the same database, users 
may be created and maintained in either product.

TrackRecord: Launch the TrackRecord web interface from QACenter 
Portal to enter, edit, and view defects.

Reconcile: Import requirements from Reconcile into QACenter Portal to 
review details and generate reports.

Using TrackRecord with Text Editors
TrackRecord makes it easy to copy data from Outline Reports into other 
applications, including text editors, spreadsheet programs, and electronic 
mail applications. When you paste data from an Outline Report into an 
application that supports Rich Text Format (RTF), such as Microsoft Word 
or Microsoft Outlook, the report’s columns, fonts, and format are 
preserved in the new document.

Tip: Information copied 
from TrackRecord to other 
applications is embedded 
statically. It will not 
change when the data in 
TrackRecord changes.

Embedding an Outline Report in a Text Document

To embed an Outline Report in a text document, follow these steps:

1 Select the headers or items you want to copy and from the Edit 
menu, choose Copy to add the Outline Report data to the Windows 
Clipboard.

2 Activate the document window for your target application.

3 From the Edit menu, choose Paste. 

If you copied an Outline Report header, the header you selected, its 
child headers, and any sibling headers below the one you copied 
appear in the target document window. If you selected an Outline 
Report item, that item is pasted to the target document.
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4 Optionally, update the style information for pasted data to make it 
conform to your document standards.

TrackRecord information pasted into other applications uses two 
styles: TR Header and TR Item. After you have pasted information 
from TrackRecord into a text editor, you can quickly adjust the 
typefaces, type sizes, and other properties of the embedded informa-
tion by changing settings for these styles.

Integrating TrackRecord with Graphics Applications
You can copy graphs generated by TrackRecord into graphics applica-
tions, such as Microsoft Paint. After you paste a TrackRecord graph, you 
can modify the graph using the application’s tools.

Additionally, you can paste graphs generated by TrackRecord into text 
editors, spreadsheet programs, and electronic mail applications that can 
accept bitmap images. For example, you can paste a bar graph from 
TrackRecord into Microsoft Word, Microsoft Excel, or Microsoft Outlook.

Pasting a TrackRecord Graph into Another Application

To paste a TrackRecord graph into another application, perform the 
following procedure:

Tip: Graphs copied from 
TrackRecord to other 
applications will not 
change when the data in 
TrackRecord changes.

1 Generate the graph from the appropriate Outline Report. Refer to 
“Working with Graphs” on page 78 for information on formatting 
TrackRecord graphs.

2 From the Edit menu, choose Copy to add the TrackRecord graph to 
the Windows Clipboard.

3 Activate the window for your target application.

4 From the Edit menu, choose Paste.

5 Optionally, if the target application lets you edit bitmap images, 
change the colors or layout of the TrackRecord graph.

Synchronizing TrackRecord with Microsoft Outlook
Those who use Microsoft Outlook can import TrackRecord task items into 
Outlook. It then displays TrackRecord task items as Outlook tasks. You 
can check off a completed task in Outlook. After synchronization, the 
task will also be shown as completed in TrackRecord. You can synchro-
nize the applications periodically to keep your items up-to-date in both 
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applications. Optionally, tasks marked as completed in either application 
can be removed from Outlook during the next synchronization.

The following table details how TrackRecord tasks appear in Outlook 
tasks:

Table 8-1. How TrackRecord Tasks Appear in Outlook

Outlook Field Contents

Subject Default value of item (Identifier and Summary by default)

Due Date Date Due field

Priority Mapped from Priority field

Body Text of the format:

“Project: <Project> <Description>” where Project 
and Description are taken from the corresponding TrackRecord 
fields

Category Set to the text TrackRecord

Caution: Three additional user-defined fields are added to the Outlook 
task item: TRIdentifier, Project, and Database. These fields maintain the 
link with TrackRecord and should not be edited.

Note: Outlook 2000 users will find a TrackRecord menu on the Outlook 
menu bar after a TrackRecord installation. Outlook 97/98 users must 
run a separate program called TROutlookSync.Exe to set synchroni-
zation options and to synchronize tasks.

Synchronizing TrackRecord and Outlook 97/98

1 In Windows Explorer, locate the TrackRecord directory and double-
click the TROutlookSync.Exe icon in the TrackRecord program group.

2 If the TrackRecord login screen appears, enter your user name and 
password. Click OK.

3 Click Options on the TrackRecord Task Synchronization dialog box.

Note: You can also use the “/sync” command line parameter to automati-
cally begin a synchronization upon launching the application. If this 
is coupled with a “/silent” parameter, no user interface will be shown 
and the synchronization will simply occur. For example: C:\Program 
Files\Compuware\TrackRecord\TROutlookSync.exe/sync.
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Tip: If you want 
synchronization to occur 
automatically, you can 
use a feature like the 
Microsoft Scheduler to 
periodically launch the 
TrackRecord Task 
Synchronization program. 
Use the “/synch /silent” 
arguments to prevent 
dialog boxes from 
appearing.

4 On the Synchronization Options dialog box (Figure 8-1), set or 
change options as necessary:

Note: If the selected query returns non-task items such as Defects or 
Projects, they will not be imported into Outlook; only tasks (or items 
that inherit from tasks) can be imported.

Figure 8-1. Synchronization Options with Microsoft Outlook

� Select a TrackRecord query for retrieving task items by selecting a 
query from the drop-down list. By default, TrackRecord will 
search for a query named My Outlook Tasks in the current data-
base and use that to determine which items should be synchro-
nized. If that query is not found, it will scan all task items and 
synchronize any tasks that are assigned to the current user and 
not marked as complete. Changing the query only affects what 
new items will be imported/synchronized with Outlook. Any 
items that have already been imported into Outlook will remain, 
and will continue to be synchronized with TrackRecord.

� Choose whether to remove completed tasks from Outlook by 
selecting or clearing the check box. By default, once an item is 
marked as complete, it is removed. When this option is cleared, 
completed items will not be removed and will continue to be 
synchronized. 

Note: You cannot mark tasks as incomplete from within Outlook. If you 
mark a completed task as incomplete in Outlook, it will be remarked 
as complete next time you synchronize.

� Choose whether to exclude TrackRecord tasks already marked as 
complete by selecting or clearing the check box. By default, com-
pleted TrackRecord tasks in the query are not added to Outlook. 
When this option is cleared, even the completed tasks will be 
added.
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Note: If the Remove Completed Items option is selected while the 
Exclude Completed tasks is cleared, all the completed tasks will be 
added to the Outlook Tasks folder and then moved to the Deleted 
Items folder.

� Select how to map TrackRecord priorities to Outlook by double-
clicking an entry in the Outlook Importance column and select-
ing High, Normal, or Low. This control allows you to map each 
TrackRecord priority to an Outlook priority. If a priority has not 
been mapped in TrackRecord, or has no priority, it will be set to 
Normal in Outlook.

5 Click OK when you are finished.

6 Click the Synchronize button.

7 Click Exit when finished.

Synchronizing TrackRecord and Outlook 2000

If you have Outlook 2000, the TrackRecord client installation process will 
install an add-in that allows you to access TrackRecord Task Synchroniza-
tion. From the Outlook Tools>TrackRecord menu, there will be three 
menu options: Synchronize, Edit Options, and Change Login. To 
synchronize using Outlook 2000, perform the following procedure:

1 In Outlook, choose Tools>TrackRecord>Options. The Synchroniza-
tion Options dialog box (Figure 8-1) appears.

2 On the Synchronization Options dialog box (Figure 8-1), set or 
change options as necessary:
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Note: If the selected query returns non-task items such as defects or 
projects, they will not be imported into Outlook; only tasks (or items 
that inherit from tasks) can be imported.

Figure 8-2. Synchronization Options with Microsoft Outlook

� Select a TrackRecord query for retrieving task items by clicking 
the drop-down list and choosing a query from the supplied list. 
By default, TrackRecord will search for a query named My Out-
look Tasks in the current database and use that to determine 
which items should be synchronized. If that query is not found, 
it will scan all task items and synchronize any tasks that are 
assigned to the current user and not marked as complete. Chang-
ing the query only affects what new items will be imported/syn-
chronized with Outlook. Any items that have already been 
imported into Outlook will remain, and will continue to be syn-
chronized with TrackRecord.

� Choose whether to remove completed tasks from Outlook by 
selecting or clearing the check box. By default, once an item is 
marked as complete, it is removed. When this option is cleared, 
completed items will not be removed and will continue to be 
synchronized. 

Note: You cannot mark tasks as incomplete from within Outlook. If you 
mark a completed task as incomplete in Outlook, it will be remarked 
as complete next time you synchronize.

� Choose whether to exclude TrackRecord tasks already marked as 
complete by selecting or clearing the check box. By default, com-
pleted TrackRecord tasks in the query are not added to Outlook. 
When this option is cleared, even the completed tasks will be 
added.
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Note: If the Remove Completed Items option is selected with the Exclude 
Completed tasks cleared, all the completed tasks will be added to 
the Outlook Tasks folder and then moved to the Deleted Items folder.

� Select how to map TrackRecord Priorities to Outlook by double-
clicking an entry in the Outlook Importance column and select-
ing High, Normal, or Low. This control allows you to map each 
TrackRecord priority to an Outlook priority. If a priority has not 
been mapped in TrackRecord, or has no priority, it will be set to 
Normal in Outlook.

3 Synchronize tasks by choosing Tools>TrackRecord>Synchronize 
Tasks. The TrackRecord Task Synchronization Status dialog box 
appears.

4 Close the dialog box when the synchronization is complete.

Connecting TrackRecord to Microsoft Project
Integrate TrackRecord with Microsoft Project to let managers and devel-
opment Team Member exchange up-to-date project status information 
quickly and easily and link development schedules to items in the Track-
Record database. Periodically synchronizing Project information and 
TrackRecord information lets you update information about project dates 
and milestones, status and priorities of tasks, and the availability of 
project Team Member.

Managers can track actual schedules against baseline schedules easily; 
each time a Team Member marks a task as complete in TrackRecord, its 
status and dates are adjusted in the project plan in Project. Similarly, a 
project Team Member can use TrackRecord to obtain a list of current tasks 
(which may include tasks defined in TrackRecord or Project). When a 
Team Member completes an assignment, TrackRecord automatically 
updates the project database and passes the new assignment information 
to Project.

Integration Overview

Figure 8-3 provides an overview of the process of integrating TrackRecord 
and Microsoft Project information. Each item is described fully in the 
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following sections. These tasks are generally performed by a project 
manager and should be done in the following order.

Figure 8-3. Microsoft Project/TrackRecord Integration Overview

Install the Microsoft Project and 
TrackRecord integration macros. 
See “Installing the Microsoft 
Project Macros” on page 126. Perform initial project setup to connect a 

Microsoft Project-based schedule with a 
TrackRecord project. See “Performing 
Initial Project Setup” on page 127.

Map Project and TrackRecord 
priorities. See “Mapping Track-
Record Priorities to Project Priori-
ties” on page 129.

Synchronize applications. TrackRecord 
creates a new Project Task item for each 
task and synchronizes status. See 
“Synchronizing a Project in TrackRecord 
with Microsoft Project” on page 130.

Synchronize the applications periodically, whenever you want to update 
project information. Refer to “What Happens During Synchronization?” 
on page 131 for an explanation of how fields are synchronized.

Installing the Microsoft Project Macros

To integrate TrackRecord and Microsoft Project information, begin by 
installing the TrackRecord macros in Microsoft Project. A new Track-
Record menu will be added to the Microsoft Project tool bar. 

Tip: You can enable two 
TrackRecord tool bar 
buttons, one for 
synchronization and the 
other for opening a task 
item, by right-clicking on 
the Microsoft Project tool 
bar and selecting 
TrackRecord.

1 Open the Integration.mpt file created for your specific version of 
Microsoft Project:

� Microsoft Project 98-2000: In Windows Explorer, double-click 
the TrackRecord Integration.mpt file to open Microsoft Project. 
By default, the file is installed in the x:\Program Files\Compu-
ware\TrackRecord folder where x is the drive where Windows 
resides on your computer. 

� Microsoft Project 2002: In Windows Explorer, double-click the 
trackrecord integration2002.mpt file to open Microsoft 
Project. By default, the file is installed in the x:\Program 
Files\Compuware\TrackRecord folder where x is the drive where 
Windows resides on your computer. 
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2 If the Microsoft Project Macro warning dialog box (Figure 8-4) 
appears, click the Enable Macros button.

Note: This dialog box will not display if you have cleared the Always ask 
before opening projects with macros check box.

Figure 8-4. Microsoft Project Dialog Box

3 Click OK.

If the Office Assistant is open, TrackRecord displays status and error 
messages through the Office Assistant.

TrackRecord Menu

The integration macros create an additional TrackRecord menu in 
Microsoft Project that contains three options:

� Synchronize Project Now – Causes TrackRecord and Microsoft 
Project to exchange project information. Refer to “What Happens 
During Synchronization?” on page 131 for information on what 
types of information are transferred during synchronization.

� Open Current Item in TrackRecord – Selecting an item, such as a 
task, milestone, or resource, in Microsoft Project and choosing this 
option causes TrackRecord to run and open the selected item.

� Options – Opens a new dialog box that lets you change the user ID, 
database, project, or priority map.

Performing Initial Project Setup

Before TrackRecord and Microsoft Project can exchange project informa-
tion, you must log in to TrackRecord from within Project and identify the 
database and TrackRecord project associated with the current schedule.
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1 Open the Microsoft Project project file you want to use.

2 From the TrackRecord menu, choose Options. The TrackRecord 
Options dialog box (Figure 8-5) appears.

Figure 8-5. TrackRecord Options Dialog Box

3 Enter your TrackRecord login name in the User field and the database 
you want TrackRecord to use in the Database field.

4 To specify a project, do one of the following:

� To use an existing project, click the drop-down list in the Project 
field. 

� To create a new TrackRecord project, click the Create a New 
Project button.

5 On the TrackRecord Login dialog box (Figure 8-6), enter your login 
password in the Password field and click OK. Note that TrackRecord 
passwords are case-sensitive.

Figure 8-6. TrackRecord Login Dialog Box

6 Perform one of the following:

� If you are using an existing project, select it from the Project list 
on the Options dialog box (Figure 8-5).
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� If you are creating a new project, select the check box beside the 
Team Members you wish to assign to the new TrackRecord project 
(Figure 8-7). Click OK when you are finished.

Figure 8-7. TrackRecord Team Member Selection Dialog Box

7 Click OK.

Mapping TrackRecord Priorities to Project Priorities

The priority assigned to a task indicates the task’s importance within a 
project. When schedules grow tight, tasks with low priorities are typically 
deferred or eliminated. TrackRecord and Project have different default 
priority settings. Before you can use resource leveling in Project, you 
must map the priority levels in TrackRecord to the corresponding priority 
levels in Project. To map priorities, perform the following procedure:

1 Run Microsoft Project.

2 Open a project you have previously configured for TrackRecord and 
Microsoft Project integration.

3 From Project’s TrackRecord menu, choose Options.
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4 When the TrackRecord Options dialog box appears, click the Priori-
ties tab.

Figure 8-8. TrackRecord Options Dialog Box – Priorities Tab. If your TrackRecord 
administrator has modified the default priorities in TrackRecord, your Priorities tab 
may differ from the one shown.

MS Project 
priority 
settings

TrackRecord 
priority 
settings

5 Click the Edit button to change any mapping assignments (Figure 8-
8). The Priority Mapping dialog box appears (Figure 8-9)

Figure 8-9. Priority Mapping Dialog Box

In this example, the TrackRecord priority “1 – Critical” is mapped to 
the Project priority “1000 - 1000”. Select an item from the drop-down 
list to change the mappings. Click OK when your changes are 
complete.

6 Click OK to close the dialog box.

Synchronizing a Project in TrackRecord with Microsoft Project
Note: Tasks are not synchronized if a Team Member has not been assigned 

to the task. If you have not assigned a TrackRecord Team Member for 
each task in Microsoft Project, do so now. Refer to “Performing Initial 
Project Setup” on page 127 for complete instructions.
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What Happens During Synchronization?

When you choose Synchronize Project Now, TrackRecord and Microsoft 
Project exchange information about Team Members, Projects, Tasks, and 
Milestones in the project.

TrackRecord adds a Microsoft Project section to the bottom of the Task 
item form. Selecting the Auto Update Summary field in the Microsoft 
Project section of a Task item form will cause the Summary field to be 
read-only in TrackRecord, allowing it to be changed through Project only. 
Clearing this option allows you to change the Summary in TrackRecord, 
but your changes will not be reflected in Microsoft Project.

The project name and description can be defined in Project and sent to 
TrackRecord on first synchronization. During syncronization, Track-
record updates the project name in Trackrecord with the name in the MS 
Project Title field found in File>Properties.

The following tables (Table 8-2 - Table 8-5) identify what fields in Track-
Record are overwritten by information from Microsoft Project and what 
fields in Microsoft Project are overwritten by information from Track-
Record.

Table 8-2. TrackRecord Team Member Item to Microsoft Project Field Mapping

TrackRecord Team 
Member

Synchronization 
Direction

MS Project 
Resource 
Field

Comment

Name --> Name Project mem-
bers are defined 
in TrackRecord 
and sent to MS 
Project.

Initials (Abbreviation) --> Initials

Email Address --> Email
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Table 8-3. TrackRecord Project Item to Microsoft Project Field Mapping

TrackRecord 
Project Field

Synchronization 
Direction

MS Project 
Project Field Comment

Name <--

(new items only)

Title Project name and 
description can be 
defined in Project 
and sent to Track-
Record on first syn-
chronization. 

Description <--

(new items only)

Comments

Team Members -->

(new or changed)

Resources Team Members are 
defined in Track-
Record.

Table 8-4. Task Mapping

TrackRecord MS 
Project Task Field

Synchronization 
Direction

MS Project 
Task Field Comment

Summary <-- Name Tasks are cre-
ated in MS 
Project. Com-
pletion status is 
captured in 
TrackRecord

Description <-- Notes

Assigned To <-- Resource

Priority <-- Priority 
(mapped)

Date Due <-- Finish (base-
line)

In order for this 
field to be 
imported, there 
must be a base-
line assigned

Date Completed --> Finish (actual) Tasks are cre-
ated in MS 
Project. Com-
pletion status is 
captured in 
TrackRecord

Completed --> % Complete

Identifier (autogener-
ated)

--> WBS field
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Table 8-5. TrackRecord Milestone Item to Microsoft Project Task Field Mapping

TrackRecord 
Milestone Field

Synchronization 
Direction

MS Project 
Task Field Comment

Name <-- Name Milestones and 
planned dates 
are defined in 
MS Project. 
Actual dates are 
captured in 
TrackRecord

Description <-- Notes

Project <-- Associated 
Project

Projected End Date <-- Finish (base-
line)

In order for this 
field to be 
imported, there 
must be a base-
line assigned

Start Date --> Project Start 
date

Milestones and 
planned dates 
are defined in 
MS Project. 
Actual dates are 
captured in 
TrackRecord

Actual End Date --> Finish (actual)

Performing Project Synchronization

1 Open the Microsoft Project file for the project you want to synchro-
nize.

2 From Project’s TrackRecord menu, choose Synchronize Project Now.

3 If you have not already done so, you will be prompted to login into 
the TrackRecord database. The TrackRecord Synchronization dialog 
box indicates the progress as TrackRecord and Project exchange infor-
mation.

4 When the TrackRecord Synchronization Complete dialog box 
appears, click OK.

Integrating TrackRecord With Visual Basic
Visual Basic is a programming environment from Microsoft in which a 
programmer uses a graphical user interface to choose and modify prese-
lected sections of code written in the BASIC programming language. You 
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can integrate TrackRecord with Visual Basic to allow you to submit a 
defect or task into the TrackRecord database from within Visual Basic. 

Required: TrackRecord must be installed after Visual Basic in order for the 
integration to work. If you installed TrackRecord first, you must 
uninstall and reinstall the product before performing these proce-
dures.

Enabling Visual Basic Integration

1 From Visual Basic’s Add-Ins menu, select Add-In Manager. The Add-
In Manager dialog box appears.

2 From the list of available add-ins, select Compuware TrackRecord.

3 Ensure that the Loaded/Unloaded and Load on Startup check boxes 
are selected.

4 Click OK to exit the dialog box.

Disabling Visual Basic Integration

1 From Visual Basic’s Add-Ins menu, select Add-In Manager. The Add-
In Manager dialog box appears.

2 From the list of available add-ins, select Compuware TrackRecord.

3 Ensure that the Loaded/Unloaded and Load on Startup check boxes 
are cleared.

4 Click OK to exit the dialog box.

Logging Into TrackRecord From Visual Basic

Log into TrackRecord from Visual Basic by performing the following 
procedure:

1 From Visual Basic’s TrackRecord menu, choose Change Login.

2 On the TrackRecord Login dialog box, 

� Enter your TrackRecord login name and password. Note that they 
may be different from your Windows login name and password. 
Passwords are case-sensitive.

� Identify the database you want TrackRecord to use in the Data-
base field by selecting a name from the drop-down list or by 
entering a new name.

If you have used TrackRecord before, the names of the databases 
you have used previously appear in the Databases list. You do 
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not need to enter the path to the database, just the database 
name.

� Click OK. 

Submitting a Defect

To enter a defect into the TrackRecord database from within Visual Basic, 
simply perform the following procedure:

1 Ensure that you are logged into TrackRecord from Visual Basic. See 
“Logging Into TrackRecord From Visual Basic” on page 134.

2 From Visual Basic’s TrackRecord menu, choose Submit Defect. The 
TrackRecord Defect Item appears.

3 Enter information into the applicable fields. For more information 
on using TrackRecord forms, refer to Chapter 3, “Entering and Edit-
ing Data”.

4 Click Save and Close when you are finished.

Submitting a Task

To enter a task into the TrackRecord database from within Visual Basic, 
simply perform the following procedure:

1 Ensure that you are logged into TrackRecord from Visual Basic. See 
“Logging Into TrackRecord From Visual Basic” on page 134.

2 From Visual Basic’s TrackRecord menu, choose Submit Task. The 
TrackRecord Task Item appears.

3 Enter information into the applicable fields. For more information 
on using TrackRecord forms, refer to Chapter 3, “Entering and Edit-
ing Data”.

4 Click Save and Close when you are finished.

Using TrackRecord With Visual C++
Nearly all world-class software, from the leading Web Browsers to 
mission-critical corporate applications, is built using the Microsoft Visual 
C++ development system. Visual C++ is the most productive tool for the 
highest-performance development for Windows and the Web. You can 
integrate TrackRecord with Visual C++ to allow you to submit a defect or 
task into the TrackRecord database from within Visual C++.
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Required: TrackRecord must be installed after Visual C++ in order for the 
integration to work. If you installed TrackRecord first, you must 
uninstall and reinstall the product before performing these proce-
dures.

Enabling Visual C++ Integration

1 From Visual C++’s Tools menu, choose Customize. The Customize 
dialog box appears.

2 Click the Add-ins and Macro Files tab.

3 From the list of available add-ins and macro files, select TRDevStu-
Addin.TRDSAddin.

4 Click the Close button to exit the dialog box.

Disabling Visual C++ Integration

1 From Visual C++’s Tools menu, choose Customize. The Customize 
dialog box appears.

2 Click the Add-ins and Macro Files tab.

3 From the list of available add-ins and macro files, clear the TRDevS-
tuAddin.TRDSAddin option.

4 Click the Close button to exit the dialog box.

Submitting a Defect

To enter a defect into the TrackRecord database from within Visual C++, 
simply perform the following procedure:

1 Click the Submit Defect icon on the Visual C++ tool bar. If the icon is 
not visible, follow the steps for “Enabling Visual C++ Integration” on 
page 136.

2 On the TrackRecord Login dialog box, 

� Enter your TrackRecord login name and password. Note that they 
may be different from your Windows login name and password. 
Passwords are case-sensitive.

� Identify the database you want TrackRecord to use in the Data-
base field by selecting a name from the drop-down list or by 
entering a new name.

If you have used TrackRecord before, the names of the databases 
you have used previously appear in the Databases list. You do 
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not need to enter the path to the database, just the database 
name.

� Click OK. 

3 The TrackRecord Defect Item appears. Enter information into the 
applicable fields. For more information on using TrackRecord forms, 
refer to Chapter 3, “Entering and Editing Data”.

4 Click Save and Close when you are finished.

Submitting a Task

To enter a task into the TrackRecord database from within Visual C++, 
simply perform the following procedure:

1 Click the Submit Task icon on the Visual C++ tool bar. If the icon is 
not visible, follow the steps for “Enabling Visual C++ Integration” on 
page 136.

2 On the TrackRecord Login dialog box, 

� Enter your TrackRecord login name and password. Note that they 
may be different from your Windows login name and password. 
Passwords are case-sensitive.

� Identify the database you want TrackRecord to use in the Data-
base field by selecting a name from the drop-down list or by 
entering a new name.

If you have used TrackRecord before, the names of the databases 
you have used previously appear in the Databases list. You do 
not need to enter the path to the database, just the database 
name.

� Click OK. 

3 The TrackRecord Task Item appears. Enter information into the appli-
cable fields. For more information on using TrackRecord forms, refer 
to Chapter 3, “Entering and Editing Data”.

4 Click Save and Close when you are finished.

Utilizing TrackRecord with Version Control Systems
Version control system (VCS) applications help you manage projects by 
controlling and tracking source and other project files. You can integrate 
TrackRecord with VCS applications, such as Microsoft Visual SourceSafe, 
Merant PVCS, and MKS Source Integrity. Integrating TrackRecord with a 
version control system allows you to check files in and out from within 
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TrackRecord, open read-only versions of source files, and synchronize 
releases with VCS labels.

Required: TrackRecord must be installed after VCS in order for the integra-
tion to work. If you installed TrackRecord first, you must uninstall 
and reinstall the product before performing these procedures.

When you integrate TrackRecord with a VCS application, each tool tracks 
parallel sets of changes to your software projects. TrackRecord tracks 
change requests and their resolution, such as defects that have been fixed 
or features that have been added. A VCS application tracks changes to 
files. By integrating the tools, you can identify which source file changes 
were associated with specific change requests.

For example, a developer fixing a defect checks out source files, makes 
changes to them, and checks them in again. If a problem with the defect 
fix is subsequently identified, you can use the VCS files to identify and 
roll back the files that were modified, making it easier to resolve the 
problem.

For each file, release, and project in a VCS application, TrackRecord 
maintains a corresponding item in the database. This item references the 
source file. In most situations, the program creates items automatically 
when you check files in or out. However, you must update information 
for milestones, projects, and for file items that already exist in Track-
Record.

Associating a TrackRecord Project with a VCS Project

To associate a TrackRecord project with a VCS project, perform the 
following procedure:

1 Open a new or existing project in TrackRecord.

� To open a new project, choose File>New>Other. From the 
Choose a Type dialog box, select Project and click the New but-
ton.

� To open an existing project, choose File>Open>Other. From the 
Item Browser, select Project and double-click the appropriate 
project name in the Items list.
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2 When the Project form appears, click the button beside the VCS 
Project Name field (Figure 8-10).

Figure 8-10. VCS Button Location

Click the VCS 
button to 
access your 
version 
control 
system.

Note: For additional information on associating a TrackRecord Project to a 
VCS Project, consult your VCS documentation.

If you do not already have Source File and Data File items that you want 
to connect with your VCS files, TrackRecord will automatically create 
these items the first time you check the file in or out from within Track-
Record. When the items are created, you will see a status message, and 
have the opportunity to enter a description of the new file.

Checking Files In and Out 

You typically check source files in and out of a VCS system in the course 
of working on a specific TrackRecord Defect or Feature. When you check 
files in and out of a VCS system from within TrackRecord, TrackRecord 
automatically records the file name and current VCS version number in 
the item’s change history. To check a file in or out from TrackRecord, 
execute the following steps:

1 Open the appropriate Defect or Feature item.

2 Verify that the project identified in the Project field is associated 
with a project in your VCS application.

3 From TrackRecord’s Edit menu, choose Source Control>Check Out 
or Check In.

Note: If the submenus of the Edit>Source Control menu are disabled, 
ensure that the type contains a field that is associated to the type 
Source File and you have a VCS login and password. For more 
information on types, refer to the TrackRecord Administrator’s 
Guide.
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You will be presented with a list of files from your VCS project, which 
can be checked in or out as appropriate.

When the file(s) are checked in, TrackRecord copies the descriptive 
comments from the Resolution Details field to the VCS Comment 
field. This comment may then be further modified as desired.

Synchronizing TrackRecord and VCS Projects

Labels are user-defined identifiers used by VCS applications to represent a 
specific version of a project or file. When you label a project, all the files 
in that project inherit the label. For example, if you assign a label of 
“Beta 1” to a project, you can retrieve the appropriate version of files 
within that project by using the project label.

Connecting your TrackRecord releases with your VCS releases works the 
same way as connections to projects and file names, with one exception: 
you can create a new VCS label from within TrackRecord, at the same 
time you create a TrackRecord release.

Tip: If TrackRecord 
cannot find the VCS 
project, verify that the 
Release item is contained 
in a Project item that 
contains a valid VCS 
Project field. To add the 
release to the Project, 
open the Project item, 
scroll to the Builds/
Releases field, and click 
Add Item. After the 
Release item links to the 
Project item, you should 
be able to display the list 
of your VCS labels.

Associating a TrackRecord Release with a VCS Label

Perform the following procedure to associate a TrackRecord release with a 
VCS label:

1 Open the Item Browser.

2 Select the Show All check box.

3 Select Release from the Types list.

4 From the Items list, select the release you wish to associate with a 
VCS label.

5 Click the button beside the VCS Release>Label field. TrackRecord 
displays a list of your VCS labels.

6 To use an existing label, select the appropriate entry in the list. To 
create a new label from within TrackRecord, click the New button.

To create a new VCS label from within TrackRecord, select the check 
box next to the VCS Release field, and click the New button. Track-
Record will use the name of the release as the default value for the 
label; you can change this value when prompted for the release 
name. When TrackRecord creates the release, it applies the label to 
the entire project associated with the Release item.

7 Click OK.
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Troubleshooting

For a detailed listing of troubleshooting and configuration information 
for one of the supported version control systems, refer to “Troubleshoot-
ing” in the TrackRecord online help or the Release Notes.

For the most current TrackRecord support information, please visit the 
Compuware Web site at: http://www.compuware.com. From this 
location, you will have access to our online Knowledgebase and the most 
current patches and updates for the product.

Integrating TrackRecord With Compuware Products
TrackRecord integrates with four of Compuware’s product families: 
QACenter, DevPartner Studio, Vantage, and Abend-AID.

Using TrackRecord With DevPartner Studio

TrackRecord is part of the DevPartner Studio Enterprise Edition (DPSEE) 
suite of software debugging tools for building components and applica-
tions using Microsoft Java. TrackRecord serves as a central repository and 
communication hub for all development-related activities and data. It 
captures information generated by the DPSEE developer tools including: 

Note: Refer to the DevPartner Studio Enterprise Edition documentation for 
general information on using these products.

� detailed information about the detection, diagnosis, and resolution 
of software problems

� platform hardware and software configuration data

� consolidated or filtered test coverage data, which reveals untested 
software by platform, user, or configuration

� defects and issues including the software build

� task and defect lists for each developer

� testing, profiling, and automated error-detection status of each 
project

TrackRecord’s ActiveLink feature submits information generated by 
DevPartner Studio tools directly to a TrackRecord project database. The 
project database is accessible to developers from within the DevPartner 
Studio tool such as Error Detection or Performance Analysis. TrackRecord 
compares new defect submissions against existing issues to reduce dupli-
cate defect entries. This integration provides users with the information 
they need from within the tools they use. 
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Note: Integration of TrackRecord and the DevPartner Studio tools is version 
dependent. You many need to upgrade your TrackRecord or DevPart-
ner Studio software if you purchased the tools at separate times.

TrackRecord can literally track anything. These features are just a limited 
glimpse of what TrackRecord can do in conjunction with the following 
DPS tools:

� Error Detection— Delivers automatic error detection for C/C++/
VC++. Once a runtime error has been found by Error Detection, it 
can be automatically entered into TrackRecord.

� SmartCheck— Delivers automatic error detection for Visual Basic. 
Once a runtime error has been found by SmartCheck, it can be auto-
matically entered into TrackRecord.

� JCheck— Provides automatic error detection for Java. Once a runt-
ime error has been found by JCheck, it can be automatically entered 
into TrackRecord.

� CodeReview— A static source code analysis tool for Visual Basic. 
Once an error has been found by CodeReview, it can be automatically 
entered into TrackRecord.

� Performance Analysis— A performance analysis tool for VB/C/C++/
VC++/Java/ASP. Once a performance error has been found by Perfor-
mance Analysis, it can be automatically entered into TrackRecord.

� Memory Profiler— A memory analysis tool for Java. Once a memory 
issue has been identified by Memory Profiler, it can be automatically 
entered into TrackRecord.

� FailSafe— An automatic error handling tool for Visual Basic. If an 
application has been instrumented with FailSafe, it can email the 
error back to TrackRecord from a remote location to ensure that an 
error does not go unreported in production.

DevPartner Studio Interaction with TrackRecord

DevPartner Studio Enterprise Edition derives much of its power from its 
underlying ActiveLink connection to TrackRecord. ActiveLink automates 
the submission of debugging/tuning tool information to a database. This 
accumulated information provides:

� Platform configuration data, including hardware resources and ver-
sion information about installed software components

� Coverage data gathered from all developers using Coverage Analysis

� Task lists for each developer
142     TrackRecord User’s Guide



� Detailed error messages from the error detection tools

Logging In to TrackRecord from DevPartner Studio Tools

When starting a DevPartner Studio tool, you are prompted to log in to a 
TrackRecord database. Logging in at this time does not start TrackRecord, 
but allows access to tasks and defects within the database. 

If you are already logged in to TrackRecord, you can change your login 
identity from within any of the DevPartner tools.

To log in to a TrackRecord database, perform the following procedure:

1 From the DevPartner tool’s TrackRecord menu, select Change Login 
(Figure 8-11).

Figure 8-11. Changing TrackRecord Login from Within JCheck

2 In the TrackRecord Login dialog box:

� Enter your login name in the Name field.

� Enter your login password in the Password field. Passwords are 
case-sensitive.

� Identify the database you want to use in the Database field. The 
names of the databases you have used recently appear in the 
Databases list. You can select the database you want to use from 
this list or enter a different database name.

3 Click OK.

Platform Configuration

When an application runs under one of the DevPartner tools, Track-
Record records hardware and software configuration information about 
the computer on which the tested application executes. The hardware 
configuration information is stored in an item called Hardware Configu-
ration and is associated to the defect or session via the Defect’s Configu-
ration field. Software configuration information is stored as a list of 
Executable File objects in a Defect or TrackRecord Session item’s Loaded 
Components field.
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The Configuration type contains fields for information such as the type 
of processor, amount of memory, screen resolution, and the operating 
system. 

A Loaded Components field in an item tracks the details of DLL, OCX, 
and the EXE files used by the application being debugged. These details 
include the link date and time and version resource strings. Many 
software vendors, including Compuware and Microsoft, use version 
resource strings to provide unique version numbers of components.

Platform configuration information, including software component 
version numbers, can aid the process of finding errors caused by compo-
nent incompatibility.

Viewing Captured 
Platform 

Configuration Data

Suppose a tester reports a defect, but a developer cannot duplicate the 
defect. One cause for discrepancies of this nature is mismatched versions 
of essential software components, such as dynamic link libraries and 
ActiveX custom controls. TrackRecord’s Advanced Search capability gives 
Team Member one tool for uncovering such discrepancies.

Troubleshooting TrackRecord and DevPartner Integration

For troubleshooting documentation, refer to “Troubleshooting” in the 
TrackRecord online help or the Release Notes.

For the most current TrackRecord support information, please visit the 
Compuware Web site at: http://www.compuware.com. From this 
location, you will have access to our online Knowledgebase and the most 
current patches and updates for the product.

Using TrackRecord With ClientVantage

TrackRecord integrates with Compuware’s Vantage tools. ClientVantage, 
a program designed to measure application performance and availability 
to maintain high service levels. 

TrackRecord can integrate with ClientVantage’s Fault Detection to 
include captured fault data as part of a defect report automatically. 

Note: Refer to the ClientVantage documentation for general information on 
using this product.

Using TrackRecord With Abend-AID

TrackRecord can be used with Abend-AID products to automate fault 
management and reduce critical application downtime. TrackRecord 
automates key areas of the problem-resolution process: notification, 
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prioritization, workgroup communications, resource management, and 
reporting.

For example, Abend-AID Fault Manager can automatically load fault 
information into a TrackRecord database, reducing the amount of 
required data entry. TrackRecord then enables you to: assign fault 
notices, track and report on the status of faults, add information to faults, 
and create graphical reports. The online access to reports and graphs 
contains information such as:

� current defects
� high priority defects by application, developer, and date
� defects fixed-by version, programmer, priority, date or any set of cate-

gories desired
� defect statistics and trends

With Abend-AID Fault Manager, you can:

� respond to application failures immediately
� report on service level agreements
� manage and justify resources
� improve application quality
� perform trend analysis

Note: Refer to the Abend-AID documentation for general information on 
using this product.

Using TrackRecord in a CARS Engagement
When Using TrackRecord in a CARS Engagement some of the features of 
TrackRecord are not available.

These include: 

� The WorkFlow Editor

� The Import/Export Wizard

� The following Administrative Menu options:

� Edit Types

� Edit Rules

� Edit WorkFlow

� Import

� Export
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Additionally, the Show All option in the Item Browser is not accessible.

The CARS Database

A default database is installed with TrackRecord and is accessible immedi-
ately for tracking defects and issues.  The following lists the fields and 
drop-down lists used in the defect items. They are listed here in alphabet-
ical order:

Table 8-6. Database fields

Field Description Field Instructions

Action Controls the Status The Status details 
what state the defect is 
in. This is set to Unre-
viewed as a default. 
Choose an Action 
from those available 
for the state. See the 
CARS Workflow section 
for the list of available 
Actions and states.

Assigned to Person currently 
responsible for the 
defect

Choose from the drop-
down list. A project 
must be entered in the 
Project field to enable 
this field.

Attachments Attach a design docu-
ment, image, etc. asso-
ciated with the defect

Click the Add button 
to browse directories 
for the appropriate 
attachment. The 
attachment is added to 
the field.

Build Found The name or number 
of the build in which 
the defect is found

Enter the build found.

Build Resolved The name or number 
of the build in which 
the defect is fixed

Enter the build 
resolved.

Build Tested The name or number 
of the build in which 
the defect is fixed

Enter the build tested.
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Date entered Date that the defect is 
entered

Date is auto-popu-
lated and disabled.

Description Detailed description of 
the defect including 
any pertinent informa-
tion necessary for its 
eventual resolution

Describe any neces-
sary information such 
as the nature of the 
defect, how it can be 
recreated, and sug-
gested resolutions, etc.

Duplicate 
Defects

Reference to defect 
already entered

Right-click within the 
field to browse for the 
defect identifier.

Entered by Name of person enter-
ing the defect

Choose from the drop-
down list.

Identifier The defect number A defect can be 
searched by this num-
ber within Track-
Record. A distinct 
number automatically 
assigned to the defect 
beginning with 
000001.

Notes Any further informa-
tion necessary for the 
resolution of the defect

Enter any notes for the 
issue or defect.

Keywords A word or phrase 
entered in the defect 
so that all defects with 
this keyword can be 
grouped together by 
sorting. For example, 
Beta Required.

Click the Add button 
to add an item, or 
right-click within the 
field to create an item.

Operating Sys-
tem

The Operating System 
of the machine on 
which the application 
under test is running. 
For example Windows 
2000 or Windows XP.

Click the drop-down 
list to select an item or 
right-click inside the 
field to create an item.

Table 8-6. Database fields

Field Description Field Instructions
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Phase Found The software develop-
ment phase in which 
the defect is found

Click the drop-down 
list to select a phase or 
right-click inside the 
field to create one. See 
the CARS Phases sec-
tion for descriptions of 
the available phases.

Phase Intro-
duced

The software develop-
ment phase in which 
the defect was intro-
duced

Click the drop-down 
list to select a phase or 
right-click inside the 
field to create one. See 
the CARS Phases sec-
tion for descriptions of 
the available phases.

Priority High, medium, or low, 
expressing the defect’s 
order of precedence

Choose a priority.

Project The name or number, 
etc. of the project with 
which the defect is 
associated

Click the drop-down 
list to select a project 
or right-click inside the 
field to create one.

Project Resource The resource responsi-
ble for the issue’s reso-
lution

Click the drop-down 
list to select an item. 
Click the Add button 
or right-click within the 
field to create a 
resource.

Release Found The number of the 
release in which the 
defect is found

Click the drop-down 
list to select a release 
or right-click inside the 
field to create a new 
one.

Release 
Resolved

The number of the 
release associated with 
the resolution of the 
defect

Click the drop-down 
list to select a release 
or right-click inside the 
field to create a new 
one.

Release Tested The number of the 
release which QA tests

Click the drop-down 
list to select a release 
or right-click inside the 
field to create a new 
one.

Table 8-6. Database fields

Field Description Field Instructions
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CARS Phases

There are six stages of software development defined for tracking defects:

Resolution The actions performed 
to resolve the defect

Click the drop-down 
list to select a resolu-
tion. Click the Add 
button or right-click 
inside the field to cre-
ate a new one.

Resolution Date The date the defect is 
resolved

Enter the date or click 
on the calendar and 
choose the appropriate 
date.

Resolution 
Details

Explanation of the 
work performed to 
resolve the defect

Enter details of the 
work performed.

Service Pack The system service 
pack installed on the 
testing machine. For 
example Windows XP 
SP1, etc.

Enter a service pack.

Summary A summary of a 
defectwith pertinent 
information necessary 
to its resolution

Enter the summary.

Status The current status of 
the defect

This automatically 
reflects the status as a 
result of the Action.

Testing 
Resource

The resource perform-
ing QA testing

Click the drop-down 
list to select a resource 
Click the Add button 
or right-click inside the 
field to create a new 
one.

Type Code The type of issue. For 
example, Bug, 
Enhancement, etc.

Click the drop-down 
list to select a type 
code. Click the Add 
button or right-click 
inside the field to cre-
ate anew one.

Table 8-6. Database fields

Field Description Field Instructions
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1 Requirements - The first stage of software development which defines 
what the potential users want the system to do.

2 Design - The approach that development or engineering uses to spec-
ify how to create the system.

3 Prototype - The original model of the system from which future ver-
sions are patterned.

4 Development - The process of analysis, design, coding, and unit test-
ing software.

5 QA - The process of exercising a system to identify differences 
between expected and actual behavior.

6 Production - A system used to process an organization’s daily work.

CARS Workflow

A defect can pass through a series of states between the time it is entered 
and the time it is closed. For example, when a defect is entered, it is in an 
Unreviewed state. It might then be assigned to someone, resolved, and 
validated. This series of actions, and the states resulting from these 
actions, is calle d a workflow. There are nine Groups of users who have 
varying permissions:

1 Everyone

2 Quality Analysis Management

3 Quality Analysis Lead

4 Quality Analysis

5 Development Management

6 Development

7

8 ***

9 Guest

The following lists the states, available actions, and who can perform 
them:
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Table 8-7. Workflow states and actions

State Action Group

Unreviewed Review - Moves to 
Reviewed

QA Management

Reviewed Assign - Moves to 
Assigned

Development 
Management

Assigned Need More Info - 
Moves to Pending 
Information

Development

Working On - Moves to 
In Progress

Development

Pending Infor-
mation

Submit Info - Moves to 
Assigned

Everyone

In Progress Need More Info - 
Moves to Pending 
Information

Development

Resolve - Moves to 
Ready To Test

Development

Ready To Test Pass - Moves to Closed QA

Fail - Moves to 
Reviewed

QA

Closed Re-Open - Moves to 
Re-Opened

QA Manage-
ment, QA Lead, 
QA, Development 
Management, 
Development

Re-Opened Review - Moves to 
Reviewed

QA Management
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Glossary
Abend-AID Fault Manager: An automated fault management tool to help 
IT managers reduce downtime and optimize resources. Provides real-time 
and historical reports and graphs for monitoring the fault resolution 
process.

abbreviation: Text used to identify an item in the TrackRecord database. 

absolute date: Entry in a date field that identifies a specific date; for 
example, May 19, 1999 or 2/14/87. Compare relative date.

access control: Function of an application that restricts user access to data 
according to permissions derived from the user’s identity or membership 
in groups.

ActiveLink tags: A mechanism to allow administrators to link the types 
and fields they create with the underlying structure.

ActiveX control: An interface object on a form that enables or enhances a 
user’s interaction with an application. ActiveX controls have an .ocx file 
name extension.

administrator: The person responsible for installing, configuring, and 
maintaining TrackRecord user accounts. The TrackRecord administrator 
may or may not be responsible for maintaining the network and database 
for a site.

API: An application program interface (API) is the specific method used 
by a computer operating system or by another application program by 
which a programmer writing an application program can make requests 
of the operating system or another application. 

ASCII file: American Standard Code for Information Interchange 
(pronounced ASK-ee). Code in which numbers from 0 to 255 represent 
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individual characters, such as letters, numbers, and punctuation marks. 
Standard for text representation.

audit trail: Record identifying each change made to an item or report and 
the identity of the person making the change. See change history.

AutoAlert: An optional component that provides email notification to 
users of the defects that pertain to them.

AutoAlert Administration Utility: A tool that allows you to add and remove 
databases that are being polled by the AutoAlert service, show users that 
have AutoAlert enabled, and set a variety of AutoAlert options.

available states: The Workflow Editor’s list of states that have been 
defined, but are not yet used in the workflow.

bug report: See defect.

calendar: TrackRecord automatically displays a list of appointments and 
tasks.

CGI request: Common gateway interface (CGI) is a standard way for a 
Web server to pass a Web user's request to an application program and to 
receive data back to forward to the user. For example, when a user fills 
out a form on a Web page and sends it in, it usually needs to be processed 
by an application program. The Web server typically passes the form 
information to a small application program that processes the data and 
may send back a confirmation message. This method or convention for 
passing data back and forth between the server and the application is 
called the common gateway interface (CGI). It is part of the Web's Hyper-
text Transfer Protocol (HTTP). 

change history: Record identifying each change made to an item or report 
and the identity of the person making the change. See audit trail.

child: An item that is subordinate to another item.

child header: A header that is subordinate to another header within an 
Outline Report. In the following example, Open Bugs is a child header of 
Bugs, and Priority 1 is a child header of Open Bugs. Compare parent 
header, sibling header.

Bugs 
Open Bugs 
Priority 1 
Priority 2 
Closed Bugs

ClientVantage: Formally known as Interval Pro, ClientVantage is designed 
to validate end-user response time from the end-user perspective and 
proactively measure application performance and availability to 
maintain high service levels. 
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cloning projects: Duplicating and reusing information from existing 
projects.

Command Line Interface: A CLI (command line interface) is a user inter-
face to a computer's operating system or an application in which the user 
responds to a visual prompt by typing in a command on a specified line, 
receives a response back from the system, and then enters another 
command, and so forth. 

coverage: Percentage of a project that has been tested, expressed as a 
percentage of lines tested or a percentage of the functions tested.

data type inheritance: TrackRecord uses a data hierarchy to develop 
related data types. When one data type (the child) is based on another 
data type (the parent), the child type inherits all the fields and controls 
of the parent type. See child and parent for more information.

database: A collection of data that is organized so that its contents can 
easily be accessed, managed, and updated. TrackRecord uses a relational 
database, a tabular database in which data is defined so that it can be 
reorganized and accessed in a number of different ways.

database lock-out: A error that will result if attempting to change the 
database (usually by creating or modifying types) while in use. A dialog 
will appear listing current users to allow the administrator to advise them 
to log off.

DBHost: Database Host. It caches values for a specific database.

defect: Report describing a problem found with software or hardware 
undergoing testing. A defect report is updated over time as a problem is 
reported, reproduced, fixed, and tested.

Defect: Item in the TrackRecord database describing a specific problem 
identified during project testing.

derived type: A data type that inherits all of the fields of its parent’s type. 
For example, a Software User object inherits all the fields from the Person 
data type.

DevPartner Studio: TrackRecord is part of the Compuware DevPartner 
Studio suite of Windows-based, software debugging tools. Easily 
integrated into every team’s development process, including Web-
enabled, e-commerce, and distributed applications to help developers 
automatically detect, diagnose, and facilitate resolution of software 
errors; maximize code performance; and ensure optimum code coverage 
and testing. 

export: To generate a formatted file containing data from the TrackRecord 
database for use by another application.
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Fault Manager: See Abend-AID Fault Manager.

favorite reports: Frequently used reports or views.

fields: Holds specific facts about an item, such as a person’s address or the 
name of a project.

filter: Process that selects information from the database according to 
user-specified criteria. 

function coverage: A measure of how much of the code for a project has 
been tested, expressed as a percentage of functions tested across all 
Coverage Analysis sessions relative to the total number of functions in a 
project.

global favorite types: Favorite types that are shared with every Track-
Record user.

global Outline Report: Outline Reports that are shared with every Track-
Record user.

Global Preferences Administration: Creating queries, reports, and global 
templates, and identifying Home Pages and favorites for all users.

global query: Queries that are shared with every TrackRecord user.

global template: Templates that are shared with every TrackRecord user.

graph: A visual summary of information.

Group Administration: Creating groups and establishing group access 
rights.

header: Entry in an outline report that corresponds to a database query. 

Header Wizard: TrackRecord utility that simplifies the process of defining 
and formatting outline reports. The Header Wizard was called the Header 
Engineer in previous TrackRecord releases.

hide: A field-level privilege setting that allows making a field invisible on 
a group-by-group basis.

Home Page: A report that opens automatically when TrackRecord is 
launched and can be accessed through the Home Page button.

import: To bring data generated by another application into the Track-
Record database.

inheritance: Property of data types that allow them to derive their struc-
tures from parent types. 

item: Object or entity of a specific type in the TrackRecord database. 
Equivalent to a record in a relational database.
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Item Browser: Provides access to information in the TrackRecord database 
and allows the creation of new items.

label: User-defined name you can attach to a specific software release or 
build in version control systems.

line coverage: A measure of how much of the code for a project has been 
tested, expressed as a percentage of code lines tested across all Coverage 
Analysis sessions relative to the total number of code lines in a project.

link: Relationship between items in the TrackRecord database. A link is 
created whenever one item references another. For example, attaching a 
note to a Person object creates a link between the two items.

mail query: A TrackRecord query in which an option is enabled to email 
users when new items match the query.

menu bar: Displays on the TrackRecord user interface below the window 
title and contains the following menus: File, Edit, Administrator, Favor-
ites, Tools, Window, and Help.

merging: The process of compiling coverage information across multiple 
test sessions.

milestone: An event or point in a schedule that marks the transition of a 
project from one phase to another.

Milestone Status: Report that identifies the current status of a project with 
respect to a specified milestone, data submitted from QACenter tools, 
and custom queries that summarize project information.

OLE-compliant: A set of APIs to create and display a document, OLE 
(Object Linking and Embedding) is Microsoft's framework for a 
compound document technology. Part of Microsoft's ActiveX technolo-
gies, OLE is part of a larger, more general concept, the Component Object 
Model. 

Outline Report: Structured view of information in the TrackRecord 
database that is updated dynamically. 

parent: An item that has one or more subordinate items.

parent header: A header that owns one or more subordinate headers 
within an outline report. In the following example, Bugs is the parent 
header of Open Bugs, and Open Bugs is the parent header of Priority 1 
and Priority 2. Compare sibling header, child header.

Bugs 
Open Bugs 
Priority 1 
Priority 2 
Closed Bugs
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password: Text string used to verify the identity of a user before granting 
the user read or write access to TrackRecord information.

priority: Arbitrary integer value assigned to a defect to indicate its signifi-
cance relative to other defects. Depending on the standards of your site, 
you can use a higher or lower number to indicate that one defect is more 
important than another.

Project Administration: Determines the organizational framework for 
completing a deliverable including tasks required to build an application, 
people who work on those tasks, and dates on which the tasks must 
finish.

QADirector: QADirector is a powerful, extensible test management 
solution for full life cycle testing of distributed large-scale applications. 

query: A means to specify criteria for data retrieval. 

Reconcile: An enterprise-wide requirement management system. It allows 
a project team to create, change, track, and report on project require-
ments.

recurring events: Event scheduled to occur at regular intervals, such as 
Every Thursday.

relative date: Entry in a date field that identifies a date relative to the 
current system date; for example, Yesterday or Tomorrow. Compare 
absolute date.

Remainder Header: A None of the Above summary item used in an 
Outline Report. It is typically used to identify items belonging to a parent 
header that fail to match all criteria.

Rich Text Format (RTF): A file format that lets you exchange a text file 
between different word processors and different operating systems.

right-click: Pressing and releasing the right mouse button while position-
ing the cursor over an object or control on the screen. Typically opens a 
shortcut menu, which displays options applicable to the control or item 
over which the cursor is positioned.

share groups: Groups whose members share queries, Outline Reports, 
Milestone Status views, and templates.

shared: Property of a report that allows TrackRecord users other than the 
report’s owner to view it. Only the owner of a report can modify a shared 
report, though other users can copy it (by saving it under a new name) 
and then modify their copy.

shortcut menu: Menu that appears when you right-click a control or item 
in a window.
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sibling header: A header that is at the same level as another header within 
an outline report. In the following example, Open Bugs is a sibling 
header of Closed Bugs, and Priority 1 is a sibling header of Priority 2. 
Compare parent header, child header.

Bugs 
Open Bugs 
Priority 1 
Priority 2 
Closed Bugs

status bar: Located at the bottom left of the screen, this bar provides 
suggestions for the actions you can perform with a tool or a selected 
object.

subproject: A project that is one component of a larger or more complex 
project.

task: Any activity in a project that has a beginning date and an end date.

Task: An item in the TrackRecord database that identifies a task in a 
project.

Team Member: An individual assigned to work on a project.

template: A document or file having a preset format, used as a starting 
point for a particular application so that the format does not have to be 
recreated each time it is used.

TestPartner: An automated functional testing tool that has been specially 
designed for testing complex applications based on Microsoft, Java and 
Web based technologies. 

toolbar: Contains shortcuts to the most commonly used tasks such as 
creating a new item or view, opening an existing item, displaying the 
Item Browser, opening the Home Page, or searching.

transient sessions: Efficient data structures that cache data from users for a 
period of ten minutes before it is removed.

type: An organizational system that provides the framework on which 
the TrackRecord database is built. Information is organized into catego-
ries such as Person, Company, Defect, or Project.

Type Editor: Inserts fields into a form, modifies fields on a form, and 
modifies settings.

type inheritance: See data type inheritance.

version control system (VCS): An application that maintains multiple 
versions of source files, controls who can read and update source files, 
and records information about changes to source files.
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views: A specification for how data is displayed. 

visible group layers: A list of all defined groups in the Workflow Editor.

volatility: A measure of the stability of code from one build to another, 
expressed as a percentage of the functions that changed between two 
builds.

WebMonitor: A monitoring component that maintains all currently 
active users sessions. 

WebServer: An optional component that allows access to the TrackRecord 
database through a Web browser.

work area: Area where the workflow is created in the Workflow Editor.

workflow: A series of actions and the states resulting from these actions.

Workflow Editor: Creates and modifies the workflow and consists of these 
frames: available states, visible group layers, and work area.
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